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1 Preface

Purpose

This document describes the installation, function, maintenance, and troubleshooting methods
of the iManager NetEco 1000S V100R002C70 monitoring software. For commercial inverters
and residential inverters, there are two scenarios in NetEco 1000S: commercial NetEco 1000S
system and residential NetEco 1000S system.

Intended Audience

This document is intended for:

l Inverter maintenance personnel

l Electronic technicians with related aptitude

Product Models

This document describes how to use the following Inverter monitoring software:

l SUN2000

l SUN8000

l SUN2000L

Symbol Conventions

The symbols that may be found in this document are defined as follows:

Symbol Description

Indicates a hazard with a high level or medium level
of risk which, if not avoided, could result in death or
serious injury.

Indicates a hazard with a low level of risk which, if
not avoided, could result in minor or moderate
injury.
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Symbol Description

Indicates a potentially hazardous situation that, if not
avoided, could result in equipment damage, data
loss, performance deterioration, or unanticipated
results.

Provides additional information to emphasize or
supplement important points in the main text.

 

Change History
Changes between document issues are cumulative. The latest document issue contains all the
changes made in earlier issues.

Draft C (2017-12-14)
This issue is the third release of the iManager NetEco 1000S V100R002C70 beta version.
Compared with Draft B (2017-11-13), this issue includes the following changes.

Modified

Navigation Tree Change Description

Installation and Commissioning > NetEco
1000S Installation and Commissioning

For details, see 4.1.4 Logging In to the
NetEco 1000S Client.

Operation and Maintenance > NetEco
1000S Web Client Operation
(Commercial) > Getting Started >
Logging In to the NetEco 1000S

For details, see 5.1.1.1.2 Logging In to the
NetEco 1000S Client.

Operation and Maintenance > NetEco
1000S Web Client Operation
(Residential) > Getting Started

For details, see 5.2.1.1 Logging In to the
NetEco 1000S.

 

New

Navigation Tree Change Description

Operation and Maintenance > NetEco
1000S Maintenance > Replacing
Certificate of the NetEco 1000S System

See 5.4.3.5 Replacing a Certificate for the
NetEco 1000S APP Communicating with
the Server.

 

Deleted
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Navigation Tree Change Description

Operation and Maintenance > NetEco
1000S Web Client Operation
(Commercial) > FAQ

Deleted chapter How Do I Enable or
Disable the HTTP Mode for Logging In
to the NetEco Client?, since HTTP mode
for logging in to the NetEco client is
disabled.

 

Draft B (2017-11-13)

This issue is the second release of the iManager NetEco 1000S V100R002C70 beta version.
Compared with Draft A (2017-09-30), this issue includes the following changes.

Modified

Navigation Tree Change Description

Installation and Commissioning > NetEco
1000S Installation and Commissioning

l For details, see 4.1.2 Installing the
NetEco 1000S Software.

l For details, see 4.1.4 Logging In to the
NetEco 1000S Client.

Operation and Maintenance > NetEco
1000S Web Client Operation
(Commercial) > Getting Started >
Logging In to the NetEco 1000S

For details, see 5.1.1.1.2 Logging In to the
NetEco 1000S Client.

Operation and Maintenance > NetEco
1000S Web Client Operation
(Commercial) > System Management >
Managing User Information

For details, see 5.1.7.1.3 Modifying User
Information.

Operation and Maintenance > NetEco
1000S Web Client Operation
(Commercial) > FAQ

For details, see 5.1.8.22 What Do I Do to
Control the User Authorization upon
First Login?.

Operation and Maintenance > NetEco
1000S Web Client Operation
(Residential) > Getting Started

For details, see 5.2.1.1 Logging In to the
NetEco 1000S.

Operation and Maintenance > NetEco
1000S Web Client Operation
(Residential) > Managing the PV Plants

For details, see 5.2.2.2 Creating a PV
Plant.

Operation and Maintenance > NetEco
1000S Web Client Operation
(Residential) > System Management >
Managing User Information

For details, see 5.2.6.1.4 Modifying User
Information.

 

New
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Navigation Tree Change Description

Operation and Maintenance > NetEco
1000S Web Client Operation
(Residential) > FAQ

l See 5.2.7.7 What Do I Do to Switch to
the Residential NetEco 1000S System.

l See 5.2.7.8 What Do I Do to Control
the User Authorization upon First
Login?.

 

Deleted

Navigation Tree Change Description

Operation and Maintenance > NetEco
1000S Web Client Operation
(Residential) > System Management >
Setting Remote Notification

Deleted chapter Setting Parameters for the
SMS Modem, since SMS Modem is
disabled in the residential NetEco 1000S
system.

 

Draft A (2017-09-30)
This issue is the first release of the iManager NetEco 1000S V100R002C70 beta version.
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2 Privacy Policy

Dear user,

Huawei Technologies Co., Ltd and its affiliates (Huawei for short) attach great importance on
your personal data and privacy. Before using the NetEco 1000S and NetEco 1000S APP,
please carefully read, learn, and agree to this policy.

By learning this privacy policy, you can understand the following information:

l How to use your personal data
l How to protect your personal data
l Contact Huawei

How to Use Your Personal Data
l NetEco 1000S: NetEco 1000S is able to send report, alarm data, and the email for

retrieving the password. In this case, NetEco 1000S collects your Email address or
mobile phone number to accept report, alarm data, and the email for retrieving the
password. You can register yourself as an installer on the residential NetEco 1000S
system. You need to provide your email address, device SN, and device registration code
when registering a system operator account. The NetEco 1000S records the login and
operation logs of your account within the recent half a year. The operation logs include
the access IP address and user name and are used for security audit.

l NetEco 1000S APP: To ensure service security, the NetEco 1000S APP collects the
identification number of your mobile terminal. Only the registered mobile terminal can
access the server.

How to Protect Your Personal Data
l NetEco 1000S: Email address and mobile phone number are only used to accept report,

alarm data, and the email for retrieving the password. Device SN, and device registration
code are only used to register yourself as an installer. Huawei will protect data security
through technical measures.

l NetEco 1000S APP: To identify the validity of a mobile terminal, the IMEI of your
mobile equipment is stored on the NetEco 1000S server. Huawei will protect data
security through technical measures, and ensure server security according to physical and
guidance proposals. Although Huawei take appropriate measures to protect your
personal data, there is still no a perfect security measure.

Your personal data will not be disclosed to a third party.

iManager NetEco 1000S
User Manual 2 Privacy Policy

Issue Draft C (2017-12-14) Huawei Proprietary and Confidential
Copyright © Huawei Technologies Co., Ltd.

5



Contact Huawei

NOTICE
Huawei support engineers can perform maintenance operations only after being authorized by
the customer, and are forbidden to perform any operations that are not approved by the
customer. In addition, fault-locating data cannot be transferred out of the customer's network
without authorization from the customer.

If you have any questions, comments, or suggestions, you can submit them to the local
Huawei branches. You can obtain the list of Huawei branches all over the world from http://
www.huawei.com/en/about-huawei/contact-us/index.htm.

Note: Due to local laws and regulations and local language using habits, the privacy policy of
the local language may be different slightly from that of the English version. Different
contents in the local language version take precedence.

Copyright © Huawei Technologies Co., Ltd. 2017. All rights reserved.

iManager NetEco 1000S
User Manual 2 Privacy Policy

Issue Draft C (2017-12-14) Huawei Proprietary and Confidential
Copyright © Huawei Technologies Co., Ltd.

6

http://www.huawei.com/en/about-huawei/contact-us/index.htm
http://www.huawei.com/en/about-huawei/contact-us/index.htm


3 Description

3.1 Product Description
For details, see iManager NetEco 1000S V100R002C70 Product Description.pdf.

3.2 Security Management Description
The NetEco 1000S provides various security features and mechanisms to protect the NetEco
1000S system and the entire operations support system (OSS) network from attacks and
eavesdropping.

3.2.1 Networking Security
Networking security provides policies such as security domain division and firewall isolation
to protect the OSS network.

3.2.1.1 Security Domain Planning
This section describes how to plan security domains. During the initial stage of networking,
system administrator need to divide an OSS network into multiple subnets based on security
domains, separate trusted domains from non-trusted domains, and properly plan IP addresses.
This ensures the security of the OSS network and NetEco 1000S servers.

Figure 3-1 shows the security domains on an OSS network. The four OSS security domains
are interconnected. Devices in the OSS server domain and device domain are essential to the
OSS network and require the highest security protection level. Security domains other than
the OSS server domain and device domain belong to subnets that are used for access.
Therefore, security risks brought about by these subnets to the OSS server domain and device
domain must be fully considered before and during the design of security policies for these
subnets. Possible security risks include eavesdropping and network attacks.
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Figure 3-1 Security domains on an OSS network

OSS Server Domain
The OSS server domain comprises devices (mainly OSS servers such as NetEco 1000S
servers and Trace Servers) that are crucial to the entire OSS network. After connecting to the
NetEco 1000S, this domain operates and maintains the entire network and even controls the
network. Therefore, this domain requires the highest level of security protection. It must be
isolated from other domains and access to devices in this domain must be restricted.

Device Domain
The device domain comprises all NEs managed by the NetEco 1000S, specifically the units of
NEs including SUN, EMI, SmartLogger, PID, PLC, and Meter.

The NEs managed by NetEco 1000S are at the same security level.

OSS Terminal Domain
The OSS terminal domain comprises PCs only for O&M operations on the OSS network.
These PCs may be placed either in central offices where NetEco 1000S servers are located or
in remote equipment rooms where only NEs are located. This domain comprises of NetEco
1000S clients, and LMTs. These terminals are applicable only to mobile network devices'
O&M services.

The OSS terminal domain and OSS server domain work in similar network environments, but
devices in the OSS terminal domain have lower security levels. Security policies in this
domain depend on customer requirements and network environments. For example, customers
determine whether to install firewalls between the OSS terminal domain and the OSS server
domain or between the OSS terminal domain and the OSS device domain. By default,
customers provide the VLAN policy.

Remote Terminal Domain
The remote terminal domain comprises terminals that remotely access the OSS network, for
example, using LANs or dial-up connections. If authorized customers, device vendors, or
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third parties want to remotely access to the OSS network, security control must be
implemented because: 1. Uncertainties exist in the environments where remote O&M
terminals are located. 2. Remote O&M terminals often attempt to access the OSS network
through public networks. Users are advised to disable the access between this domain and the
OSS server domain and provide remote access through a secure VPN channel as required.

3.2.1.2 Firewall Deployment
During OSS network deployment, firewalls must be deployed between the entities.

Firewalls should be deployed between the following entities:

l The OSS server domain and the device domain
l The OSS server domain and the OSS terminal domain
l The device domain and the OSS terminal domain

Policies for deploying firewalls contains: configuring the firewall port and configuring the IP
access.

3.2.2 Platform Security
This section describes operations for enhancing platform security, including operating system
hardening, database hardening, antivirus solution deployment. These operations increase the
security levels of operating systems and databases and provide a secure and reliable platform
for OSS service applications.

In terms of security risks on operating systems, provide security hardening solutions for
increasing the security levels of operating systems and databases. Figure 3-2 describes the
security policies for operating systems and databases.

Figure 3-2 Security policies for operating systems and databases

l OS hardening: You are advised to perform security hardening on the PC running the
NetEco software according to Policies for MySQL Database Hardening in 3.2.2.1
Operating System and Database Hardening.

l Database hardening: The MySQL database is automatically installed when you install
the NetEco software and has been hardened upon delivery. For details about the
hardening policies, see Policies for MySQL Database Hardening in 3.2.2.1 Operating
System and Database Hardening.

l Antivirus software: The NetEco software does not contain the antivirus software for the
OS upon factory delivery. You need to install the mainstream commercial antivirus
software on the OS of the NetEco.
Third-party antivirus software is integrated into Huawei products to protect Windows
against virus and worm threats.

3.2.2.1 Operating System and Database Hardening
Security hardening policies are based on the features of NetEco 1000S service applications.
The policies can increase the security levels of operating systems and databases.
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Policies for Windows Hardening

Main policies for Windows hardening are as follows:

l Set auditing and user account policies.
– Auditing policies:

Set events to be audited, such as events about user account login and management
success and failure.

– User account policies:
Set attributes for user account passwords, such as shortest and longest storage
duration, length, and complexity.

– Policies for locking user accounts:
Set thresholds for user account locking, locking duration, and time for resetting the
account-locking timer.

– Event log settings:
Set logs that user Guest cannot query, event log size, and storage mode. Event logs
include application logs, security logs, and system logs.

l Security options:
For example, user account, auditing, network security, and network access.

l More security protection polices:
For example, shared folder deletion, registry settings, user rights assignment, firewall
settings, and directory permission settings.

NOTE

For details about the hardening policies and suggested measures, see 3.2.2.2 Windows OS Security
Hardening.

You are advised to use the mainstream commercial Windows hardening tool to harden the Windows OS.

Policies for MySQL Database Hardening

The policies for hardening the MySQL database are as follows:

l Installation and configuration
– Control the user who can access the MySQL.user table.
– Control the access to the MySQL database.
– Set the maximum number of allowed login attempts.
– Close default ports.
– Record user login.
– Change the password of the database administrator and delete empty passwords.
– Add the password complexity check for database users.
– Set the timeout interval for database connection.

l Permission minimization management
– Manage authorization with the GRANT option.
– Forbid users other than the database administrator to access the objects in the

MySQL database.
– Set the OS rights for the MySQL installation path.
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– Set the OS rights for the MySQL parameter file.
– Set the OS rights for the MySQL log file.
– Forbid the remote login of database administrators.
– Forbid database access from another PC.
– Delete the default test database.

NOTE

The user administrator in the MySQL database hardening policies is the system administrator of
MySQL database.

Database security hardening has been performed for NetEco 1000S V100R002C70 upon factory
delivery.

3.2.2.2 Windows OS Security Hardening
When the NetEco 1000S software runs on Windows, perform security hardening for the
Windows OS to improve the NetEco 1000S security.

Prerequisites
You have obtained the SecureCAT SetWin.exe installation package for the security
hardening tool and the SetWin_2K12R2_CIS_V1.1.0.inf configuration file from Huawei
technical support engineers.

Context
The NetEco 1000S can run on Windows 7, Windows 10 or Windows Server 2012. This
section describes how to perform security hardening for the Windows Server 2012 OS. To
learn the detailed security hardening policy for Windows 7 and Windows 10, see Windows OS
Security Hardening Policy.pdf.

Procedure

Step 1 Copy SecureCAT SetWin.exe and SetWin_2K12R2_CIS_V1.1.0.inf to the Windows Server
2012 OS to be hardened.

Step 2 Double-click SecureCAT SetWin.exe to install the security hardening tool.

After the installation is complete, the SetWin icon is displayed on the desktop.

Step 3 Right-click the SetWin icon and choose Run as Administrator from the shortcut menu.

The home page of the SetWin tool is displayed, as shown in Figure 3-3.
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Figure 3-3 SetWin home page

Step 4 Click Language on the menu bar.

The tool supports Chinese and English (default). After changing the language, restart the tool
for the change to take effect.

Step 5 Choose Configuration > Import Configuration File.

In the displayed Open File to import dialog box, select the
SetWin_2K12R2_CIS_V1.1.0.inf file saved in Step 1.

Step 6 When the "Import successful" message is displayed, click OK.

Step 7 Back up the OS.

1. Choose Policy > Roll back.
A message is displayed, prompting you to confirm that the user password meets the
requirements.

2. Click Yes.
A dialog box is displayed for you to save the backup file.

3. Set a name for the backup file and click Save.
It is recommended that the backup file be named after the current date.

Step 8 Optional: Configure the security hardening policy.

Set security hardening items in the left navigation tree on the Policy tab page.
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NOTICE
l If you perform security hardening remotely, choose SetWin Policies > Security Settings

> Security Options > Network Security in the left navigation tree and clear LAN
Manager authentication in the right pane. If LAN Manager authentication is not
cleared, remote access to the OS will fail after security hardening.

l The item Rename administrator account is under SetWin Policies > Security Settings
> Security Options > Accounts. After security hardening, the system administrator will
be renamed SWMaster. If you do not want the system administrator user to be renamed,
clear Rename administrator account.

Step 9 Choose Policy > Execute.

The message shown in Figure 3-4 is displayed.

Figure 3-4 Confirming password complexity

Step 10 Click Yes.

The message shown in Figure 3-5 is displayed.
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Figure 3-5 Confirming policy execution

Step 11 Click Yes.

When a browser is displayed, click Allow blocked content. The browser displays the
execution status of each security hardening item. If an item fails to be executed, view the
operation logs and solve the problem. If the problem persists, roll back the operation by
following instructions provided in Exception Handling.

When the "Execution completed" message indicating completion of security hardening is
displayed, click OK. A dialog box is displayed, prompting you whether to restart the OS for
the policy to take effect. Do not restart the OS because you still need to configure the firewall
port.

Step 12 Configure the firewall port.

1. Open the control panel.
2. Choose Windows Firewall > Advanced settings.

The Windows Firewall with Advanced Security page is displayed.
3. In the left navigation tree, right-click Inbound Rules and choose New Rule.

The New Inbound Rule Wizard page is displayed.
4. In the Rule Type pane, select Port and click Next.
5. Select Specific local ports and enter 8010,8443,33000,16100,11000-11500,2121 in the

text box.
6. Click Next until you go to the pane for setting a rule name.

Set a rule name.
7. Click Finish.

NOTE

If the created rule is displayed in the Inbound Rules pane and the rule state is , the rule has taken
effect.
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Step 13 Restart the OS to complete security hardening.

----End

Exception Handling

If the security hardening operation fails or you want to cancel it, perform the following steps
to roll back the operation:

Step 1 Right-click the SetWin icon and choose Run as Administrator.

The login page is displayed.

Step 2 Enter the user name and password and click Yes.

After performing security hardening, you must enter the user name and password of the
administrator to log in to the tool.

If Rename administrator account is selected for the security hardening policy in Step 8 in
Procedure, the user name of the system administrator is automatically changed to
SWMaster. The password remains unchanged.

Step 3 Choose Policy > Roll back.

The Open Rollback File dialog box is displayed.

Step 4 Select the file backed up in Step 7 in Procedure.

The rollback automatically starts. When the rollback is complete, you will be asked whether
to restart the OS for the configuration to take effect. Determine whether to restart the OS
based on the actual situation.

----End

3.2.2.3 Antivirus Solutions for Operating Systems

This section describes the antivirus solutions for operating systems to prevent viruses from
attacking NetEco 1000S software and virus spreading.

The NetEco 1000S software does not contain the antivirus software for the OS upon factory
delivery. You need to install the mainstream commercial antivirus software on the OS of the
NetEco 1000S.

l Update the antivirus software to the latest version in time.
l Enable the firewall.
l Enable the anti-DoS attack function.
l Enable the anti-port-scanning function.

NOTE

The preceding measures are some common functions of the antivirus software. To ensure your
information security, you must enable these functions in time.

3.2.3 Application Security
This section describes application security solutions dedicated to service applications, such as
user management, session management, and log management.
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3.2.3.1 User Authentication and Authorization Management

The system administrator must authenticate users and manage authorities so that only
authorized users can log in to the system and perform operations. This ensures system
security.

Users need to enter correct user names and passwords to log in to the NetEco 1000S. After
user authentication succeeds, the NetEco 1000S authenticates user operations and users can
perform only the operations that they are allowed to preform.

Role-based User Management Policies
l The commercial NetEco 1000S system provides four types of roles: system

administrator, system operators, guest users, and OpenAPI users.
l The residential NetEco 1000S system provides four types of roles: system administrator,

installers, customers, and OpenAPI users.

Role system administrator needs to classify users into the corresponding roles based on the
management mode.

Role system administrator is unique and cannot be added, modified or deleted.

User Information and Password Policies
l User information policies

User information managed on the NetEco 1000S includes the user name, description,
account validity, password, password validity period, user type.

l Password policies
Password policies include:
– Password complexity policy: Complex passwords are required to reduce possibility

of password cracking. Security administrators can set the password complexity
policy on the NetEco 1000S client. For details about password complexity
requirements, see 5.1.7.1.7 Setting a Password Policy.

– Password update policy: Security administrators need to pose restrictions on
password updates, such as password update period, message prompting for a new
password, and password validity period, to ensure that users update passwords
timely.

Authority Management Policies

Four types of roles provided by the NetEco 1000S system have different rights. You can set
user rights by specifying roles for users.

NOTE

l For details about the role rights in commercial NetEco 1000S system, see 5.1.7.1.1 User Categories.

l For details about the role rights in residential NetEco 1000S system, see 5.2.6.1.1 User Categories.

Idle Logout Time

The NetEco 1000S supports automatic client automatically logged out. If a user does not
perform any operations during the preset period, the NetEco 1000S client automatically
logged out. When the user attempts to log in to the NetEco 1000S client again, the user name
and password are required.
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3.2.3.2 Log Auditing
System administrator can audit operations and activities performed by NetEco 1000S users
and check for any illegal user operations.
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4 Installation and Commissioning

4.1 NetEco 1000S Installation and Commissioning
This section describe the installation and commissioning procedures of NetEco 1000S.

4.1.1 Installing Hardware

Direct Connection Using the RS232 Cable
Direct connection using the RS232 cable: It is applicable only to local commissioning. In this
case, you can search Inverter based on serial port addresses.

NOTE

Direct connection using the the RS232 cable applies only to the Windows 7 OS. The following serial
port-related functions are available only in the Windows 7 OS:

l Searching Devices Based on Serial Port Addresses

l Setting Parameters for the SMS Modem

l Setting Communication Parameters

You can connect the RS485 serial port on the Inverters to the idle RS232 serial port on the PC
by using the RS232 cable (RS485 needs to be converted to RS232 through the signal
converter). You can also connect multiple Inverters to one RS485 bus which is connected to
the PC serial port.

l The serial port number is the one used for connecting the monitoring PC and a device.
l The address of the RS485 bus is the RS485 Com Address of the Inverter. For details

about how to obtain this address, see the corresponding User Manual on the monitored
device side.
Contact Huawei technical support engineers to obtain the User Manual on the monitored
device side.
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NOTICE
It is recommended that no more than six inverters be connected to the bus for better
monitoring performance.
If new physical or logical serial ports are added on the PC on which the NetEco 1000S is
running, you need to restart the NetEco 1000S. Otherwise, the newly added ports cannot be
automatically identified by the NetEco 1000S.
Currently, the serial-port connection mode does not support security authentication, which
may introduce security risks. You are advised to use network cables for connection.

Connection by Using Network Cables
Connection by using network cables: It is applicable to remote Inverter monitoring. In this
case, you can search target device based on IP addresses.

l Connection using the SmartLogger: Connect the inverter, EMI, PID, PLC, or Meter to
the SmartLogger and then connect the SmartLogger to the monitoring PC through an IP
network.
The IP address is that of the SmartLogger. For details about how to obtain the IP address,
see the corresponding Smart Logger User Manual.
Contact Huawei technical support engineers to obtain the Smart Logger User Manual.

l Direct connection to the FE: Inverters that support direct connection to the FE can be
directly connected to the FE and can access the NetEco 1000S through the client.

4.1.2 Installing the NetEco 1000S Software

Preinstallation Check
Before installing the NetEco 1000S software, check whether the PC meets the requirements
listed in Table 4-1.
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Table 4-1 Preinstallation check item

Check Item Description

Software
package

Contacted Huawei technical support engineers to obtain the software
package
iManagerNetEco1000S_V100R002C70SPCXXX_win7_standard.zip or
iManagerNetEco1000S_V100R002C70SPCXXX_win2012_enterprise.zip.
To obtain the software package, Huawei technical support engineers can
choose SUPPORT > Software > Energy > PV Inverter > Smart PV
Plant System > iManager NetEco 1000S > V100R002C70 at http://
support.huawei.com/carrier/.
Contact the Huawei technical support engineers and obtain the signature
files
iManagerNetEco1000S_V100R002C70SPCXXX_win7_standard.zip.asc
and
theiManagerNetEco1000S_V100R002C70SPCXXX_win2012_enterpris
e.zip.asc from the path SUPPORT > Software > Energy > PV Inverter >
Smart PV Plant System > iManager NetEco 1000S > V100R002C70 on
the http://support.huawei.com/carrier/ website.
NOTE

l If the Windows Server 2012 OS is used, obtain the
iManagerNetEco1000S_V100R002C70SPCXXX_win2012_enterprise.zip
installation package and
iManagerNetEco1000S_V100R002C70SPCXXX_win2012_enterprise.zip.asc
digital signature file.

l If the Windows 7 or Windows 10 OS is used, obtain the
iManagerNetEco1000S_V100R002C70SPCXXX_win7_standard.zip
installation package and
iManagerNetEco1000S_V100R002C70SPCXXX_win7_standard.zip.asc
digital signature file.

You can check the integrity of the software package by referring to 5.1.8.6
Verifying OpenPGP Signature.
NOTE

Software package integrity check is related to the software security. You must
perform the check to ensure the software security.

Hardware Minimum configuration:
l Standard edition: CPU: 1*quad-core 2.4 GHz; memory: 4 GB; hard

disk: 250 GB
l Enterprise edition: CPU: 1*octa-core 2.4 GHz; memory: 12 GB; hard

disk: 600GB

Recommended configuration:
l Standard edition: CPU: 1*quad-core 3.6 GHz; memory: 4 GB; hard

disk: 500 GB or above
l Enterprise edition: CPU: 2*octa-core 3.6 GHz; memory: 16 GB; hard

disk: 2TB or above
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Check Item Description

Software Operating system:
l Standard edition: Windows 7 professional edition, Windows 7

enterprise edition, Windows 10 professional edition, or Windows 10
enterprise edition

l Enterprise edition: Windows Server 2012 standard edition
NOTE

The NetEco 1000S supports the Chinese, English, German, French, and Japanese
operating systems. For the Chinese, German, French, and Japanese operating
systems, only the NetEco 1000S with the same language can be installed. For the
English operating system, there is no requirement on the language of the NetEco
1000S.

Web browser: Internet Explorer 11 or Chrome 50.

The antivirus software that can be updated properly must be installed on
the PC.
You are not advised to install other applications.
You are not allowed to install the MySQL database.
Services that are unnecessary or have potential security risks must be
disabled.
Operating system patches must be updated in a timely manner.

Only users in the system administrator group can install the NetEco 1000S.
WARNING

Only a fixed user in the system administrator group can install and maintain the
NetEco 1000S. Other users in the system administrator group are not allowed to
reinstall the NetEco 1000S. Otherwise, the database for the installed NetEco 1000S
will be initialized and all data will be lost.

You are not allowed to share the NetEco 1000S installation directory with other
system accounts or grant the NetEco 1000S permission to other system accounts.
Otherwise, security risks may occur.

 

Procedure

Step 1 After the software package is decompressed, double-click setup.bat in the folder.

NOTICE
The path where the software package is decompressed consists of only letters or contains
letters, digits, and underscores (_). Otherwise, the installation fails.

During the installation, you can click Cancel in any window that has the Cancel button. A
Are you sure to cancel installation? dialog box is displayed.

l Click Yes to exit the installation.
l Click No to continue the installation.

The Select Installation Language window is displayed.
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Step 2 Choose English, and click OK.

The Introduction window is displayed.

Step 3 Click Next.

The Copyright Notice window is displayed.

Read the terms of the copyright notice in the Copyright Notice window.

Step 4 Select I agree, and click Next.

The Select Installation Directory window is displayed.

The default installation directory is D:\NetEco1000S\NetEco1000S.

WARNING
You are not allowed to install the software in a system volume.

You are not allowed to share the NetEco 1000S installation directory with other system
accounts or grant the NetEco 1000S permission to other system accounts. Otherwise, the
software cannot be used.

Step 5 Specify an installation directory and click Next.

NOTE

If the specified installation directory does not exist, the following information is displayed.
The directory D:\NetEco1000S\NetEco1000S does not exit. Do you want to create 
it?
l Click Yes to create the specified installation directory.

l Click No to return to the last step to re-specify an installation directory.

The installation directory consists of only letters or contains letters, digits, and underscores (_). The
installation directory length cannot exceed 50 characters.

The Set Currency and TimeZone Parameters window is displayed.

Step 6 Choose the currency and time zone you need, and click Next.

The Select Software Components window is displayed.

Step 7 Select NetEco 1000S for installation and click Next.

The Confirm Installation window is displayed.

Step 8 Confirm the installation settings and click Next.

The installation status window is displayed.

The Installation Completed window is displayed after the installation process reaches 100%.

Step 9 Click Finish.

When the software is installed successfully, the NetEco 1000S shortcut menu is available
under Start > All Program.
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NOTICE
l You are not allowed to change the OS time whereas installing the software.
l After the software is installed successfully, you are advised to remove the software

package. Otherwise, security risks may occur.

----End

4.1.3 Starting NetEco 1000S Services
This section describes how to start the NetEco 1000S services. Before logging in to the
NetEco 1000S, you need to start the NetEco 1000S services. Otherwise, the login will be fail.

Procedure

Step 1 Choose Start > All Program > NetEco 1000S > NetEco 1000S Service to start the NetEco
1000S services in the operating system.

l When the service is starting, the icon  is displayed in the lower right corner of the
taskbar of the desktop.

l After being started, the icon  is displayed
in the lower right corner of the taskbar of the desktop.

----End

Related Operations

Stop NetEco 1000S services.

Right-click the NetEco 1000S service icon in the lower right corner of the taskbar of the
desktop and choose Exit from the shortcut menu.

4.1.4 Logging In to the NetEco 1000S Client
This section describes how to log in to the NetEco 1000S before using the service functions
supported by NetEco 1000S.

Prerequisites
l You have started the NetEco 1000S services. For details about how to start the services,

see 4.1.3 Starting NetEco 1000S Services.
l You have obtained the user Account/Email and password for logging in to the NetEco

1000S.

Procedure

Step 1 Log in to the NetEco 1000S client in a correct mode as required.

iManager NetEco 1000S
User Manual 4 Installation and Commissioning

Issue Draft C (2017-12-14) Huawei Proprietary and Confidential
Copyright © Huawei Technologies Co., Ltd.

23



NOTICE
The web browser must be Internet Explorer 11 or Chrome 50. Otherwise, some browser
problems may occur when users query data.

Login Mode Procedure

Local login Use either of the following methods to log in to the NetEco 1000S
client:
l Choose Start > All Program > NetEco 1000S > NetEco 1000S

Client in the operating system.
l Double-click the NetEco 1000S client icon on the desktop of a PC

that running a Windows operating system.

Remote login 1. Open the web browser.
2. Enter https://IP address:8443 in the address bar, and press Enter.

 

If you have selected Use Security Web Service during NetEco 1000S installation, the GUI
shown in Figure 4-1 or Figure 4-2 will be displayed when you start the client.

Figure 4-1 Website Security Certificate window (Internet Explorer)

Figure 4-2 Website Security Certificate window (Chrome 50)
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NOTE

The HTTPS secure communication channel between the NetEco 1000S browser and the server is set up
to ensure that sensitive data (such as passwords) is transmitted securely. A security certificate is required
when the HTTPS channel is set up. A default security self-signed certificate is provided by the NetEco
1000S, but this default certificate is not issued by a Certificate Authority (CA). As a result, the message
There is a problem with this website's security certificate. is displayed. To replace the certificate, see
5.4.3.2 Replacing a Certificate for the NetEco 1000S Client Communicating with the Server.

Between the browser and the server using TLSv1.1 or TLSv1.2 way connection, these two ways are safe
connection mode.

When using the Internet Explorer, click Continue to this website (not recommended) in
Figure 4-1. When using the Chrome, choose Advanced > Proceed to IP or domain name
(unsafe) in Figure 4-2.

The Login window is displayed, as shown in Figure 4-3.

Figure 4-3 Login

Step 2 On the Login page, select a language to be used by the NetEco 1000S client from the drop-
down list box.

NOTE

l Chinese, English, Japanese, German, and French are supported. If you do not select a language, the
language used during the NetEco 1000S client installation is used.

l The selected language takes effect only for the currently user who is logged in using the current
browser.

l After changing the language, only the static information (information not entered by users) is
changed, such as the titles, menu names, and messages. Dynamically generated information such as
operation logs are still recorded and displayed in the language used during the NetEco 1000S client
installation. Information entered by users, such as the plant name, plant description, and device
name, are displayed in the language in which the information is entered.

l After you select a language on the Login page or the home page, the browser will record the
language information (for 30 days). If the browser cache is not cleared or disabled, the recorded
language is used upon your next login.

Step 3 Set Account/Email and Password when you log in to the NetEco 1000S for the first time,
and click Login.
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NOTICE
If the User Authorization page is displayed here, select Agree to the Privacy Policy and
Agree to the Terms of Use (If the Terms of Use is set not to be displayed, you cannot view
the Terms of Use here) before clicking OK to continue the operations. For details, see
5.1.8.22 What Do I Do to Control the User Authorization upon First Login?.

The System Initial Password page is automatically displayed after the password expires.
Change the password and log in to the NetEco 1000S client using the new password.

NOTICE
l Use the system administrator user when you log in to the NetEco 1000S for the first time.

This user has the highest operation rights.
l To improve system security, you are advised to change the initial keys set before product

delivery in a timely manner and periodically (at an interval of 3 months) change the user
key to avoid security risks, such as violent key cracking.

l The password cannot the user name or the reversed user name.
l The length ranges from 8 to 32 characters.
l The password contains three of the following:

– Lowercase letters
– Uppercase letters
– Digits

l The password is advised to contain special characters, which include !"#$%&'()*
+,-./:;<=>?@[\]^`{_|}~ and space.

If you forget the password, perform the following operations.

NOTICE
l Ensure that the email server has been configured. Otherwise, the password cannot be reset.

For details about how to configure the email server, see 5.1.7.3.1 Setting Parameters for
the Email Server.

l This operation requires that the current user is the system operators or guest users.
l A user can reset a password three times a day at most.

1. Click Forget Password.
The Reset Password page is displayed, as shown in Figure 4-4.
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Figure 4-4 Reset Password

2. Enter the email address and verification code.
3. Click OK.

The Operation succeeded. Confirm the initialization password within 5 minutes.
Otherwise, the confirmation email will be invalid. prompt message is displayed.

4. Click OK.
Check the email for retrieving the password and perform the operations specified in the
email.

NOTICE
If the link in the email cannot be accessed, check whether the IP address contained in the
link is the same as the IP address of the NetEco 1000S server. If no, change the IP
address contained in the link to the IP address of the NetEco 1000S server. Then, you can
access the link successfully.

----End

Exception Handling

When user B logs in to the client after user A logs in to it, the following problems may occur:

l After user B enters the login address in the address box of the browser, the login window
for user A is displayed but that for user B is not displayed.

l After user B logs in to the client, user A's session window is automatically switched to
user B's login window and user A is logged out.

The preceding problems are caused by the browser mechanism. They can be prevented using
the following methods:

l When using the Internet Explorer, choose File > New Session from the menu bar.
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In the displayed session window, enter the login address. You can log in to the client as
user B successfully.

l When using the Chrome, open the menu and choose New incognito window.
In the displayed incognito window, enter the login address. You can log in to the client as
user B successfully.

4.1.5 Logging Out of the NetEco 1000S Client

Procedure

Step 1 Click  in the upper right corner from the main menu to log out. The Login page is displayed.

----End

4.1.6 Logging Out of the NetEco 1000S Services

Prerequisites
You have logged out of the NetEco 1000S client. For detailed operations, see 4.1.5 Logging
Out of the NetEco 1000S Client.

Procedure

Step 1 Right-click the NetEco 1000S service icon  in the lower right corner of the task bar of the
desktop and choose Exit from the shortcut menu.

NOTE

If the  icon is not displayed in the lower right corner in the Windows operating system, perform the
following steps to stop the NetEco 1000S services:
1. Start the task manager.
2. Click the Services tab.
3. Stop the NetEcoSUNService Service.
4. Stop the NetEcoSUNMysql Service.

----End

4.1.7 Remove the NetEco 1000S Software
This section describes how to remove the NetEco 1000S software.

Prerequisites
The NetEco 1000S software has been installed.

Procedure

Step 1 Right-click NetEco 1000S in the lower right corner of the desktop and choose Exit from the
shortcut menu.

NOTE

If the NetEco 1000S service is not started, skip this step.
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Step 2 Choose Start > All Program > NetEco 1000S > Uninstall NetEco 1000S in the operating
system to start the uninstallation program.

The Select Software Components window is displayed.

Step 3 Select the NetEco 1000S component, and click Next.

Step 4 Click Yes.

The NetEco 1000S uninstallation progress is displayed in the window.

Step 5 Click Finish when the uninstallation is complete.

The Conformation dialog box is displayed.

Step 6 Determine whether to restart the operating system.
l If you click Yes, the operating system is restarted, and the NetEco 1000S installation

directory is deleted automatically.
l If you click No, the operating system will not be restarted, and you need to manually

delete the NetEco 1000S installation directory.

----End

4.2 NetEco 1000S APP Installation and Commissioning
This section describes installation and commissioning procedure of NetEco 1000S APP.

4.2.1 NetEco 1000S APP Networking
This section describes the networking schemes when the NetEco 1000S APP is used on the
mobile device.

The mobile device supports the following two typical networking schemes when the NetEco
1000S APP is used on the mobile device:

NOTE

Customers are responsible for all network design and network-device-level security planning.

l The mobile device is connected to the internal network of the NetEco 1000S directly.
Figure 4-5 shows the networking diagram.

Figure 4-5 Mobile device connecting to the internal network of the NetEco 1000S
directly
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NOTICE
The following requirements must be met when the mobile device is directly connected to the
internal network:
l You have configured a wireless router in the internal network.
l The mobile device is located in an area covered by Wi-Fi signals.

l The mobile device is connected to the internal network of the NetEco 1000S through the
virtual private network (VPN). Figure 4-6 shows the networking diagram.

Figure 4-6 Mobile device connecting to the internal network of the NetEco 1000S
through the VPN

NOTICE
The following requirements must be met when the mobile device is connected to the internal
network through the VPN:
l The VPN device is installed on the customer's internal network.
l Parameters, including the network port and virtual gateway, of the VPN device are

configured through the serial port or network port on the PC.
Configuration methods and parameters of the VPN devices vary with the vendors. For
details, see the VPN device description.

l Mobile terminal VPN access is configured on the mobile device. For example, choose
Settings > Wireless&networks; > VPN > Add VPN network on a Huawei mobile phone
to configure the VPN access.

l Port 33000 of the NetEco 1000S server is opened.

4.2.2 Installing the NetEco 1000S APP Software
This section describes the operating environment requirements of NetEco 1000S APP, how to
download and install the NetEco 1000S APP software.

Preinstallation Check

Before installing the NetEco 1000S APP software, check whether the mobile device meets the
requirements listed in Table 4-2.
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Table 4-2 Check items

Check
Item

Description

Operating
environm
ent

When the NetEco 1000S APP runs on a mobile device, the mobile device
must meet the following requirements:
l The mobile device must run the following OSs:

– Mobile phone or Pad running the OS later than Android 4.0
– Mobile phone or iPad running the OS later than iOS 6.0

l The mobile device is connected to the Internet properly. The rate is 500
kbit/s and higher.

l There are sufficient space and power on the mobile device so that new
apps can be installed.

Software
package

The NetEco 1000S APP software package has been obtained. If it is not
obtained, download it using the following methods:
l Mobile device running Android: Search for neteco on the Google Play.
l Mobile device running iOS: Search for neteco on the APP Store.

 

Procedure
1. Click the NetEco 1000S APP software package, and then install the NetEco 1000S APP

software according to the system information.
After the installation is complete, the icon of the NetEco 1000S APP is displayed on the
desktop of the mobile device.

4.2.3 Security Configuration for NetEco 1000S APP
To ensure system security, you must perform the following configurations before accessing
the NetEco 1000S system through the NetEco 1000S APP.

Context
The identification number of the mobile terminal has been anonymized on the NetEco 1000S
APP screen to protect user's privacy.

Procedure

Step 1 Obtain the identification number of the mobile terminal.

NOTE

Identification number of the iOS mobile terminal is the IDFV identifier. Identification numbers of other
mobile terminals are IMEIs/MEIDs of mobile phones or MAC addresses of tablets.

l Method of obtaining the IDFV identifier: When using the iOS mobile terminal to log in
to the NetEco 1000S APP, click IDFV on the login page to view the identifier.

l Method of obtaining the IMEI/MEID: Enter *#06# in the dial keyboard of your mobile
phone.

l Method of obtaining the MAC address: Choose Settings > WLAN > Advanced settings
on your tablet to view the MAC address.
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NOTE

The navigation path of Advanced settings may vary depending on the OS version. Choose the
corresponding path as required.

Step 2 Add the identification number of the mobile terminal to the NetEco 1000S.

1. Log in to the NetEco 1000S system through the web browser.

2. Choose System > User Management from the main menu.

3. Click Mobile Terminal, and then add the identification number of the mobile terminal.

----End

4.2.4 Logging In to the NetEco 1000S APP
After installing the NetEco 1000S APP on the mobile terminal, you can access the NetEco
1000S server through the NetEco 1000S APP.

Prerequisites
l You have added the identification number of the mobile terminal in the NetEco 1000S

system. For details, see 4.2.3 Security Configuration for NetEco 1000S APP.

l You have installed the NetEco 1000S APP software on the mobile terminal. For detailed
operations, see 4.2.2 Installing the NetEco 1000S APP Software.

l You have obtained the user Account/Email and password for logging in to NetEco 1000S
APP.

l The mobile terminal has been connected to the network.

Context

The NetEco 1000S APP can be installed on mobile terminals running iOS6.0, Android4.0,
and later versions. Different Android versions support different communication protocols.

l Versions earlier than Android4.4: supports TLSv1.

l Android4.4 and later: support TLSv1, TLSv1.1, and TLSv1.2.

The NetEco 1000S APP supports the TLSv1, TLSv1.1, and TLSv1.2 by default. The TLSv1
has security risks. You are advised to upgrade the Android. For mobile terminals running
Android4.4 or later, disable the TLSv1 by following the instructions provided in 5.3.4 How
Do I Disable the TLSv1?.

Procedure

Step 1 Click the NetEco 1000S APP icon on the desktop of the mobile terminal to open the login
page.

Step 2 Optional: Set the server address of the NetEco 1000S server if this is the first time that you
log in to the NetEco 1000S APP.

Server Addr. indicates the IP address of the NetEco 1000S server. Specify the IP address or
domain name of the server as required.
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Figure 4-7 Setting the server address

Step 3 Enter Account/Email and password.

Step 4 Click Log In.

NOTICE
If the message The Privacy Policy is updated. Log in to read and agree the Privacy Policy
on WebUI. is displayed, log in to the NetEco 1000S client and agree the Privacy Policy
before logging in to the NetEco 1000S app to continue the operations. For details, see 5.1.8.22
What Do I Do to Control the User Authorization upon First Login?.

After you successfully log in to the NetEco 1000S service, the Overview window is
displayed, as shown in Figure 4-8.
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Figure 4-8 Summary window

NOTE

l You can click  to view the version of the NetEco 1000S APP.

l You can click  to deregister an application.

l You can click  to update data on the overview page.

----End

4.3 Planning Operating System Users and Their Initial
Passwords

This section describes the user names and their initial passwords required during the operation
of the NetEco 1000S system.

Table 4-3 lists the user names and initial passwords required during the installation and
operation of the NetEco 1000S system, and their creation time.
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Table 4-3 Planning of user names and passwords

System or
Device

User
Name

Initial
User
Password

Description How to Change the
Password

MySQL administ
rator

NetEco_1
23

Administrator who
managing the MySQL
database.

You are advised to
change the password
after you install the
NetEco 1000S for the
first time, and change
the password every
three months.
For details, see
5.4.1.1.2 Changing
the Passwords of
MySQL Users.

dbuser NetEco_1
23

User used for NetEco
1000S system access the
MySQL database.

NetEco
1000S

admin Changeme
123

User who operates and
maintains the NetEco
1000S system. You can
manage the NetEco
1000S users by creating
users.
NOTE

When you log in to the
NetEco 1000S for the
first time, the system
forces the user to change
the password to make
sure the security of
visiting the system.

You are advised to
change the password
after you install the
NetEco 1000S for the
first time, and change
the password every
three months.
For details, see
5.1.7.1.5 Modifying
the Password of the
Current User.

emscom
m

/EzFp
+2%r6@I
xSCv

User used for the
reauthentication of the
device and NetEco
1000S.

You are advised to
change the password
after you install the
NetEco 1000S for the
first time, and change
the password every
three months.
For details, see
5.1.3.11 Changing
the Authentication
Passwords of the
SmartLogger and
NetEco 1000S.
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System or
Device

User
Name

Initial
User
Password

Description How to Change the
Password

ftpuser NetEco12
3

User ftpuser is used by
the NetEco 1000S to
transfer NetEco 1000S
files. Normally, during
the installation of the
NetEco 1000S, user
ftpuser is automatically
created in the system,
and therefore you need
not create user ftpuser
manually.

You are advised to
change the password
after you install the
NetEco 1000S for the
first time, and change
the password every
three months.
For details, see
5.1.8.12 How Do I
Change the
Password of the
ftpuser user?.

plantcon
troller

Modifyme
123

User used for the Plant
Controller devices to
transfer files to the
NetEco 1000S.

You are advised to
change the password
after you install the
NetEco 1000S for the
first time, and change
the password every
three months.
For details, see
5.1.8.16 How Do I
Change the
Password of the
plantcontroller
user?.

 

4.4 Communication Matrix
For details, see iManager NetEco 1000S V100R002C70 Communication Matrix.xls.
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5 Operation and Maintenance

5.1 NetEco 1000S Web Client Operation (Commercial)
This section describes how to log in to the NetEco 1000S and how to perform the operations
to the NetEco 1000S on the web client.

You are not allowed to change the OS time whereas the software is running. When you need
to change the OS time, you must log out the NetEco service first, for details, see 5.1.1.2
Logging Out of the NetEco 1000S.

5.1.1 Getting Started

5.1.1.1 Logging In to the NetEco 1000S

5.1.1.1.1 Starting NetEco 1000S Services

This section describes how to start the NetEco 1000S services. Before logging in to the
NetEco 1000S, you need to start the NetEco 1000S services. Otherwise, the login will be fail.

Procedure

Step 1 Choose Start > All Program > NetEco 1000S > NetEco 1000S Service to start the NetEco
1000S services in the operating system.

l When the service is starting, the icon  is displayed in the lower right corner of the
taskbar of the desktop.

l After being started, the icon  is displayed
in the lower right corner of the taskbar of the desktop.

----End

Related Operations
Stop NetEco 1000S services.

iManager NetEco 1000S
User Manual 5 Operation and Maintenance

Issue Draft C (2017-12-14) Huawei Proprietary and Confidential
Copyright © Huawei Technologies Co., Ltd.

37



Right-click the NetEco 1000S service icon in the lower right corner of the taskbar of the
desktop and choose Exit from the shortcut menu.

5.1.1.1.2 Logging In to the NetEco 1000S Client

This section describes how to log in to the NetEco 1000S before using the service functions
supported by NetEco 1000S.

Prerequisites
l You have started the NetEco 1000S services. For details about how to start the services,

see 5.1.1.1.1 Starting NetEco 1000S Services.
l You have obtained the user Account/Email and password for logging in to the NetEco

1000S.

Procedure

Step 1 Log in to the NetEco 1000S client in a correct mode as required.

NOTICE
The web browser must be Internet Explorer 11 or Chrome 50. Otherwise, some browser
problems may occur when users query data.

Login Mode Procedure

Local login Use either of the following methods to log in to the NetEco 1000S
client:
l Choose Start > All Program > NetEco 1000S > NetEco 1000S

Client in the operating system.
l Double-click the NetEco 1000S client icon on the desktop of a PC

that running a Windows operating system.

Remote login 1. Open the web browser.
2. Enter https://IP address:8443 in the address bar, and press Enter.

 

If you have selected Use Security Web Service during NetEco 1000S installation, the GUI
shown in Figure 5-1 or Figure 5-2 will be displayed when you start the client.
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Figure 5-1 Website Security Certificate window (Internet Explorer)

Figure 5-2 Website Security Certificate window (Chrome 50)

NOTE

The HTTPS secure communication channel between the NetEco 1000S browser and the server is set up
to ensure that sensitive data (such as passwords) is transmitted securely. A security certificate is required
when the HTTPS channel is set up. A default security self-signed certificate is provided by the NetEco
1000S, but this default certificate is not issued by a Certificate Authority (CA). As a result, the message
There is a problem with this website's security certificate. is displayed. To replace the certificate, see
5.4.3.2 Replacing a Certificate for the NetEco 1000S Client Communicating with the Server.

Between the browser and the server using TLSv1.1 or TLSv1.2 way connection, these two ways are safe
connection mode.

When using the Internet Explorer, click Continue to this website (not recommended) in
Figure 5-1. When using the Chrome, choose Advanced > Proceed to IP or domain name
(unsafe) in Figure 5-2.

The Login window is displayed, as shown in Figure 5-3.
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Figure 5-3 Login

Step 2 On the Login page, select a language to be used by the NetEco 1000S client from the drop-
down list box.

NOTE

l Chinese, English, Japanese, German, and French are supported. If you do not select a language, the
language used during the NetEco 1000S client installation is used.

l The selected language takes effect only for the currently user who is logged in using the current
browser.

l After changing the language, only the static information (information not entered by users) is
changed, such as the titles, menu names, and messages. Dynamically generated information such as
operation logs are still recorded and displayed in the language used during the NetEco 1000S client
installation. Information entered by users, such as the plant name, plant description, and device
name, are displayed in the language in which the information is entered.

l After you select a language on the Login page or the home page, the browser will record the
language information (for 30 days). If the browser cache is not cleared or disabled, the recorded
language is used upon your next login.

Step 3 Set Account/Email and Password when you log in to the NetEco 1000S for the first time,
and click Login.

NOTICE
If the User Authorization page is displayed here, select Agree to the Privacy Policy and
Agree to the Terms of Use (If the Terms of Use is set not to be displayed, you cannot view
the Terms of Use here) before clicking OK to continue the operations. For details, see
5.1.8.22 What Do I Do to Control the User Authorization upon First Login?.

The System Initial Password page is automatically displayed after the password expires.
Change the password and log in to the NetEco 1000S client using the new password.
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NOTICE
l Use the system administrator user when you log in to the NetEco 1000S for the first time.

This user has the highest operation rights.
l To improve system security, you are advised to change the initial keys set before product

delivery in a timely manner and periodically (at an interval of 3 months) change the user
key to avoid security risks, such as violent key cracking.

l The password cannot the user name or the reversed user name.
l The length ranges from 8 to 32 characters.
l The password contains three of the following:

– Lowercase letters
– Uppercase letters
– Digits

l The password is advised to contain special characters, which include !"#$%&'()*
+,-./:;<=>?@[\]^`{_|}~ and space.

If you forget the password, perform the following operations.

NOTICE
l Ensure that the email server has been configured. Otherwise, the password cannot be reset.

For details about how to configure the email server, see 5.1.7.3.1 Setting Parameters for
the Email Server.

l This operation requires that the current user is the system operators or guest users.
l A user can reset a password three times a day at most.

1. Click Forget Password.
The Reset Password page is displayed, as shown in Figure 5-4.

iManager NetEco 1000S
User Manual 5 Operation and Maintenance

Issue Draft C (2017-12-14) Huawei Proprietary and Confidential
Copyright © Huawei Technologies Co., Ltd.

41



Figure 5-4 Reset Password

2. Enter the email address and verification code.
3. Click OK.

The Operation succeeded. Confirm the initialization password within 5 minutes.
Otherwise, the confirmation email will be invalid. prompt message is displayed.

4. Click OK.
Check the email for retrieving the password and perform the operations specified in the
email.

NOTICE
If the link in the email cannot be accessed, check whether the IP address contained in the
link is the same as the IP address of the NetEco 1000S server. If no, change the IP
address contained in the link to the IP address of the NetEco 1000S server. Then, you can
access the link successfully.

----End

Exception Handling

When user B logs in to the client after user A logs in to it, the following problems may occur:

l After user B enters the login address in the address box of the browser, the login window
for user A is displayed but that for user B is not displayed.

l After user B logs in to the client, user A's session window is automatically switched to
user B's login window and user A is logged out.

The preceding problems are caused by the browser mechanism. They can be prevented using
the following methods:

l When using the Internet Explorer, choose File > New Session from the menu bar.
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In the displayed session window, enter the login address. You can log in to the client as
user B successfully.

l When using the Chrome, open the menu and choose New incognito window.

In the displayed incognito window, enter the login address. You can log in to the client as
user B successfully.

5.1.1.2 Logging Out of the NetEco 1000S

5.1.1.2.1 Logging Out of the NetEco 1000S Client

Procedure

Step 1 Click  in the upper right corner from the main menu to log out. The Login page is displayed.

----End

5.1.1.2.2 Logging Out of the NetEco 1000S Services

Prerequisites

You have logged out of the NetEco 1000S client. For detailed operations, see 5.1.1.2.1
Logging Out of the NetEco 1000S Client.

Procedure

Step 1 Right-click the NetEco 1000S service icon  in the lower right corner of the task bar of the
desktop and choose Exit from the shortcut menu.

NOTE

If the  icon is not displayed in the lower right corner in the Windows operating system, perform the
following steps to stop the NetEco 1000S services:

1. Start the task manager.

2. Click the Services tab.

3. Stop the NetEcoSUNService Service.

4. Stop the NetEcoSUNMysql Service.

----End

5.1.1.3 Getting to Know the NetEco 1000S Home Page

This section describes the NetEco 1000S home page. Getting familiar with the NetEco 1000S
home page helps you quickly find the entry for an operation and improve operation efficiency.

Figure 5-5 shows the home page of the NetEco 1000S client after the login. Table 5-1
describes items on the home page.
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Figure 5-5 NetEco 1000S home page

Table 5-1 Items on the NetEco 1000S home page

No. Name Description

1 Device
navigation tree

You can choose the device to be operated.

2 Menu bar Indicates the main menu of the system.

3 Operation
display area

Displays the GUI of the selected function.

4 You can click this icon to select a language to be used by the
NetEco 1000S client.
NOTE

l Chinese, English, Japanese, German, and French are supported. If
you do not select a language, the language used during the NetEco
1000S client installation is used.

l The selected language takes effect only for the currently user who
is logged in using the current browser.

l After changing the language, only the static information
(information not entered by users) is changed, such as the titles,
menu names, and messages. Dynamically generated information
such as operation logs are still recorded and displayed in the
language used during the NetEco 1000S client installation.
Information entered by users, such as the plant name, plant
description, and device name, are displayed in the language in
which the information is entered.

l After you select a language on the Login page or the home page,
the browser will record the language information (for 30 days). If
the browser cache is not cleared or disabled, the recorded language
is used upon your next login.

5 Current logged-
in user

Displays the name of the current logged-in user.

6 Password
changing icon

You can click this icon to change the current user name.
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No. Name Description

7 User
Authorization
icon

You can click this icon to open the User Authorization page
to view the Privacy Policy and Terms of Use.
NOTE

l If the Terms of Use is set to not be displayed, you cannot view the
Terms of Use here.

l If no user authorization is required upon the first login, there will
not be this icon. For detailed operations, see 5.1.8.22 What Do I
Do to Control the User Authorization upon First Login?.

8 Help icon You can click Help under this icon to open the online help.
You can click About under this icon to check the version
information.

9 Exit icon You can click this icon to exit the client.

10 NetEco Alarm
icon

Displays whether the NetEco 1000S has generated alarms.

l : The NetEco 1000S has generated alarms. For details,
see 5.1.6.6 Querying NetEco Alarms.

l : The NetEco 1000S generates no alarm.

11 Alarm board
icon

Displays the number of the current alarms. Alarms of different
alarm severities are marked in different colors. You can click
this icon to enter the Alarms window. Table 5-2 lists the icon
meaning.

 

Table 5-2 Alarm status images

Image Status

Critical

Minor

Major

Warning

 

5.1.2 Managing the PV Plants

5.1.2.1 Browsing the PV Plant List

This section describes how to browse the PV Plant list to learn the overview of all PV plants
connected to the NetEco 1000S.
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Prerequisites

You have logged in to the NetEco 1000S client. For detailed operations, see 5.1.1.1.2 Logging
In to the NetEco 1000S Client.

Context

The PV plant list displayed on the Plant List page varies according to the logged-in user. The
details are as follows:

l system administrator: displays all PV plants connected to the NetEco 1000S.

l system operators or guest users: displays only PV plants that the current user can access.

Procedure

Step 1 Choose Monitor from the main menu.

Step 2 Choose PV System in the navigation tree on the left.

Step 3 Choose the Plant List tab in the operation display area.

The Plant List page is displayed, as shown in Figure 5-6.

Figure 5-6 Plant List

You can view data, such as the current status and performance ratio, of each PV plant on the
Plant List page. For details, see Table 5-3.

Table 5-3 Parameter description

Parameter Description

PV plant name Name of a PV plant.
NOTE

l You can click a PV plant name to switch to the Details page of
the PV plant.

l You can click  next to the PV plant name column to sort PV
plants by name in ascending or descending order.

l PV plant names are sorted in Unicode mode. The priority of PV
plants whose names contain -, digits, uppercase letters, _,
lowercase letters, and Chinese characters decreases in sequence.

Status Alarm with the highest severity in a PV plant.
NOTE

l You can click  next to the Status column to sort alarms by
severity in ascending or descending order.

l If no devices are connected in the current PV plant, - will be
displayed.
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Parameter Description

PV plant address Address of a PV plant.
NOTE

l Click  on the left of PV plant address to sort PV plants in
ascending or descending order.

l PV plant addresses are sorted in Unicode mode. The priority of
PV plants whose names contain hyphens (-), digits, uppercase
letters, underscores (_), lowercase letters, or Chinese characters
decreases in sequence.

Rated Power Total rated power of inverters in a PV plant.

Performance Ratio Energy generation performance ratio of a PV plant.
NOTE

If none of the inverters in the PV plant is configured with string
capacity or no EMIs are connected to the PV plant, a hyphen (-) is
displayed.

Total Power Total power of a PV plant.

Energy Yield of Current
Day

Current-day energy yield of a PV plant.

Total Energy Yield Total energy yield of a PV plant.

Income Total income of a PV plant.
NOTE

Currency of the total income of a PV plant is the standard currency
selected when the NetEco 1000S is installed.

Time zone City Time zone where the plant is located.

Enable
daylight
saving time

Indicating whether the daylight saving time is used in the
time zone where the plant is located.
If the daylight saving time is not used, - will be displayed.

 

----End

5.1.2.2 Creating a PV Plant

This section describes how to create a plant. After the NetEco 1000S is installed, a default
plant is available. You can also create another plant as required.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.1.1.1.2

Logging In to the NetEco 1000S Client.
l You have logged in as system administrator or system operator.

Procedure

Step 1 Choose Monitor from the main menu.
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Step 2 Click in the navigation tree on the left.

The Create PV Plant window is displayed.

Step 3 Set plant parameters by referring to Table 5-4.

Table 5-4 PV Plant parameters

Parameter name Mandatory
(Yes/No)

Description

PV plant name Yes Name of a PV plant.

PV plant address No Address of a PV plant.
You can set this parameter as required.

PV plant description No Description of a PV plant.
You can enter utility information about the PV
plant.

SN No SN of the inverters directly connected to the FE
or SmartLogger. Multiple SNs are separated by
semicolons (;).
You can enter the SN of the inverters directly
connected to the FE or SmartLogger. After a PV
plant is created on the NetEco 1000S, the
inverters directly connected to the FE or
SmartLogger automatically mounts the
SmartLogger and devices connected to the
SmartLogger to the PV plant.

City Yes Select the time zone for the plant from the drop-
down list box. The time zone where the NetEco
1000S server is located is selected by default.
If the daylight saving time is used in the selected
time zone, the Enable daylight saving time
check box will be displayed. You can select the
check box to enable daylight saving time.

Electricity price Yes Price of the power.
Value range: 0.0000-99.9999

Currency Yes Price unit.
You can set the unit in the Income Settings
dialog box by choosing System > System
Settings > Income Settings.

 

Step 4 Click Save.

----End
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5.1.2.3 Obtaining an Overview of a PV Plant
You can learn the device status and PV plant running information by querying the overview of
the PV plant.

Prerequisites
You have logged in to the NetEco 1000S client. For detailed operations, see 5.1.1.1.2 Logging
In to the NetEco 1000S Client.

Procedure

Step 1 Choose Monitor from the main menu.

Step 2 Choose PV System or a user-defined plant in the navigation tree on the left.

Step 3 Click the Details tab in the operation display area.

Running status information about the selected plant is displayed on the Details tab page, such
as power generation efficiency and cumulative generated power.

NOTE

If the DST is enabled on the SmartLogger, the following situations may occur:

l When users query data generated on the date shifting to the DST, the queried graph or table has no
data on this time segment.

l When users query data generated on the date shifting out of the DST, the queried graph or table
displays only the latest one data record on this time segment.

----End

Follow-up Procedure
Perform the following operations on the Details tab page:
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Procedure Step

View details about Energy
Yield of Current Day, Total
Energy Yield, Performance
Ratio, CO2 Reduction, Total
Power, Specific Energy,
Income, and Total
Irradiance.
NOTE

l You can view details about
Income only on the Details
page of the PV system.

l Performance Ratio, Specific
Energy and Total Irradiance
are not displayed on the
Details tab page of the PV
System.

l Performance Ratio and
Total Irradiance are
displayed on the Details tab
page of the plant only when
devices in the plant contain
environment monitors.

l If multiple EMIs are
connected to the PV plant,
values of Performance Ratio
and Total Irradiance are
calculated according to data
reported by the EMI selected
on the Settings tab page of
the PV plant.

l If the value of Performance
Ratio is displayed in red for a
plant, the performance ratio is
abnormal. Handle the issue
by following the instructions
provided in 5.1.8.18 How Do
I Solve the Problem that the
Calculated Performance
Ratio Is Inaccurate?.

The way of viewing each running information about a
plant is the same. Viewing information about Energy
Yield of Current Day is used as an example:
1. Move the mouse pointer to the pane displaying the

information about Energy Yield of Current Day.
The View Details link is displayed.

Figure 5-7 View Details

2. Click View Details.
Information about Energy Yield of Current Day for
each device is displayed in the Details window.
NOTE

In the PV System, information about Energy Yield of
Current Day for each plant will be displayed.

iManager NetEco 1000S
User Manual 5 Operation and Maintenance

Issue Draft C (2017-12-14) Huawei Proprietary and Confidential
Copyright © Huawei Technologies Co., Ltd.

50



Procedure Step

View the information about
inverters accessed in PV plant.
NOTE

If the value of Total string
capacity in inverter information
is displayed in red, Total string
capacity is not configured for the
inverter. Configure it by
following the instructions
provided in 5.1.3.6 Modifying
the Information About a
Device.

l On the Details tab page of the PV System, you can
view the icons of the inverters connected to all PV
plants.

l On the Details tab page of the PV plant, you can view
the icons of all the inverters connected to the PV
plant.

NOTE
The inverter icons indicate the following inverter versions:

l Icons of SUN2000 inverter

l 28KTL and earlier versions: 

l 33KTL to 30KTL-A versions: 

l 50KTL-C1 and later versions: 

l Icon of SUN8000 inverter: 

l Icon of SUN2000L inverter: 
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Procedure Step

View the PV plant power and
total irradiance curve.

View the PV plant power and total irradiance curve in the
PV Plant Power Statistics area, as shown in Figure 5-8.

Figure 5-8 PV plant power and total irradiance curve

Each coordinate is defined as follows:
l Left vertical coordinate: PV plant power
l Right vertical coordinate: total irradiance

The PV plant power and total irradiance are displayed
only when an EMI is connected to the PV plant.
Values of the vertical coordinates are calculated based
on the EMI selected on the Settings page for the PV
plant.

l Horizontal coordinate: data collection period. The
interval is two hours. For how to configure Collection
time, please see 5.1.2.6 Modifying the Information
About a PV Plant.

NOTE
The start time of the horizontal coordinate is an even number. If
the data collection start time configured in 5.1.2.6 Modifying
the Information About a PV Plant is an odd number, use the
previous one even number as the start time of the horizontal
coordinate. For example, if the start time for Collection time is
set to 01:00, the start time of the horizontal coordinate is 00:00.

Click Power or Total Irradiance on

 to close the corresponding
curve and click them again to display the curve.

Switch to the Performance
Data page.

Click MORE on the right of Details.

Switch the mode for displaying
power statistics.

Click Table or Graph in the lower area of the PV Plant
Power Statistics column.

l : The power statistics are displayed in a
table.

l : The power statistics are displayed in a
line chart.

NOTE
The power statistics are displayed in a line chart by default.
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5.1.2.4 Browsing the Device List of a PV Plant

This section describes how to browse the device list of a plant to learn the devices in the plant.

Prerequisites

You have logged in to the NetEco 1000S client. For detailed operations, see 5.1.1.1.2 Logging
In to the NetEco 1000S Client.

Procedure

Step 1 Choose Monitor from the main menu.

Step 2 Choose PV System or a user-defined plant in the navigation tree on the left.

Step 3 Click the Device List tab in the operation display area.

Key information about all devices under the selected plant is displayed on the Device List tab
page, as shown in Figure 5-9.

Figure 5-9 Overview of Device Information

NOTE

If multiple environmental monitoring instruments (EMIs) are connected to the PV plant, you can select
the EMI to be checked from the EMI drop-down list in the upper left corner. Coefficients, such as Total
irradiance, Daily irradiation amount, and Environment temperature, of the EMI are displayed.

 in the upper right corner provides the function of displaying only specified columns in the
table on the Device List tab page. To display specified columns, perform the following steps:

1. Click .

The Select Column dialog box is displayed.

2. Select the names of the columns that need to be displayed. Then, click OK.

----End

Follow-up Procedure

System administrator and system operators can also perform the following operations on the
Device List tab page:
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Operation Steps

Start the real-time data
collection task

1. Select one or more devices for which you want to
start the real-time data collection task.

2. Click .
3. In the displayed dialog box, click OK.
NOTE

The period with which the SmartLogger collects real-time data
of devices vary with its version.

l The SmartLogger of an old version (earlier than
V100R001C95SPC020) collects real-time data of devices
every minute.

l The SmartLogger of a new version (V100R001C95SPC020
or later) collects real-time data of devices using the value of
Real-time data collection period on the Settings tab page
of a PV plant as the period.

If you modify Real-time data collection period after starting
the real-time data collection task mounted under the
SmartLogger of a new version, you need to stop the task and
then start it again. In this way, the SmartLogger can collect real-
time data using the new Real-time data collection period value
as the period.

Stop the real-time data
collection task

1. Select one or more devices for which you want to
stop the real-time data collection task.

2. Click .
3. In the displayed dialog box, click OK.

 

5.1.2.5 Browsing Alarm Information About a PV Plant

This section describes how to browse alarm information about a plant to learn about the
current alarms for all devices under the plant.

Prerequisites

You have logged in to the NetEco 1000S client. For detailed operations, see 5.1.1.1.2 Logging
In to the NetEco 1000S Client.

Procedure

Step 1 Choose Monitor from the main menu.

Step 2 Choose PV System or a user-defined plant in the navigation tree on the left.

Step 3 Click the Alarm tab in the operation display area.

The current alarms for all devices under the selected plant is displayed on the Alarm tab page,
as shown in Figure 5-10.
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Figure 5-10 Overview of Alarm Information about a PV Plant

Step 4 Optional: Click an alarm name in the Alarm Name column to view the details.

NOTE

Alarms that have not been browsed are highlighted in bold.

Step 5 Optional: Click Export to export the queried alarm information into a CSV file.

----End

Follow-up Procedure

Click Lock. Alarms are no longer automatically updated on the Alarm page. In this way, you
can view the alarms reported only before the lock. To enable the automatic update function
again and view newly reported alarms, click Scroll Unlock.

NOTE

If excessive alarms are generated, these alarms are displayed on multiple pages. In this case, pages
except the first one are locked and the Scroll Unlock button is unavailable for you to unlock those
pages.

By default, the alarm lock function on the Alarm page is disabled.

5.1.2.6 Modifying the Information About a PV Plant

This section describes how to modify the information about a plant on the NetEco 1000S if
the information is inconsistent with that about the actual plant.

Prerequisites

You have logged in to the NetEco 1000S client. For detailed operations, see 5.1.1.1.2 Logging
In to the NetEco 1000S Client.

Procedure

Step 1 Choose Monitor from the main menu.

Step 2 Select the plant whose information is to be changed in the navigation tree on the left.

Step 3 Click the Settings tab in the operation display area.

Information about the selected plant is displayed on the Settings tab page.
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NOTE

In PV Plant Description area, Initialization time indicates the creating time of the plant, and it is non-
editable.

Step 4 Click Refresh in the upper right corner to refresh the parameter information.

Step 5 Modify the following information about a plant as required.
l The guest user could only modify the parameters in Table 5-5.
l The system administrator and system operator can modify the parameters both in Table

5-5 and Table 5-6.

Table 5-5 Basic parameters of the PV plant

Parameter Type Parameter Description

PV Plant
Description

PV plant name Enter a PV plant name.

Description Enter the description of a PV plant.

PV plant address Enter the PV plant address.

Parameter Setting Ratio threshold(%) Set the ratio threshold as required.

Electricity price Set the electricity price as required.
NOTE

l If you want to update the income within
historical time segments (current day also
included), change the electricity price, click
Update Income, and select a historical time
segment.

l If you need the income to be calculated based on
the new electricity price from current day on,
click Save in the upper-right corner of the
configuration page.

Currency Set the currency as required.

CO2 emission
reduction coefficient
(kg/kWh)

Set the CO2 emission reduction coefficient as
required.
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Table 5-6 Parameters of the PV plant

Parameter Type Parameter Description

Parameter Setting Reference Value
Settings

Incomplete historical energy yield data may
lead to an inaccurate income value. You can set
reference values to correct the income value.
1. On the Settings page of PV plants, click

Reference Value Settings.
The Reference Value Settings dialog box is
displayed.

2. Click Auto Calculate or enter a total energy
yield reference value, and specify the
electricity price.
NOTE

– The default value is the electricity price set
for the PV plant.

– The value of this parameter cannot be
modified. It is automatically calculated by
multiplying Total energy yield reference
value(kWh) and Electricity price.

3. Click OK to save the modification.

Time Zone
Setting

Change the time zone for the plant.
1. Click Time Zone Settings on the Settings

page of the plant.
The Time Zone Settings dialog box is
displayed.

2. Select the time zone for the plant from the
City drop-down list box.

3. Enable or disable the daylight saving time
from the Enable daylight saving time
drop-down list box.
NOTE

You can set the parameter only if the selected
time zone uses the daylight saving time.

4. Click OK to save the setting.

Performance ratio
configuration
NOTE
l For details about

how to calculate
the plant
performance
ratio, see
5.1.5.3.2
Querying the
Energy Yield
Performance
Ratio of the PV
Plant.

Line loss(%) Line loss indicates the power loss when electric
lines are transferring power. Line loss should
be excluded from the energy yield for
calculating the plant Specific Energy and
Performance Ratio.
Value range: 0.00–10.00.
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Parameter Type Parameter Description

EMI Data from EMI selected here is used to
calculate the values of Performance Ratio and
Availability, as well as the EMI values of PV
Plant Overview, PV Plant Analysis, and Data
Export.
1. Click Select EMI.

The Select EMI dialog box is displayed.
2. Select a target EMI.

NOTE
– Mean value on the Select EMI page

indicates that the average value is used for
calculation. The Mean value option is
displayed only when multiple EMIs access
the PV plant.
If only one EMI is connected to the PV plant,
set this parameter to the connected EMI by
default.

– Select Display EMIs of other plants. Select
an EMI that is connected to other plants.

3. Click OK.

Component peak
power
temperature
coefficient(%/°C)

Used for calculating the temperature correction
coefficient.
Value range: 0.00–0.99.

Update Historical
PR

1. Click Update Historical PR.
The Update Historical PR dialog box is
displayed.

2. Specify Start time and End time.
NOTE

The specified time period must be within recent
30 days. The time of the current date or later
cannot be selected.

3. Click OK.
Specific Energy, Performance Ratio, and
Availability, as well as EMI values of the
PV Plant Overview, PV Plant Analysis,
and Data Export of the PV plant within the
time segments selected are calculated based
on the latest parameters.

Availability
Configuration

PR value
range(%)

Availability is not calculated for the period
when the PR value is outside the configured
range.
Default value: 65-95

Minimum
irradiance(W/m2)

Default value: 50
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Parameter Type Parameter Description

Downtime rate
threshold(%)

Availability is not calculated for the period
when the downtime rate exceeds the configured
threshold.
Default value: 10

Update Historical
Availability

1. Click Update Historical Availability.
The Update Historical Availability dialog
box is displayed.

2. Set Start time and End time.
NOTE

– The interval between Start time and End
time must not exceed 30 days.

– The interval between Start time and the
current time must not exceed 30 days.

3. Click OK.

Communicate
Parameter

Collection time Collection time indicates that the SmartLogger
or the inverter directly connected to the FE in
the current plant needs to collect device
performance data of this period on a day.

Real-time data
collection period

Real-time data collection period indicates that
the SmartLogger or the inverter directly
connected to the FE in the current plant needs
to collect changed device performance data by
this period in real time.

Full
synchronization
period (minutes)

Full synchronization period (minutes)
indicates that the SmartLogger or the inverter
directly connected to the FE in the current plant
needs to collect all device performance data by
this period in real time.

Performance file
collection period
(minutes)

Performance file collection period (minutes)
indicates that the SmartLogger or the inverter
directly connected to the FE in the current plant
needs to collect historical device performance
data by this period.

 

Step 6 Modify the plant image.

1. Click Upload.
2. Select a plant image and click Open.

NOTE

The size of the plant image must be less than 5 MB, and the image can be saved only in jpg, png, or gif
format. Otherwise, the image fails to be uploaded.

Step 7 Optional: Remotely control devices.
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l Click  to synchronize time. The NetEco 1000S performs time synchronization to
synchronize time from the NetEco 1000S server to devices in the current plant.

NOTE

You can synchronize time only as system administrator.

l Power on or off inverters, see 5.1.3.8 Remotely Controlling an Inverter.

----End

5.1.2.7 Deleting a PV Plant

This section describes how to delete a plant that is created incorrectly or do not need to be
managed after network adjustment from the NetEco 1000S.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.1.1.1.2

Logging In to the NetEco 1000S Client.

l You have logged in as system administrator or system operator.

Procedure

Step 1 Choose Monitor from the main menu.

Step 2 Select the plant to be deleted in the navigation tree on the left.

Step 3 Click .

A confirmation dialog box containing the message Are you sure you want to delete? is
displayed.

NOTE

A plant can be deleted only when no device exists under it. Otherwise,  is dimmed.

Step 4 Click Yes.

A dialog box containing the message Deletion succeeded is displayed.

Step 5 Click OK.

----End

5.1.3 Managing Devices

5.1.3.1 Accessing Devices Through the SmartLogger

This section describes how to enable devices to access the NetEco 1000S through the
SmartLogger, helping manage and monitor devices through the NetEco 1000S.
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Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.1.1.1.2

Logging In to the NetEco 1000S Client.
l Devices access NetEco 1000S through SmartLogger. SmartLogger and NetEco 1000S

must be in the same time zone. For details on how to set the time zone of SmartLogger,
see 5.1.3.6 Modifying the Information About a Device or Smart Logger User Manual.

l You have set the IP address of NetEco 1000S on the web page of the SmartLogger. For
detailed operations, see Smart Logger User Manual.

l You have obtained the authentication passwords of the SmartLogger and NetEco 1000S
and the SN of the SmartLogger.

l You have created the target plant. For detailed operations, see 5.1.2.2 Creating a PV
Plant.

Context
l If the NetEco 1000S or SmartLogger is powered on and started before the device, the

device list displayed on the NetEco 1000S is different from that on the SmartLogger, or
the device list is incomplete. You need to manually search for devices on the
SmartLogger.

l After devices are added or replaced, you also need to manually search for devices on the
SmartLogger or restart the SmartLogger, and then search for devices on the NetEco
1000S again.

l The TLS protocol is used for the NetEco 1000S to communicate with the SmartLogger.

NOTICE
The TLS protocol provides the following three versions:
l TLS1.0: This version has security risks.
l TLS1.1: This version is secure.
l TLS1.2: This version is secure.
In order to be compatible with the low version of the device, the NetEco 1000S supports all of
the preceding protocol versions by default. TLS1.0 has security risks. For security purposes,
you are advised to use TLS1.1 or TLS1.2. For details, see 5.1.8.13 How Do I Modify the
Data or File Transmission Protocol?.
The SmartLogger may not support TLS1.1/1.2. You are advised to replace the SmartLogger
with the one supporting TLS1.1/1.2 or upgrade the SmartLogger to the version supporting
TLS1.1/1.2.

Procedure
l If the SmartLogger has accessed the NetEco 1000S, perform the following

operations to add the SmartLogger to the plant:

NOTE

This operation requires that the current user is the system administrator.

Step 1 Choose Maintenance> Device Access from the main menu.
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Step 2 In the Device Access page, select the target SmartLogger and click Add to PV plant.

NOTE

The SmartLogger and NetEco 1000S are connected through password authentication. Authentication
Status may be any of the following values:

l Successful: indicates that the authentication passwords on both sides are the same. Then, perform
Step 3.

l Failed: You can perform the following operations to reconfigure the authentication password:

1. Click Set Authentication Password.

2. Enter the authentication password same as the SmartLogger side and click OK.

The authentication passwords on the SmartLogger and NetEco 1000S sides are /EzFp
+2%r6@IxSCv by default. You are advised to change the password every three months. For
details, see 5.1.3.11 Changing the Authentication Passwords of the SmartLogger and
NetEco 1000S.

3. Click Refresh on the Device Access page. When Authentication Status changes to Successful,
perform Step 3.

l Not authenticated: perform Step 3.

– Not authenticated: It indicates the current version of SmartLogger is too early and does not
support authentication. When you perform the next step, a security risk may occur. To ensure
connection security, you are advised to upgrade SmartLogger to a version supporting
authentication.

– The NetEco 1000S allows you to set whether to allow the access of the SmartLogger that does
not support authentication. For details, see 5.1.7.4.3 Setting Communication Parameters.

Step 3 On the Select Power Station page, select the target plant and click OK.

Step 4 Click OK in the Confirm dialog box.

Step 5 View operation results.

1. Choose Monitor from the main menu.
2. Select the target PV plant and expand to view the added SmartLogger and devices

mounted under it.

----End

l If the SmartLogger does not access the NetEco 1000S, perform the following
operations to add the SmartLogger to the plant:

NOTE

This operation requires that the current user is the system administrator or system operator.

Step 1 Choose Monitor from the main menu.

Step 2 Select the target plant in the navigation tree on the left.

Step 3 Click the Add Device tab in the operation display area, and then click Add Device button.

Step 4 On the Add Device SN page, perform the following operations to add the SmartLogger:

NOTE

The SmartLogger and the NetEco 1000S are connected through password authentication. If the
SmartLogger does not support password authentication, enable Compatible Access only supports SSL
authentication NEs. For details, see 5.1.7.4.3 Setting Communication Parameters. Then the
SmartLogger can automatically connect to the PV plant by referring to the following instructions.

1. Enter the SN of the SmartLogger to be added to the current PV plant and click
Advanced Settings.
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2. Enter the authentication password same as the SmartLogger side and click OK.
The authentication passwords on the SmartLogger and NetEco 1000S sides are /EzFp
+2%r6@IxSCv by default. You are advised to change the password every three months.
For details, see 5.1.3.11 Changing the Authentication Passwords of the SmartLogger
and NetEco 1000S.

When the SmartLogger added to the PV plant accesses the NetEco 1000S, the following
prompt is displayed in the lower right corner of the NetEco 1000S.

Figure 5-11 Device access prompt

Step 5 Click Refresh in Figure 5-11 or re-select the target PV plant in in the navigation tree on the
left to view the added SmartLogger and devices mounted under it.

----End

5.1.3.2 Accessing the Directly Connected Inverter
This section describes how to enable the inverter directly connected to the FE to access the
NetEco 1000S, helping manage and monitor devices through the NetEco 1000S.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.1.1.1.2

Logging In to the NetEco 1000S Client.
l The inverter to be accessed has accessed the NetEco 1000S in FE direct connection

mode.
l You have set the IP address of NetEco 1000S on the inverter. For detailed operations, see

Inverter User Manual.
l You have obtained the authentication password between the inverter and NetEco 1000S

and the SN of the inverter.
l You have created the target plant. For detailed operations, see 5.1.2.2 Creating a PV

Plant.

Context
The TLS protocol is used for the NetEco 1000S to communicate with the inverter.
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NOTICE
The TLS protocol provides the following three versions:
l TLS1.0: This version has security risks.
l TLS1.1: This version is secure.
l TLS1.2: This version is secure.
In order to be compatible with the low version of the device, the NetEco 1000S supports all of
the preceding protocol versions by default. TLS1.0 has security risks. For security purposes,
you are advised to use TLS1.1 or TLS1.2. For details, see 5.1.8.13 How Do I Modify the
Data or File Transmission Protocol?.
The inverter may not support TLS1.1/1.2. You are advised to replace the inverter with the one
supporting TLS1.1/1.2 or upgrade the inverter to the version supporting TLS1.1/1.2.

Procedure
l If the inverter has accessed the NetEco 1000S, perform the following operations to

add the inverter to the plant:

NOTE

This operation requires that the current user is the system administrator.

Step 1 Choose Maintenance> Device Access from the main menu.

Step 2 In the Device Access page, select the target inverter and click Add to PV plant.

NOTE

The inverter and NetEco 1000S are connected through password authentication. Authentication
Statusmay be any of the following values:

l Successful: indicates that the authentication passwords on both sides are the same. Then, perform
Step 3.

l Failed: You can perform the following operations to reconfigure the authentication password:

1. Click Set Authentication Password.

2. Enter the authentication password same as the inverter side and click OK.

The authentication passwords on the inverter and NetEco 1000S sides are /EzFp+2%r6@IxSCv
by default.

You are advised to change the password every three months. For details, see 5.1.3.11 Changing
the Authentication Passwords of the SmartLogger and NetEco 1000S.

3. Click Refresh on the Device Access page. When Authentication Status changes to Successful,
perform Step 3.

l Not authenticated: perform Step 3.

– Not authenticated: It indicates the current version of inverter is too early and does not support
authentication. When you perform the next step, a security risk may occur. To ensure
connection security, you are advised to upgrade SmartLogger to a version supporting
authentication.

– The NetEco 1000S allows you to set whether to allow the access of the inverter that does not
support authentication. For details, see 5.1.7.4.3 Setting Communication Parameters.

Step 3 On the Select Power Station page, select the target plant and click OK.

Step 4 Click OK in the Confirm dialog box.
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Step 5 View operation results.

1. Choose Monitor from the main menu.
2. Select the target PV plant and expand to view the added inverter and devices mounted

under it.

----End

l If the inverter does not access the NetEco 1000S, perform the following operations
to add the inverter to the plant:

NOTE

This operation requires that the current user is the system administrator or system operators.

Step 1 Choose Monitor from the main menu.

Step 2 Select the target plant in the navigation tree on the left.

Step 3 Click the Add Device tab in the operation display area, and then click Add Device button.

Step 4 Enter the SN of the inverter to be added to the current PV plant and click Advanced Settings.

Step 5 Enter the authentication password same as the inverter side and click OK.

When the inverter added to the PV plant accesses the NetEco 1000S, the following prompt is
displayed in the lower right corner of the NetEco 1000S.

Figure 5-12 Device access prompt

Step 6 Click Refresh in Figure 5-12 or re-select the target PV plant in in the navigation tree on the
left to view the added inverter.

----End

5.1.3.3 Searching Devices Based on Serial Port Addresses

This section describes how to search Inverter devices based on serial port addresses when
Inverters are connected to the monitoring PC using serial cables. The NetEco 1000S can
automatically identify and add new devices after the search. The serial-port connection mode
applies to local commissioning and is not recommended for remote connection.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.1.1.1.2

Logging In to the NetEco 1000S Client.
l You have logged in as system administrator.
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l You have obtained the serial port number, start bus address, and end bus address for an
Inverter.

l The Inverter is in the same time zone as the NetEco 1000S. If they are not in the same
time zone, change the time zone of the Inverter by following instructions provided in
User Manual on the monitored device side.

Context
If one of the following changes occurs on a device that has been added to the NetEco 1000S,
you need to search the device again so that information about the device can be updated on
the NetEco 1000S.

l The connection mode between the device and the NetEco 1000S is changed: Network
cable-based connection is changed to the RS232 cable-based direct connection.

l The RS485 Com Address of the device is changed.

NOTICE
Currently, the serial-port connection mode does not support security authentication, which
may introduce certain security risks. You are advised to use network cables for connection.
For details, see 5.1.3.1 Accessing Devices Through the SmartLogger or 5.1.3.2 Accessing
the Directly Connected Inverter.

Procedure

Step 1 Enable the function of serial ports.

Navigate to the NetEco 1000S installation directory\WebRoot\WEB-INF\classes directory,
open the userManagement.properties file, change the value of isStartCom to 1, and save
the change result. Then, restart the NetEco 1000S.

Step 2 Choose Monitor from the main menu.

Step 3 Click in the navigation tree on the left.

Step 4 Enter the serial port number, start bus address, and end bus address for the Inverter device and
select the PV Plant to which the device belongs by referring to Table 5-7.

Table 5-7 Parameters for searching devices based on serial port addresses

Parameter Description

Serial port No. Serial port number for connecting the device to the PC.

Start bus address/End bus
address

Start bus address/End bus address of the RS485 Com
Address.

PV Plant Name of the PV Plant to which the device belongs.

 

Step 5 Click Search.
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The added devices are displayed in the navigation tree on the left after the search.

Step 6 Disable the function of serial ports.

Navigate to the NetEco 1000S installation directory\WebRoot\WEB-INF\classes directory,
open the userManagement.properties file, change the value of isStartCom to 0, and save
the change result. Then, restart the NetEco 1000S.

NOTICE
To ensure NetEco 1000S system security, the NetEco 1000S shields the function of serial
ports by default. After completing the operation, disable this function immediately.

----End

5.1.3.4 Browsing the Details About a Device

On the Monitor tab page of the NetEco 1000S client, you can view the information about the
SmartLogger, inverter, EMI, PID device, and Meter. This section describes how to browse the
details about a device to learn about its running status, such as the basic information and real-
time performance data.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.1.1.1.2

Logging In to the NetEco 1000S Client.
l You have added a device to the NetEco 1000S and the device state is normal. For

detailed operations, see 5.1.3.1 Accessing Devices Through the SmartLogger, 5.1.3.2
Accessing the Directly Connected Inverter or 5.1.3.3 Searching Devices Based on
Serial Port Addresses.

Procedure

Step 1 Choose Monitor from the main menu.

Step 2 Choose the target device in the navigation tree on the left.

Step 3 Click the Details tab in the operation display area.

Basic information and real-time performance data of the selected device is displayed on the
Details tab page.

NOTE

If the DST is enabled on the SmartLogger, the following situations may occur:

l When users query data generated on the date shifting to the DST, the queried graph or table has no
data on this time segment.

l When users query data generated on the date shifting out of the DST, the queried graph or table
displays only the latest one data record on this time segment.

----End
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Follow-up Procedure
System administrator and system operators can also perform the following operations on the
device Details tab page:

Operation Steps

Start the real-time data collection
task
NOTE

You can start the real-time data

collection task when its status is .

Click .
NOTE

The period with which the SmartLogger collects real-time
data of devices vary with its version.

l The SmartLogger of an old version (earlier than
V100R001C95SPC020) collects real-time data of
devices every minute.

l The SmartLogger of a new version
(V100R001C95SPC020 or later) collects real-time
data of devices using the value of Real-time data
collection period on the Settings tab page of a PV
plant as the period.

If you modify Real-time data collection period after
starting the real-time data collection task mounted under
the SmartLogger of a new version, you need to stop the
task and then start it again. In this way, the SmartLogger
can collect real-time data using the new Real-time data
collection period value as the period.

Stop the real-time data collection
task
NOTE

You can stop the real-time data

collection task when its status is .

Click .

 

5.1.3.5 Browsing Alarm Information About a Device
On the Monitor tab page of the NetEco 1000S client, you can view and configure the
information about the SmartLogger, inverter, EMI, PID device, and Meter. This section
describes how to browse alarm information about a device to learn about the current alarms
for the device.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.1.1.1.2

Logging In to the NetEco 1000S Client.
l You have added a device to the NetEco 1000S and the device state is normal. For

detailed operations, see 5.1.3.1 Accessing Devices Through the SmartLogger, 5.1.3.2
Accessing the Directly Connected Inverter or 5.1.3.3 Searching Devices Based on
Serial Port Addresses.

l .
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Procedure

Step 1 Choose Monitor from the main menu.

Step 2 Choose the target device in the navigation tree on the left.

Step 3 Click the Alarm tab in the operation display area.

The information about all the current alarms of the target device is displayed in the Alarm tab
page. Figure 5-13 shows the information about all the current alarms of an inverter.

Figure 5-13 The information about all the current alarms of the target device

Step 4 Optional: Click an alarm name in the Alarm Name column to view the details.

NOTE

Alarms that have not been browsed are highlighted in bold.

Step 5 Optional: Click Export to export the queried alarm information into a CSV file.

----End

Follow-up Procedure

Click Lock. Alarms are no longer automatically updated on the Alarm page. In this way, you
can view the alarms reported only before the lock. To enable the automatic update function
again and view newly reported alarms, click Scroll Unlock.

NOTE

If excessive alarms are generated, these alarms are displayed on multiple pages. In this case, pages
except the first one are locked and the Scroll Unlock button is unavailable for you to unlock those
pages.

By default, the alarm lock function on the Alarm page is disabled.

5.1.3.6 Modifying the Information About a Device

On the Monitor tab page of the NetEco 1000S client, you can configure the information
about the SmartLogger, inverter, EMI, PID device, and Meter.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.1.1.1.2

Logging In to the NetEco 1000S Client.
l You have logged in as system administrator or system operator.
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l You have added a device to the NetEco 1000S and the device state is normal. For
detailed operations, see 5.1.3.1 Accessing Devices Through the SmartLogger, 5.1.3.2
Accessing the Directly Connected Inverter or 5.1.3.3 Searching Devices Based on
Serial Port Addresses.

Procedure

Step 1 Choose Monitor from the main menu.

Step 2 Choose the target device in the navigation tree on the left.

Step 3 Click the Settings tab in the operation display area.

Device information about the selected device is displayed on the Settings tab page.

Step 4 Modify configuration information about the selected device by referring to Table 5-8.

Table 5-8 Modifying device configuration information

Device
Type

If You Need
To...

Then...

SmartLog
ger

Change the
name and
description of a
SmartLogger

1. Choose the Device Information tab.
2. Click Refresh in the upper right corner of the page.

The latest parameter values will be displayed on the
NetEco 1000S for the SmartLogger.

3. Enter the new name and description in the
corresponding text boxes.

4. Click Save in the upper right corner of the Settings
page.

Switch to the
SmartLogger
web client

1. Choose the Device Information tab.
2. Click the Device address link under Communication

Parameter, as shown in Figure 5-14.
Switch to the web client of the SmartLogger.

Figure 5-14 Device Address

You can also switch to the web client on the Device
Management tab page. The details are as follows:
1. Choose Maintenance > Device Maintenance from the

main menu.
2. Click the Device Management tab.
3. Set Device type to SmartLogger.
4. Click the Device address link in the Communication

address column for the SmartLogger whose web client
you want to access.

NOTE
The switch to the web client is successful only when the PC can
be used to access the SmartLogger web client directly.
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Device
Type

If You Need
To...

Then...

Enable or
disable the
SmartLogger

Choose the Device Information tab.
The value of Connect indicates the status of the
SmartLogger. According to Figure 5-15, the SmartLogger
has started.

Figure 5-15 SmartLogger connection status

l To disable the SmartLogger:
1. Click Disable.

The message "After connection is disabled, NetEco
will disconnect and forbid SmartLogger
connection" is displayed.

2. Click OK.
The SmartLogger is disabled, and the value of
Connect changes to the value shown in Figure
5-16.

Figure 5-16 SmartLogger connection status

l To restore the connection between the SmartLogger
and NetEco 1000S, click Enable.

Control an
inverter
remotely

For details, see Power on or off all inverters in the same
plant or SmartLogger in batches in 5.1.3.8 Remotely
Controlling an Inverter.

Modify the time
zone parameters,
power control
parameters,
NetEco
communications
parameters, or
CO2 emission
reduction
coefficient of the
SmartLogger

The methods for modifying time zone, active power
control, reactive power control, or NetEco
communications parameters, and CO2 emission reduction
coefficient are similar. The following describes how to
change the time zone parameter.
1. Choose the Time Zone Parameter tab.
2. Set the value of City as required.
3. Click Submit.

After Submitted successfully is displayed in the
Information column, the specified parameter is
delivered to the device side.

NOTE
Click Synchronize to synchronize the parameter values
configured on the SmartLogger to the NetEco 1000S.
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Device
Type

If You Need
To...

Then...

Inverter Synchronize the
parameter values
of the inverter to
the NetEco
1000S

Click Synchronize on the page for the parameter values to
be synchronized.

Change the
name and
description of an
Inverter

1. Choose the Device Information tab.
2. Enter the new name and description in the

corresponding text boxes.
3. Click Save in the upper right corner of the Device

Information page.
After the device name and description are changed, the
device name is delivered to the device.

Change the total
string capacity
of inverters

1. Choose the Device Information tab.
2. Enter the target value in the Total string capacity text

box.
NOTE

Click Batch Apply if you need to apply the configured value
of Total string capacity to multiple inverters. Then select the
target devices in the displayed dialog box and click OK.

3. Click Save in the upper right corner of the Device
Information page.

Set string
parameters of an
inverter

1. Choose the Device Information tab.
2. Click String Details Setup.

The String Details Setup page is displayed.
3. Select the strings to be configured in the String Setup

area.
4. Set parameters for the strings in the Panel Setup area.
5. Click OK to save the settings.
NOTE

If you need to apply the string configurations to multiple
inverters, click Batch Apply. Then select the target devices in the
displayed dialog box and click OK.
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Device
Type

If You Need
To...

Then...

Modify the
power grid
parameters,
protection
parameters,
feature
parameters, or
power
adjustment
parameters

The methods for changing power grid parameters,
protection parameters, feature parameters, or power
adjustment parameters are similar. The following
describes how to change the power grid parameters.
1. Choose the Grid Parameters tab.
2. Set the parameters as required.

NOTE
For details about the parameters, see User Manual on the
monitored device side.

3. Select the parameters to be modified.
4. Click Submit.

After Submitted successfully is displayed in the
Information column, the specified parameter is
delivered to the device side.

NOTE
If you need to apply the configurations to multiple inverters, click
Batch settings. Then select the target devices in the displayed
dialog box and click OK.

Correct the total
energy yield of
the inverter

1. Choose the Adjust Total Energy Yield tab.
2. Set the value of the total energy yield as required.
3. Select the parameters to be modified.
4. Click Submit.

After Submitted successfully is displayed in the
Information column, the specified parameter is
delivered to the device side.

NOTE
If you need to apply the configurations to multiple inverters, click
Batch settings. Then select the target devices in the displayed
dialog box and click OK.

EMI Change the
name and
description of an
EMI

1. Click Refresh in the upper right corner of the page.
The latest parameter values will be displayed on the
NetEco 1000S for the EMI.

2. Enter the new name and description in the
corresponding text boxes,

3. Click Save in the upper right corner of the Settings
page.

PID Change the
name and
description of a
PID

1. Choose the Device Information tab.
2. Click Refresh in the upper right corner of the page.

The latest parameter values will be displayed on the
NetEco 1000S for the PID.

3. Enter the new name and description in the
corresponding text boxes.

4. Click Save in the upper right corner of the Settings
page.
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Device
Type

If You Need
To...

Then...

Modify PID
parameter

1. Choose the PID Parameter tab.
2. Set parameters as required.
3. Select the parameters to be modified.
4. Click Submit.

After Submitted successfully is displayed in the
Information column, the specified parameter is
delivered to the device side.

NOTE

l For details about the parameters, see the User Manual on the
monitored device side.

l Click Synchronize to synchronize the parameter values
configured on the PID to the NetEco 1000S.

Meter Change the
name and
description of a
Meter

1. Click Refresh in the upper right corner of the page.
The latest parameter values will be displayed on the
NetEco 1000S for the Meter.

2. Enter the new name and description in the
corresponding text boxes.

3. Click Save in the upper right corner of the Settings
page.

 

----End

5.1.3.7 Deleting Devices

This section describes how to delete devices that have been connected to the NetEco 1000S
and that do not need to be managed or have been damaged from the NetEco 1000S.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.1.1.1.2

Logging In to the NetEco 1000S Client.
l You have logged in as system administrator or system operator.

l You have added a device to the NetEco 1000S and the device state is normal. For
detailed operations, see 5.1.3.1 Accessing Devices Through the SmartLogger, 5.1.3.2
Accessing the Directly Connected Inverter or 5.1.3.3 Searching Devices Based on
Serial Port Addresses.

Procedure
l Delete devices connecting to the plant:

a. Choose Monitor from the main menu.

b. Click  in the upper part of the navigation tree.
c. In the displayed Delete Device window, select the target devices and click OK.
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d. Click Yes in the Warning dialog box.

The Deletion succeeded dialog box is displayed.

e. Click OK.

l Delete devices that have been connected to the NetEco 1000S but are not connected
to a specific plant:

a. Choose Maintenance > Device Access from the main menu.

b. In the displayed Device Access page, select the check box corresponding to the
SmartLogger you want to delete and click Delete.

c. Click Yes in the Warning dialog box.

The Deletion succeeded dialog box is displayed.

d. Click OK.

5.1.3.8 Remotely Controlling an Inverter

This section describes how to control an inverter that has been connected to the NetEco
1000S, including powering on and off the inverter, restarting the inverter and starting the arc-
fault circuit interrupter (AFCI) self-check.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.1.1.1.2

Logging In to the NetEco 1000S Client.

l You have logged in as system administrator or system operator.

l You have added a device to the NetEco 1000S and the device state is normal. For
detailed operations, see 5.1.3.1 Accessing Devices Through the SmartLogger, 5.1.3.2
Accessing the Directly Connected Inverter or 5.1.3.3 Searching Devices Based on
Serial Port Addresses.

Procedure
l Control one inverter:

a. Choose Monitor from the main menu.

b. Select the target inverter in the navigation tree on the left.

c. Click the Details tab in the operation display area.

The page for inverter details is displayed.

d. Issue the control commands to the inverter according to Table 5-9.

Table 5-9 Controlling one inverter

If You Need To... Then...

Power on the inverter
Click .

Power off the inverter
Click .
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If You Need To... Then...

Start the AFCI self-check
Click .
NOTE

l If the AFCI controller ID on the inverter side is set to 0,
this button is not displayed in the Details window.

l Only the inverter SUN2000 V2 supports the AFCI self-
check function.

Restart the inverter
Click .
NOTE

The inverter SUN2000 of some versions supports the restart
function.

 

l Power on or off all inverters in the same plant or SmartLogger in batches:

The method for powering or off inverters in the same plant or SmartLogger in batches is
the same. This section uses the method for powering or off inverters in the same plant as
an example.

a. Choose Monitor from the main menu.

b. Select the target plant in the navigation tree on the left.

c. Click the Settings tab in the operation display area.

The page for setting the plant is displayed.

d. Issue the control commands to all inverters in the current plant according to Table
5-10.

NOTE

If the inverters are connected to the plant through the SmartLogger, issue the control
commands to the SmartLogger in the plant.

Table 5-10 Controlling inverters in batches

If You Need To... Then...

Power on all inverters
Click .

Power off all inverters
Click .

 

5.1.3.9 Remotely Controlling a SmartLogger

This section describes how to control a SmartLogger connected to the NetEco1000S,
including restarting the SmartLogger, starting the SmartLogger to search for mounted devices,
and deleting devices mounted under the SmartLogger.
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Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.1.1.1.2

Logging In to the NetEco 1000S Client.
l You have added a device to the NetEco1000S and the device state is normal. For detailed

operations, see 5.1.3.1 Accessing Devices Through the SmartLogger.
l You have logged in as system administrator or system operator.

Procedure

Step 1 Choose Monitor from the main menu.

Step 2 Select the target SmartLogger in the navigation tree on the left.

Step 3 Click the Details tab in the operation display area.

Step 4 Issue the control commands to the SmartLogger according to Table 5-11.

Table 5-11 Remotely controlling the SmartLogger

If You Need To... Then...

Restart the SmartLogger If the SmartLogger needs to restart due to a fault, you
can perform the following operation:

Click .

Start the SmartLogger to search
for mounted devices

If the number of inverters mounted under the
SmartLogger is different from the actual one on the
NetEco1000S, you can start the SmartLogger on the
NetEco1000S to search for devices to ensure that the
number of inverters on the NetEco1000S is the same as
the actual one.

Click .

Delete devices mounted under
the SmartLogger

If the device mounted under the SmartLogger needs to
be deleted due to a fault or aging, you can perform the
following operation:

Click .

 

----End

5.1.3.10 Remotely Controlling a PID Device
This section describes how to control a Potential Induced Degradation (PID) device that has
been connected to the NetEco 1000S, including powering on and off the PID device.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.1.1.1.2

Logging In to the NetEco 1000S Client.
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l You have added a device to the NetEco1000S and the device state is normal. For detailed
operations, see 5.1.3.1 Accessing Devices Through the SmartLogger.

l You have logged in as system administrator or system operator.

Procedure

Step 1 Choose Monitor from the main menu.

Step 2 Select the target PID device in the navigation tree on the left.

Step 3 Click the Details tab in the operation display area.

Step 4 Issue the control commands to the PID device according to Table 5-12.

Table 5-12 Controlling the PID device

If You Need To... Then...

Power on the PID device
Click .

Power off the PID device
Click .

 

NOTE

If the protocol version of a PID device is D3.0, the  button is available on the Details tab page of

the PID device. You can click  to restart the PID device.

----End

5.1.3.11 Changing the Authentication Passwords of the SmartLogger and NetEco
1000S

The SmartLogger and NetEco 1000S are connected through password authentication. To
ensure connection security, you are advised to change the authentication passwords of the
SmartLogger and NetEco 1000S periodically (for example, every three months).

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.1.1.1.2

Logging In to the NetEco 1000S Client.
l You have logged in as system administrator or system operator.
l The SmartLogger has accessed the PV plant. The connection between the SmartLogger

and NetEco 1000S is normal. For detailed operations, see 5.1.3.1 Accessing Devices
Through the SmartLogger.

Context
l The authentication passwords on the SmartLogger and NetEco 1000S sides are /EzFp

+2%r6@IxSCv by default.
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l The password must comply with the following rules:

The password cannot be the same as the account name.

The password contains 16 characters, and it must contain four of the following:

– Lowercase letters

– Uppercase letters

– Digits

– special characters

NOTE

You can change the authentication password between the inverter directly connected to the FE and the
NetEco 1000S by referring to this section.

Procedure

Step 1 Choose Monitor from the main menu.

Step 2 Select the target plant in the navigation tree on the left.

Step 3 Click the Add Device tab in the operation display area, and then click  in the Operation
column of the SN.

The Set Device Authentication Password dialog box is displayed.

Step 4 On the Set Device Authentication Password page, use the following methods to change the
authentication password:

l If you want to change the authentication passwords on the SmartLogger and NetEco
1000S sides at the same time to ensure connection security:

Select Issue new authentication password to device, reset Password and Confirm
Password, and click OK.

l If the connection between the SmartLogger and NetEco 1000S fails due to authentication
password inconsistency, and if you only need to change the authentication password on
the NetEco 1000S side:

Deselect Issue new authentication password to device, enter the password same as the
SmartLogger side, and click OK.

----End

5.1.4 Managing Other Devices
This section describes how to use the NetEco 1000S to manage other devices. Other devices
are non-Huawei-developed devices, such as Plant Controller, Power Meter, and Electricity
Meter.

5.1.4.1 Enabling the Other Device Access Menu

After the NetEco 1000S is installed, the Other Device Access menu is not enabled by default.
When adding other devices to the NetEco 1000S, you need to manually enable this menu.
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Context

Other devices are non-Huawei-developed devices, such as Plant Controller, Power Meter, and
Electricity Meter, Power Meter, and Electricity Meter is restricted. For detailed technical
solutions, contact Huawei technical support engineers.

Procedure

Step 1 Navigate to the following directory:

NetEco 1000S installation directory\WebRoot\WEB-INF\classes

Step 2 Open the userManagement.properties file, change the value of isShowThirdEquipment to
1, and save the change result.

Step 3 Restart the NetEco 1000S services and log in to the NetEco 1000S client.

Choose Maintenance from the main menu. The Other Device Access menu is displayed.

----End

5.1.4.2 Adding Other Devices

This section describes how to add other devices to the NetEco 1000S so that you can check
performance data of other devices through the NetEco 1000S. Other devices are non-Huawei-
developed devices, such as Plant Controller, Power Meter, and Electricity Meter.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.1.1.1.2

Logging In to the NetEco 1000S Client.
l You have logged in as system administrator.
l You have enabled the Other Device Access menu. For details, see 5.1.4.1 Enabling the

Other Device Access Menu.
l Communication between the Plant Controller and NetEco 1000S is normal.

Procedure

Step 1 Choose Maintenance > Other Device Access from the main menu.

Step 2 In the Other Device Access window, click Add Device.

Step 3 In the displayed Add Device dialog box, set related parameters.
l To add the Plant Controller, set related parameters according to Table 5-13.

NOTE

Before adding the Plant Controller, ensure that you have created a target PV plant, for detailed
operations, see 5.1.2.2 Creating a PV Plant.

Table 5-13 Plant Controller parameters

Parameter Description

Device Type Set this parameter to PlantControl.
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Parameter Description

Device Name Set this parameter as required. The specified name is displayed
in the Other Device Access page.

PV Plant Set this parameter to the PV plant to which the Plant
Controller belongs.

Device Mark Set this parameter to the value of PV Plant name configured
on the Plant Controller.

 

l To add the Electricity Meter or Power Meter, set related parameters according to Table
5-14.

NOTE

Before adding the Electricity Meter or Power Meter, ensure that you have added the target Plant
Controller.

Table 5-14 Electricity Meter or Power Meter parameters

Parameter Description

Device Type Set this parameter to ElectricityMeter or
PowerMeter.

Device Name Set this parameter as required. The specified
name is displayed in the Other Device
Access page.

Plant Controller Set this parameter to the name of the Plant
Controller on which the Electricity Meter or
Power Meter needs to be mounted.

 

Step 4 Click OK.

The window shown in Figure 5-17 is displayed after the setting is saved.

Figure 5-17 Device list

Perform the following operations in the Figure 5-17 as required.
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Operation Procedure

Change the name, mark, or
description of a device.
NOTE

Only the Plant Controller
supports the changing of
device mark.

Click  in the row of the target device.

Delete an added device.
Click  in the row of the target device.

 

----End

Follow-up Procedure

After the device is added, you can query the performance data of the device.

1. Choose Historical Data > Performance Data from the main menu.
2. Choose an Electricity Meter or Power Meter to be queried in the navigation tree on the

left.
3. Set query conditions in the operation display area, and then click Query.

The performance parameters of Electricity Meter or Power Meter are displayed, the
specific parameters are as follows:
– Power Meter: Active power, Reactive power, Power factor, Voltage Uab,

Voltage Ubc, Voltage Uca, Current Ia, Current Ib, Current Ic, Set value
reactive power limitation, Set value cos phi, Set value Q.

– Electricity Meter: Time, Energy Yield, Self-Consumed Energy.

5.1.5 Historical Data Query

5.1.5.1 Querying Alarm Logs

This section describes how to query alarm logs on the NetEco 1000S. You can set query
criteria to obtain the required alarm logs.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.1.1.1.2

Logging In to the NetEco 1000S Client.
l You have logged in as the system administrator, system operator, or guest user who has

been assigned the historical data query permissions.

Procedure

Step 1 Choose Historical Data > Alarm Log from the main menu.

Step 2 Choose an target device to be queried in the navigation tree on the left.

Step 3 Set query conditions in the operation display area, and then click Query.
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All the alarm records that meet the query conditions are displayed in one or more pages, as
shown in Figure 5-18.

Figure 5-18 Alarm Log

Clearance Type includes Automatic clear, NetEco recovery and Cleared by the system.

Alarms corresponding to different clearance types are as follows:

l Automatic clear: The value of Clearance Type for an automatically cleared alarm on
the device side is Automatic clear.

l Cleared by the system: When devices reports active alarms to the NetEco 1000S again
after reporting 30,000 active alarms to the NetEco 1000S, the NetEco 1000S
automatically clears the earliest 1000 alarms and Clearance Type of these cleared
alarms is Cleared by the system.

l NetEco recovery: After you enable the automatic active alarm synchronization function,
the NetEco 1000S automatically compares alarms reported from the device side with
alarms cached in the NetEco 1000S. When an alarm is different from the cached alarm,
the NetEco 1000S clears this alarm and considers it as the historical alarm, that is, alarm
of the NetEco recovery type.

NOTE

Alarms of the NetEco recovery type can be queried only when you enable the automatic active
alarm synchronization function. The function enabling and disabling methods are as follows:

– Enable the function: Navigate to the NetEco 1000S software installation path\WebRoot
\WEB-INF\classes directory and change the value of isAutoActiveAlarm in the
struts.properties file to 1. Then, restart the NetEco 1000S services.

– Disable the function: Change the value of isAutoActiveAlarm in the struts.properties file to
0 and restart the NetEco 1000S services.

– Set the synchronization start time: Modify activeCurrentAlarm_Time in the
struts.properties file and restart the NetEco 1000S services.

The default value of activeCurrentAlarm_Time is 23:00 on the NetEco 1000S, indicating
that active alarms are synchronized at 23:00 everyday.

The automatic active alarm synchronization function is enabled on the NetEco 1000S by default.

Step 4 Optional: Click Export to export the queried alarm records into a CSV file.

----End

5.1.5.2 Querying Performance Data

This section describes how to query performance data on the NetEco 1000S.
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5.1.5.2.1 Querying the Performance Data of the PV System

This section describes how to query the performance data of the PV System. You can set
query criteria to obtain the required performance data.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.1.1.1.2

Logging In to the NetEco 1000S Client.
l You have logged in as the system administrator, system operator, or guest user who has

been assigned the historical data query permissions.

Procedure

Step 1 Choose Historical Data > Performance Data from the main menu.

Step 2 Choose the PV System to be queried in the navigation tree on the left.

Step 3 Set search criteria and click Query in the operation display area. The window shown in
Figure 5-19 is displayed.

NOTE

You can set search criteria to query performance data by Day, Month, Year, or Total.

l You can view the accumulated power of all PV plants in the PV system in the PV
System Power Statistics line chart.

l You can view power of five PV plants in the PV Plant Power Statistics line chart by
default. To view the power of a specific PV plant, click Select PV Plants to select the
target PV plant.

NOTE

When you query performance data by Day, queried data is displayed based on the following rules:

l Within one month: The line chart displays 5-minute data.

l Greater than one month and less than three years: The line chart displays 15-minute data.

If the DST is enabled on the SmartLogger, the following situations may occur:

l When users query data generated on the date shifting to the DST, the queried graph or table has no
data on this time segment.

l When users query data generated on the date shifting out of the DST, the queried graph or table
displays only the latest one data record on this time segment.
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Figure 5-19 Power statistics line chart

Step 4 Optional: To export queried data to the PC for viewing, click Export and save the file to the
PC.

NOTICE
When a third-party editing tool is used to open the exported file, the tool should support
UCS-2 Decoding Mode. Otherwise, data cannot be decoded.

----End

5.1.5.2.2 Querying the Performance Data of a PV Plant

This section describes how to query the performance data of a plant. You can set query
criteria to obtain the required performance data.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.1.1.1.2

Logging In to the NetEco 1000S Client.

l You have logged in as the system administrator, system operator, or guest user who has
been assigned the historical data query permissions.

Procedure

Step 1 Choose Historical Data > Performance Data from the main menu.

Step 2 Choose a plant to be queried in the navigation tree on the left.

Step 3 Set query conditions according to the following table and click Query in the operation display
area.
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Table 5-15 Setting query conditions

Query Conditions Queried Data

Select Day and set the query
date.

l The PV Plant Power Statistics line chart displays
power of the selected PV plant.

l The Inverter Power Statistics in PV Plant line
chart displays power of five inverters in the selected
PV plant by default. To view power of a specific
inverter, click Select Inverters to select the target
inverter.

NOTE
If the DST is enabled on the SmartLogger, the following
situations may occur:

l When users query data generated on the date shifting to
the DST, the queried graph or table has no data on this
time segment.

l When users query data generated on the date shifting out
of the DST, the queried graph or table displays only the
latest one data record on this time segment.

1. Select Month, Year, or Total,
and set the query month or
query year separately.

2. Select the query counter
Energy yield, Specific
Energy, Performance ratio
or Meter Measurement.

NOTE

l The Performance ratio option
is displayed only when the
environmental monitoring
instrument (EMI) accesses the
PV plant.
When a PV plant is connected
with multiple EMIs, if you do
not specify a EMI, the
performance ratio is calculated
based on the value of the first
connected EMI by default. If
you need to configure a EMI,
see 5.1.2.6 Modifying the
Information About a PV
Plant.

l The Meter Measurement
option is displayed only when
the Electricity Meter accesses
the PV plant.
For detailed operations to access
a Electricity Meter to PV plant,
see 5.1.4.2 Adding Other
Devices.

l PV plant power generation statistics and inverter
power generation statistics

l PV plant equivalent power generation duration and
inverter equivalent power generation duration

l PV plant Performance ratio and inverter
Performance ratio

l Generated power in a electric meter of a PV plant
and Meter Statistics Performance Ratio

NOTE
If the Electricity Meter accesses the PV Plant, but the EMI
have not accessed the PV Plant, you cannot query certain data
about Meter Statistics Performance Ratio of Meter
Measurement.

NOTE
If the value of Performance ratio or Specific Energy cannot
be queried, total string capacity may not be configured for
inverters. To solve this problem, perform the following
operations:

1. Configure total string capacity for the target inverter. For
details, see 5.1.3.6 Modifying the Information About a
Device.

2. Re-collect historical data of the latest 30 days for the
target inverter. For details, see 5.1.5.4 Synchronizing
Historical Performance Data.

3. Query the value of Specific energy or Performance ratio
again.

 

Step 4 Optional: To export queried data to the PC for viewing, click Export and save the file to the
PC.
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NOTICE
When a third-party editing tool is used to open the exported file, the tool should support
UCS-2 Decoding Mode. Otherwise, data cannot be decoded.

----End

5.1.5.2.3 Querying the Performance Data of a Device

This section describes how to query the performance data of a device. You can set query
criteria to obtain the required performance data. The devices whose data can be queried
include the SmartLogger, inverter, EMI, PID, and Meter.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.1.1.1.2

Logging In to the NetEco 1000S Client.

l You have logged in as the system administrator, system operator, or guest user who has
been assigned the historical data query permissions.

Procedure

Step 1 Choose Historical Data > Performance Data from the main menu.

Step 2 Choose a device to be queried in the navigation tree on the left.

Step 3 Set query conditions in the operation display area, and then click Query.

All qualified performance data is displayed on one or more pages. Figure 5-20 shows the
inverter performance data.

Figure 5-20 Querying the performance data of a device

Step 4 Optional: To export queried data to the PC for viewing, click Export and save the file to the
PC.

NOTICE
When a third-party editing tool is used to open the exported file, the tool should support
UCS-2 Decoding Mode. Otherwise, data cannot be decoded.

----End
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Follow-up Procedure

You can also perform the following operations on the Querying the performance data of a
device page:

Operation Steps Description

Display
performance
data in a line
chart

In the operation display area, click
Graph.

Display the queried performance
data in a line chart.

Set the
vertical
coordinate of
the line chart

1. Click .
The Select Counters dialog box
is displayed.

2. Enter the values for the Y1 and
Y2 coordinates.
NOTE

The preceding two values must be
different.

3. Click OK.

View the performance data based
on different performance counters
in the line chart by setting the
vertical coordinate.

Display
daylight
saving time
(DST)

Select Show DST. After DST starts, DST marks are
displayed behind each time in the
Generated On column.
For example, 2013-09-17 09:40:00
DST.

 

5.1.5.3 Querying Report Data

You can query the power generation statistics, power generation performance ratio and
income of the plant and the index values of the inverters in the NetEco 1000S system for data
analysis.

Context
NOTE

If the DST is enabled on the SmartLogger, the following situations may occur:

l When users query data generated on the date shifting to the DST, the queried graph or table has no
data on this time segment.

l When users query data generated on the date shifting out of the DST, the queried graph or table
displays only the latest one data record on this time segment.

Report data can be emailed to users. For details about the sending rules, see 5.1.7.3.4 Setting
Report Sending Rules.

5.1.5.3.1 Querying the Energy Yield of the PV Plant

This section describes how to query the energy yield of the PV plant to learn data, such as the
energy generated in a certain period, active power, and irradiation strength.
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Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.1.1.1.2

Logging In to the NetEco 1000S Client.
l You have logged in as the system administrator, system operator, or guest user who has

been assigned the historical data query permissions.

Procedure

Step 1 Choose Historical Data > Data Analysis from the main menu.

Step 2 Choose PV Plant Analysis > Energy Yield in the navigation tree on the left

Step 3 Click  to select the target plant in the operation display area.

NOTE

A maximum of 5 plants can be selected.

Step 4 Set query conditions according to the following table and click Query.

Table 5-16 Setting query conditions

Query Conditions Queried Data

Querying data by Day Active power and total irradiance of every 15 minutes
from 00:00 on the current day

Querying data by Week Active power and total irradiance of every hour from
00:00 on each day in the current week
NOTE

The current week is not the natural week. It considers the
current date as the last day of the current week.

Querying data by Month energy yield and accumulated radiation of each day in
the current month

Querying data by Year energy yield and accumulated radiation of each
month in the current year

Querying data by Total energy yield and accumulated radiation of the each
year

 

Step 5 Select the data display style.

To display queried data in a chart, click Graph. To display queried data in a table, click
Table.

Step 6 Optional: To export queried data to the PC for viewing, click Export on the Table tab page
and save the file to the PC.
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NOTICE
When a third-party editing tool is used to open the exported file, the tool should support
UCS-2 Decoding Mode. Otherwise, data cannot be decoded.

----End

5.1.5.3.2 Querying the Energy Yield Performance Ratio of the PV Plant

This section describes how to query the energy yield performance ratio of the PV plant to
learn the power energy efficiency of the PV plant in a certain period.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.1.1.1.2

Logging In to the NetEco 1000S Client.
l You have logged in as the system administrator, system operator, or guest user who has

been assigned the historical data query permissions.

Context

The PV plant performance ratio indicates the rated output loss of the PV plant array caused by
the following reasons: the temperature and irradiation are not fully used, or system
components are invalid or faulty. The performance ratio reflects the overall operation of
devices in the PV plant system from the PV module side to the box-type input substation side
in the recording time period.

The inverter performance ratio indicates the ratio between the actual energy yields and
theoretical energy yields of inverters. The calculation formula is as follows: PR = EAC / (YR ×
PO) x 100%.

l EAC indicates the actual energy yields of inverters in a day.

l (YR x PO) indicates the theoretical energy yields of inverters in the same period.

– YR indicates the inverter equivalent power generation duration. The calculation
formula is as follows: YR = H/GSTC. Unit: kW·h.

NOTE

H indicates the total irradiance on the inclined plane of the PV plant array. The formula for
calculating the total increased irradiance in the recording period is as follows: HT = ∑time (Hk x ε).

l ∑time indicates that the sum is calculated by recording time.

l Hk indicates the Kth 5-minute increased irradiance of the current day monitored by the EMI.
The unit is kWh.

l ε indicates the temperature correction coefficient. ε = 1 – (Tk – 25) x Component peak power
temperature coefficient.

l Tk indicates the Kth 5-minute component surface temperature monitored by the EMI.

l Component peak power temperature coefficient indicates the empirical value of the
temperature coefficient. It is the component peak power temperature coefficient that is
configured for the PV plant where inverters are located. Configure this counter by
referring to 5.1.2.6 Modifying the Information About a PV Plant.

GSTC indicates the standard irradiation strength of the PV panel. The default value is 1 kW/m2.
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– PO indicates the string capacity. Configure this counter by referring to 5.1.2.6
Modifying the Information About a PV Plant.

The PV plant performance ratio indicates the sum of actual energy yields of inverters
multiplied by (1 – Line loss) and divided by the sum of theoretical energy yields of inverters.
The calculation formula is as follows: PR = ∑iEAC

(i)(1 - Line loss) / ∑i(YR × PO)(i).

l Line loss indicates the power loss when electric lines are transferring power. Configure
this counter by referring to 5.1.2.6 Modifying the Information About a PV Plant.

Procedure

Step 1 Choose Historical Data > Data Analysis from the main menu.

Step 2 Choose PV Plant Analysis > Performance Ratio in the navigation tree on the left.

Step 3 Click  to select the target plant in the operation display area.

NOTE

A maximum of 5 plants can be selected.

Step 4 Set query conditions according to the following table and click Query.

Table 5-17 Setting query conditions

Query Conditions Queried Data

Querying data by Month Energy yield and performance ratio of each day in the
current month

Querying data by Year Energy yield and performance ratio of each month in
the current year

Querying data by Total Energy yield and performance ratio of each year

 

NOTE

When a PV plant is connected with multiple EMIs, if you do not specify a EMI, the performance ratio is
calculated based on the value of the first connected EMI by default. If you need to configure a EMI, see
5.1.2.6 Modifying the Information About a PV Plant.

Step 5 Select the data display style.

To display queried data in a chart, click Graph. To display queried data in a table, click
Table.

Step 6 Optional: To export queried data to the PC for viewing, click Export on the Table tab page
and save the file to the PC.
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NOTICE
When a third-party editing tool is used to open the exported file, the tool should support
UCS-2 Decoding Mode. Otherwise, data cannot be decoded.

----End

5.1.5.3.3 Querying the income of the PV Plant

This section describes how to query the income of the PV plant to learn the income generated
in a certain period.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.1.1.1.2

Logging In to the NetEco 1000S Client.

l You have logged in as the system administrator, system operator, or guest user who has
been assigned the historical data query permissions.

Procedure

Step 1 Choose Historical Data > Data Analysis from the main menu.

Step 2 Choose PV Plant Analysis > Income in the navigation tree on the left

Step 3 Click  to select the target plant in the operation display area.

NOTE

A maximum of 5 plants can be selected.

Step 4 Set query conditions according to the following table and click Query.

Table 5-18 Setting query conditions

Query Conditions Queried Data

Querying data by Month Income of each day in the current month.

Querying data by Year Income of each month in the current year.

Querying data by Total Total income of each year.

 

Step 5 Select the data display style.

To display queried data in a chart, click Graph. To display queried data in a table, click
Table.

Step 6 Optional: To export queried data to the PC for viewing, click Export on the Table tab page
and save the file to the PC.

iManager NetEco 1000S
User Manual 5 Operation and Maintenance

Issue Draft C (2017-12-14) Huawei Proprietary and Confidential
Copyright © Huawei Technologies Co., Ltd.

92



NOTICE
When a third-party editing tool is used to open the exported file, the tool should support
UCS-2 Decoding Mode. Otherwise, data cannot be decoded.

----End

5.1.5.3.4 Querying Plant or Inverter Availability

This topic describes how to query plant or inverter availability during a certain period.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.1.1.1.2

Logging In to the NetEco 1000S Client.

l You have logged in as the system administrator, system operator, or guest user who has
been assigned the historical data query permissions.

l Inverters have connected to the NetEco 1000S through the SmartLogger, and there are at
least 10 inverters connected to the same SmartLogger. For details about how to connect
an inverter, see 5.1.3.1 Accessing Devices Through the SmartLogger.

l Total string capacity has been configured for inverters. For details, see 5.1.3.6
Modifying the Information About a Device.

l An environmental monitoring instrument (EMI) is connected to a plant. For details, see
5.1.3.1 Accessing Devices Through the SmartLogger.

l Availability parameters have been configured for a plant. For details, see 5.1.2.6
Modifying the Information About a PV Plant.

Context

Availability is a key counter for evaluating the performance and reliability of a plant or
inverter. At least 10 inverters connected to the same SmartLogger are required for calculating
availability.

The availability calculation formula is as follows: EA = 1 – ∑iE(i)
loss/(Etotal + ∑iE(i)

loss).

l ∑i indicates the sum calculated by recording time.

l E(i)
loss indicates the energy yield loss of an inverter during a certain period. E(i)

loss = PR x
H x P. You can obtain the total energy yield loss by adding the energy yield loss of all
inverters together.

– PR indicates the daily average PR value that meets configured PR value range in
the last 10 days. For details on how to configure PR value range, see 5.1.2.6
Modifying the Information About a PV Plant.

– H indicates the radiation increment during the recording period.

– P indicates the total string capacity of inverters that are in stopped state (or the
active power output is 0).

l Etotal indicates the actual total energy yield of a plant.
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Procedure
l Query the plant availability.

a. Choose Historical Data > Data Analysis from the main menu.

b. Choose PV Plant Analysis > Availability in the navigation tree on the left.

c. Click  to select the target plant in the operation display area.

NOTE

A maximum of five plants can be selected.

d. Set query conditions according to Table 5-19 and click Query.

Table 5-19 Setting query conditions

Query Conditions Queried Data

Querying data by Month Daily availability data of plants in the current
month

Querying data by Year Monthly availability data of plants in the
current year

Querying data by Total Yearly availability data of plants

 

e. Select the data display style.

To display queried data in a chart, click Graph. To display queried data in a table,
click Table.

f. Optional: To export queried data to the PC for viewing, click Export on the Table
tab page and save the file to the PC.

NOTICE
When a third-party editing tool is used to open the exported file, the tool should support
UCS-2 Decoding Mode. Otherwise, data cannot be decoded.

l Query the inverter availability.

a. Choose Historical Data > Data Analysis from the main menu.

b. Choose Inverter Analysis > Availability in the navigation tree on the left.

c. Click  to select the target SmartLogger in the operation
display area.

NOTE

A maximum of five SmartLoggers can be selected.

d. Set query conditions according to Table 5-20 and click Query.
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Table 5-20 Setting query conditions

Query Conditions Queried Data

Querying data by Month Daily availability data of inverters in the
current month

Querying data by Year Monthly availability data of inverters in the
current year

Querying data by Total Yearly availability data of inverters

 
e. Select the data display style.

To display queried data in a chart, click Graph. To display queried data in a table,
click Table.

f. Optional: To export queried data to the PC for viewing, click Export on the Table
tab page and save the file to the PC.

NOTICE
When a third-party editing tool is used to open the exported file, the tool should support
UCS-2 Decoding Mode. Otherwise, data cannot be decoded.

5.1.5.3.5 Querying Index Values of the Inverters

You can query values of some indexes for some inverters as required to learn the running
status of these indexes in a certain period.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.1.1.1.2

Logging In to the NetEco 1000S Client.
l You have logged in as the system administrator, system operator, or guest user who has

been assigned the historical data query permissions.

Context

The inverter performance ratio indicates the ratio between the actual energy yields and
theoretical energy yields of inverters. The calculation formula is as follows: PR = EAC / (YR ×
PO) x 100%. For definitions of parameters, see 5.1.5.3.2 Querying the Energy Yield
Performance Ratio of the PV Plant.

Procedure

Step 1 Choose Historical Data > Data Analysis from the main menu.

Step 2 Choose Inverter Analysis > Comparative Analysis in the navigation tree on the left.

Step 3 In the operation area, click  to select the inverters to be queried.
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NOTE

A maximum of 50 inverters can be selected.

Step 4 Set query conditions according to the following table and click Query.

Table 5-21 Setting query conditions

Query Conditions Queried Data

Querying data by Day Values of the selected indexes for the selected
inverters of every 15 minutes on the current day

Querying data by Week Values of the selected indexes for the selected
inverters of each hour on each day in the current
week
NOTE

The current week is not the natural week. It considers
the current date as the last day of the current week.

Querying data by Month Values of the selected indexes for the selected
inverters of each day in the current month

Querying data by Year Values of the selected indexes for the selected
inverters of each month in the current year

Querying data by Total Values of the selected indexes for the selected
inverters of a year

 

Step 5 click  to select the indexes to be queried.

NOTE

l When selecting indexes, you can select only one index for the Y1 and Y2 coordinates separately, and
indexes selected for the Y1 and Y2 coordinates must be different.

l If the value of Performance ratio or Specific energy cannot be queried, total string capacity may
not be configured for inverters. To solve this problem, perform the following operations:

1. Configure total string capacity for the target inverter. For details, see 5.1.3.6 Modifying the
Information About a Device.

2. Re-collect historical data of the latest 30 days for the target inverter. For details, see 5.1.5.4
Synchronizing Historical Performance Data.

3. Query the value of Specific energy or Performance ratio again.

Step 6 Select the data display style.

To display queried data in a chart, click Graph. To display queried data in a table, click
Table.

NOTE

If you use the Chrome browser to view a large number of curves, a layout error may occur on the page.
To solve this problem, perform the following operations:

1. Access chrome://flags/ using the Chrome browser.

2. Set Display list 2D canvas to Disabled.

3. Click RELAUNCH NOW.
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Step 7 Optional: To export queried data to the PC for viewing, click Export on the Table tab page
and save the file to the PC.

NOTICE
When a third-party editing tool is used to open the exported file, the tool should support
UCS-2 Decoding Mode. Otherwise, data cannot be decoded.

----End

5.1.5.4 Synchronizing Historical Performance Data

This section describes how to synchronize historical performance data from a device to the
NetEco 1000S by creating a synchronization task on the NetEco 1000S. This solves the
problem that historical performance data cannot be automatically synchronized to the NetEco
1000S after the device is disconnected from the NetEco 1000S for more than 6 hours.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.1.1.1.2

Logging In to the NetEco 1000S Client.

l You have logged in as system administrator or system operator.

l You have added a device to the NetEco 1000S and the device state is normal.

– The device has been connected to the NetEco 1000S over the SmartLogger, and the
SmartLogger is SmartLogger1000 V100R001C91 or later. For details, see 5.1.3.1
Accessing Devices Through the SmartLogger.

– The inverter has been connected to the NetEco 1000S over the FE. For details, see
5.1.3.2 Accessing the Directly Connected Inverter.

Context
l If the device is connected to the NetEco 1000S for the first time using the SmartLogger,

and if it has been running before the connection and stores performance files on the
SmartLogger, you can start the historical performance data synchronization task to
synchronize historical performance data of the device before it is connected to the
NetEco 1000S to the NetEco 1000S. The SmartLogger saves historical performance data
of the latest one month.

l If the inverter directly connected to the FE is connected to the NetEco 1000S for the first
time, and if it has been running before the connection and stores performance files, you
can start the historical performance data synchronization task to synchronize historical
performance data of the inverter before it is connected to the NetEco 1000S to the
NetEco 1000S. The inverter directly connected to the FE saves historical performance
data of the latest one year.

l The synchronization on the NetEco 1000S succeeds only when the SmartLogger or the
inverter directly connected to the FE stores historical performance data that needs to be
synchronized.
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NOTICE
When historical performance data is being synchronized on the device, if you create another
synchronization task for the device, the creation fails.

Procedure

Step 1 Choose Historical Data > Synchronize Historical Data from the main menu.

The Synchronize Historical Data page is displayed, as shown in Figure 5-21.

Figure 5-21 Synchronizing historical data

Step 2 On the Data Synchronization page, click Create Synchronization Task.

The Create Synchronization Task dialog box is displayed, as shown in Figure 5-22.

Figure 5-22 Creating a synchronization task

Step 3 Choose a device for which you want to create a supplementary collection task from the device
navigation tree.

NOTE

By clicking the drop-down box in Figure 5-22 red area, you can quickly filter device type.

Step 4 Set the time range as required.

The time range can be set to Today, Last three Days, Last seven Days, Last thirty Days, or
Customize.

NOTE

The time range of the Customize cannot exceed 30 days.
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Step 5 Click OK.

The supplementary collection task is performed automatically after the task is created.

----End

Follow-up Procedure

If the supplementary collection task fails to be executed, click  to execute the task again.

You can click  to stop a synchronization task.

5.1.5.5 Exporting Historical Data
This section describes how to export 5-minute historical data of a PV plant in the recent one
month on the NetEco 1000S. The data includes data of inverters and EMIs in a PV plant.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.1.1.1.2

Logging In to the NetEco 1000S Client.
l You have logged in as the system administrator, system operator, or guest user who has

been assigned the historical data query permissions.

Procedure
Step 1 Choose Historical > Data Export from the main menu.

The Data Export dialog is displayed, as shown in Figure 5-23.

Figure 5-23 Data Export
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Step 2 Select Start time.

NOTE

Start time cannot be one week earlier than End time. Otherwise, The time range cannot exceed 7
days. is displayed.

Step 3 Select End time.

NOTE

End time cannot be earlier than Start time. Otherwise, The Start time must be earlier than the end
time. is displayed when you click OK.

Step 4 Select the PV plant whose data needs to be exported in the Select PV Plant area.

When there are multiple PV plants, enter the PV plant name in the text box and click  to
search for the PV plant whose data needs to be exported.

Step 5 Click OK.

A message asking you whether to open or save data is displayed at the bottom of the browser.

Step 6 Open or save historical data as required.

NOTICE
When a third-party editing tool is used to open the exported file, the tool should support
UCS-2 Decoding Mode. Otherwise, data cannot be decoded.

----End

5.1.6 Device Maintenance

5.1.6.1 Upgrading a Device

This section describes how to upload a software package and remotely upgrade a device
through the NetEco 1000S.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.1.1.1.2

Logging In to the NetEco 1000S Client.

l You have added a device to the NetEco 1000S and the device state is normal. For
detailed operations, see 5.1.3.1 Accessing Devices Through the SmartLogger, 5.1.3.2
Accessing the Directly Connected Inverter or 5.1.3.3 Searching Devices Based on
Serial Port Addresses.

l You have logged in as system administrator.

l You have contacted Huawei technical support engineers to obtain the software package
required for device upgrade and have checked the integrity of the software package.
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NOTE

You can check the integrity of the software package by referring to 5.1.8.6 Verifying OpenPGP
Signature.

Software package integrity check is related to the software security. You must perform the check to
ensure the software security.

Procedure

Step 1 Choose Maintenance > Software Management from the main menu.

Step 2 Click the Device Upgrade Management or Batch Upgrade Management tab.

NOTE

l To upgrade some specified devices (for example, SmartLogger, inverter, PLC or PID), you can
perform related operations on the Device Upgrade Management tab page.

l To upgrade inverters under the same SmartLogger (the version of the SmartLogger must be
V100R001C95SPC030 or later) at the same time, you can perform related operations on the Batch
Upgrade Management tab page. This function applies only to the scenario where the device
accesses the NetEco 1000S through the SmartLogger.

Step 3 Upload the device software package to be upgraded.

1. Click Software Package Management.
2. Click Upload on the Software Package Management page.
3. Click Browser to select the software package, and then click Upload.

After the upload is complete, information about the new software package is displayed in
the software package list.

NOTE

To delete the uploaded software package, select the software version in the software package list
and click Delete.

4. Click Close.

Step 4 Upgrade the software package of the device.

1. Select the devices to be upgraded in the device list.

NOTE

– You can filter out the list of target devices by device name or plant name.

– On the Batch Upgrade Management tab page:

n If the SmartLogger allows inverters to be selected for upgrade, a check box will be
displayed before an inverter under the SmartLogger. Select the check box before a target
inverter to upgrade.

n If the SmartLogger does not allow inverters to be selected for upgrade, a check box will
not be displayed before an inverter under the SmartLogger. Select the SmartLogger to
upgrade inverters in batches.

2. Click Select Version.
The Select Target Version dialog box is displayed, showing all upgrade software
packages for the device type.
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NOTE

– If the selected target device is an inverter, the Select Target Version dialog box shows the
software packages applicable to the protocol version of the selected inverter.

– If the selected target device is a SmartLogger, the Select Target Version dialog box shows the
software packages applicable to the V version (VXX in VXXRXXCXX) of the selected
SmartLogger.

3. Select the target version in the Select Target Version window and click OK.
4. Click Upgrade above the device list.

The upgrade progress is displayed in the Upgrade Progress column of the device list.
When you upgrade multiple devices at the same time on the Device Upgrade
Management tab, you can click Stop Upgrade to stop the upgrade task whose Current
Status is Waiting.
Click Details under Current Status. Details about the inverter upgrade are displayed, as
shown in Figure 5-24.

Figure 5-24 Inverter upgrade details

NOTE

When Loading completed. is displayed, the NetEco automatically activates the inverter, and The
inverter is going to activate automatically is displayed. If the device does not meet activation
requirements, the NetEco automatically activates the device after activation requirements are met. After
the device is activated successfully, the NetEco displays the latest device version.

----End

5.1.6.2 Obtaining Device Logs

This section describes how to obtain device logs for device analysis and maintenance.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.1.1.1.2

Logging In to the NetEco 1000S Client.
l You have added a device to the NetEco 1000S and the device state is normal. For

detailed operations, see 5.1.3.1 Accessing Devices Through the SmartLogger, 5.1.3.2
Accessing the Directly Connected Inverter or 5.1.3.3 Searching Devices Based on
Serial Port Addresses.

l You have logged in as system administrator or system operator.

Context

Remotely obtaining device logs applies SmartLogger, inverters, PLC and PID.
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Procedure

Step 1 Choose Maintenance > Device Maintenance from the main menu.

Step 2 Click the Device Log tab.

The Device Log window is displayed.

Step 3 Select a device in the device list, and click Obtain.

When Finish is displayed in the Execution Status column, device logs are synchronized to
the NetEco 1000S.

NOTE

l You can filter out the list of target devices by device name or plant name.

l You can click  in the Operation column to stop obtaining device logs.

Step 4 Click Download the log or  in the Log File column to download the device log file to the
local PC.

----End

5.1.6.3 Obtaining the Inverter Patrol Report

This section describes how to obtain the inverter patrol report to help technical support
engineers learn the running counter values and state of health (SOH) of inverters and to
provide reference for device maintenance and exception location.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.1.1.1.2

Logging In to the NetEco 1000S Client.
l You have added a device to the NetEco 1000S and the device state is normal. For

detailed operations, see 5.1.3.1 Accessing Devices Through the SmartLogger, 5.1.3.2
Accessing the Directly Connected Inverter or 5.1.3.3 Searching Devices Based on
Serial Port Addresses.

l You have logged in as system administrator or system operator.

Procedure

Step 1 Choose Maintenance > Device Maintenance from the main menu.

Step 2 Click the Inverter Patrol tab.

The Inverter Patrol tab page is displayed.

NOTE

You can filter out the list of target devices by device name or plant name.

Step 3 Start the inverter patrol.

1. Select the target inverter in the device list and click Start Patrolling or  in the
Operation column.

2. When the following information is displayed, click OK:
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Are you sure you want to execute the task

Step 4 Obtain the inverter patrol report.

1. Select the target inverter for which a patrol report has been generated and click Batch
Download Report.
A message asking you whether to open or save data is displayed at the bottom of the
browser.

2. Click Download the report or  in the Patrol report colum to download the patrol
report to the local PC.

----End

5.1.6.4 Managing Device List

User can view and export the device version, SN, and communication address on the Device
Management page, as well as modify device names in batches.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.1.1.1.2

Logging In to the NetEco 1000S Client.
l You have added a device to the NetEco 1000S and the device state is normal. For

detailed operations, see 5.1.3.1 Accessing Devices Through the SmartLogger, 5.1.3.2
Accessing the Directly Connected Inverter or 5.1.3.3 Searching Devices Based on
Serial Port Addresses.

l You have logged in as system administrator or system operator.

NOTE

A user in the system operator group can only view and export the device information about the plants to
which the user has access, and batch modify device names for the plants to which the user has access.

Procedure

Step 1 Choose Maintenance > Device Maintenance from the main menu.

Step 2 Click the Device Management tab.

The Device Management window is displayed.

Step 3 Set Device name, Version No., SN, PV plant name or Device type, and click Query.

Target devices meeting the preset condition are filtered out.

NOTE

For a device whose Device type is SmartLogger, you can click the Device address link in the
Communication address column to switch to the web client of the SmartLogger.

Step 4 Click Export.

You can export information about devices displayed on the page.

To modify device names in batches, go to the next step.

Step 5 Change Device Name in the exported .xls file, and save the file.
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Step 6 In the Device Management window, click Import Names.

The Import Names dialog box is displayed.

Step 7 Click Browse, and select the .xls file saved in Step 5.

NOTICE
Only .xls files can be imported. The file size must be less than 2 MB. The file must contain
the Device Name and SN columns, and the columns must not be empty.

Step 8 Click Execution.

NOTICE
During the Execution, the modification task will be stopped if you close the Import Names
dialog box.

During the Execution, you can click Stop to stop unfinished modification task.

If modifying device names fails, Details in Import Names will provide the device whose
name fails to be modified and the failure cause.

Step 9 Click Close.

----End

5.1.6.5 Replacing a Device

This section describes how to replace a device. If the device connecting to the NetEco 1000S
needs to be replaced due to a fault or aging, you can replace it with a new one. Devices
supporting the replacement include the inverter, EMI, Meter, and SmartLogger.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.1.1.1.2

Logging In to the NetEco 1000S Client.
l The current user is system administrator or system operator.
l You have added a device to the NetEco 1000S and the device state is normal. For

detailed operations, see 5.1.3.1 Accessing Devices Through the SmartLogger, 5.1.3.2
Accessing the Directly Connected Inverter or 5.1.3.3 Searching Devices Based on
Serial Port Addresses.

l The old device has been deleted or is disconnected from the NetEco 1000S.
l The new device and the old device are connected to the same PV Plant.

Procedure

Step 1 Choose Maintenance > Device Maintenance from the main menu.
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Step 2 Click the Device Management tab.

The Device Management window is displayed.

Step 3 Click Replace Device.

The Replace Device dialog box is displayed.

Step 4 Select a device type, and enter the Old device SN, New device SN and Device name. Then
click OK.

NOTE

Device name specified here is the name of the new device to be displayed in the NetEco 1000S. Device
name must be different from the names of the existing devices in the same PV plant.

If you attempt to replace an inverter, meter, or EMI, and the old and new devices are not
connected to the same SmartLogger, the following message is displayed.
The devices are not connected to the same SmartLogger. Continue?

Step 5 Click OK, and complete the device replacement as prompted.

NOTE

If you want to cancel the replacement, click Cancel.

----End

5.1.6.6 Querying NetEco Alarms
If the NetEco 1000S certificate has expired, the license has expired, or remote notification
emails fail to be sent, the NetEco 1000S will generate a corresponding NetEco alarm. You can
query NetEco alarms to learn the NetEco alarm information for the NetEco 1000S and handle
alarms accordingly.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.1.1.1.2

Logging In to the NetEco 1000S Client.
l You have logged in as system administrator.

Context
Check the NetEco alarm icon in the upper right of the home page of the NetEco 1000S client
to determine whether a NetEco alarm exists. If a NetEco alarm exists, view the detailed alarm
information on the NetEco Alarm page.

l : A NetEco alarm is generated on the NetEco 1000S.

l : No NetEco alarm is generated on the NetEco 1000S.

Procedure

Step 1 On the home page of the NetEco 1000S client, click the NetEco alarm icon .

The NetEco Alarm page is displayed.

Step 2 Set Time and Clear Status, and click Query.

NetEco alarms that meet the conditions can be queried.
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Step 3 Click Alarm Name for a NetEco alarm record to view the detailed alarm information and
troubleshooting advice.

NOTE

NetEco alarms whose details are not queried will be highlighted in bold.

Step 4 Optional: Click Export to export the queried alarm information into a CSV file.

----End

5.1.6.7 Obtaining NetEco Logs

This section describes how to obtain NetEco logs. The logs help you learn the operating status
of the NetEco 1000S and locate problems when the NetEco 1000S is not running properly.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.1.1.1.2

Logging In to the NetEco 1000S Client.
l You have logged in as system administrator.

Context

The NetEco records run logs automatically every day. When the system becomes abnormal,
the system administrator quickly obtains the corresponding logs through the client to locate
the problem.

Procedure

Step 1 Choose Maintenance > NetEco Maintenance from the main menu.

The NetEco Maintenance page is displayed.

Step 2 Obtain the trace log.

The trace log records the system run log. When the system becomes abnormal, you can obtain
the trace log to locate the problem.

1. Click the Trace Log tab.
2. Click Refresh. The latest log information is displayed.
3. Select the log to be obtained.

NOTE

You can enter the log name keyword, such as the date, in the File Name text box and click Search
to search for all logs whose names contain this keyword.

4. Click Download.
A message asking you whether to open or save the log is displayed at the bottom of the
browser. You can open or save the log as required.

Step 3 Obtain other logs.

Other logs record all logs except the trace log. These logs include database error logs,
configuration file modification logs, attack logs, FTP logs, and script logs. When problems
cannot be located using the trace log, you can obtain other logs to facilitate problem location.
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1. Click the Other Logs tab.

2. Click Refresh. The latest log information is displayed.

3. Select the log to be obtained.

NOTE

You can enter the log name keyword, such as the date, in the File Name text box and click Search
to search for all logs whose names contain this keyword.

4. Click Download.

A message asking you whether to open or save the log is displayed at the bottom of the
browser. You can open or save the log as required.

----End

5.1.6.8 Smart I-V Curve Diagnosis

The smart I-V curve diagnosis function allows you to check the health status of strings for the
inverters connected to the NetEco 1000S.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.1.1.1.2

Logging In to the NetEco 1000S Client.

l The current user is system administrator or system operator.

l String parameters have been configured for inverters. For details about how to configure
the parameters, see 5.1.3.6 Modifying the Information About a Device.

l The inverter license controls the smart I-V curve diagnosis function. To ensure that smart
I-V curve diagnosis works properly, perform scheduled inspection and import the
inverter license file. For details, see 5.1.6.9 Managing Device Licenses.

Procedure

Step 1 Choose Maintenance > Smart I-V Curve Diagnosis from the main menu.

The Smart I-V Curve Diagnosis page is displayed, as shown in Figure 5-25.

Figure 5-25 Smart I-V Curve Diagnosis

The content in the red frame in Figure 5-25 is the conditions and suggestions for smart I-V
curve diagnosis. Read the content carefully and ensure that the conditions are met. To
minimize the content, click Operation Suggestion.

Step 2 Click Start Scanning.

The Settings of Task page is displayed, as shown in Figure 5-26.
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Figure 5-26 Task Settings

Step 3 Set the I-V diagnosis task.

1. Set I-V diagnosis parameters, as described in Table 5-22.

Table 5-22 Description of I-V diagnosis parameters

Parameter Description

Task name Set this parameter to a string of a maximum of 64
characters.

Task type Value:
– Task On Plant-Level: The health check applies to

strings for all inverters connected to a PV plant.
– Task On Inverter-Level: The health check applies

to all strings for an inverter.
NOTE

– If Task type is set to Task On Plant-Level, the object is
a SmartLogger. A maximum of 10 SmartLoggers can be
scanned simultaneously, and the SmartLoggers must be
connected to the same plant.
A task whose type is Task On Plant-Level will be
displayed on the Plant-Level Task tab page under
Smart I-V Curve Diagnosis after creation.

– If Task type is set to Task On Inverter-Level, the
object is an inverter. A maximum of 10 inverters can be
scanned simultaneously, and the inverters must be
connected to the same plant.
A task whose type is Task On Inverter-Level will be
displayed on the Inverter-Level Task tab page under
Smart I-V Curve Diagnosis after creation.
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Parameter Description

Scanning mode Select an appropriate scanning mode from the drop-
down list box.
Value:
– Standard mode(128 scanning spots)
– Rapid mode(64 scanning spots)

PV plant In the PV plant area, select the object to be scanned.
You can also enter a search criterion in the text box,

and click  to search for the object that meets the
search criterion.

Cleaning status Specifies the cleaning status of a string. Select a value
as required.

Environmental data Select a mode from the drop-down list box.
Value range:
– Auto: The system will automatically calculate the

values of Irradiance and Temperature of panel.
– Manually: You need to manually enter the values

of Irradiance and Temperature of panel.

Irradiance This parameter is displayed only if Environmental
data is set to Manually.
Value range: 200.0000 to 9999.9999

Temperature Of Panel This parameter is displayed only if Environmental
data is set to Manually.
Value range: –100.0000 to 100.0000

 
2. Click Save.

After a task is set, smart I-V curve diagnosis starts immediately, as shown in Figure 5-27.

Figure 5-27 Executing a diagnosis task

To stop a I-V diagnosis task, click  in the Operation column. After a diagnosis task is
stopped or the string diagnosis scanning is complete,  will not be displayed on the page.

After diagnosis tasks are completed,

l By default, the Plant-Level Task tab page displays the diagnosis results of all
SmartLoggers in the tasks. You can click  next to a task name to collapse the
corresponding information.
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l By default, the Inverter-Level Task tab page displays the diagnosis results of all
inverters in the tasks. You can click  next to a task name to collapse the corresponding
information.

Step 4 View the diagnosis result and diagnosis details.

1. Click .
The diagnosis task execution result is displayed, as shown in Figure 5-28.

Figure 5-28 Diagnosis result

Table 5-23 describes the parameters in the diagnosis result.

Table 5-23 Description of diagnosis parameters

Parameter Description

Task Status Status of the I-V diagnosis task

Health condition Health status of strings

Abnormal Type A value is displayed for the exception type when the
value of Health condition is Abnormal.

Operation – Export the diagnosis details: Select the string
whose diagnosis details are to be exported and
click Export to export the diagnosis details in
batches.

– View the diagnosis details. For details, see Step
4.2.

 
2. View the diagnosis details.

a. Click Read The Details.
The diagnosis details are displayed, as shown in Figure 5-29.
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Figure 5-29 Diagnosis details

You can view the detailed parameters and current and power curves of strings on
the Read The Details page.

b. Click Export.
You can export the detailed information of strings.

Step 5 Query the intelligent diagnostic report.

1. Click  under Operation column in Figure 5-27.
The Diagnostic Report page is displayed.

2. The basic information of the string diagnosis task is displayed under Information of
Task area.

3. Query Overview on Diagnosis.
The pie chart and detailed information of the diagnosis result are displayed, as shown in
Figure 5-30.

Figure 5-30 PV string diagnosis overview

For the overview parameter description, see Table 5-24.
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Table 5-24 PV string diagnosis overview

Parameters Description

Legend Corresponds to each legend in the pie chart.

Quantity Sum of the strings.

Ratio Proportion of the strings.

Description Description of health status for strings.

Following Advise
Click  to display suggestions for each exception.

 

4. Query List Of Defective Strings.

Information of all defective strings is displayed, as shown in Figure 5-31.

Figure 5-31 Defective string list

NOTE

In the red frame, the optimal value, intermediate value, and average value of the scanned normal
strings are displayed as well as related parameter information of corresponding strings.

5. Select a string under the Comparison column to display the I-V curve comparison
analysis diagram of the corresponding string, as shown in Figure 5-32.

Figure 5-32 String I-V curve comparison analysis diagram

6. Optional: Click Export in the upper left corner of the page. Select the format of the
intelligent diagnostic report to be exported in the drop-down list box as required.

There are CSV Format and PDF Format available.

----End

iManager NetEco 1000S
User Manual 5 Operation and Maintenance

Issue Draft C (2017-12-14) Huawei Proprietary and Confidential
Copyright © Huawei Technologies Co., Ltd.

113



5.1.6.9 Managing Device Licenses
The inverter license controls the smart I-V curve diagnosis function. You can manage device
licenses on the NetEco 1000S client, for example, loading device licenses and viewing device
license information. The NetEco 1000S supports license management only for inverters.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.1.1.1.2

Logging In to the NetEco 1000S Client.
l You have added a device to the NetEco 1000S and the device state is normal. For

detailed operations, see 5.1.3.1 Accessing Devices Through the SmartLogger, 5.1.3.2
Accessing the Directly Connected Inverter or 5.1.3.3 Searching Devices Based on
Serial Port Addresses.

l You have logged in as system administrator or system operator.

Procedure

Step 1 On the main menu, choose Maintenance > Device License Management.

Step 2 In the navigation tree on the left, select the target device.

You can also specify parameters such as Device name, SN and License Status on the License
Details, License Application, License Loading, or License Revocation tab page, and then
click Query. The devices that meet the search criteria are displayed.

Step 3 Perform operations according to Table 5-25.
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Table 5-25 License-related operations

Task Name Task
Description

Procedure

Querying
license
information

For routine
operation and
maintenance, the
license validity
and function
usage are
queried routinely
to check whether
the license is
about to expire
and solve the
problems in a
time manner. In
this way, the
device can
function
properly.

Choose License Details to view the license
information of the target device.
1. Select the target device and click Refresh. The

license information is refreshed.
2. Click Device Name of the target device. Then the

function control information of the device will be
displayed in the lower part of the page, as shown
in Figure 5-33.

Figure 5-33 Function control information

3. Optional: Export license details.
– Select Export All from the Export Details

drop-down list box and save the license
information of all devices that are queried to
the PC.

– Select the target device in the displayed
operation area. Select Export Selected from
the Export details drop-down list box and save
the license information of the target device to
the PC.

NOTE
The license information file is saved as a .csv file.

Exporting a
license
application
file

The license
application file
contains the
content required
for applying the
device license.
When you need
to apply for a
device license,
export a license
application file
on the License
Application
page.

1. Choose License Application.
2. Export the license application file.

– Select Export All from the Export License
Application File drop-down list box and save
the license application file of all devices that
are queried to the PC.

– Select the target device in the displayed
operation area. Select Export Selected from
the Export License Application File drop-
down list box and save the license application
file of the target device to the PC.

NOTE
The license application file is saved as an .xls file.
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Task Name Task
Description

Procedure

Loading a
license

If the license has
not been
imported for the
device or the
license is about
to expire, you
need to import
the new license
file to the device,
ensuring that the
device functions
properly.

1. Choose License Loading.
2. Click Upload License.

The Upload License dialog box is displayed.
3. Click Browse and select the license to be

imported.
The License file format should be either .dat
or .zip. The number of license file in .zip file
cannot exceed 6000.

4. Click Upload.
The license file is uploaded.

5. Load the license.
– Select Load All from the Load License drop-

down list box and import the loaded license file
to all the devices that are queried.

– Select the target device in the displayed
operation area. Select Load Selected from the
Load License drop-down list box and import
the loaded license file to the target device.

Revoking a
license

Before a device
is replaced, the
current device
license needs to
be revoked so
that the
revocation code
can be generated
and used for
applying for a
new device
license. After the
monitoring board
or device is
replaced, you
can import the
new license file
to the device,
and then the
device functions
properly.

1. Choose License Revocation.
2. Select the device whose license needs to be

revoked.
3. Click Revoke License.
4. In the displayed Warning dialog box, enter the

password of the user and click OK.
5. Optional: Export the revocation code file.

– Select Export All from the Export Revocation
Code File drop-down list box and save the
revocation code file of all devices that are
queried to the PC.

– Select the target device in the displayed
operation area. Select Export Selected from
the Export Revocation Code File drop-down
list box and save the revocation code file of the
target device to the PC.

NOTE

l The revocation code file is saved as an .csv file.

l You need to log in as an admin user to export the
revocation code file.

 

----End

5.1.7 System Management
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5.1.7.1 Managing User Information
This section describes how to manage user information. The user management function
allows you to manage the information about and operation rights of users.

5.1.7.1.1 User Categories

This section describes user categories. You need to familiarize yourself with these user
categories before managing users.

Software users: system administrator, system operators, and guest users.

Third-party user: OpenAPI users.

Operation permissions vary by user. Table 5-26 lists the software users and their operation
permissions.

Table 5-26 User operation permissions

User Category Operation Permissions

System administrator
NOTE

l The system administrator
cannot be deleted or
modified.

l To improve system security,
you are advised to change
the initial keys set before
product delivery in a timely
manner and periodically (at
an interval of 3 months)
change the user key to
avoid security risks, such as
violent key cracking.

The system administrator has all the operation permissions,
including:
l PV plant management: creates, modifies, and deletes

PV plants; sets information of PV plants, and browses
information about PV plants, device lists, and current
alarms.

l Device management: manually and automatically
connects devices, searches, modifies, and deletes
devices, sets information of devices, browses
information about devices and current alarms, and
remotely controls a SmartLogger and PID.

l Managing Other Devices: adds other devices.
l Historical data: queries alarm logs, performance data,

and data analysis; synchronizes historical performance
data, and exports data.

l Device maintenance: upgrades devices, replaces
devices, manages devices, patrol to the inverter, obtains
NetEco logs and device logs, and performs smart I-V
curve diagnosis.

l System management: manages users, sets remote
notification, queries user logs, has license management,
and sets the system parameters.
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User Category Operation Permissions

System operators l PV plant management: creates, modifies, and deletes
PV plants, sets information of PV plants, and browses
information about PV plants, device lists, and current
alarms.

l Device management: automatically connects devices,
modifies and deletes devices, sets information of
devices, browses information about devices and current
alarms, and remotely controls a SmartLogger and PID.

l Historical data: queries alarm logs, performance data,
and data analysis; synchronizes historical performance
data, and exports data.

l Device maintenance: patrol to the inverter, manages
devices, performs smart I-V curve diagnosis and
obtains device logs.

l System management: manages users and sets remote
notification rules.

Guest users l PV plant management: modifies descriptions and
parameters of PV plants, browses information about PV
plants, device lists, and current alarms, and uploads and
deletes PV plant images.

l Device management: browses information, settings and
current alarms about devices.

l Historical data query: queries alarm logs, performance
data, and data analysis; and exports data.

NOTE

l Historical data query permissions need to be assigned by the
system administrator or operator to the guest user.

l After the system administrator or operator modifies the
permissions of the guest user, the guest user needs to log in to
the NetEco 1000S client again to refresh the permissions.
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User Category Operation Permissions

OpenAPI users
NOTE

l The OpenAPI users can
only be created by the
system administrator and
system operators.

l The OpenAPI users do not
have permission to access
the NetEco 1000S or query
other user information in
the NetEco 1000S.

l For account security
purposes, you are advised to
change the user password
periodically (for example,
at an interval of 3 months)
to avoid security risks, such
as violent key cracking.

l If the system
administrator creates
the OpenAPI user, only
the system
administrator can reset
the password.

l If the system operator
creates the OpenAPI
user, the system
administrator or
operator can reset the
password.

You can access the data query interface to query the
following data:
l PV plant list;
l Device list (only inverter and EMI data included);
l Real-time monitoring data of a specific PV plant;
l Real-time monitoring data of a device under a specific

PV plant (only inverter and EMI data included);
l Yearly, monthly, and daily performance data of a

specific PV plant as well as its total performance data.

 

5.1.7.1.2 Adding a User

This section describes how to add a user on the NetEco 1000S. You can add users as required.
The operation permissions of users vary according to user categories.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.1.1.1.2

Logging In to the NetEco 1000S Client.

l You have logged in as system administrator or system operator.

Procedure

Step 1 Choose System > User Management from the main menu.

The User Management window is displayed.

Step 2 Choose User from the menu bar on the left.

The User page is displayed, as shown in Figure 5-34.
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Figure 5-34 User

NOTE

System operators can see only their own information and information about guest users and OpenAPI
users they have created.

Step 3 Click Create User.

The Create User window is displayed.

Step 4 Set the user parameters according to Table 5-27 and then click OK.

Table 5-27 Parameter description

Parameter Description

User name Name of the new user.
The user name can only contain English characters (A to Z
and a to z), digits, hyphens, or underlines.
NOTE

The user name cannot be null or NULL.

l System operators can only create guest users and OpenAPI users.
The operators can also bind PV Plant with guest users and bind
the PV Plants whose data can be queried with OpenAPI users.
After the login, guest users can only manage PV Plants bound
with the guest users and OpenAPI users can only query data of
PV Plants bound with the OpenAPI users.

l When the system administrator adds the permission of a device
for the guest or OpenAPI users created by the system operator, the
system operator has no permission of this device.

l When the system administrator cancels the permission of a device
managed by the system operator, guest users and OpenAPI users
created by the system operator still have the permission of this
device.

See 5.1.7.1.6 Setting an Account Policy to set the user name
length.
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Parameter Description

Password Password of the new user. The password must comply with
the following rules:
l The password cannot be the same as the user name or the

user name in a reversed order.
l The password contains 8 to 32 characters.
l The password contains three of the following:

– Lowercase letters
– Uppercase letters
– Digits

The password is advised to contain special characters, which
include !"#$%&'()*+,-./:;<=>?@[\]^`{_|}~ and space.
NOTE

The system administrator can set the password complexity policy on
the NetEco 1000S client. For details, see 5.1.7.1.7 Setting a
Password Policy.

Email address Email address of the user.

User type Type of the user. The type can be Operator, Guest, or
OpenAPI User.

Optional permissions
NOTE

This parameter would not
be displayed when creating
users in the Operator
group.

The system administrator or operator can assign the historical
data query permissions to the guest user.
l Select Query historical data: indicating that the user has

the historical data query permissions.
l Clear Query historical data: indicating that the user does

not have the historical data query permissions.

Description Description of the user.
The description cannot contain more than 255 characters.

User status Status of the user. The status includes:
l Disable: The user is disabled and cannot log in to the

NetEco 1000S.
l Enable: The user can log in to the NetEco 1000S.

Select a PV plant that can
be accessed

Permission for the user to access the PV plant.

 

The added user is displayed in the user list in the User Management window.

----End

5.1.7.1.3 Modifying User Information

This section describes how to modify user information. If information about a user needs to
changed, the password of the user is forgotten or the account is locked, you can modify
information about the user as an administrator.
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Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.1.1.1.2

Logging In to the NetEco 1000S Client.

l You have logged in as system administrator or system operator.

Procedure

Step 1 Choose System > User Management from the main menu.

The User Management window is displayed.

Step 2 Choose User from the menu bar on the left.

The User page is displayed, as shown in Figure 5-35.

Figure 5-35 User

NOTE

System operators can see only their own information and information about guest users and OpenAPI
users they have created.

Step 3 In the User page, you can do the following operations in Table 5-28.

NOTE

l The admin user can manage all users.

l System operators can manage only users created by it.

Table 5-28 operations

Operations Description

Enable If the Use Status is invalid, you can click  to enable the account.

Disable If the Use Status is normal, you can click  to disable the account.

Unlock If the Use Status is lock, you can click  to unlock the account.

Edit Click  to modify the Email address, use status, optional permissions,
description and control permission of an account.
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Operations Description

Password reset When a user forgets the password for logging in to the NetEco 1000S,
the user can reset the password, and then use the new password to log
in to the NetEco 1000S.
NOTE

The password of the system administrator cannot be reset. Therefore, you have to
remember the password of this user.

l The password cannot be the same as the user name or the user name in a
reversed order.

l The password contains 8 to 32 characters.

l The password contains three of the following:

– Lowercase letters

– Uppercase letters

– Digits

l The password is advised to contain special characters, which include !"#$
%&'()*+,-./:;<=>?@[\]^`{_|}~ and space.

1. Click .
2. In the displayed window, set New password and Confirm

password.
3. Click OK.

Delete
Click . In the displayed window, click OK to delete the account.

 

----End

Other operations
In the User page, the description of all parameter is as shown in Table 5-29.

Table 5-29 GUI parameters

Parameter Description

User Name Displays names of all accounts in the system.

Email
address

Email address of the user.

User Type Displays the type of an account. The type includes Administrator,
Operator, Guest, and OpenAPI User.

Description Displays the description of an account.
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Parameter Description

Status Displays the status of an account. The status includes:
l normal: indicates that the account is properly used.
l invalid: indicates that the account is currently not used.
l lock: indicates that the account is automatically locked by the system

after the user enters the incorrect password for multiple times or
disobeys the password policy.

 

5.1.7.1.4 Querying PV Plants to Which a User Belongs

This section describes how to query PV plants to which a user belongs. This helps learn the
PV plants that the user can operate and user information recorded in the PV plants, facilitating
the PV plant administrator's management operation.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.1.1.1.2

Logging In to the NetEco 1000S Client.
l You have logged in as system administrator or system operator.

Procedure

Step 1 Choose System > User Management from the main menu.

The User Management window is displayed.

Step 2 Choose User from the menu bar on the left.

The User page is displayed, as shown in Figure 5-36.

Figure 5-36 User

NOTE

System operators can see only their own information and information about guest users and OpenAPI
users they have created.

Step 3 Set search criteria.
l PV plant: Enter the name of the to-be-queried PV plant. You can enter names of

multiple PV plants and separate them by semicolon (;).
l User Name: Enter the to-be-queried user name.
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NOTE

You can set PV plant or User Name as required.

Step 4 Click Query.

----End

5.1.7.1.5 Modifying the Password of the Current User

This section describes how to modify the password of the current user. You are advised to
modify user password regularly to ensure system security.

Prerequisites
You have logged in to the NetEco 1000S client. For detailed operations, see 5.1.1.1.2 Logging
In to the NetEco 1000S Client.

Procedure

Step 1 Click from the main menu.

The Modify Password dialog box is displayed, as shown in Figure 5-37.

NOTICE
To improve system security, you are advised to change the initial keys set before product
delivery in a timely manner and periodically (at an interval of 3 months) change the user key
to avoid security risks, such as violent key cracking.

Figure 5-37 Modify Password

Step 2 Optional: The current user is system administrator or system operators can change the
password in the following way.
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1. Choose System > User Management from the main menu;
2. The User Management dialog box is displayed, Choose Modify Password from the

menu bar on the left,as shown in Figure 5-38;
3. Click Set in Figure 5-38, The Modify Password dialog box is displayed, as shown in

Figure 5-37.

Figure 5-38 Modify admin Password

Step 3 Enter the old password and new password and confirm the new password.

NOTE

l The password cannot be the same as the user name or the user name in a reversed order.

l The password contains 8 to 32 characters.

l The password contains three of the following:

– Lowercase letters

– Uppercase letters

– Digits

l The password is advised to contain special characters, which include !"#$%&'()*+,-./:;<=>?
@[\]^`{_|}~ and space.

Step 4 Click OK.

----End

5.1.7.1.6 Setting an Account Policy

This topic describes how to set an account policy to improve access security of the NetEco.
The account policy settings include the length of the user name and the policies related to user
login.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.1.1.1.2

Logging In to the NetEco 1000S Client.
l You have logged in as system administrator.

Context
l The account policy applies to the following users after the account policy is successfully

set:
– New users.
– Users whose information is modified.

l Account policies apply to all accounts except system administrator.
l The NetEco provides the default account policy, and you can modify it as required.
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The current login account will be locked if the number of consecutive failed login attempts
exceeds the preset value within a certain period. The locking policy is as follows:

l system administrator: The current login IP address will be locked. You can use another
IP address to log in to the NetEco 1000S.

l system operators or guest users: The current login account will be locked. For details
about how to unlock the account, see 5.1.7.1.3 Modifying User Information.

Procedure

Step 1 Choose System > User Management from the main menu.

Step 2 In the navigation tree on the left, choose Account Policy.
l system operators or guest users: The current login account will be locked if the number

of consecutive failed login attempts exceeds the preset value within a certain period. For
details about how to unlock the account, see 5.1.7.1.3 Modifying User Information.

l system administrator: The current login IP address will be locked 5 minutes if the
number of consecutive failed login attempts more than 5 within 10 minutes.

NOTICE
Restart the service will make the lock failed, please use caution.

Step 3 On the Account Policy page, set the account policy as required.

When Account disabling policy is selected, this policy is applicable to all users except the
admin user. If a user has not logged in for a consecutive period longer than the period

iManager NetEco 1000S
User Manual 5 Operation and Maintenance

Issue Draft C (2017-12-14) Huawei Proprietary and Confidential
Copyright © Huawei Technologies Co., Ltd.

127



specified in The account has not been used for (consecutive days), the account will be
disabled.

To enable a disabled account, see 5.1.7.1.3 Modifying User Information and perform the
required operations.

Step 4 Click Apply.

----End

5.1.7.1.7 Setting a Password Policy

You can set a password policy to improve access security of the NetEco. The password policy
settings include the user password complexity rules, password change interval, and character
restriction.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.1.1.1.2

Logging In to the NetEco 1000S Client.
l You have logged in as system administrator.

Context
l A password policy applies to all users once it is configured. After the minimum length of

the user password is specified and validated, if an online user wants to change the
password, the user needs to set the new password based on the specified minimum
password length requirements.

l You need to set a password based on the password policy when you create a user.
l A new password policy does not affect the configured password.
l The NetEco provides the default password policy, and you can modify it as required.

NOTICE
Disabling the functions of password strength policies and password change intervals will
lower account security. You are advised to enable all password security policies provided by
the NetEco.

Procedure

Step 1 Choose System > User Management from the main menu.

The User Management window is displayed. Choose Password Policy from the menu bar on
the left, as shown in Figure 5-39.
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Figure 5-39 Password Policy

Step 2 In the window shown in Figure 5-39, set Password Policy as required.

NOTE

When you change the passwords of other users as system administrator, the value of Enable account
lock policy has no impact on the change. That is, the password change interval is not limited when you
change the passwords of other users as system administrator.

Step 3 Click Apply.

----End

5.1.7.1.8 Managing the Online Users

You can view online user to find unauthorized login users and log out these users, which
prevents unauthorized operations performed on the NetEco 1000S client.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.1.1.1.2

Logging In to the NetEco 1000S Client.

l You have logged in as system administrator.

Procedure

Step 1 Choose System > User Management from the main menu.

Step 2 In the navigation tree on the left, choose View Online User.

Step 3 On the View Online User page, view online users, and their login time, login IP addresses,
and roles to which they belong. In addition, you can perform the following operations:

Task Procedure

Update online user information Click Refresh to update the online user
information.
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Task Procedure

Force a user to log out When viewing online users, you can force
an unauthorized user to log out. This
prevents the unauthorized user from
performing unauthorized operations on the
NetEco 1000S client.

1. On the View Online User page, click
in the Operation column where the
required user information is located.

2. In the Warning dialog box, click OK.
NOTE

You are advised to view the online users at
regular time, force the unauthorized users to log
out in time.

Enter Single session Mode Users can enter the single-session mode to
prevent the interference from other users'
operations.
1. Select Single session Mode.
2. In the Warning dialog box, click OK.
NOTE

l After entering the single-session mode, users
can log in to the NetEco 1000S only on one
terminal.

l After entering the single-session mode, the
logged-in users are not affected.

l Single-session is a safe mode, recommended
for use.

Exit Single session Mode 1. Deselect Single Session Mode .
2. In the Warning dialog box, click OK.
NOTE

After exiting the single-session mode, users can
re-log in to the NetEco 1000S on multiple
terminals.

 

----End

5.1.7.1.9 Setting the Idle Logout Time

This topic describes how to set the client to be logged out automatically. To prevent other
users from performing unauthorized operations, the NetEco 1000S allows you to set related
idle parameters. The client is automatically logged out after being left idle for a specified
period of time.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.1.1.1.2

Logging In to the NetEco 1000S Client.
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l You have logged in as system administrator.

Context

This operation applies to the system administrator, system operators, and guest users. For
OpenAPI users, the idle logout time is 20 minutes and cannot be modified.

Procedure

Step 1 Choose System > User Management from the main menu.

Step 2 Choose Logout Time Setting on the left.

The Logout Time Setting page is displayed, as shown in Figure 5-40.

Figure 5-40 Logout Time Setting

Step 3 Set the value of Logout time (minutes).

By default, NetEco 1000S enables the function of logging out users after timeout. To disable
this function, clear Logout Time Settings.

NOTE

The logout time ranges from 1 to 1440 minutes. Setting the logout time within 3 minutes is advised.

Step 4 Click Save.

----End

Follow-up Procedure

After the client is automatically logged out, the current user needs to log in to the NetEco
1000S again.

5.1.7.1.10 Setting an IP Access Control Policy

This section describes how to set an access control policy. In this way, users can only use the
specified IP address to log in to the NetEco, ensuring the access security of the NetEco.
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Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.1.1.1.2

Logging In to the NetEco 1000S Client.
l You have logged in as system administrator.

Context
To ensure the access security of the NetEco, you are advised to set an access control policy.

Procedure

Step 1 Choose System > User Management from the main menu.

The User Management window is displayed. Choose Client IP Address from the menu bar
on the left. In the displayed Client IP Address window, click Create, as shown in Figure
5-41.

Figure 5-41 Client IP Address

Step 2 Set Start IP address, End IP address, and Description for accessing the client and click
OK.

----End

5.1.7.1.11 Setting Login Time Control Policies

After the login time control policies are set, users other than admin can log in to the NetEco
1000S only at the specified control time, which ensures NetEco 1000S access security.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.1.1.1.2

Logging In to the NetEco 1000S Client.
l You have logged in as system administrator.

Context
If system administrator wants to control the time segment on which other users can access the
NetEco 1000S, login time control policies need to be set. After the login time control policies
are enabled, the following functions can be implemented:
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l Users other than admin can log in to the NetEco 1000S only on the control time
segment.

l The logged-in user will be forcibly logged out if the valid access time expires.

Procedure

Step 1 Choose System > User Management > Login Time Control from the main menu

The Login Time Control page is displayed, as shown in Figure 5-42.

Figure 5-42 Login Time Control

Step 2 Select Enable login time control.

Information shown in Figure 5-43 is displayed.

Figure 5-43 Login time control enabling prompt
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Step 3 Set login time control policies according to Table 5-30.

Table 5-30 Setting login time control policies

Parameter Configuration Method

Start date Select the start date for the login from the
drop-down list.

End date Select the end date for the login from the
drop-down list.
The end date must be later than or equal to
the start date.

Start time Select the start time for the login from the
drop-down list. Other users are allowed to
access the NetEco 1000S since the start
time.

End time Select the end time for the login from the
drop-down list. Other users are not allowed
to access the NetEco 1000S after the end
time.
The end time must be later than or equal to
the start time.

Description (Optional) Enter the description information
about the login time control policy. A
maximum of 255 characters are allowed.

 

----End

5.1.7.1.12 Setting Access Control Policies for Mobile Terminals

This section describes how to set access control policies for mobile terminals. In this way,
users can log in to the NetEco only from the specified mobile terminal, ensuring the access
security of the NetEco.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.1.1.1.2

Logging In to the NetEco 1000S Client.
l You have logged in as system administrator.
l You have obtained the identification number of the mobile terminal.

NOTE

Identification number of the iOS mobile terminal is the IDFV identifier. Identification numbers of other
mobile terminals are IMEIs/MEIDs of mobile phones or MAC addresses of tablets.

Context

To ensure the access security of the NetEco, enable the access control policies for mobile
terminals is advised.
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The identification number of the mobile terminal has been anonymized on the NetEco 1000S
WebUI to protect user's privacy.

Procedure

Step 1 Choose System > User Management from the main menu.

The User Management window is displayed. Choose Mobile Terminal Access Control
from the menu bar on the left, as shown in Figure 5-44.

Figure 5-44 Mobile Terminal Access Control

Step 2 In the displayed Mobile Terminal Access Control window, click Create Mobile Terminal.

The Create Mobile Terminal page is displayed, as shown in Figure 5-45

Figure 5-45 Mobile terminal access setting

Step 3 Enter the identification number of the mobile terminal that is allowed to access the NetEco,
set Description, and click OK.

After the access control policies are set, the page similar to Figure 5-46 is displayed.

Figure 5-46 Access Control Policy

Step 4 Perform the following operations in the Figure 5-44 window.

l Select Enable Access Control: The access control policy for the mobile terminal is
enabled, and users can log in to the NetEco only from the specified mobile terminal.

l Deselect Enable Access Control: The access control policy for the mobile terminal is
disabled, and users can log in to the NetEco from any mobile terminals.

----End
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Follow-up Procedure

l You can click  under Operation in Figure 5-46 to modify the specified mobile
terminal.

l You can click  under Operation in Figure 5-46 to delete the specified mobile
terminal.

5.1.7.2 Querying User Operation Logs
This section describes how to query user operation logs to know the operations performed by
users.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.1.1.1.2

Logging In to the NetEco 1000S Client.
l You have logged in as system administrator.

Context
The NetEco 1000S checks whether the operation log is out of the life cycle, or whether the
number of user operation logs exceeds the preset threshold, at the specified time every day. If
the operation log is out of the life cycle, the NetEco 1000S automatically deletes the
exceeding logs. If the number exceeds the threshold, the NetEco 1000S automatically deletes
20% of the operation logs.

l Check time: 01:00 every day.
l Life cycle: half a year by default. You can change the life cycle of operation logs by

referring to 5.1.8.22 What Do I Do to Control the User Authorization upon First
Login?.

l Threshold: 100,000.

NOTE

The user operation logs about user authorization will not be deleted, unless this user is deleted.

Procedure

Step 1 Choose System > Log Management from the main menu.

The Log Management window is displayed.
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Figure 5-47 Log Management

Step 2 Optional: Set the query criteria by referring to Table 5-31.

Table 5-31 Query criteria parameters

Parameter Description

User name Name of a user.
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Parameter Description

Module Module in which an operation is performed, including:
l Device management: involves plant creation, modification, and

deletion, device search, device access, and device deletion.
l Configuration management: involves device information

modification and control command delivery.
l Security management: involves user login and logout, and user

creation, user information modification, and user deletion.
l Software management: involves software package upload, device

upgrade, and software package deletion.
l Performance management: involves historical performance data

synchronization.
l Smart I-V Curve Diagnosis: involves the start, execution, and

stop of smart I-V curve diagnosis tasks and export of diagnosis
reports.

l Device log: involves the obtaining of device logs.
l Remote notification: involves email server parameter and SMS

message server parameter modification, and remote notification
rules creation, modification, deletion, enabling, and disabling.

NOTE
The product feature you have purchased may use personal information of
users when providing services or maintenance. Therefore, you are obligated
to take measures, in compliance with the laws of the countries concerned and
the user privacy policies of your company, to ensure that the personal data of
users is fully protected.

Personal data such as phone numbers and email addresses are masked in the
NetEco GUI and encrypted in the NetEco during batch data transmission to
ensure data security.

l License management: involves querying License Information,
importing or revoking a License and obtaining an ESN.

l System settings: involves the clock synchronization, baud rate
modification, alarm resetting, benefit setting, and collection
period setting.

Object Object on which an operation is performed, including:
l Local NetEco
l NetEco 1000S user
l plant
l Device

Client IP address IP address of the PC client or identification number of the mobile
client used for the login.
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Parameter Description

Operation type Type of operation a user has performed, including:
l System login
l System logout
l Search
l Add
l Synchronize
l Upgrade
l Modify
l Delete
l Reset
l String scanning

Operation time The value must be a time segment.
The start time must be earlier than or equal to the end time.

Contents Operation performed by a certain user.

Level Log level, including:
l Risk
l Minor
l Warning

Log type Log type, including:
l System Logs: record NetEco 1000S running exceptions, network

faults, and NetEco 1000S attacks.
l Operation Logs: record device addition and deletion.
l Security Logs: record NetEco 1000S security operation

information, such as logging in to the client, changing the
password, creating a user, and exiting the client.

 

Step 3 Click Query.

----End

5.1.7.3 Setting Remote Notification
This section describes how to set remote notification. The NetEco 1000S notifies users of
information about alarms or generated power remotely based on remote notification rules.

5.1.7.3.1 Setting Parameters for the Email Server

This section describes how to set parameters for the email server for sending emails to users.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.1.1.1.2

Logging In to the NetEco 1000S Client.
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l You have logged in as system administrator.

NOTE

You need to disable the mail filtering function of the antivirus software for the operating system.

l The PC on where the NetEco 1000S software is installed is properly connected to the
email server, and you have obtained the email server's IP address (or domain name) and
port number that are used for email transmission from the email server OM personnel.

NOTICE
TLS communication protocols include TLS1.0, TLS1.1, and TLS1.2. The NetEco supports
TLS1.1, and TLS1.2 protocols. TLS1.0 has security risks. The NetEco uses TLS1.2 by
default.

If an email server supports only TLS1.0, the communication connection may be insecure. In
this case, replace the email server with one supporting TLS1.1 or TLS1.2.

NOTE

The product feature you have purchased may use personal information of users when providing services
or maintenance. Therefore, you are obligated to take measures, in compliance with the laws of the
countries concerned and the user privacy policies of your company, to ensure that the personal data of
users is fully protected.

Personal data such as phone numbers and email addresses are masked in the NetEco GUI and encrypted
in the NetEco during batch data transmission to ensure data security.

Procedure

Step 1 Choose System > Remote Notification from the main menu.

Step 2 Choose Email Server.

The Setting parameters for email server window is displayed, as shown in Figure 5-48.
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Figure 5-48 Setting parameters for email server

Step 3 Setting parameters for email server by referring to Table 5-32.
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Table 5-32 Setting parameters for email server

Parameters Description

Email sending server Enter the IP address or domain name of the SMTP email server.
If the domain name of a website is www.yourdomain.com, the
domain name of the SMTP email server for this website may be
one of the following:
l smtp.yourdomain.com
l mail.yourdomain.com
l smtp.mail.yourdomain.com
For example, the domain name of the SMTP email server for
email@126.com is smtp.126.com.
If the domain name of the SMTP email server obtained based on
the preceding domain naming rule is invalid and email-based
remote notification fails to be enabled, contact the email service
provider to obtain the valid domain name of the SMTP email
server.
The domain names of the SMTP email servers for some frequently
used email boxes are as follows:
l 126.com: smtp.126.com.
l gmail(google.com): smtp.gmail.com.
l 21cn.com: smtp.21cn.com.
l 163.com: smtp.163.com.
l sohu.com: smtp.sohu.com.
l yahoo.com: smtp.mail.yahoo.com.

Email sending port
No.

Port of email server
NOTE

Select the Enable SSL, the SMTPS protocol is used, the default port is
465. Clear the Enable SSL check box, the SMTP protocol is used, the
default port is 25. Ensure that the server port is correct for successful email
transmission.

Sender email address Enter the email address of the sender.

Check permission If the SMTP email server requires authentication, select Check
permission, and set the user name and password for connecting to
the SMTP email server.

Enable SSL Select the Enable SSL, the SMTPS protocol is used. Clear the
Enable SSL check box, the SMTP protocol is used.
Use the SMTPS protocol to send email is advised.
NOTE

If Enable SSL is selected, you must verify that the email server supports
the SMTPS. Otherwise, email sending will fail.

 

Step 4 Optional: Test whether the parameters for the email server are set correctly.

1. Click Test in the Setting parameters for email server page.
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2. Enter the Recipient email address in the Test Email text box, and click OK.

The test mail is received.

Step 5 Click Save.

----End

Exception Handling

If The test email has been sent. Please check. is displayed on the NetEco 1000S during
testing whether the parameters configured for the email server are correct, but the test mail is
not received, check the following items:

l Select Check permission.

l Sender email address and User name are the same.

5.1.7.3.2 Setting Parameters for the SMS Modem

This section describes how to set parameters for the SMS modem for sending SMS messages
to users.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.1.1.1.2

Logging In to the NetEco 1000S Client.

l You have logged in as system administrator.

l NetEco 1000S is standard edition.

l The SMS modem has been properly installed, and you have obtained the serial port
number used for communication between the PC and the SMS modem.

l You have obtained the phone number of the SMS center from the telecom operator
providing the SMS service.

l You have enabled the function of serial ports.

NOTICE
To ensure NetEco 1000S system security, the NetEco 1000S shields the function of serial
ports by default. After completing the operation, disable this function immediately.

Perform the following operations to enable and disable the function:

l Enable the function: Navigate to the NetEco 1000S installation directory\WebRoot
\WEB-INF\classes directory, open the userManagement.properties file, change the
value of isStartCom to 1, and save the change result. Then, restart the NetEco 1000S.

l Disable the function: Navigate to the NetEco 1000S installation directory\WebRoot
\WEB-INF\classes directory, open the userManagement.properties file, change the
value of isStartCom to 0, and save the change result. Then, restart the NetEco 1000S.
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NOTE

The product feature you have purchased may use personal information of users when providing services
or maintenance. Therefore, you are obligated to take measures, in compliance with the laws of the
countries concerned and the user privacy policies of your company, to ensure that the personal data of
users is fully protected.
Personal data such as phone numbers and email addresses are masked in the NetEco GUI and encrypted
in the NetEco during batch data transmission to ensure data security.

Procedure

Step 1 Choose System > Remote Notification from the main menu.

Step 2 Click SMS Modem.

The Setting parameters for SMS modem window is displayed, as shown in Figure 5-49.

Figure 5-49 Setting parameters for SMS modem

Step 3 Setting parameters for SMS modem by referring to Table 5-33.

Table 5-33 Setting parameters for SMS modem

Parameters Description

Serial port No. Enter the RS232 serial port number for communication,
through which the SMS modem and the PC are connected.

Baud rate Choose a matching baud rate.

SMC No. Enter the number of the SMC which is obtained from the
SMC operator.
NOTE

SMC No. must be set according to the following requirements:

l A country code must be added preceding the calling number.
For example, if the subscriber is located in China, the entered
calling number is in the following format: +86Calling number.

l If short messages are successfully sent but the subscriber does
not receive the short messages, you need to remove the
country code.
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Step 4 Optional: Test that parameters for the SMS modem are set correctly.

1. Click Test in the Setting parameters for SMS modem page.
2. Enter the test Phone NO. in the Receiver phone No. text box.
3. Click OK.

Step 5 Click Save.

----End

5.1.7.3.3 Setting Alarm Sending Rules

This section describes how to set alarm sending rules. Based on the preset alarm sending
rules, the NetEco 1000S sends emails or SMS messages to notify users of alarm information.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.1.1.1.2

Logging In to the NetEco 1000S Client.
l You have logged in as system administrator or system operator.
l You have set the email server. For details operations, see 5.1.7.3.1 Setting Parameters

for the Email Server.
l In the NetEco 1000S standard system, to send SMS messages, the GSM modem must be

set beforehand. For details, see 5.1.7.3.3 Setting Alarm Sending Rules.

Context
l The NetEco 1000S notifies users of alarm information by email: After the NetEco 1000S

receives an alarm reported by a device, the NetEco 1000S waits for 3 minutes, and then
sends all alarm information received within 3 minutes to users using one email.

NOTE

Alarm send delay time specifies the time that the NetEco 1000S waits before sending alarms.
The default value of Alarm send delay time is 180s, that is, 3 minutes. After the value of Alarm
send delay time is changed, the waiting period changes accordingly.

l The NetEco 1000S notifies users of alarm information by SMS: The NetEco 1000S
sends the alarm information to users by SMS once receiving an alarm reported by a
device.

NOTE

l The product feature you have purchased may use personal information of users when providing
services or maintenance. Therefore, you are obligated to take measures, in compliance with the laws
of the countries concerned and the user privacy policies of your company, to ensure that the personal
data of users is fully protected.

l Personal data such as phone numbers and email addresses are masked in the NetEco GUI and
encrypted in the NetEco during batch data transmission to ensure data security.

Procedure

Step 1 Choose System > Remote Notification from the main menu.

Step 2 Click Alarm Send Settings.

Step 3 In the Setting Alarm Sending Rules page, you can perform the following operations.
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Setting Alarm
Sending Rules

Operation Method

Create alarm
sending rules

A alarm notification rule is enabled by default once it is created.
1. Click Create.
2. On the Create Rule page, set parameters and click Save.
NOTE

l You can select the alarm email and SMS language by setting Mail
language.

– Available languages include: Chinese, English, Japanese, French, and
German.

– The Mail language uses the display language on the NetEco 1000S by
default.

l In the NetEco 1000S standard system, at least one of parameters Recipient
email address and Recipient phone No. must be set.

Enable alarm
sending rules

Enable a disabled alarm notification rule.
Select one or more alarm sending rules and click Enable to enable
the alarm sending rules.

Disable alarm
sending rules

Disable a alarm notification rule that is not used currently.
Select one or more alarm sending rules and click Disable to disable
the alarm sending rules.

Modify alarm
sending rules

Modify a alarm notification rule to meet management requirements.

1. Click  in the Operation column where the required alarm
notification rule is located.

2. On the Modify Rule page, modify the alarm notification rule
information.

Delete alarm
sending rules

Delete an unused alarm notification rule to ensure sufficient memory
and proper running of tasks on the server.

1. Click  in the Operation column where the required alarm
notification rule is located.

2. In the Warning dialog box, click Yes.

 

----End

5.1.7.3.4 Setting Report Sending Rules

This section describes how to set report sending rules. The NetEco 1000S sends emails to
users each day to notify users of day energy, income and total energy generated by the plant
based on rules.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.1.1.1.2

Logging In to the NetEco 1000S Client.
l You have logged in as system administrator or system operator.
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l You have set the email server. For details, see 5.1.7.3.1 Setting Parameters for the
Email Server.

Procedure

Step 1 Choose System > Remote Notification from the main menu.

Step 2 Choose Report Send Settings.

NOTE

l The product feature you have purchased may use personal information of users when providing
services or maintenance. Therefore, you are obligated to take measures, in compliance with the laws
of the countries concerned and the user privacy policies of your company, to ensure that the personal
data of users is fully protected.

l Personal data such as email addresses are anonymized in the NetEco GUI and encrypted in the
NetEco during batch data transmission to ensure data security.

Enter search criteria in Recipient email address or PV plant text box, and click Query.
Target reports sending rules meeting the preset condition are filtered out.

Figure 5-50 Report Send Settings

Step 3 In the Report Send Settings page, you can perform the following operations.

Setting Report
Sending Rules

Operation Method

Create report
sending rules

Based on the created report sending rules, the NetEco 1000S sends
emails to users each day to notify users of day energy and total
energy generated by the plant. This helps maintenance personnel that
are not onsite to learn the day energy and total energy generated by
the plant on the NetEco 1000S in time.
A report sending rule is enabled by default once it is created.
1. Click Create.
2. Set Rule name, Mail language, Mail subject, PV plant, Daily

send time, and Recipient email address on the Create Rule
page.
NOTE

– Available mail languages include: Chinese, English, Japanese, French,
and German. The Mail language uses the display language on the
NetEco 1000S by default.

– The NetEco 1000S has a mail subject by default. The language of the
mail subject is the display language and changes with the Mail
language settings.

– The NetEco 1000S sends day energy and total energy generated by the
PV Plant from 00:00 of the current day to Daily send time.

3. Click Save.
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Setting Report
Sending Rules

Operation Method

Enable report
sending rules

Enable a disabled report sending rule.
Select one or more report sending rules and click Enable to enable
the report sending rules.

Disable report
sending rules

Disable a report sending rule that is not used currently.
Select one or more report sending rules and click Disable to disable
the report sending rules.

Modify report
sending rules

Modify a report sending rule to meet management requirements.

1. Click  in the Operation column where the required report
sending rule is located.

2. On the Modify Rule page, modify the report sending rule
information.

Delete report
sending rules

Delete an unused report sending rule to ensure sufficient memory and
proper running of tasks on the server.

1. Click  in the Operation column where the required report
sending rule is located.

2. In the Warning dialog box, click Yes.

Export report
sending rules

1. Click Export drop-down list box.
– Select Export All from the Export drop-down list box and

save all the report sending rules that are queried to the PC.
– Select the target device in the displayed operation area. Select

Export Selected from the Export drop-down list box and save
the selected report sending rules to the PC.

The message shown in Figure 5-51 is displayed.

Figure 5-51 Message for rule export

2. Select whether to export personal data in plaintext format, and
click OK.
Personal data refers to the email information about recipients.

 

----End
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Result

After the report sending rules are set, the NetEco 1000S automatically sends a report email to
the specified mailbox.

The contents of a report email include the plant and inverter parameters as well as the Daily
Energy Yield bar graph, Income chart, and Active Power line chart. The energy Daily
Energy Yield graph and Income chart provide the energy yield and income of every day in
the current month, as shown in Figure 5-52.

Figure 5-52 Energy yield and income

The Active Power line chart provides the active power of every hour on the current day, as
shown in Figure 5-53.

Figure 5-53 Active power

Table 5-34 describes the descriptions of parameters in the report email.

Table 5-34 Report email

Type Parameter Description

Total Daily Energy Yield Total energy yield of PV plants on the current
day.
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Type Parameter Description

NOTE
Total data
indicates data of
all PV plants
selected when
you set the
report sending
rules.

Total Energy Yield Total energy yield of PV plants.

Total income Total income generated by PV plants.

Detailed PV
plant parameter

PV plant name Name of a PV plant selected when you set the
report sending rules.

Total string capacity Total string capacity of inverters under the PV
plant. If this parameter is not set, - is
displayed.

Total Energy Yield Total energy yield of the PV plant.

Daily Energy Yield Energy yield of the PV plant on the current
day.

Day Performance
Ratio

Performance ratio of the PV plant on the
current day.

Daily income Income of the PV plant on the current day.

Total income Total income generated by the PV plant.

Inverter
parameter

Number of Inverters Number of inverters connected to the PV
plant.

Inverter specific
energy mean value

Average equivalent energy generation
duration of inverters under the PV plant.

Specific energy
maximum value

Maximum equivalent energy generation
duration of inverters under the PV plant.

Specific energy
minimum value

Minimum equivalent energy generation
duration of inverters under the PV plant.

Ratio threshold Ratio threshold of the PV plant. If this
parameter is not set, - is displayed.

Number of inverters
with lower mean value
ratio

Number of inverters whose ratio is lower than
the average value.

 

NOTE

The table below inverter data lists Total Energy Yield, Daily Energy Yield, Specific Energy, and
Mean Value Ratio of each inverter. Mean Value Ratio is the ratio of Specific Energy to Inverter
specific energy mean value of an inverter. When the ratio is smaller than Ratio threshold, it is
displayed in red. In this case, you need to check the inverter to ensure that related functions are
available.
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5.1.7.4 Setting System Parameters

This section describes how to set system parameters to modify communication parameters,
reset alarms, synchronize the clock time, and set the income unit.

5.1.7.4.1 Resetting Alarms

This section describes how to reset alarms. When the target device restores its factory defaults
or changes its connection mode, you must reset alarms for the target device on the NetEco
1000S. In this case, all the existing alarm records for the target device will be deleted, and
alarms are synchronized from the target device to the NetEco 1000S again.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.1.1.1.2

Logging In to the NetEco 1000S Client.
l You have logged in as system administrator.

Procedure

Step 1 Choose System > System Settings from the main menu.

Step 2 Click Reset Alarm.

The Reset Alarm window is displayed, as shown in Figure 5-54.

Figure 5-54 Reset Alarm

Step 3 Select the devices for which you want to reset alarms and click Reset Alarm.

The Warn dialog box is displayed.
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NOTE

If you select Synchronize and reset SmartLogger?, the command for resetting alarms will be sent to
the SmartLogger. The SmartLogger then clears all alarms of the device in it after receiving the
command.

Step 4 Click OK.

After alarms are reset, alarm records on the NetEco 1000S will be deleted. However, all
alarms of the device still exist on the device side.

----End

5.1.7.4.2 Clock Synchronization

This section describes how to synchronizes the time on the monitoring PC on which the
NetEco 1000S is installed to devices. This ensures time consistency between the devices and
the NetEco 1000S.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.1.1.1.2

Logging In to the NetEco 1000S Client.
l You have logged in as system administrator.

Context
By default, the time synchronization function is not started.

If the time synchronization function is started, the NetEco 1000S performs time
synchronization per hour to synchronize time from the NetEco 1000S server to devices
mounted to the plant.

Procedure

Step 1 Choose System > System Settings from the main menu.

Step 2 Click Clock Synchronization.

Figure 5-55 Clock Synchronization
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Step 3 Select this check box. and click Save.

The message Are you sure you want to issue the command? is displayed.

Step 4 Click OK.

The message The synchronization command has been issued is displayed.

Step 5 Click OK.

----End

5.1.7.4.3 Setting Communication Parameters

This section describes how to set communication parameters. If a device is connected to the
monitoring PC using a serial port, the baud rate of the device must be the same as that set on
the NetEco 1000S. Otherwise, the device communicates with the monitoring PC improperly.
By default, the baud rates of the device and NetEco 1000S are 9600. In normal cases, you can
retain the default settings unless the actual transmission rate is insufficient. After the baud rate
is changed, you need to restart the NetEco 1000S for the setting to take effect.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.1.1.1.2

Logging In to the NetEco 1000S Client.
l You have logged in as system administrator.

Procedure

Step 1 Choose System > System Settings from the main menu.

Step 2 Click Communicate Parameter.

The Communicate Parameter window is displayed.

Step 3 Changing Baud rate

1. Select a baud rate from the Baud rate drop-down list and click Save.
The message To change the baud rate, you need to restart the NetEco service. Do you
want to continue? is displayed.

2. Click Yes.
The message Modification succeeded. Please restart the NetEco service. is displayed.

3. Click OK.
4. See 5.1.1.2 Logging Out of the NetEco 1000S and 5.1.1.1 Logging In to the NetEco

1000S to restart NetEco 1000S service.

Step 4 Set whether the SmartLogger supporting only SSL authentication is allowed to access the
NetEco 1000S.

The SmartLogger and NetEco 1000S use the following two authentication modes by default:
SSL authentication and user name/password authentication. The NetEco 1000S can be
compatible with the SmartLogger supporting only SSL authentication, which has security
risks. It is recommended that such SmartLogger be replaced with the SmartLogger supporting
both authentication modes or the SmartLogger be upgraded to the version supporting both
authentication modes.
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l Select Compatible Access only supports SSL authentication NEs: The SmartLogger
supporting only SSL authentication is allowed to access the NetEco 1000S, and the
device connection is normal.

l Deselect Compatible Access only supports SSL authentication NEs: The
SmartLogger supporting only SSL authentication is allowed to access the NetEco 1000S,
but the device is disconnected. To ensure the access security of the NetEco 1000S, you
are advised to deselect Compatible Access only supports SSL authentication NEs.

NOTE

After installing and upgrading NetEco 1000S, Compatible Access only supports SSL authentication
NEs is selected by default.

----End

5.1.7.4.4 Setting Income

NetEco 1000S uses Standard currency selected during the installation for income statistics.
You can set exchange rates between different types of currency and Standard currency to
collect statistics on the income of all PV plants.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.1.1.1.2

Logging In to the NetEco 1000S Client.
l You have logged in as system administrator.

Procedure

Step 1 Choose System > System Settings from the main menu.

Step 2 Choose Income Settings.

The page as shown in Figure 5-56 is displayed.
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Figure 5-56 Income Setting

NOTE

NetEco 1000S uses Standard currency for income statistics. Standard currency indicates the currency
type selected when you set currency parameters.

Step 3 Click Add Currency.

The Add Currency Unit dialog box is displayed, as shown in Figure 5-57.

Figure 5-57 Add currency unit

Step 4 Set the currency used for the PV plant and the exchange rate of the currency against
Standard currency, and save the setting.

----End
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Follow-up Procedure

l In the  area of the Add Currency Unit dialog box, edit or delete
the currency.

5.1.7.4.5 Setting Prompt Information

This section describes how to set whether to enable the prompt information displayed after
you log in to the client, access devices, and create a PV plant on the NetEco 1000S client.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.1.1.1.2

Logging In to the NetEco 1000S Client.

l You have logged in as system administrator.

Context

After you log in to the NetEco 1000S, access devices, or create a PV plant, the prompt
information is displayed in the lower right corner of the NetEco 1000S client.

You can enable or disable the prompt information as required.

Procedure

Step 1 Choose System > System Settings from the main menu.

Step 2 Choose Tip Message Settings.

The Tip Message Settings page is displayed, as shown in Figure 5-58.

Figure 5-58 Tip Message Settings

Step 3 Set whether to enable the prompt information.

l Enable the prompt information: select Enable tip message display.

l Disable the prompt information: deselect Enable tip message display.

Prompt information is enabled on the NetEco 1000S by default.

Step 4 Click Save.

----End
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5.1.7.5 License Management

License management includes querying license information, obtaining an ESN, importing a
license, and revoking a license. Manage the license to ensure that the NetEco 1000S can be
used normally.

5.1.7.5.1 License Usage Description

The license is used to enable or disable the inverter management function. After the NetEco
1000S is installed, there is a license trial period of 90 days by default. During the trial period,
a license file needs to be imported so that all the functions of the NetEco 1000S can be used.

If a license file is not imported when the trial period expires, login to the NetEco 1000S client
will be limited. After login is limited, the users in the system operator group and visiting user
group will not be able to visit the client. Only the system administrator can visit the client.
After login, the page requiring license import is displayed.

To ensure that you can use all the functions of the NetEco 1000S, check and import a license
file periodically.

How to Obtain a License

Obtain the ESN of the NetEco 1000S server or the license revocation code, and then contact
Huawei technical support to apply for a new license.

5.1.7.5.2 Querying License Information About the NetEco

Query the expiration date and function control of the current License routinely to check
whether the License is about to expire, and solve the problems in a timely manner. In this
way, the NetEco 1000S function can be used normally.

Prerequisites
l The License has been imported to NetEco 1000S. If it has not been imported, import it

by referring to 5.1.7.5.3 Importing a License File.
l You have logged in as system administrator.

Procedure

Step 1 Choose System > License Management from the main menu.

Step 2 Choose License Information.

The License Information page is displayed.

On the License Information page, check the basic information, function control information,
and ESN information about the License. For details, see Table 5-35.

Table 5-35 License information

Item Attribute Description

Basic License
Information

Expired on The License is valid until 03:00 this date.
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Item Attribute Description

Function Control Function Name Functions provided by the NetEco 1000S.

Supported or Not Whether the function is supported by the
License file.

ESN Information ESN list ESNs of all the NICs managed by the
License. Each ESN is separated by a comma
(,).

ESN quantity The number of ESNs of all the NICs
managed by the License.

 

NOTE

When the License is about to expire, a prompt will be displayed at the upper part of the License
Information page. Handle the problem by following the prompt.

----End

5.1.7.5.3 Importing a License File

When a License is not imported in NetEco 1000S, or NetEco 1000S License is expires, or
cannot meet network management requirements, you must import a new License to the
NetEco 1000S to ensure normal services of the NetEco.

Prerequisites
l You have logged in as system administrator.
l A new License is obtained.

Procedure

Step 1 Choose System > License Management from the main menu.

Step 2 Choose Import License.

The Import License page is displayed.

Step 3 Click Browse and select a License file.

The License file must be less than 1 MB and the file format should be .dat.

Step 4 Click Upload.

A dialog box for activating the License is displayed.

Step 5 Click Yes.

----End

5.1.7.5.4 Revoking a License

If the NIC is faulty or a new NIC needs to be used, revoke the current license to generate a
revocation code which is used to apply for a new license file for free.
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Prerequisites
l You have logged in as system administrator.
l License usage is normal in the current environment.

Context
If a NIC is found faulty or the existing NIC needs to be replaced, revoke the existing license
to generate a revocation code that can be used for applying for a new license file.

After NIC replacement, import the new license file to NetEco 1000S. After that, the NetEco
1000S functions can be used properly. For details about how to import a license file, see
5.1.7.5.6 Importing a License on the Page Requiring License Import.

Procedure
Step 1 Choose System > License Management from the main menu.

Step 2 Choose Revoke License.

The Revoke License page is displayed.

Step 3 Click Revoke.

A warning is displayed, as shown in Figure 5-59.

Figure 5-59 Revocation warning

Step 4 Click OK.

A dialog box is displayed, as shown in Figure 5-60.

Figure 5-60 Password confirming
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Step 5 Enter the password of the user and click OK.

The generated revocation code will be displayed beside the Revocation code parameter.

If the revocation code is not generated, contact Huawei technical support.

----End

5.1.7.5.5 Obtaining an ESN

If no license is available for the NetEco 1000S, obtain the equipment serial number (ESN) of
the NetEco 1000S server to apply for a license.

Prerequisites
l You have obtained the Media Access Control (MAC) address of the NetEco server.
l You have logged in as system administrator.
l No license is available or the license has expired.

Context

If no license file is found or the license has expired after the NetEco 1000S is installed, obtain
the ESN to apply for a new license.

Procedure

Step 1 Choose System > License Management from the main menu.

Step 2 Choose Obtain ESN.

The Obtain ESN page is displayed.

Step 3 Obtain the ESN.
l Obtain the ESN of the current logged-in server only.

NOTE

You can use this method to obtain the ESN of the current logged-in server only. Obtain the ESNs of
other servers by entering their MAC addresses.

1. Click Choose MAC address. In the drop-down list, select a MAC address to generate an
ESN.
The MAC addresses provided in the drop-down list are the MAC addresses of the
NetEco 1000S servers.

NOTICE
If there are multiple options, select each MAC address one by one and obtain the ESN
for each MAC address.

2. Click Obtain ESN.

l Obtain the ESNs of other servers by entering their MAC addresses.

a. Click Enter a MAC address, and enter a MAC address of the NetEco server.
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A maximum of 20 MAC addresses can be entered. Separate two MAC addresses
with a comma (,).

b. Click Obtain ESN.

The generated ESN is displayed at the lower part of the page, as shown in Figure 5-61.

Figure 5-61 Generating an ESN

----End

Follow-up Procedure

When you need to apply for a new license file, contact Huawei technical support and use the
obtained ESN to apply for a new license file.

After the new license is issued, import the license to the NetEco 1000S. For details, see
5.1.7.5.6 Importing a License on the Page Requiring License Import.

5.1.7.5.6 Importing a License on the Page Requiring License Import

If the license has expired or is invalid, import a new license file or obtain the ESN of the
NetEco 1000S on the page requiring license import.

Prerequisites
l The trial period of the NetEco 1000S has expired, or the license has expired or is invalid.

l You have logged in as system administrator.

Context

If The trial period of the NetEco 1000S has expired, or the license has expired or is invalid,
log in to the NetEco 1000S client as the system administrator. The page requiring license
import is displayed.

Import a new license file.
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NOTICE
If you perform an operation after more than 10 minutes elapse since the page requiring license
import is displayed, the login page will be displayed again. To ensure that you can perform
operations successfully, perform the following steps within 10 minutes after the page
requiring license import is displayed.

Procedure
l If you have obtained a new license, perform the following operations:

a. Click Browse on the right of License File.
A dialog box for selecting a file is displayed.

b. Select the license file to be imported and click OK.
c. Click Upload.

The dialog box shown in Figure 5-62 is displayed.

Figure 5-62 Confirm

d. Click Yes.
The dialog box shown in Figure 5-63 is displayed.

Figure 5-63 Information

e. Click OK.
f. Click Return on the right of License File.

The NetEco 1000S login page is displayed.
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l If no license file is available, perform the following operations to obtain the ESN of the
NetEco 1000S so that you can use the ESN to apply for a new license.

a. Obtain the ESN.
n Obtain the ESN of the current logged-in server only:

Click Choose MAC address, in the drop-down list, select a MAC address to
generate an ESN.
The MAC addresses provided in the drop-down list are the MAC addresses of
the NetEco servers.

NOTICE
If there are multiple options, select each MAC address one by one and obtain the
ESN for each MAC address.

n Obtain the ESNs of other servers by entering their MAC addresses:
Click Enter a MAC address, and enter a MAC address of the NetEco server.
A maximum of 20 MAC addresses can be entered. Separate two MAC
addresses with a comma (,).

b. Click Generate ESN.
The generated ESN is displayed at the lower part of the page.
Contact Huawei technical support engineers to apply for a new license using the
obtained ESN, and a.

5.1.8 FAQs

5.1.8.1 What Do I Do When the Internet Explorer Browser Displays a Message
Asking Me to Close the Compatibility View on to the Login Page?

Symptom

Figure 5-64 Message indicating that the compatibility view needs to be closed
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Possible Causes

You have enabled the compatibility view of the Internet Explorer browser.

Procedure

Step 1 Choose Tools > Compatibility View Settings on the Internet Explorer menu bar.

Step 2 Clear the check box for Display all websites in Compatibility View.

Figure 5-65 Compatibility View Settings

----End

5.1.8.2 What Do I Do When Characters in a CSV File Are Displayed in Disorder?

Symptom

When users open a CSV file exported from the NetEco 1000S, the characters in the file are
displayed in disorder.

Possible Causes

When data in a list is exported to a CSV file, the default separator used by the operating
system is not comma (,).
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Procedure

Step 1 Choose Start > Control Panel.

Step 2 In the displayed Control Panel window, click Region and Language.

Step 3 In the displayed Region and Language window, click the Formats tab.

Step 4 Click Additional settings.

Step 5 In the displayed dialog box, set List separator to comma (,) on the Numbers tab page.

Step 6 Click OK.

----End
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5.1.8.3 What Do I Do When the NetEco 1000S Service Icon Is Not Displayed?

Symptom
On a PC running the Windows operating system, the NetEco 1000S service icon is not
displayed on the right of the taskbar when the NetEco 1000S service is running.

Possible Causes
An exception occurs in the resource manager of the operating system.

This problem does not affect the functions of the NetEco 1000S. You can ignore it.

Procedure
To restart the NetEco 1000S service, perform the following steps:

Step 1 Log off the Windows operating system.

Step 2 Log in to the Windows operating system again and then start the NetEco 1000S services.

----End

5.1.8.4 How Do I Solve the Problem that the Login Page Fails to Be Displayed
When I Access theNetEco 1000S Using a Web Browser?

Symptom
The login page fails to be displayed when I access NetEco 1000S using a web browser.

Possible Causes
l Connection mode setting on the browser is not correct.
l The network is connected improperly.
l The PC where the NetEco 1000S is installed is powered off.
l The NetEco 1000S service has not been started on the PC.

Procedure

Step 1 Set the connection mode:

Choose Tools > Internet Options on the menu bar of the browser. On the Advanced tab
page, select Use TLS 1.2 and Use TLS 1.1 under Settings, do not select Use TLS 1.0, Use
SSL 2.0 or Use SSL 3.0. Click OK.
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Step 2 Choose Start > Search programs and files in the operating system. In the displayed dialog
box, enter cmd and press Enter. The command-line interface (CLI) is displayed.

Step 3 Run the following command to check whether the network between the PC on which users
can log in to the NetEco 1000S and the PC where the NetEco 1000S is installed is connected
properly:

ping IP address

NOTE

Replace IP address with the IP address of the PC on which the NetEco 1000S is installed.

l If the IP address cannot be pinged, go to Step 4.

l If the IP address can be pinged, go to Step 6.

Step 4 Check whether the PC on which the NetEco 1000S is installed is started.

l If the PC is started, go to Step 5.

l If the PC is not started, perform the following operations:

a. Start the PC on which the NetEco 1000S is installed.

b. Choose Start > All Program > NetEco 1000S > NetEco 1000S Service in the
operating system to start the NetEco 1000Sservice.
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Step 5 Check whether the network cable of the PC where the NetEco 1000S is installed is loosened
or disconnected.

In normal cases, the indicator of the network port where the network cable is inserted is green.
The indicator blinks when data is transmitted.

l If the network cable is loosened or disconnected, connect it again.
l If the network cable is connected properly but the IP address of the NetEco 1000S server

still cannot be pinged, check whether network connection problems occur on the user
side.

Step 6 Check whether the NetEco 1000S service has been started on the PC.
l If the NetEco 1000S service is not started, choose Start > All Program > NetEco 1000S

> NetEco 1000S Service in the operating system to start the NetEco 1000S service.
l If the NetEco 1000S service has been started but logging in to the NetEco 1000S using

the web browser fails, contact Huawei technical support.

----End

5.1.8.5 How Do I Solve the Problem that the Serial Port for the SMS Modem to
Connect to a PC Is Always Occupied After the SMS Is Enabled?

Question
How do I solve the problem that the serial port for the SMS modem to connect to a PC is
always occupied after the SMS is enabled?

NOTE

After the serial cable between the SMS modem and the PC is disconnected or removed, the serial port is
still occupied.
The product feature you have purchased may use personal information of users when providing services
or maintenance. Therefore, you are obligated to take measures, in compliance with the laws of the
countries concerned and the user privacy policies of your company, to ensure that the personal data of
users is fully protected.
Personal data such as phone numbers and email addresses are masked in the NetEco GUI and encrypted
in the NetEco during batch data transmission to ensure data security.

Answer
Perform the following steps to restart the NetEco 1000S service:

Step 1 Right-click the NetEco 1000S service icon in the lower right corner of the taskbar of the
desktop and choose Exit to stop the NetEco 1000S service from the shortcut menu.

Step 2 Choose Start > All Program > NetEco 1000S > NetEco 1000S Service to start the NetEco
1000S service in the operating system.

----End

5.1.8.6 Verifying OpenPGP Signature
This section describes how to verify the integrity of an obtained software package, thereby
preventing network risks that may be caused by malicious alteration or damage during the
transmission of the software package. A software package can be installed only after it passes
the verification.

iManager NetEco 1000S
User Manual 5 Operation and Maintenance

Issue Draft C (2017-12-14) Huawei Proprietary and Confidential
Copyright © Huawei Technologies Co., Ltd.

168



Prerequisites
You have obtained the signature file for the NetEco 1000S software package. The NetEco
1000S software package and its signature file are in a one-to-one relationship, and are stored
in the same directory.

Context
l The GNU Privacy Guard for Windows (Gpg4Win) is a free open-source GNU tool. It

can be used to verify OpenPGP signatures in the Windows operating system.
l You can download the Gpg4Win software package used with the Windows operating

system from http://www.gpg4win.org/, and then double-click gpg4win-2.2.1.exe to
install the Gpg4Win tool by following the wizard. You are advised to retain all the
default settings during the installation.

Procedure

Step 1 Download the public key file.

Download the OpenPGP Signature Verification Guide package from http://
support.huawei.com/carrier/digitalSignatureAction, and then decompress the package to
obtain the public key file KEYS.

Step 2 Import the public key file.

1. Log in to the server on which the software package to be verified is stored, and enter the
command-line interface (CLI).

2. Go to the directory (for example, C:\Users\) for storing the KEYS file, and then import
the KEYS file.
gpg --import "C:\Users\KEYS"
C:\Users\KEYS indicates the directory for storing the KEYS file. You need to rename
the directory based on site conditions.
The following information is displayed:
gpg: key 27A74824: public key "OpenPGP signature key for Huawei software 
(created on 30th Dec,2013) <support@huawei.com>" imported  
gpg: Total number processed: 1  
gpg: imported: 1 (RSA: 1)

3. Check whether the public key file is successfully imported.
gpg --fingerprint
If the following information is displayed, the public key file is successfully imported:
pub 2048R/27A74824 2013-12-30 Key fingerprint = B100 0AC3 8C41 525A 19BD C087 
99AD 81DF 27A7 4824 uid OpenPGP signature key for Huawei software (created on 
30th Dec,2013) support@huawei.com

Step 3 Verify the public key.

In normal cases, the validity of the OpenPGP public key needs to be verified according to the
ID, fingerprint, and user ID (uid) of the public key published by the involved entity. Huawei
publishes the following information about the OpenPGP public key:

l Key ID: 27A74824
l Key fingerprint: B100 0AC3 8C41 525A 19BD C087 99AD 81DF 27A7 4824
l User ID (uid): OpenPGP signature key for Huawei software (created on 30th Dec,2013)

support@huawei.com
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After the validity of the public key is verified, you can do as follows to set the trust level of
the public key:

1. Set the trust level of the public key.
gpg --edit-key "OpenPGP signature key for Huawei" trust
When the system displays Your decision?, enter 5. When the system displays Do you
really want to set this key to ultimate trust? (y/N), enter y.
1 = I don't know or won't say  
2 = I do NOT trust  
3 = I trust marginally  
4 = I trust fully  
5 = I trust ultimately  
m = back to the main menu 
Your decision? 5  
Do you really want to set this key to ultimate trust? (y/N) y

2. Run the following command to exit:
quit

Step 4 Verify the signature.

gpg --verify "C:\Users\NetEco1000SV100R002C70SPCXXX_win7_standard.zip.asc

NOTE

l C:\Users\ indicates the path of the signature file. You need to change it based on site conditions.

l iManagerNetEco1000S_V100R002C70SPCXXX_win7_standard.zip.asc indicates the name of
the signature file. You need to rename the file based on site conditions.

l Contact the Huawei technical support engineers and obtain the signature files
iManagerNetEco1000S_V100R002C70SPCXXX_win7_standard.zip.ascand
theiManagerNetEco1000S_V100R002C70SPCXXX_win2012_enterprise.zip.asc from the path
SUPPORT > Software > Energy > PV Inverter > Smart PV Plant System > iManager NetEco
1000S > V100R002C70 on the http://support.huawei.com/carrier/ website.

– If the Windows Server 2012 OS is used, obtain the
iManagerNetEco1000S_V100R002C70SPCXXX_win2012_enterprise.zip installation
package and iManagerNetEco1000S_V100R002C70SPCXXX_win2012_enterprise.zip.asc
digital signature file.

– If the Windows 7 or Windows 10 OS is used, obtain the
iManagerNetEco1000S_V100R002C70SPCXXX_win7_standard.zip installation package
and iManagerNetEco1000S_V100R002C70SPCXXX_win7_standard.zip.asc digital
signature file.

The following information is displayed, where the RSA key ID in bold is the same as the
public key ID (if no error message, such as WARNING, The signature has expired, and The
public key has been revoked is displayed for any other information, the signature is valid):

gpg: Signature made Thu Jan 9 15:29:06 2014 CST using RSA key ID 27A74824  
gpg: Good signature from "OpenPGP signature key for Huawei software (created on  
30th Dec,2013) <support@huawei.com>"

NOTE

When signatures of multiple files need to be verified for a software package, the software package is
safe only when the verification results of all the files are PASS. If the verification result of any file is
WARNING or FAIL, the software package fails the verification, and security risks exist. If this occurs,
you need to re-download the software package.
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Table 5-36 Examples of signature verification results

Verification Result
Scenario

Output Information Example Verification
Result

The signature
verification is successful
without any exceptions.

gpg: Signature made Thu Jan 9 15:29:06
2014 CST using RSA key ID 27A74824
gpg: Good signature from "OpenPGP
signature key for Huawei software
(created on 30th Dec,2013)
<support@huawei.com>

PASS

The signature
verification fails.

gpg: Signature made Thu Jan 9 15:29:06
2014 CST using RSA key ID 27A74824
gpg: BAD signature from "OpenPGP
signature key for Huawei software
(created on 30th Dec,2013)
<support@huawei.com>"

FAIL

The public key cannot be
found.

gpg: Signature made Thu Jan 9 15:20:01
2014 CST using RSA key ID 27A74824
gpg: Cannot check signature: public key
not found

FAIL

The signature
verification is successful
but the public key is not
set to ultimate trust.

gpg: Signature made Thu Jan 9 15:29:06
2014 CST using RSA key ID 27A74824
gpg: Good signature from "OpenPGP
signature key for Huawei software
(created on 30th Dec,2013)
<support@huawei.com>" gpg:
WARNING: This key is not certified
with a trusted signature! gpg: There is no
indication that the signature belongs to
the owner. Primary key fingerprint: B100
0AC3 8C41 525A 19BD C087 99AD
81DF 27A7 4824

WARNING

The corresponding
source file cannot be
found.

gpg: no signed data gpg: cannot hash
datafile: No data

FAIL

The signature has
expired.

gpg: Signature made 04/24/13 10:50:29
CST using RSA key ID 133B64E5 gpg:
Expired signature from " OpenPGP
signature test key
<support@huawei.com>" gpg: Signature
expired 04/25/13 10:50:29 CST

FAIL
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Verification Result
Scenario

Output Information Example Verification
Result

The signature
verification is successful
but the public key has
been revoked.

gpg: Signature made 06/13/13 11:14:49
CST using RSA key ID 133B64E5 gpg:
Good signature from " OpenPGP
signature test key
<support@huawei.com>" gpg:
WARNING: This key has been revoked
by its owner! gpg: This could mean that
the signature is forged. gpg: reason for
revocation: Key is no longer used gpg:
revocation comment:

WARNING

The corresponding
signature file cannot be
found for the source file.

None WARNING

 

----End

5.1.8.7 How Do I Update the NetEco 1000S Software?

Question
How do I update the NetEco 1000S software?

Answer

Step 1 Contact Huawei technical support engineers to obtain the software package. To obtain the
software package, Huawei technical support engineers can choose SUPPORT > Software >
Energy > PV Inverter > Smart PV Plant System > iManager NetEco 1000S >
V100R002C70 at http://support.huawei.com/carrier/.

NOTE

l If the Windows Server 2012 OS is used, obtain the
iManagerNetEco1000S_V100R002C70SPCXXX_win2012_enterprise.zip installation package
and iManagerNetEco1000S_V100R002C70SPCXXX_win2012_enterprise.zip.asc digital
signature file.

l If the Windows 7 or Windows 10 OS is used, obtain the
iManagerNetEco1000S_V100R002C70SPCXXX_win7_standard.zip installation package and
iManagerNetEco1000S_V100R002C70SPCXXX_win7_standard.zip.asc digital signature file.

You can check the integrity of the software package by referring to 5.1.8.6 Verifying
OpenPGP Signature.

NOTE

Software package integrity check is related to the software security. You must perform the check to
ensure the software security.

Step 2 Stop the service, process and close the installation directory of the NetEco 1000S.

NOTE

If the service and process of the NetEco 1000S are not started, NetEco 1000S installation directory is not
opened, skip this step.
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Step 3 Upgrade the NetEco 1000S by following the instructions provided in iManager NetEco 1000S
V100R002C70 Upgrade Guide.

----End

5.1.8.8 What Do I Do If a Certificate Error Message or a Security Alarm Is
Displayed on Internet Explorer?

Symptom

When log in to NetEco 1000S using Internet Explorer or Chrome, Internet Explorer or
Chrome displays a certificate error message similar to that shown in Figure 5-66 or Figure
5-67.

Figure 5-66 Certificate error message

Figure 5-67 Website Security Certificate window (Chrome 50)

Possible Causes

Trusted certificate has not been loaded in the browser.

Procedure

Step 1 Log in to a PC as a user in the Administrators user group.
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After the certificate is replaced on Internet Explorer, the certificate is also replaced on
Chrome. This section mainly describes how to replace the certificate on Internet Explorer.

NOTE

If you install only Chrome, choose Manage Certificate > Trusted Root Certification Authorities >
Import in the setting window of the Chrome browser and import the certificate as prompted.

If you start Internet Explorer 11 in the Windows 7 operating system, you need to log in a PC
as a user in the Administrators user group and then start Internet Explorer as user
Administrator. Otherwise, you cannot properly set Internet Explorer:

1. Choose Start > Internet Explorer.
2. In the displayed shortcut menu, choose Run as Administrator.

Step 2 View the certificate.

1. When the Internet Explorer displays the security certificate message as shown in Figure
5-68, click Continue to this website.

Figure 5-68 Security certificate

2. As shown in Figure 5-69, click Certificate Error.

Figure 5-69 Certificate Error

3. In the displayed dialog box, click View Certificate.

Step 3 In the displayed root certificate dialog box as shown in Figure 5-70, click Install Certificate.
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Figure 5-70 Installing the root certificate

Step 4 In the displayed Certificate Import Wizard dialog box, click Next.

Step 5 Set the certificate store to Trusted Root Certification Authorities, as shown in Figure 5-71.
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Figure 5-71 Setting the certificate store

Step 6 Click Next.

Step 7 After confirming the certificate import information, click Finish.

Step 8 If the system displays the Security Warning dialog box asking you whether to install the
certificate, click Yes. Otherwise, skip this step.

Step 9 In the displayed dialog box indicating the import is successful, click OK.

Step 10 Click OK to close the Certificate dialog box.

Step 11 In the window of Internet Explorer, choose Tools > Internet Options.

Step 12 In the displayed Internet Options dialog box, click Advanced.

Step 13 In the Settings group box, clear Warn about certificate address mismatch under Security.

Step 14 Click OK to close the Internet Options dialog box.

Step 15 Restart the web browser and log in to NetEco 1000S again.

----End
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5.1.8.9 How Do I Manage the NetEco 1000S Through the Local IP Address
(127.0.0.1) If I Fail to Log In to the NetEco 1000S Client After Setting the Client IP
Address Policy?

Question

When the IP address you have set is not within the IP address range of the existing network,
you will fail to log in to the NetEco 1000S client through the existing network.

Answer

For this problem, the NetEco 1000S allows you to enter https://127.0.0.1:8443 in the address
box of the browser only on the local PC where the NetEco 1000S software is installed to log
in to the NetEco 1000S client and set a proper IP policy for the NetEco 1000S.

5.1.8.10 What Do I Do If the Software Cannot Be Properly Used After I Share the
Software Installation Directory?

Question

After you share the NetEco 1000S software installation directory with other users, you cannot
log in to the NetEco 1000S or you can log in to the NetEco 1000S but the performance file
cannot be exported.

NOTICE
You are not allowed to share the NetEco 1000S installation directory with other system
accounts or grant the NetEco 1000S permission to other system accounts. Otherwise, security
risks may occur.

Answer

When you share the NetEco 1000S software installation directory with other users, the
NetEco 1000S software deletes user NETWORK SERVICE that is automatically generated
during software installation and is used for accessing the NetEco 1000S software installation
directory to ensure security, causing the preceding problem. You can perform the following
operations to solve the problem.

Step 1 Cancel the sharing of the NetEco 1000S software installation directory.

1. Right-click the NetEco 1000S software installation directory and choose Properties
from the shortcut menu. The Properties dialog box is displayed.

2. Choose Sharing > Advanced Sharing. The Advanced Sharing dialog box is displayed.
3. Deselect Share this folder and click OK.

Step 2 Add user NETWORK SERVICE.

1. Right-click the NetEco 1000S software installation directory and choose Properties
from the shortcut menu. The Properties dialog box is displayed.
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2. In the Properties dialog box, choose Security > Edit.
3. In the displayed dialog box, click Add. The dialog box shown in Figure 5-72 is

displayed.

Figure 5-72 Adding a user

4. Enter NETWORK SERVICE in Figure 5-72 marked in red and click OK. The
Properties dialog box is displayed again. Select FULL control and modify and click
OK.

NOTICE
After you click OK, the system might display a security warning dialog box. Click
Continue.

Step 3 Restart the NetEco 1000S.

----End

5.1.8.11 What Do I Do When Devices Fail to Be Detected?

Symptom
Devices fail to be detected based on serial port addresses.

Possible Causes
l The baud rate set on the NetEco 1000S is inconsistent with that of the device.
l The serial port addresses configured for the device are duplicate.
l The address of RS-485 serial port for the device is out of the default search range (1 to

20) of the NetEco 1000S.

Procedure

Step 1 Check whether the baud rate setting on the device is consistent with that on the NetEco
1000S.

1. Obtain information about the baud rate set for the device by referring to User Manual on
the monitored device side.

iManager NetEco 1000S
User Manual 5 Operation and Maintenance

Issue Draft C (2017-12-14) Huawei Proprietary and Confidential
Copyright © Huawei Technologies Co., Ltd.

178



2. Obtain information about the baud rate set on the NetEco 1000S by referring to 5.1.7.4.3
Setting Communication Parameters.

3. Check whether the baud rate set for the device is the same as that set on the NetEco
1000S.
– If the two baud rates are the same, go to Step 2.
– If the two baud rates are different, change the baud rate on either the device or the

NetEco 1000S.

Step 2 Check whether the value of RS485 Com Address for the device is duplicate by referring to
User Manual on the monitored device side.
l If the value of RS485 Com Address is unique, go to Step 3.
l If the value of RS485 Com Address is duplicate, change the parameter value by

referring to User Manual on the monitored device side.

Step 3 Check whether the value of RS485 Com Address for the device is within the default search
range (1 to 20) of the NetEco 1000S.

If value is out of the default search range, change the address search range on the NetEco
1000S, or change the value of RS485 Com Address by referring to User Manual on the
monitored device side.

----End

5.1.8.12 How Do I Change the Password of the ftpuser user?
After the SmartLogger connects to the NetEco 1000S, log in to the FTPS server of the NetEco
1000S as user ftpuser and upload performance data. You are advised to change the password
periodically to ensure system security.

Prerequisites
l You have obtained the password for ftpuser.

Please see Installation and Commissioning > Planning Operating System Users and
Their Initial Passwords for details about the password of ftpuser.

l You have started the NetEco services. For details about how to start the services, see
5.1.1.1.1 Starting NetEco 1000S Services.

l The Smart Logger supports FTPS.

NOTE

You are advised to change the password after you install the NetEco 1000S for the first time, and change
the password every three months.

Procedure

Step 1 Run the script NetEco software installation\tools\ConfigTools.bat. When the following
information is displayed, enter 1 and press Enter.
1) Change FTPServer password 
2) Change database password 
3) Change Modbus SSL config 
4) Change FTPS SSL config 
5) Change external IP of the NetEco 
6) Change local IP of the NetEco 
7) Exit 
 
Please choose 1-7:
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Step 2 When the following information is displayed, enter ftpuser, and press Enter.
Please input FTPserver username:

Step 3 When the following information is displayed, enter current password and press Enter.
Please input the old password:

Step 4 When the following information is displayed, enter new password and press Enter.
Please input new FTPserver password:

NOTE

l The password cannot be the same as the user name or the user name in a reversed order.

l The password contains 8 to 32 characters.

l The password contains three of the following:

– Lowercase letters

– Uppercase letters

– Digits

l The password is advised to contain special characters, which include !"#$%&'()*+,-./:;<=>?
@[\]^`{_|}~ and space.

Step 5 When the following information is displayed, enter new password again and press Enter.
Please confirm new FTPserver password:

Step 6 When the following information is displayed, the password is changed successfully.
FTPServer password changed. 
Change succeeded.

NOTE

Password take effect after the next restart NetEco 1000S.

----End

5.1.8.13 How Do I Modify the Data or File Transmission Protocol?
This section describes how to modify the data or file transmission protocol. Data is
transmitted using the Modbus protocol and files are transmitted using the FTPS between the
NetEco 1000S and SmartLogger. Data and files are transmitted using the Modbus protocol
between the NetEco 1000S and inverters directly connected to the FE.

Context
The data or file transmission protocol needs to be modified, that is, modifying the TLS
protocol of the Modbus or FTP.

To be compatible with devices of earlier versions, the NetEco 1000S supports the TLSv1.0,
TLSv1.1, and TLSv1.2 at the same time by default. TLSv1.0 has security risks. To ensure
connection security, you are advised to use TLSv1.1 or TLSv1.2.
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NOTICE
If the SmartLogger or inverters directly connected to the FE does not support TLSv1.1/1.2,
the SmartLogger or inverters directly connected to the FE may be disconnected after you
change the protocol to TLSv1.1 or TLSv1.2. You are advised to replace the SmartLogger or
inverters directly connected to the FE with the one supporting TLSv1.1/1.2 or upgrade the
SmartLogger or inverters directly connected to the FE to the version supporting TLSv1.1/1.2.

Procedure

Step 1 Logging Out of the NetEco 1000S services, for detailed operations, see 5.1.1.2.2 Logging
Out of the NetEco 1000S Services.

Step 2 Run the script NetEco software installation\tools\ConfigTools.bat. The following
information is displayed:
1) Change FTPServer password 
2) Change database password 
3) Change Modbus SSL config 
4) Change FTPS SSL config 
5) Change external IP of the NetEco 
6) Change local IP of the NetEco 
7) Exit 
 
Please choose 1-7:

Step 3 Modify the transmission protocol.
l Modify the data transmission protocol.

a. Enter 3 and press Enter. The following information is displayed:
The old config is : TLSv1,TLSv1.1,TLSv1.2 
1) TLSv1,TLSv1.1,TLSv1.2 
2) TLSv1.1,TLSv1.2 
3) TLSv1.2 
4) Cancel 
 
Please choose 1-4:

b. Set the data transmission mode as required.
n Supporting TLS1.0, TLS1.1, and TLS1.2: Enter 1 and press Enter.

NOTICE
TLSv1.0 has security risks. To ensure connection security, you are advised to
use TLSv1.1 or TLSv1.2.

When the following information is displayed, the protocol type is changed
successfully:
Modbus SSL changed to TLSv1, TLSv1.1, TLSv1.2
Change succeeded.

n Supporting TLS1.1 and TLS1.2: Enter 2 and press Enter.
When the following information is displayed, the protocol type is changed
successfully:
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Modbus SSL changed to TLSv1.1, TLSv1.2  
Change succeeded.

n Supporting Only TLS1.2: Enter 3 and press Enter.
When the following information is displayed, the protocol type is changed
successfully:
Modbus SSL changed to TLSv1.2  
Change succeeded.

l Modify the file transmission protocol.

a. Enter 4 and press Enter. The following information is displayed:
The old config is : TLSv1,TLSv1.1,TLSv1.2 
1) TLSv1,TLSv1.1,TLSv1.2 
2) TLSv1.1,TLSv1.2 
3) TLSv1.2 
4) Cancel 
 
Please choose 1-4:

b. Set the file transfer mode as required.
n Supporting TLS1.0, TLS1.1, and TLS1.2: Enter 1 and press Enter.

NOTICE
TLSv1.0 has security risks. To ensure connection security, you are advised to
use TLSv1.1 or TLSv1.2.

When the following information is displayed, the protocol type is changed
successfully:
FTPS SSL config changed to TLSv1, TLSv1.1, TLSv1.2
Change succeeded.

n Supporting TLS1.1 and TLS1.2: Enter 2 and press Enter.
When the following information is displayed, the protocol type is changed
successfully:
FTPS SSL config changed to TLSv1.1, TLSv1.2  
Change succeeded.

n Supporting Only TLS1.2: Enter 3 and press Enter.
When the following information is displayed, the protocol type is changed
successfully:
FTPS SSL config changed to TLSv1.2  
Change succeeded.

Step 4 Restart the NetEco 1000S for the settings to take effect.

----End

5.1.8.14 How Do I Ensure that Performance Data Can Be Properly Reported When
the NetEco 1000S and SmartLogger Are Deployed On Different Network
Segments?

If the NetEco 1000S and SmartLogger are deployed on different network segments, you need
to set the external IP address of the NetEco 1000S using the configuration file so that
performance data can be properly reported between the NetEco 1000S and SmartLogger.
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Procedure

Step 1 Logging Out of the NetEco 1000S services, for detailed operations, see 5.1.1.2.2 Logging
Out of the NetEco 1000S Services.

Step 2 Run the script NetEco software installation\tools\ConfigTools.bat. When the following
information is displayed, type 5 and press Enter.
1) Change FTPServer password 
2) Change database password 
3) Change Modbus SSL config 
4) Change FTPS SSL config 
5) Change external IP of the NetEco 
6) Change local IP of the NetEco 
7) Exit 
 
Please choose 1-7:

Step 3 When the following information is displayed, type the external IP address of the NetEco and
press Enter.
 Please input external IP of the NetEco:

Step 4 When the following information is displayed, the external IP address of the NetEco is
changed successfully.
External IP of the NetEco is changed to xxx.xx.xx.xx 
Change succeeded.

Step 5 Type 7 and press Enter to exit.

Step 6 Restart the NetEco 1000S for the settings to take effect.

----End

5.1.8.15 How Do I Replace the Key File of the NetEco 1000S?

To ensure the security and reliability of the NetEco 1000S key, the system administrator needs
to periodically replace the NetEco 1000S key to improve the security of the NetEco 1000S.

Prerequisites
l You have started the NetEco 1000S services. For details about how to start the services,

see 5.1.1.1.1 Starting NetEco 1000S Services.
l You have logged in to the NetEco 1000S client.

Context

You are advised to replace the Key file every 3 months to improve the security of the NetEco
1000S.

Procedure

Step 1 Stop the NetEco 1000S services. For detailed operations, see 5.1.1.2.2 Logging Out of the
NetEco 1000S Services.

Step 2 Run the script NetEco software installation directory\tools\KeysTools.bat.

The following information is displayed:

please input database username:
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Step 3 Type dbuser and press Enter.

The following information is displayed:

please input database password:

Step 4 Type the password of dbuser user and press Enter.

The following information is displayed:

Do you want to start replacing the key?Y: start. N: cancel.

Step 5 Type Y and press Enter.

When the following information is displayed, the key is successfully replaced:

Starting database ... 
database started 
 
Change succedded

NOTICE
The command window is automatically closed after the key is replaced. You cannot manually
close the command window during the key replacement. Otherwise, data interruption will
occur.

If any statement indicating the replacement failure is displayed, perform the operations as
prompted or contact Huawei technical support.

Step 6 After the replacement is complete, restart the NetEco 1000S services.

----End

5.1.8.16 How Do I Change the Password of the plantcontroller user?
User plantcontroller is used for plant controller devices to transfer files to the NetEco. You
are advised to change the password periodically to ensure system security.

Prerequisites
l You have obtained the password of plantcontroller user.

Please see User_Manual > Installation and Commissioning > Planning Operating
System Users and Their Initial Passwords for details about the password of
plantcontroller user.

l You have started the NetEco 1000S services. For details about how to start the services,
see 5.1.1.1.1 Starting NetEco 1000S Services.

NOTE

You are advised to change the password after you install the NetEco 1000S for the first time, and change
the password every three months.

Procedure

Step 1 Run the script NetEco software installation\tools\ConfigTools.bat. When the following
information is displayed, type 1 and press Enter.
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1) Change FTPServer password 
2) Change database password 
3) Change Modbus SSL config 
4) Change FTPS SSL config 
5) Change external IP of the NetEco 
6) Change local IP of the NetEco 
7) Exit 
 
Please choose 1-7:

Step 2 When the following information is displayed, type plantcontroller, and press Enter.
Please input FTPserver username:

Step 3 When the following information is displayed, type current password and press Enter.
Please input the old password:

Step 4 When the following information is displayed, type new password and press Enter.
Please input new FTPserver password:

NOTE

l The password cannot be the same as the user name or the user name in a reversed order.

l The password contains 8 to 32 characters.

l The password contains three of the following:

– Lowercase letters

– Uppercase letters

– Digits

l The password is advised to contain special characters, which include !"#$%&'()*+,-./:;<=>?
@[\]^`{_|}~ and space.

Step 5 When the following information is displayed, enter new password again and press Enter.
Please confirm new FTPserver password:

Step 6 When the following information is displayed, the password is changed successfully.
FTPServer password changed. 
Change succeeded.

NOTE

Password take effect after the next restart NetEco 1000S.

----End

5.1.8.17 What Do I Do If the Email Server Fails to Send an Email?

This section describes how to solve the problem that the email server fails to send an email.

Possible Causes

The possible causes of the failure are as follows:

l Incorrect network configuration

l Incorrect IP address or domain name of the email sending server

l Incorrect port number for email sending

l Incorrect user name or password

l Incorrect sender or recipient email address
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Procedure

Step 1 Check the network configuration.

1. Choose Start > Control Panel > Network and Internet > Network and Sharing
Center > Network Connections in the operating system.

NOTE

The navigation path of Network Connections on the Control Panel may vary depending on the
OS version. Choose the corresponding path as required.

The Network Connections dialog box is displayed.

2. Click Properties.

The Local Area Connection Properties dialog box is displayed, as shown in Figure
5-73.

Figure 5-73 Local area connection properties

3. Select Internet Protocol Version 4 (TCP/IPv4) and click Properties.

4. Select Obtain an IP address automatically and Obtain DNS server address
automatically, and click OK.

5. Check whether the problem has been resolved.

– If the problem has been resolved, no further operation is required.

– If the problem persists, go to the next step.
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Step 2 Check Email sending server.

1. Check whether the IP address or domain name configured for Email sending server is
correct.

If the configuration is correct, go to the next step. Otherwise, configure the correct IP
address or domain name by referring to 5.1.7.3.1 Setting Parameters for the Email
Server.

2. Check whether the problem has been resolved.

– If the problem has been resolved, no further operation is required.

– If the problem persists, go to the next step.

Step 3 Check Email sending port No.

1. Check whether the setting of Email sending port No is correct.

If the configuration is correct, go to the next step. Otherwise, configure the correct port
number by referring to 5.1.7.3.1 Setting Parameters for the Email Server.

2. Check whether the problem has been resolved.

– If the problem has been resolved, no further operation is required.

– If the problem persists, go to the next step.

Step 4 Check User name and Password.

1. Check whether User name and Password are correctly configured.

If the configuration is correct, go to the next step. Otherwise, configure the correct user
name and password by referring to 5.1.7.3.1 Setting Parameters for the Email Server.

2. Check whether the problem has been resolved.

– If the problem has been resolved, no further operation is required.

– If the problem persists, go to the next step.

Step 5 Check Sender email address and Recipient email address.

1. Check whether Sender email address and Recipient email address are correctly
configured.

If the configuration is correct, go to the next step. Otherwise, configure the correct email
address by referring to 5.1.7.3.1 Setting Parameters for the Email Server.

2. Check whether the problem has been resolved.

– If the problem has been resolved, no further operation is required.

– If the problem persists, go to the next step.

Step 6 If the problem persists after the preceding possible causes are ruled out, contact Huawei
technical support engineers.

----End

5.1.8.18 How Do I Solve the Problem that the Calculated Performance Ratio Is
Inaccurate?

This section describes how to locate the cause of performance ratio inaccuracy and solve this
problem.
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Possible Causes

The total component capacity is not configured for inverters.

Procedure

Step 1 Check whether total component capacity is configured for all inverters.

1. Log in to the NetEco 1000S client as the system administrator or a user in the system
operator group.

2. Click the Monitor tab.
3. Choose the inverter to be checked from the navigation tree in the left pane and click the

Settings tab in the right pane.
The Device Information page is displayed.

4. Check whether Total string capacity is configured.
– If it is configured, view the configuration pages of all inverters in sequence and

check whether Total string capacity has been configured for all inverters.

NOTE

If any inverters are not configured with Total string capacity, configure Total string
capacity for them.

– If it is not configured, enter the target value in the Total string capacity text box
and click Save in the upper right corner.

NOTE

To change the total string capacity of multiple inverters to the value set in last step, click
Batch Apply and select target devices.

5. Check whether the problem has been resolved.
– If the problem has been resolved, no further operation is required.
– If the problem persists, go to the next step.

Step 2 If the problem persists after the preceding possible causes are ruled out, contact Huawei
technical support engineers.

----End

5.1.8.19 Failure to Receive Emails

Symptom

After the alarm or report sending rules are configured on the NetEco 1000S client, no alarm or
report emails are received.

Possible Causes
l Reasons related to the sender's server: The sender's server categorizes the emails as junk

emails and therefore does not send the emails.
An email may be categorized as a junk email for the following reasons:
– The number of emails sent in a day exceeds the limit.
– The content of the email is the same as or similar to that of another email.
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l Reasons related to the recipient's server:
– The emails are categorized as junk emails and therefore cannot be received.
– In Windows Server 2012, the email server is used for email receiving by default.

The cause may be that the default host name or domain name of the email server is
not recognized. As a result, the emails fail to be received.
This problem may occur if customers use the email server installed by themselves.

Procedure

Step 1 Check the sender's email server.
l In Windows Server 2012, enable the SMTP server for email sending.
l In Windows 7 or Windows 10, upgrade the mailbox to a VIP mailbox for email sending.

For detailed operations, contact Huawei technical support engineers.

Step 2 Check whether the problem has been resolved.
l If the problem has been resolved, no further operation is required.
l If the problem persists, go to the next step.

Step 3 Check the recipient's mailbox.

Check whether junk emails contain emails from the NetEco 1000S. If yes, set the mailbox so
that emails from the NetEco 1000S are not categorized as junk emails.

Step 4 Check whether the problem has been resolved.
l If the problem has been resolved, no further operation is required.
l If the problem persists, go to the next step.

Step 5 If the operating system is Windows Server 2012, change the email server attribute.

Set the host name or domain name of the email server to a value in the ****.****.****
format, such as mail.neteco.com.

Step 6 Check whether the problem has been resolved.
l If the problem has been resolved, no further operation is required.
l If the problem persists, contact Huawei technical support.

----End

5.1.8.20 What Do I Do If the Client Does Not Display the Language Selected
During Last Access After Access to the NetEco 1000S Using a Web Browser?

Symptom
When a user accesses the NetEco 1000S using a web browser again, the client does not
display the language selected during last access.

Possible Causes
l The browser has been configured to delete browsing history on exit.
l Cookies have been disabled for the browser.
l The URL entered in the address box of the browser for accessing the client carries a

language attribute.
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Procedure

Step 1 Cancel browsing history deletion upon exit for the browser.

1. Choose Tools > Internet Options from the main menu of the browser.
2. On the General tab page, clear Delete browsing history on exit.

Step 2 Allow cookies.

1. Choose Tools > Internet Options from the main menu of the browser.
2. On the Privacy tab page, click Advanced.

The Advanced Privacy Settings dialog box is displayed.
3. Select Override automatic cookie handing, select Accept under First-party Cookies

and Third-party Cookies, select Always allow session cookies, and click OK.

Step 3 Delete the language attribute (webLang=xxx) carried in the client access URL.

For example, if the client access URL is https://IP address:8443/index.action?
webLang=zh_CN, delete the language attribute from the URL. That is, use https://IP
address:8443/index.action to access the client.

----End

5.1.8.21 What Should I Do When Running the SSLTools.bat Script to Generate a
New Certificate Fails?

Symptom

Running the SSLTools.bat script to generate a new certificate fails, and the following
information is displayed.

Create keystore file failed.

Possible Cause

vcredist.x86.exe is not installed for the current operating system.

Procedure

Step 1 Obtain vc_redist.x86.exe from the Microsoft official website and save it to the current
operating system.

Step 2 Double-click vcredist.x86.exe and install it.

Step 3 Run the SSLTools.bat script again to generate a new certificate.

----End

5.1.8.22 What Do I Do to Control the User Authorization upon First Login?

For NetEco 1000S of V100R002C70 or later versions, no user authorization is required upon
the first login by default. However, you can modify userManagement.properties to change the
system configuration so that user authorization is required upon the first login.
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Prerequisites

The NetEco 1000S is of V100R002C70 or a later version.

Procedure

Step 1 Update the Privacy Policy and Terms of Use in compliance with local laws and regulations.

The methods of updating the Privacy Policy or Terms of Use are similar. The following
describes how to update Privacy Policy.

1. Navigate to NetEco 1000S installation directory\tools\userPrivacy\template to obtain
userPrivacy.xml:

NOTE

To update Terms of Use, please navigate to NetEco 1000S installation directory\tools
\UseOfTerms\template to obtain UseOfTerms.xml.

2. Store userPrivacy.xml under NetEco 1000S installation directory\tools\userPrivacy,
open the file in text mode, and edit it.

NOTE

To update Terms of Use, please store UseOfTerms.xml under NetEco 1000S installation
directory\tools\UseOfTerms.

NOTICE
– The file under NetEco 1000S installation directory\tools\userPrivacy must be

named as userPrivacy.xml. If not, modify it.
– The file under NetEco 1000S installation directory\tools\UseOfTerms must be

named as UseOfTerms.xml. If not, modify it.

3. Update the version and time for the Privacy Policy.
Modify the tag content based on Table 5-37 and actual conditions.

Table 5-37 Updating the version and time

Pair Description

<version>
1.0
</version>

Version of the Privacy Policy.
Modify the version when the Privacy Policy is
updated. The first issue is version 1.0, the second
issue version 2.0, and so forth.

<updateTime >
2017-07-06
</updateTime>

Update time of the Privacy Policy.
Modify the time when the Privacy Policy is
updated. The time format is as 2017-07-06.

 
4. Update the Privacy Policy in Chinese, English, Japanese, French, and German based on

Table 5-38 and actual conditions, and save the updates.
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Table 5-38 Five language environments

Pair Description

<country name="zh_CN">
<detail>
Details of Privacy Policy.
</detail>
</country>

The Privacy Policy displayed in Chinese
environment.

<country name="en_US">
<detail>
Details of Privacy Policy. 
</detail>
</country>

The Privacy Policy displayed in English
environment.

<country name="ja_JP">
<detail>
Details of Privacy Policy.
</detail>
</country>

The Privacy Policy displayed in Japanese
environment.

<country name="fr_FR">
<detail>
Details of Privacy Policy.
</detail>
</country>

The Privacy Policy displayed in French
environment.

<country name="de_DE">
<detail>
Details of Privacy Policy.
</detail>
</country>

The Privacy Policy displayed in German
environment.

 

Step 2 Navigate to NetEco 1000S software installation directory\tools, and run the UserTools.bat
script.

The following information is displayed:
1 Update userPrivacy file.
2 Update UseOfTerms file.
3 Change life cycle of operatelog<1~3650>.
4 Exit.
Please Choose:

Step 3 Enter 1 and press Enter.

NOTE

If you need to synchronize the updated Terms of Use to the NetEco 1000S, enter 2 and press Enter.

The Privacy Policy is updated successfully.
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Step 4 Navigate to the following directory:

NetEco 1000S installation directory\WebRoot\WEB-INF\classes

Step 5 Open the userManagement.properties file, change the value of PrivacyStatementType and
isShowUseTerms to 1, and save the change result.

NOTE

l If you only want to display Privacy Policy on User Authorization page, please only change the
value of PrivacyStatementType to 1.

l If you want not to display User Authorization page, please change the value of
PrivacyStatementType to 0.

Step 6 Restart the NetEco 1000S.

The settings become valid.

The User Authorization page is displayed upon the first login, you need to view the Privacy
Policy and and Terms of Use and select Agree to the Privacy Policy and Agree to the Terms
of Use (If the Terms of Use is set not to be displayed, you cannot view the Terms of Use here)
before clicking OK to continue the operations.

----End

Follow-up Procedure
l If the Privacy Policy and Terms of Use are updated, you can run the UserTools.bat script

to synchronize the updated Privacy Policy and Terms of Use to the NetEco 1000S. For
details, refer to Step 1, Step 2, and Step 3 in Procedure.

NOTICE
The NetEco 1000S automatically detects the version of Privacy Policy or Terms of Use
(when the Terms of Use is set to be displayed on User Authorization page) at 00:00:00
every day. If a version change is detected, you will be forcibly logged out of both the
NetEco 1000S client and the NetEco 1000S app. You need to select Agree to the
Privacy Policy and Agree to the Terms of Use on the NetEco 1000S client before using
the NetEco 1000S.

l You can also run the UserTools.bat script to change the life cycle of operation logs.

NOTE

l The life cycle of operation logs is half a year by default.
l This function is irrelevant to updating Privacy Policy and Terms of Use.

a. Go to NetEco 1000S software installation directory\tools, and run the
UserTools.bat script.
The following information is displayed:
1 Update userPrivacy file.
2 Update UseOfTerms file.
3 Change life cycle of operatelog<1~3650>.
4 Exit.
Please Choose:

b. Enter 3 and press Enter.
The following information is displayed:
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Please input the life cycle of operatelog:
c. Enter the number of days as required and press Enter.

User-defined life cycle of operation logs ranges from 1 to 3650, indicating 1–3650
days.

d. Restart the NetEco 1000S to validate the settings.

5.2 NetEco 1000S Web Client Operation (Residential)
This section describes how to log in to the residential NetEco 1000S and how to perform the
operations to the NetEco 1000S on the web client.

You are not allowed to change the OS time whereas the software is running.

5.2.1 Getting Started

5.2.1.1 Logging In to the NetEco 1000S
This section describes how to log in to the NetEco 1000S before using the service functions
supported by NetEco 1000S.

Prerequisites
l NetEco 1000S is switched to a residential system. For details, see 5.2.7.7 What Do I Do

to Switch to the Residential NetEco 1000S System.
l You have obtained the user Account/Email and password for logging in to the NetEco

1000S.

Procedure

Step 1 Open the web browser.

NOTICE
The web browser must be Internet Explorer 11 or Chrome 50. Otherwise, some browser
problems may occur when users query data.

Step 2 Enter https://IP address:8443 in the address bar, and press Enter.

Step 3 the GUI shown in Figure 5-74 or Figure 5-75 will be displayed when you start the client.
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Figure 5-74 Website Security Certificate window (Internet Explorer)

Figure 5-75 Website Security Certificate window (Chrome 50)

l When using the Internet Explorer, click Continue to this website (not recommended)
in Figure 5-74.

l When using the Chrome, choose Advanced > Proceed to IP or domain name (unsafe) in
Figure 5-75.

The Login window is displayed, as shown in Figure 5-76.

Figure 5-76 Login
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Step 4 On the Login page, select a language to be used by the NetEco 1000S client from the drop-
down list box.

NOTE

l Chinese, English, Japanese, German, and French are supported. If you do not select a language, the
language used during the NetEco 1000S client installation is used.

l The selected language takes effect only for the currently user who is logged in using the current
browser.

l After changing the language, only the static information (information not entered by users) is
changed, such as the titles, menu names, and messages. Dynamically generated information such as
operation logs are still recorded and displayed in the language used during the NetEco 1000S client
installation. Information entered by users, such as the plant name, plant description, and device
name, are displayed in the language in which the information is entered.

l After you select a language on the Login page or the home page, the browser will record the
language information (for 30 days). If the browser cache is not cleared or disabled, the recorded
language is used upon your next login.

Step 5 Enter Account/Email and Password, and click Login.

NOTICE
If the User Authorization page is displayed here, select Agree to the Privacy Policy and
Agree to the Terms of Use before clicking OK to continue the operations.

The System Initial Password page is automatically displayed after the password expires.
Change the password and log in to the NetEco 1000S client using the new password.

NOTICE
l Use the system administrator user when you log in to the NetEco 1000S for the first time.

This user has the highest operation rights.

l To improve system security, you are advised to change the initial keys set before product
delivery in a timely manner and periodically (at an interval of 3 months) change the user
key to avoid security risks, such as violent key cracking.

l The password cannot the user name or the reversed user name.

l The length ranges from 8 to 32 characters.

l The password contains three of the following:

– Lowercase letters

– Uppercase letters

– Digits

l The password is advised to contain special characters, which include !"#$%&'()*
+,-./:;<=>?@[\]^`{_|}~ and space.

If you forget the password, perform the following operations.
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NOTICE
l Ensure that the email server has been configured. Otherwise, the password cannot be reset.

For details about how to configure the email server, see 5.2.6.3.1 Setting Parameters for
the Email Server.

l This operation requires that the current user is an installer or customer.
l A user can reset the password three times a day at most.

1. Click Forget Password.
The Reset Password page is displayed, as shown in Figure 5-77.

Figure 5-77 Reset Password

2. Enter the email address and verification code.
3. Click OK.

The Operation succeeded. Confirm the initialization password within 5 minutes.
Otherwise, the confirmation email will be invalid. prompt message is displayed.

4. Click OK.
Check the email for retrieving the password and perform the operations specified in the
email.

NOTICE
If the link in the email cannot be accessed, check whether the IP address contained in the
link is the same as the IP address of the NetEco 1000S server. If no, change the IP
address contained in the link to the IP address of the NetEco 1000S server. Then, you can
access the link successfully.

----End
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Exception Handling
When user B logs in to the client after user A logs in to it, the following problems may occur:

l After user B enters the login address in the address box of the browser, the login window
for user A is displayed but that for user B is not displayed.

l After user B logs in to the client, user A's session window is automatically switched to
user B's login window and user A is logged out.

The preceding problems are caused by the browser mechanism. They can be prevented using
the following methods:

l When using the Internet Explorer, choose File > New Session from the menu bar.
In the displayed session window, enter the login address. You can log in to the client as
user B successfully.

l When using the Chrome, open the menu and choose New incognito window.
In the displayed incognito window, enter the login address. You can log in to the client as
user B successfully.

5.2.1.2 Logging Out of the NetEco 1000S

Procedure

Step 1 Click  in the upper right corner from the main menu to log out. The Login page is displayed.

----End

5.2.1.3 Getting to Know the NetEco 1000S Home Page
This section describes the NetEco 1000S home page. Getting familiar with the NetEco 1000S
home page helps you quickly find the entry for an operation and improve operation efficiency.

Figure 5-78 shows the homepage of the NetEco 1000S client after the login. Table 5-39
describes the items on the homepage.

Figure 5-78 NetEco 1000S homepage
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Table 5-39 NetEco 1000S homepage

No. Name Description

1 Menu bar Indicates the main menu of the system.

2 Operation
display area

Displays the GUI of the selected function.

3 You can click this icon to select a language to be used by the
NetEco 1000S client.
NOTE

l Chinese, English, Japanese, German, and French are supported. If
you do not select a language, the language used during the NetEco
1000S client installation is used.

l The selected language takes effect only for the current user who
has logged in using the current browser.

l After changing the language, only the static information
(information not entered by users) is changed, such as the titles,
menu names, and messages. Dynamically generated information
such as operation logs are still recorded and displayed in the
language used during the NetEco 1000S client installation.
Information entered by users, such as the plant name, plant
description, and device name, are displayed in the language in
which the information is entered.

l After you select a language on the Login page or the home page,
the browser will record the language information (for 30 days). If
the browser cache is not cleared or disabled, the recorded language
is used upon your next login.

4 Current
logged-in user

Displays the name of the current logged-in user.

5 Password
changing icon

You can click this icon to change the current password.

6 User
Authorization
icon

You can click this icon to open the User Authorization page
to view the Privacy Policy and Terms of Use.

7 Help icon You can click Help under this icon to open the online help.
NOTE

The customer cannot access the online help.

You can click About under this icon to check the version
information.

8 Exit icon You can click this icon to exit the client.

9 NetEco Alarm
icon

Displays whether the NetEco 1000S has generated alarms.

l : The NetEco 1000S has generated alarms. For details,
see 5.2.5.6 Querying NetEco Alarms.

l : The NetEco 1000S generates no alarm.
NOTE

The customer cannot access the alarm information about the
management system.
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No. Name Description

10 Alarm board
icon

Displays the number of the current alarms. Alarms of different
alarm severities are marked in different colors.
You can click this icon to enter the Alarms window. Table
5-40 lists the icon meaning.
NOTE

The customer cannot access the alarm board information.

 

Table 5-40 Alarm status images

Image Status

Critical

Minor

Major

Warning

 

5.2.2 Managing the PV Plants

5.2.2.1 Viewing the Plant List
You can learn the overview of all plants connected to the NetEco 1000S by viewing the plant
list.

Prerequisites
You have logged in to the NetEco 1000S client. For details, see 5.2.1.1 Logging In to the
NetEco 1000S.

Context
The plant list displayed on the Plant List page varies with the login users. The details are as
follows:

l system administrator: Displays all PV plants connected to the NetEco 1000S.
l Installer or customer: Displays only PV plants that the current user can access.

Procedure
l If you log in to the NetEco 1000S as the system administrator or installer, you can view

the plant list on the Overview and Monitor pages. For details, see Table 5-41.
l If you log in to the NetEco 1000S as a customer, you can view the plant list only on the

Overview page. For details, see Table 5-41.
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Table 5-41 Procedure for viewing the plant list

Methods of
Viewing the Plant
List

Procedure

On the Overview
page

1. Choose Overview form the main menu.
2. You can view the plant list on the Overview page, as shown in

Figure 5-79. For detailed parameters, see Table 5-42.
l If the number of PV plants that you can access is 0 or greater

than 1, the Overview page displays the plant list by default.
l If you can access only one PV plant, the Overview page

displays the PV plant overview by default. You need to click

 in the upper left corner of the page to view
the plant list.

On the Monitor
page

1. Choose Monitor from the main menu.
2. In the navigation pane on the left, choose PV System.
3. In the displayed operation area, choose Plant List.

You can query the data about all plants in Plant List, as shown
in Figure 5-80. For details, see Table 5-42.

 

Figure 5-79 plant list in overview

Figure 5-80 plant list in monitor

Table 5-42 Parameter description

Item Description

PV plant Name of a PV plant.
NOTE

Click the PV plant name. The Details page of the PV plant is
displayed.

Status Alarm with the highest severity in a PV plant.
NOTE

If no devices are connected in the current PV plant, - will be
displayed.

Country Country where a PV plant is located. Not displayed by
default.
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Item Description

City City where a PV plant is located. Not displayed by default.

Address Address of a PV plant.

Zip code Zip code of the address where a PV plant is located. Not
displayed by default.

Rated Power Total rated power of inverters connected to the PV plant

Specific Energy Total equivalent power generation duration of a PV plant.

Total Power Current total power of a PV plant.

Energy Yield of Current
Day

Current-day energy yield

Total Energy Yield Total energy yield of a PV plant.

Income Total income of a PV plant.
NOTE

Currency of the total income of a PV plant is the standard currency
selected when the NetEco 1000S is installed.

Time zone City Time zone where the PV plant is located.

Enable
daylight
saving time

Indicating whether the daylight saving time is used in the
time zone where the PV plant is located.
If the daylight saving time is not used, - will be displayed.

 

NOTE

l You can click  next to the PV plant, Country, City, Address, and Zip code column to sort PV
plants by parameter in ascending or descending order.

Parameters are sorted in Unicode mode. The priority of PV plants whose names contain hyphens (-),
digits, uppercase letters, underscores (_), lowercase letters, and Chinese characters decreases in
sequence.

l You can click  next to the Status column to sort alarms by severity in ascending or descending
order.

Follow-up Procedure

 in the upper right corner provides the function of displaying only specified columns in the
table on the Plant List tab page. To display specified columns, perform the following steps:

Step 1 Click .

The Select Column dialog box is displayed.

Step 2 Select the names of the columns that need to be displayed. Then, click OK.

----End

iManager NetEco 1000S
User Manual 5 Operation and Maintenance

Issue Draft C (2017-12-14) Huawei Proprietary and Confidential
Copyright © Huawei Technologies Co., Ltd.

202



5.2.2.2 Creating a PV Plant

This section describes how to create a plant. After the NetEco 1000S is installed, a default
plant is available. You can also create another plant as required.

Prerequisites
l You have logged in to the NetEco 1000S client. For details, see 5.2.1.1 Logging In to

the NetEco 1000S.
l You have logged in as the system administrator or installer.
l The IP address of the NetEco 1000S has been registered with the inverter, and the

inverter has been successfully registered with the management system. For details about
how to configure the IP address of the NetEco 1000S on the inverter, see the inverter
user manual.

l You have obtained the device SN and registration code.

Procedure

Step 1 Choose Overview from the main menu.

Step 2 Click  in the upper left corner.

The Create PV Plant window is displayed, as shown in Figure 5-81.

Figure 5-81 create pv plant

Step 3 Set plant parameters by referring to Table 5-43.

Table 5-43 PV Plant parameters

Item Mandatory
(Yes/No)

Description

PV plant name Yes Name of a PV plant.
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Item Mandatory
(Yes/No)

Description

Country Yes Country where a PV plant is located.

City Yes City where a PV plant is located.

Address Yes Address of a PV plant.

Time Zone Yes Select the time zone for the plant from the drop-
down list box. The time zone where the NetEco
1000S server is located, or the time zone of the
country where the plant is located, is selected by
default.
If the daylight saving time is used in the selected
time zone, the Enable daylight saving time check
box will be displayed. You can select the check box
to enable daylight saving time.

Zip code Yes Zip code of the address where a PV plant is located.

Electricity price Yes Price of the power.
Value range: 0.0000-99.9999

Currency Yes Price unit. You can set the unit in the Income
Settings dialog box by choosing System > System
Settings > Income Settings.

PV Plant Image No 1. Click Upload.
2. Select a plant photo and click Open.

NOTE
The size of the photo must be less than 5 MB and
in .jpg, .png, or .gif format. Otherwise, the upload will
fail.

Device Yes
1. Click .
2. Specify the SN, registration code, and total string

capacity (optional) of the SUN2000L inverter.
After a PV plant is created on the NetEco 1000S,
the SUN2000L inverter automatically mounts to
the PV plant.

NOTE
If you are a registered user, the SN and registration code
entered during the registration will be automatically linked
and displayed.

PV plant
description

No Description of a PV plant.
Enter utility information about the PV plant.

 

Step 4 Click Save.

----End
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Other Operations

You can click  in the navigation tree on the left of the Monitor page to create a PV plant.
The Create PV Plant window displayed here does not have PV Plant Image. For details
about how to fill in other parameters, see Table 5-43.

5.2.2.3 Obtaining an Overview of a PV Plant

You can learn the device status and PV plant running information by querying the overview of
the PV plant.

Prerequisites

You have logged in to the NetEco 1000S client. For details, see 5.2.1.1 Logging In to the
NetEco 1000S.

Procedure
l If you log in to the NetEco 1000S as the system administrator or installer, you can obtain

an overview of the PV plant on the Overview and Monitor pages. For details, see Table
5-44.

l If you log in to the NetEco 1000S as a customer, you can obtain an overview of the PV
plant on the Overview page. For details, see Table 5-44.

Table 5-44 Procedure for obtaining an overview of the PV plant

Where to Obtain an
Overview of the PV
Plant

Procedure

On the Overview page 1. Choose Overview from the main menu.
The Plant List page is displayed.
NOTE

If you can only access one PV plant, the Overview page displays
the plant list by default.

2. Click a name in the plant list.
The overview of the PV plant is displayed.

On the Monitor page 1. Choose Monitor from the main menu.
2. In the navigation pane on the left, choose PV System or a

user-defined PV plant.
3. In the displayed operation area, choose the Details tab.

The overview of the PV plant is displayed.

 

Follow-up Procedure
l On the Overview page, the system administrator, installer, or customer can perform the

following operations.
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Table 5-45

Procedure Step

View all indicators of the PV
plant.

View Energy Yield of Current Day, Total Energy
Yield, Total Power, Specific Energy, Income, and
CO2 Reduction on the Overview page.

View the inverter details. View the details of inverters under the PV plant on
the left of the Overview page.

View the PV plant
information.

View the basic information about the PV plant on
the right of the Overview page.

View the PV plant power
curve.

View the power curves of the PV plant in the lower
left part of the Overview page.
Meanings of the coordinates are as follows:
l Vertical coordinate: Active power of the PV

plant.
l Horizontal coordinate: data collection period.

The interval is two hours. For how to configure
Collection time, please see 5.2.2.6 Modifying
the Information About a PV Plant.

NOTE
The start time of the horizontal coordinate is an even
number. If the data collection start time configured in
5.2.2.6 Modifying the Information About a PV Plant is
an odd number, use the previous one even number as the
start time of the horizontal coordinate. For example, if the
start time for Collection time is set to 01:00, the start time
of the horizontal coordinate is 00:00.

View and export the historical
data about the energy yields
and incomes of the PV plant.

1. View the historical data about the energy yields
and incomes of the PV plant in the lower right
part of the Overview page.
Meanings of the coordinates are as follows:
l Vertical coordinate on the left: energy yields
l Vertical coordinate on the right: incomes
Horizontal coordinate: time period. Click

 to switch
between the time periods.

2. Click to export the history information
about the energy yields and incomes of the PV
plant.

 
l On the Details page under Monitor, the system administrator or installer can perform

the following operations.
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Operation Procedure

View details about Energy
Yield of Current Day, Total
Energy Yield, Total Power,
Specific Energy, Income, and
CO2 Reduction.
NOTE

You can view details about
Income only on the Details page
of the PV system.

The way of viewing the running information about
all PV plants is the same. Viewing information
about Energy Yield of Current Day is used as an
example.
1. Move the mouse pointer to the pane displaying

the information about Energy Yield of Current
Day. The View Details link is displayed.

Figure 5-82 Viewing details

2. Click View Details.
Information about Energy Yield of Current
Day for each device is displayed in the Details
window.
NOTE

In a PV system, information about Energy Yield of
Current Day for each plant will be displayed.

View the information about the
inverters connected to the PV
plant
NOTE

If the value of Total string
capacity in inverter information
is displayed in red, Total string
capacity is not configured for the
inverter. Configure it by
following the instructions
provided in 5.2.3.4 Modifying
the Information About a
Device.

l On the Details tab page of the PV system, you
can view the icons of the inverters connected to
all PV plants.

l On the Details tab page of the PV plant, you can
view the icons of all the inverters connected to
the PV plant.

NOTE

Icons of SUN2000L: 
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Operation Procedure

View the PV plant power
curve.

View the PV plant power curve in the PV Plant
Power Statistics area.
Each coordinate is defined as follows:
l Vertical coordinate: PV plant power
l Horizontal coordinate: data collection period.

The interval is two hours. For how to configure
Collection time, please see 5.2.2.6 Modifying
the Information About a PV Plant.

NOTE
The start time of the horizontal coordinate is an even
number. If the data collection start time configured in
5.2.2.6 Modifying the Information About a PV Plant is
an odd number, use the previous one even number as the
start time of the horizontal coordinate. For example, if the
start time for Collection time is set to 01:00, the start time
of the horizontal coordinate is 00:00.

Switch to the Performance
Data page.

Click MORE on the right of Details.

Switch the mode for displaying
power statistics.

Click Table or Graph in the lower area of the PV
Plant Power Statistics column.

l : The power statistics are displayed
in a table.

l : The power statistics are
displayed in a graph.

NOTE
The power statistics are displayed in a graph by default.

 

5.2.2.4 Browsing the Device List of a PV Plant
This section describes how to browse the device list of a plant to learn the devices in the plant.

Prerequisites
l You have logged in to the NetEco 1000S client. For details, see 5.2.1.1 Logging In to

the NetEco 1000S.
l You have logged in as the system administrator or installer.

Procedure

Step 1 Choose Monitor from the main menu.

Step 2 Choose PV System or a user-defined plant in the navigation tree on the left.

Step 3 Click the Device List tab in the operation display area.

Key information about all devices under the selected plant is displayed on the Device List tab
page, as shown in Figure 5-83.
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Figure 5-83 Overview of Device Information

 in the upper right corner provides the function of displaying only specified columns in the
table on the Device List tab page. To display specified columns, perform the following steps:

1. Click .
The Select Column dialog box is displayed.

2. Select the names of the columns that need to be displayed. Then, click OK.

----End

Follow-up Procedure

System administrator and installers can also perform the following operations on the Device
List tab page:

Operation Steps

Start the real-time data
collection task

1. Select one or more devices for which you want to
start the real-time data collection task.

2. Click .
3. In the displayed dialog box, click OK.

Stop the real-time data
collection task

1. Select one or more devices for which you want to
stop the real-time data collection task.

2. Click .
3. In the displayed dialog box, click OK.

 

5.2.2.5 Browsing Alarm Information About a PV Plant

This section describes how to browse alarm information about a plant to learn about the
current alarms for all devices under the plant.

Prerequisites
l You have logged in to the NetEco 1000S client. For details, see 5.2.1.1 Logging In to

the NetEco 1000S.
l You have logged in as the system administrator or installer.

Procedure

Step 1 Choose Monitor from the main menu.

Step 2 Choose PV System or a user-defined plant in the navigation tree on the left.
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Step 3 Click the Alarm tab in the operation display area.

The current alarms for all devices under the selected plant is displayed on the Alarm tab page,
as shown in Figure 5-84.

Figure 5-84 Overview of Alarm Information about a PV Plant

Step 4 Optional: Click an alarm name in the Alarm Name column to view the details.

NOTE

Alarms that have not been browsed are highlighted in bold.

Step 5 Optional: Click Export to export the queried alarm information into a CSV file.

----End

Follow-up Procedure

Click Lock. Alarms are no longer automatically updated on the Alarm page. In this way, you
can view the alarms reported only before the lock. To enable the automatic update function
again and view newly reported alarms, click Scroll Unlock.

NOTE

If excessive alarms are generated, these alarms are displayed on multiple pages. In this case, pages
except the first one are locked and the Scroll Unlock button is unavailable for you to unlock those
pages.

By default, the alarm lock function on the Alarm page is disabled.

5.2.2.6 Modifying the Information About a PV Plant

This section describes how to modify the information about a plant on the NetEco 1000S if
the information is inconsistent with that about the actual plant.

Prerequisites
l You have logged in to the NetEco 1000S client. For details, see 5.2.1.1 Logging In to

the NetEco 1000S.
l You have logged in as the system administrator or installer.

Procedure

Step 1 Choose Monitor from the main menu.
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Step 2 Select the plant whose information is to be changed in the navigation tree on the left.

Step 3 Click the Settings tab in the operation display area.

Information about the selected plant is displayed on the Settings tab page.

NOTE

In PV Plant Description area, Initialization time indicates the creating time of the plant, and it is non-
editable.

Step 4 Click Refresh in the upper right corner to refresh the parameter information.

Step 5 Modify the following information in Table 5-46 about a plant as required.

Table 5-46 Parameters of the PV plant

Parameter Type Parameter Description

PV Plant
Description

PV plant name Enter a PV plant name.

Description Enter the description of a PV plant.

Country Select the country where a PV plant is located.

City Enter the city where a PV plant is located.

Address Enter the PV plant address.

Zip code Zip code of the address where a PV plant is
located.

Parameter Setting Ratio
threshold(%)

Set the ratio threshold as required.

Electricity price Set the electricity price as required.
NOTE

l If you want to update the income within
historical time segments (current day also
included), change the electricity price, click
Update Income, and select a historical time
segment.

l If you need the income to be calculated based on
the new electricity price from current day on,
click Save in the upper-right corner of the
configuration page.

Currency Set the currency as required.

CO2 emission
reduction
coefficient (kg/
kWh)

Set the CO2 emission reduction coefficient as
required.
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Parameter Type Parameter Description

Reference Value
Settings

Incomplete historical energy yield data may
lead to an inaccurate income value. You can set
reference values to correct the income value.
1. On the Settings page of PV plants, click

Reference Value Settings.
The Reference Value Settings dialog box is
displayed.

2. Click Auto Calculate or enter a total energy
yield reference value, and specify the
electricity price.
NOTE

– The default value is the electricity price set
for the PV plant.

– The value of this parameter cannot be
modified. It is automatically calculated by
multiplying Total energy yield reference
value(kWh) and Electricity price.

3. Click OK to save the modification.

Time Zone
Setting

Change the time zone for the plant.
1. Click Time Zone Settings on the Settings

page of the plant.
The Time Zone Settings dialog box is
displayed.

2. Select the time zone for the plant from the
City drop-down list box.

3. Enable or disable the daylight saving time
from the Enable daylight saving time
drop-down list box.
NOTE

You can set the parameter only if the selected
time zone uses the daylight saving time.

4. Click OK to save the setting.

Communicate
Parameter

Collection time Collection time indicates that the inverter in
the current plant needs to collect device
performance data of this period on a day.

Real-time data
collection period

Real-time data collection period indicates that
the inverter in the current plant needs to collect
changed device performance data by this period
in real time.

Full
synchronization
period (minutes)

Full synchronization period (minutes)
indicates that the inverter in the current plant
needs to collect all device performance data by
this period in real time.
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Parameter Type Parameter Description

Performance file
collection period
(minutes)

Performance file collection period (minutes)
indicates that the inverter in the current plant
needs to collect historical device performance
data by this period.

 

Step 6 Modify the plant image.

1. Click Upload.
2. Select a plant image and click Open.

NOTE

The size of the plant image must be less than 5 MB, and the image can be saved only in jpg, png, or gif
format. Otherwise, the image fails to be uploaded.

Step 7 Optional: Remotely control devices.

l Click  to synchronize time. The NetEco 1000S performs time synchronization to
synchronize time from the NetEco 1000S server to devices in the current plant.

NOTE

You can synchronize time only as system administrator.

l Power on or off inverters, see 5.2.3.6 Remotely Controlling an Inverter.

----End

5.2.2.7 Deleting a PV Plant

This section describes how to delete a plant that is created incorrectly or do not need to be
managed after network adjustment from the NetEco 1000S.

Prerequisites
l You have logged in to the NetEco 1000S client. For details, see 5.2.1.1 Logging In to

the NetEco 1000S.
l You have logged in as the system administrator or installer.

Procedure

Step 1 Choose Monitor from the main menu.

Step 2 Select the plant to be deleted in the navigation tree on the left.

Step 3 Click .

A confirmation dialog box containing the message Are you sure you want to delete? is
displayed.

NOTE

A plant can be deleted only when no device exists under it. Otherwise,  is dimmed.
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Step 4 Click Yes.

A dialog box containing the message Deletion succeeded is displayed.

Step 5 Click OK.

----End

5.2.3 Managing Devices

5.2.3.1 Accessing the Inverter
This section describes how to enable the inverter to access the NetEco 1000S, helping manage
and monitor devices through the NetEco 1000S.

Prerequisites
l You have logged in to the NetEco 1000S client. For details, see 5.2.1.1 Logging In to

the NetEco 1000S.
l You have logged in as the system administrator or installer.
l The inverter to be accessed has accessed the NetEco 1000S in FE direct connection

mode.
l You have set the IP address of NetEco 1000S on the inverter. For detailed operations, see

Inverter User Manual.
l You have obtained the device SN and registration code.
l You have created the target plant. For detailed operations, see 5.2.2.2 Creating a PV

Plant.

Context
The TLS protocol is used for the NetEco 1000S to communicate with the inverter.

NOTICE
The TLS protocol provides the following three versions:
l TLS1.0: This version has security risks.
l TLS1.1: This version is secure.
l TLS1.2: This version is secure.
In order to be compatible with the low version of the device, the NetEco 1000S supports all of
the preceding protocol versions by default. TLS1.0 has security risks. For security purposes,
you are advised to use TLS1.1 or TLS1.2.
The inverter may not support TLS1.1/1.2. You are advised to replace the inverter with the one
supporting TLS1.1/1.2 or upgrade the inverter to the version supporting TLS1.1/1.2.

Procedure
l If the inverter has accessed the NetEco 1000S, perform the following operations to

add the inverter to the plant:
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NOTE

This operation requires that the current user is the system administrator.

Step 1 Choose Maintenance> Device Access from the main menu.

Step 2 In the Device Access page, select the target inverter and click Add to PV plant.

NOTE

The inverter and NetEco 1000S are connected through password authentication. Authentication
Statusmay be any of the following values:

l Successful: indicates that the authentication passwords on both sides are the same. Then, perform
Step 3.

l Failed: You can perform the following operations to reconfigure the authentication password:
1. Click Set Authentication Password.
2. Enter the authentication password same as the inverter side and click OK.

The authentication passwords on the inverter and NetEco 1000S sides are /EzFp+2%r6@IxSCv
by default.
You are advised to change the password every three months. For details, see 5.2.3.7 Changing
the Authentication Passwords of the SUN2000L inverter and NetEco 1000S.

3. Click Refresh on the Device Access page. When Authentication Status changes to Successful,
perform Step 3.

l Not authenticated: perform Step 3.
– Not authenticated: It indicates the current version of inverter is too early and does not support

authentication. When you perform the next step, a security risk may occur. To ensure
connection security, you are advised to upgrade inverter to a version supporting authentication.

– The NetEco 1000S allows you to set whether to allow the access of the inverter that does not
support authentication. For details, see 5.2.6.4.3 Setting Communication Parameters.

Step 3 On the Select Power Station page, select the target plant and click OK.

Step 4 Click OK in the Confirm dialog box.

Step 5 View operation results.

1. Choose Monitor from the main menu.
2. Select the target PV plant and expand to view the added inverter and devices mounted

under it.

----End

l If the inverter does not access the NetEco 1000S, perform the following operations
to add the inverter to the plant:

NOTE

This operation requires that the current user is the system administrator or installer.

Step 1 Choose Monitor from the main menu.

Step 2 Select the target plant in the navigation tree on the left.

Step 3 Click the Add Device tab in the operation display area, and then click Add Device button.

Step 4 Enter the SN, registration code, and total string capacity (optional) of the inverter, and click
OK.

When the inverter added to the PV plant accesses the NetEco 1000S, the following prompt is
displayed in the lower right corner of the NetEco 1000S.
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Figure 5-85 Device access prompt

Step 5 Click Refresh in Figure 5-85 or re-select the target PV plant in the navigation tree on the left
to view the added inverter.

----End

5.2.3.2 Browsing the Details About a Device

On the Monitor tab page of the NetEco 1000S client, you can view the information about the
inverter and optimizer. This section describes how to browse the details about a device to
learn about its running status, such as the basic information and real-time performance data.

Prerequisites
l You have logged in to the NetEco 1000S client. For details, see 5.2.1.1 Logging In to

the NetEco 1000S.

l You have logged in as the system administrator or installer.

l You have added a device to the NetEco 1000S and the device state is normal. For
detailed operations, see 5.2.3.1 Accessing the Inverter.

Procedure

Step 1 Choose Monitor from the main menu.

Step 2 Choose the target device in the navigation tree on the left.

Step 3 Click the Details tab in the operation display area.

Basic information and real-time performance data of the selected device is displayed on the
Details tab page.

----End

Follow-up Procedure

System administrator and installers can also perform the following operations on the device
Details tab page:

NOTE

There is no Start/Stop real-time monitoring button on the Details tab page of optimizer.
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Operation Steps

Start the real-time data collection
task
NOTE

You can start the real-time data

collection task when its status is .

Click .

Stop the real-time data collection
task
NOTE

You can stop the real-time data

collection task when its status is .

Click .

 

5.2.3.3 Browsing Alarm Information About a Device

This section describes how to browse alarm information about an inverter to learn about the
current alarms for the device.

Prerequisites
l You have logged in to the NetEco 1000S client. For details, see 5.2.1.1 Logging In to

the NetEco 1000S.
l You have logged in as the system administrator or installer.
l You have added a device to the NetEco 1000S and the device state is normal. For

detailed operations, see 5.2.3.1 Accessing the Inverter.

Procedure

Step 1 Choose Monitor from the main menu.

Step 2 Choose the target device in the navigation tree on the left.

Step 3 Click the Alarm tab in the operation display area.

The information about all the current alarms of the target device is displayed in the Alarm tab
page. Figure 5-86 shows the information about all the current alarms of an inverter.

Figure 5-86 The information about all the current alarms of the target device

Step 4 Optional: Click an alarm name in the Alarm Name column to view the details.

NOTE

Alarms that have not been browsed are highlighted in bold.
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Step 5 Optional: Click Export to export the queried alarm information into a CSV file.

----End

Follow-up Procedure

Click Lock. Alarms are no longer automatically updated on the Alarm page. In this way, you
can view the alarms reported only before the lock. To enable the automatic update function
again and view newly reported alarms, click Scroll Unlock.

NOTE

If excessive alarms are generated, these alarms are displayed on multiple pages. In this case, pages
except the first one are locked and the Scroll Unlock button is unavailable for you to unlock those
pages.

By default, the alarm lock function on the Alarm page is disabled.

5.2.3.4 Modifying the Information About a Device

On the Monitor tab page of the NetEco 1000S client, you can configure the information
about the inverter and optimizer.

Prerequisites
l You have logged in to the NetEco 1000S client. For details, see 5.2.1.1 Logging In to

the NetEco 1000S.

l You have logged in as the system administrator or installer.

l You have added a device to the NetEco 1000S and the device state is normal. For
detailed operations, see 5.2.3.1 Accessing the Inverter.

Procedure

Step 1 Choose Monitor from the main menu.

Step 2 Choose the target device in the navigation tree on the left.

Step 3 Click the Settings tab in the operation display area.

Device information about the selected device is displayed on the Settings tab page.

Step 4 Modify configuration information about the selected device by referring to Table 5-47.

Table 5-47 Modifying device configuration information

Device
Type

If You Need
To...

Then...

Inverter Synchronize the
parameter
values of the
inverter to the
NetEco 1000S

Click Synchronize on the page for the parameter values
to be synchronized.
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Device
Type

If You Need
To...

Then...

Change the
name and
description of an
Inverter

1. Choose the Device Information tab.
2. Enter the new name and description in the

corresponding text boxes.
3. Click Save in the upper right corner of the Device

Information page.
After the device name and description are changed, the
device name is delivered to the device.

Change the total
string capacity
of inverters

1. Choose the Device Information tab.
2. Enter the target value in the Total string capacity text

box.
NOTE

Click Batch Apply if you need to apply the configured value
of Total string capacity to multiple inverters. Then select the
target devices in the displayed dialog box and click OK.

3. Click Save in the upper right corner of the Device
Information page.

Set string
parameters of an
inverter

1. Choose the Device Information tab.
2. Click String Details Setup.

The String Details Setup page is displayed.
3. Select the strings to be configured in the String Setup

area.
4. Set parameters for the strings in the Panel Setup area.
5. Click OK to save the settings.
NOTE

If you need to apply the string configurations to multiple
inverters, click Batch Apply. Then select the target devices in
the displayed dialog box and click OK.
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Device
Type

If You Need
To...

Then...

Modify the
power grid
parameters,
protection
parameters,
feature
parameters, or
power
adjustment
parameters

The methods for changing power grid parameters,
protection parameters, feature parameters, or power
adjustment parameters are similar. The following
describes how to change the power grid parameters.
1. Choose the Grid Parameters tab.
2. Set the parameters as required.

NOTE
For details about the parameters, see User Manual on the
monitored device side.

3. Select the parameters to be modified.
4. Click Submit.

After Submitted successfully is displayed in the
Information column, the specified parameter is
delivered to the device side.

NOTE
If you need to apply the configurations to multiple inverters,
click Batch settings. Then select the target devices in the
displayed dialog box and click OK.

Correct the total
energy yield of
the inverter

1. Choose the Adjust Total Energy Yield tab.
2. Set the value of the total energy yield as required.
3. Select the parameters to be modified.
4. Click Submit.

After Submitted successfully is displayed in the
Information column, the specified parameter is
delivered to the device side.

NOTE
If you need to apply the configurations to multiple inverters,
click Batch settings. Then select the target devices in the
displayed dialog box and click OK.

Optimizer Change the
name and
description of an
Optimizer

1. Click Refresh in the upper right corner of the page.
The latest parameter values will be displayed on the
NetEco 1000S for the Optimizer.

2. Enter the new name and description in the
corresponding text boxes.

3. Click Save in the upper right corner of the Settings
page.

 

----End

5.2.3.5 Deleting Devices
This section describes how to delete devices that have been connected to the NetEco 1000S
and that do not need to be managed or have been damaged from the NetEco 1000S.
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Prerequisites
l You have logged in to the NetEco 1000S client. For details, see 5.2.1.1 Logging In to

the NetEco 1000S.
l You have logged in as the system administrator or installer.
l You have added a device to the NetEco 1000S and the device state is normal. For

detailed operations, see 5.2.3.1 Accessing the Inverter.

Procedure
l Delete devices connecting to the plant:

Step 1 Choose Monitor from the main menu.

Step 2 Click  in the upper part of the navigation tree.

Step 3 In the displayed Delete Device window, select the target devices and click OK.

Step 4 Click Yes in the Warning dialog box.

The Deletion succeeded dialog box is displayed.

Step 5 Click OK.

----End

l Delete devices that have been connected to the NetEco 1000S but are not connected
to a specific plant:

NOTE

This operation requires that the current user is the system administrator.

Step 1 Choose Maintenance > Device Access from the main menu.

Step 2 In the displayed Device Access page, select the check box corresponding to the inverter you
want to delete and click Delete.

Step 3 Click Yes in the Warning dialog box.

The Deletion succeeded dialog box is displayed.

Step 4 Click OK.

----End

5.2.3.6 Remotely Controlling an Inverter
This section describes how to control an inverter that has been connected to the NetEco
1000S, including powering on and off the inverter, and restarting the inverter.

Prerequisites
l You have logged in to the NetEco 1000S client. For details, see 5.2.1.1 Logging In to

the NetEco 1000S.
l You have logged in as the system administrator or installer.
l You have added a device to the NetEco 1000S and the device state is normal. For

detailed operations, see 5.2.3.1 Accessing the Inverter.
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Procedure
l Control one inverter:

a. Choose Monitor from the main menu.
b. Select the target inverter in the navigation tree on the left.
c. Click the Details tab in the operation display area.

The page for inverter details is displayed.
d. Issue the control commands to the inverter according to Table 5-48.

Table 5-48 Controlling one inverter

If You Need To... Then...

Power on the inverter
Click .

Power off the inverter
Click .

Restart the inverter
Click .

 
l Power on or off all inverters in the same plant in batches:

a. Choose Monitor from the main menu.
b. Select the target plant in the navigation tree on the left.
c. Click the Settings tab in the operation display area.

The page for setting the plant is displayed.
d. Issue the control commands to all inverters in the current plant according to Table

5-49.

Table 5-49 Controlling inverters in batches

If You Need To... Then...

Power on all inverters
Click .

Power off all inverters
Click .

 

5.2.3.7 Changing the Authentication Passwords of the SUN2000L inverter and
NetEco 1000S

The SUN2000L inverter and NetEco 1000S are connected through password authentication.
To ensure connection security, you are advised to change the authentication passwords of the
inverter and NetEco 1000S periodically (for example, every three months).

Prerequisites
l You have logged in to the NetEco 1000S client. For details, see 5.2.1.1 Logging In to

the NetEco 1000S.
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l You have logged in as the system administrator or installer.

l You have added a device to the NetEco 1000S and the device state is normal. For
detailed operations, see 5.2.3.1 Accessing the Inverter.

Context
l The authentication passwords on the inverter and NetEco 1000S sides are /EzFp

+2%r6@IxSCv by default.

l The password must comply with the following rules:

The password cannot be the same as the account name.

The password contains 16 characters, and it must contain four of the following:

– Lowercase letters

– Uppercase letters

– Digits

– special characters

Procedure

Step 1 Choose Monitor from the main menu.

Step 2 Select the target plant in the navigation tree on the left.

Step 3 Click the Add Device tab in the operation display area, and then click  in the Operation
column of the SN.

The Set Device Authentication Password dialog box is displayed.

Step 4 On the Set Device Authentication Password page, use the following methods to change the
authentication password:

l If you want to change the authentication passwords on the inverter and NetEco 1000S
sides at the same time to ensure connection security:

Select Issue new authentication password to device, reset Password and Confirm
Password, and click OK.

l If the connection between the inverter and NetEco 1000S fails due to authentication
password inconsistency, and if you only need to change the authentication password on
the NetEco 1000S side:

Deselect Issue new authentication password to device, enter the password same as the
inverter side, and click OK.

----End

5.2.4 Historical Data Query

5.2.4.1 Querying Alarm Logs

This section describes how to query alarm logs on the NetEco 1000S. You can set query
criteria to obtain the required alarm logs.
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Prerequisites
l You have logged in to the NetEco 1000S client. For details, see 5.2.1.1 Logging In to

the NetEco 1000S.

l You have logged in as the system administrator or installer.

Procedure

Step 1 Choose Historical Data > Alarm Log from the main menu.

Step 2 Choose an target device to be queried in the navigation tree on the left.

Step 3 Set query conditions in the operation display area, and then click Query.

All the alarm records that meet the query conditions are displayed in one or more pages, as
shown in Figure 5-87.

Figure 5-87 Alarm Log

Clearance Type includes Automatic clear, NetEco recovery and Cleared by the system.

Alarms corresponding to different clearance types are as follows:

l Clearance Type: The value of Clearance Type for an automatically cleared alarm on
the device side is Automatic clear.

l Cleared by the system: When devices reports active alarms to the NetEco 1000S again
after reporting 30,000 active alarms to the NetEco 1000S, the NetEco 1000S
automatically clears the earliest 1000 alarms and Clearance Type of these cleared
alarms is Cleared by the system.

l NetEco recovery: After you enable the automatic active alarm synchronization function,
the NetEco 1000S automatically compares alarms reported from the device side with
alarms cached in the NetEco 1000S. When an alarm is different from the cached alarm,
the NetEco 1000S clears this alarm and considers it as the historical alarm, that is, alarm
of the NetEco recovery type.

NOTE

Alarms of the NetEco recovery type can be queried only when you enable the automatic active
alarm synchronization function. The function enabling and disabling methods are as follows:

– Enable the function: Navigate to the NetEco 1000S software installation path\WebRoot
\WEB-INF\classes directory and change the value of isAutoActiveAlarm in the
struts.properties file to 1. Then, restart the NetEco 1000S services.

– Disable the function: Change the value of isAutoActiveAlarm in the struts.properties file to
0 and restart the NetEco 1000S services.

– Set the synchronization start time: Modify activeCurrentAlarm_Time in the
struts.properties file and restart the NetEco 1000S services.

The default value of activeCurrentAlarm_Time is 23:00 on the NetEco 1000S, indicating
that active alarms are synchronized at 23:00 everyday.

The automatic active alarm synchronization function is enabled on the NetEco 1000S by default.
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Step 4 Optional: Click Export to export the queried alarm records into a CSV file.

----End

5.2.4.2 Querying Performance Data
This section describes how to query performance data on the NetEco 1000S.

5.2.4.2.1 Querying the Performance Data of the PV System

This section describes how to query the performance data of the PV System. You can set
query criteria to obtain the required performance data.

Prerequisites
l You have logged in to the NetEco 1000S client. For details, see 5.2.1.1 Logging In to

the NetEco 1000S.
l You have logged in as the system administrator or installer.

Procedure

Step 1 Choose Historical Data > Performance Data from the main menu.

Step 2 Choose the PV System to be queried in the navigation tree on the left.

Step 3 Set search criteria and click Query in the operation display area. The window shown in
Figure 5-88 is displayed.

NOTE

You can set search criteria to query performance data by Day, Month, Year, or Total.

l You can view the accumulated power of all PV plants in the PV system in the PV
System Power Statistics line chart.

l You can view power of five PV plants in the PV Plant Power Statistics line chart by
default. To view the power of a specific PV plant, click Select PV Plants to select the
target PV plant.

NOTE

When you query performance data by Day, queried data is displayed based on the following rules:

l Within one month: The line chart displays 5-minute data.

l Greater than one month and less than three years: The line chart displays 15-minute data.
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Figure 5-88 Power statistics line chart

Step 4 Optional: To export queried data to the PC for viewing, click Export and save the file to the
PC.

NOTICE
When a third-party editing tool is used to open the exported file, the tool should support
UCS-2 Decoding Mode. Otherwise, data cannot be decoded.

----End

5.2.4.2.2 Querying the Performance Data of a PV Plant

This section describes how to query the performance data of a plant. You can set query
criteria to obtain the required performance data.

Prerequisites
l You have logged in to the NetEco 1000S client. For details, see 5.2.1.1 Logging In to

the NetEco 1000S.
l You have logged in as the system administrator or installer.

Procedure

Step 1 Choose Historical Data > Performance Data from the main menu.

Step 2 Choose a plant to be queried in the navigation tree on the left.

Step 3 Set query conditions according to the following table and click Query in the operation display
area.
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Table 5-50 Setting query conditions

Query Conditions Queried Data

Select Day and set the query
date.

l The PV Plant Power Statistics line chart displays
power of the selected PV plant.

l The Inverter Power Statistics in PV Plant line
chart displays power of five inverters in the selected
PV plant by default. To view power of a specific
inverter, click Select Inverters to select the target
inverter.

1. Select Month, Year, or Total,
and set the query month or
query year separately.

2. Select the query counter
Energy Yield, Specific
Energy.

l Statistics about energy yields of PV plants and
inverters

l Specific energy of PV plants and inverters
NOTE

If the value of Specific energy cannot be queried, total string
capacity may not be configured for inverters. To solve this
problem, perform the following operations:

1. Configure total string capacity for the target inverter. For
details, see 5.2.3.4 Modifying the Information About a
Device.

2. Re-collect historical data of the latest 30 days for the
target inverter. For details, see 5.2.4.3 Synchronizing
Historical Performance Data.

3. Query the value of Specific energy again.

 

Step 4 Optional: To export queried data to the PC for viewing, click Export and save the file to the
PC.

NOTICE
When a third-party editing tool is used to open the exported file, the tool should support
UCS-2 Decoding Mode. Otherwise, data cannot be decoded.

----End

5.2.4.2.3 Querying the Performance Data of a Device

This section describes how to query the performance data of a device. You can set query
criteria to obtain the required performance data. The devices whose data can be queried
include the inverter and optimizer.

Prerequisites
l You have logged in to the NetEco 1000S client. For details, see 5.2.1.1 Logging In to

the NetEco 1000S.

l You have logged in as the system administrator or installer.
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Procedure

Step 1 Choose Historical Data > Performance Data from the main menu.

Step 2 Choose a device to be queried in the navigation tree on the left.

Step 3 Set query conditions in the operation display area, and then click Query.

All qualified performance data is displayed on one or more pages. Figure 5-89 shows the
inverter performance data.

Figure 5-89 Querying the performance data of a device

Step 4 Optional: To export queried data to the PC for viewing, click Export and save the file to the
PC.

NOTICE
When a third-party editing tool is used to open the exported file, the tool should support
UCS-2 Decoding Mode. Otherwise, data cannot be decoded.

----End

Follow-up Procedure

You can also perform the following operations on the Querying the performance data of a
device page:

Operation Steps Description

Display
performance
data in a line
chart

In the operation display area, click
Graph.

Display the queried performance
data in a line chart.

Set the
vertical
coordinate of
the line chart

1. Click .
The Select Counters dialog box
is displayed.

2. Enter the values for the Y1 and
Y2 coordinates.
NOTE

The preceding two values must be
different.

3. Click OK.

View the performance data based
on different performance counters
in the line chart by setting the
vertical coordinate.
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Operation Steps Description

Display
daylight
saving time
(DST)

Select Show DST. After DST starts, DST marks are
displayed behind each time in the
Generated On column.
For example, 2013-09-17 09:40:00
DST.

 

5.2.4.3 Synchronizing Historical Performance Data

This section describes how to synchronize historical performance data from a device to the
NetEco 1000S by creating a synchronization task on the NetEco 1000S. This solves the
problem that historical performance data cannot be automatically synchronized to the NetEco
1000S after the device is disconnected from the NetEco 1000S for more than 6 hours.

Prerequisites
l You have logged in to the NetEco 1000S client. For details, see 5.2.1.1 Logging In to

the NetEco 1000S.
l You have logged in as the system administrator or installer.
l You have added a device to the NetEco 1000S and the device state is normal. For

detailed operations, see 5.2.3.1 Accessing the Inverter.

Context
l If the SUN2000L inverter is connected to the NetEco 1000S for the first time, and if it

has been running before the connection and stores performance files, you can start the
historical performance data synchronization task to synchronize historical performance
data of the inverter before it is connected to the NetEco 1000S to the NetEco 1000S. The
inverter SUN2000L saves historical performance data of the latest one year.

l If the optimizer connected to the SUN2000L inverter is connected to the NetEco 1000S,
has been running before the connection, and stores performance files, you can start a
historical performance data synchronization task to synchronize historical performance
data of the device before it is connected to the NetEco 1000S to the NetEco 1000S. The
optimizer saves historical performance data of the latest two days.

l The synchronization on the NetEco 1000S succeeds only when the SUN2000L inverter
or the optimizer connected to the SUN2000L inverter stores historical performance data
that needs to be synchronized.

NOTICE
When historical performance data is being synchronized on the device, if you create another
synchronization task for the device, the creation fails.

Procedure
l Synchronize historical performance data of the SUN2000L inverter.
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Step 1 Choose Historical Data > Synchronize Historical Data from the main menu.

The Synchronize Historical Data page is displayed, as shown in Figure 5-90.

Figure 5-90 Synchronizing historical data

Step 2 On the Data Synchronization page, click Create Synchronization Task.

The Create Synchronization Task dialog box is displayed, as shown in Figure 5-91.

Figure 5-91 Creating a synchronization task

Step 3 Choose a device for which you want to create a supplementary collection task from the device
navigation tree.

NOTE

By clicking the drop-down box in Figure 5-91, you can quickly filter device type.

Step 4 Set the time range as required.

The time range can be set to Today, Last three Days, Last seven Days, Last thirty Days, or
Customize.

NOTE

The time range of the Customize cannot exceed 30 days.

Step 5 Click OK.

The supplementary collection task is performed automatically after the task is created.

----End

l Synchronize historical performance data of the optimizer connected to the SUN2000L
inverter.
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Step 1 Choose Historical Data > Synchronize Historical Data from the main menu.

The Synchronize Historical Data page is displayed, as shown in Figure 5-92.

Figure 5-92 Synchronizing historical data

Step 2 Select Optimizer Data Synchronization tab, and click Create Synchronization Task.

The Create Synchronization Task dialog box is displayed, as shown in Figure 5-93.

Figure 5-93 Creating a optimizer synchronization task

Step 3 Choose a device for which you want to create a supplementary collection task from the device
navigation tree.

Step 4 Set the time range as required.

The time range can be set to Today, Last three Days, Last seven Days, or Customize.

NOTE

The time range of the Customize cannot exceed 7 days.

Step 5 Click OK.

The supplementary collection task is performed automatically after the task is created.

----End

Follow-up Procedure

If the supplementary collection task fails to be executed, click  to execute the task again.

You can click to stop a synchronization task.
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5.2.5 Device Maintenance

5.2.5.1 Upgrading a Device

This section describes how to upload a software package and remotely upgrade a device
through the NetEco 1000S.

Prerequisites
l You have logged in to the NetEco 1000S client. For details, see 5.2.1.1 Logging In to

the NetEco 1000S.
l You have logged in as system administrator.
l You have added a device to the NetEco 1000S and the device state is normal. For

detailed operations, see 5.2.3.1 Accessing the Inverter.
l You have contacted Huawei technical support engineers to obtain the software package

required for device upgrade and have checked the integrity of the software package.

Procedure

Step 1 Choose Maintenance > Software Management from the main menu.

Step 2 Click the Device Upgrade Management or Optimizer Upgrade Management tab.

NOTE

l To upgrade the inverter, you can perform related operations on the Device Upgrade Management
tab page.

l To upgrade the optimizer connected to the SUN2000L inverter, you can perform related operations
on the Optimizer Upgrade Management tab page.

Step 3 Upload the device software package to be upgraded.

1. Click Software Package Management.
2. Click Upload on the Software Package Management page.
3. Click Browser to select the software package, and then click Upload.

After the upload is complete, information about the new software package is displayed in
the software package list.

NOTE

To delete the uploaded software package, select the software version in the software package list
and click Delete.

4. Click Close.

Step 4 Upgrade the software package of the device.

1. Select the devices to be upgraded in the device list.

NOTE

You can filter out the list of target devices by device name or plant name.

2. Click Select Version.
The Select Target Version dialog box is displayed, showing all upgrade software
packages for the device type.
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NOTE

– If the selected target device is an inverter, the Select Target Version dialog box shows the
software packages applicable to the protocol version of the selected inverter.

– If the selected target device is an optimizer, the Select Target Version dialog box shows the
software packages applicable to the protocol version of the selected optimizer.

3. Select the target version in the Select Target Version window and click OK.

4. Click Upgrade above the device list.

The upgrade progress is displayed in the Upgrade Progress column of the device list.

When you upgrade multiple devices at the same time on the Device Upgrade
Management tab, you can click Stop Upgrade to stop the upgrade task whose Current
Status is Waiting.

Click Details under Current Status. Details about the inverter upgrade are displayed, as
shown in Figure 5-94.

Figure 5-94 Inverter upgrade details

NOTE

When Loading completed. is displayed, the NetEco automatically activates the inverter, and The
inverter is going to activate automatically is displayed. If the device does not meet activation
requirements, the NetEco automatically activates the device after activation requirements are met. After
the device is activated successfully, the NetEco displays the latest device version.

----End

5.2.5.2 Obtaining Device Logs

This section describes how to obtain device logs for device analysis and maintenance.

Prerequisites
l You have logged in to the NetEco 1000S client. For details, see 5.2.1.1 Logging In to

the NetEco 1000S.

l You have logged in as the system administrator or installer.

l You have added a device to the NetEco 1000S and the device state is normal. For
detailed operations, see 5.2.3.1 Accessing the Inverter.

Context

Remotely obtaining device logs applies inverters, optimizer.
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Procedure

Step 1 Choose Maintenance > Device Maintenance from the main menu.

Step 2 Click the Device Log, or Optimizer Log tab.

The Device Log, or Optimizer Log window is displayed.

NOTE

l To obtain optimizer logs, you can perform related operations on the Optimizer Log tab page.
l To obtain logs of inverter, you can perform related operations on the Device Log tab page.

Step 3 Select a device in the device list, and click Obtain.

When Finish is displayed in the Execution Status column, device logs are synchronized to
the NetEco 1000S.

NOTE

l You can filter out the list of target devices by device name or plant name.

l You can click  in the Operation column to stop obtaining device logs.

Step 4 Click Download the log or  in the Log File column to download the device log file to the
local PC.

----End

5.2.5.3 Obtaining the Inverter Patrol Report
This section describes how to obtain the inverter patrol report to help technical support
engineers learn the running counter values and state of health (SOH) of inverters and to
provide reference for device maintenance and exception location.

Prerequisites
l You have logged in to the NetEco 1000S client. For details, see 5.2.1.1 Logging In to

the NetEco 1000S.
l You have logged in as the system administrator or installer.
l You have added a device to the NetEco 1000S and the device state is normal. For

detailed operations, see 5.2.3.1 Accessing the Inverter.

Procedure

Step 1 Choose Maintenance > Device Maintenance from the main menu.

Step 2 Click the Inverter Patrol tab.

The Inverter Patrol tab page is displayed.

NOTE

You can filter out the list of target devices by device name or plant name.

Step 3 Start the inverter patrol.

1. Select the target inverter in the device list and click Start Patrolling or  in the
Operation column.
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2. When the following information is displayed, click OK:
Are you sure you want to execute the task

NOTE

You can click Stop Patrolling above the device list to stop the patrol task.

Step 4 Obtain the inverter patrol report.

1. Select the target inverter for which a patrol report has been generated and click Batch
Download Report.
A message asking you whether to open or save data is displayed at the bottom of the
browser.

2. Click Download the report or  in the Patrol report colum to download the patrol
report to the local PC.

----End

5.2.5.4 Managing Device List
User can view and export the device version, SN, and communication address on the Device
Management page, as well as modify device names in batches.

Prerequisites
l You have logged in to the NetEco 1000S client. For details, see 5.2.1.1 Logging In to

the NetEco 1000S.
l You have logged in as the system administrator or installer.
l You have added a device to the NetEco 1000S and the device state is normal. For

detailed operations, see 5.2.3.1 Accessing the Inverter.

NOTE

An installer can only view and export the device information about the plants to which the user has
access, and batch modify device names for the plants to which the user has access.

Procedure

Step 1 Choose Maintenance > Device Maintenance from the main menu.

Step 2 Click the Device Management tab.

The Device Management window is displayed.

Step 3 Set Device name, Version No., SN, PV plant name or Device type, and click Query.

Target devices meeting the preset condition are filtered out.

Step 4 Click Export.

You can export information about devices displayed on the page.

To modify device names in batches, go to the next step.

Step 5 Change Device Name in the exported .xls file, and save the file.

Step 6 In the Device Management window, click Import Names.

The Import Names dialog box is displayed.

iManager NetEco 1000S
User Manual 5 Operation and Maintenance

Issue Draft C (2017-12-14) Huawei Proprietary and Confidential
Copyright © Huawei Technologies Co., Ltd.

235



Step 7 Click Browse, and select the .xls file saved in Step 5.

NOTICE
Only .xls files can be imported. The file size must be less than 2 MB. The file must contain
the Device Name and SN columns, and the columns must not be empty.

Step 8 Click Execution.

NOTICE
During the Execution, the modification task will be stopped if you close the Import Names
dialog box.

During the Execution, you can click Stop to stop unfinished modification task.

If modifying device names fails, Details in Import Names will provide the device whose
name fails to be modified and the failure cause.

Step 9 Click Close.

----End

5.2.5.5 Replacing a Device
This section describes how to replace a device. If the device connecting to the NetEco 1000S
needs to be replaced due to a fault or aging, you can replace it with a new one. Devices
supporting the replacement include the inverter, optimizer.

Prerequisites
l You have logged in to the NetEco 1000S client. For details, see 5.2.1.1 Logging In to

the NetEco 1000S.
l You have logged in as the system administrator or installer.
l You have added a device to the NetEco 1000S and the device state is normal. For

detailed operations, see 5.2.3.1 Accessing the Inverter.
l The old device has been deleted or is disconnected from the NetEco 1000S.
l The new device and the old device are connected to the same PV Plant.

Procedure

Step 1 Choose Maintenance > Device Maintenance from the main menu.

Step 2 Click the Device Maintenance tab.

The Device Management page is displayed.

Step 3 Click Replace Device.

The Replace Device dialog box is displayed.
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Step 4 Select a device type, and enter the Old device SN, New device SN and Device name. Then
click OK.

NOTE

Device name specified here is the name of the new device to be displayed in the NetEco 1000S. Device
name must be different from the names of the existing devices in the same PV plant.

If you attempt to replace an optimizer, and the old and new devices are not connected to the
same inverter, the following message is displayed.
Devices not connected to same inverter. Continue?

Step 5 Click OK, and complete the device replacement as prompted.

NOTE

If you want to cancel the replacement, click Cancel.

----End

5.2.5.6 Querying NetEco Alarms

If the NetEco 1000S certificate has expired, the license has expired, or remote notification
emails fail to be sent, the NetEco 1000S will generate a corresponding NetEco alarm. You can
query NetEco alarms to learn the NetEco alarm information for the NetEco 1000S and handle
alarms accordingly.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.2.1.1

Logging In to the NetEco 1000S.
l You have logged in as system administrator.

Context

Check the NetEco alarm icon in the upper right of the home page of the NetEco 1000S client
to determine whether a NetEco alarm exists. If a NetEco alarm exists, view the detailed alarm
information on the NetEco Alarm page.

l : A NetEco alarm is generated on the NetEco 1000S.

l : No NetEco alarm is generated on the NetEco 1000S.

Procedure

Step 1 On the home page of the NetEco 1000S client, click the NetEco alarm icon .

The NetEco Alarm page is displayed.

Step 2 Set Time and Clear Status, and click Query.

NetEco alarms that meet the conditions can be queried.

Step 3 Click Alarm Name for a NetEco alarm record to view the detailed alarm information and
troubleshooting advice.

NOTE

NetEco alarms whose details are not queried will be highlighted in bold.
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Step 4 Optional: Click Export to export the queried alarm information into a CSV file.

----End

5.2.5.7 Obtaining NetEco Logs

This section describes how to obtain NetEco logs. The logs help you learn the operating status
of the NetEco 1000S and locate problems when the NetEco 1000S is not running properly.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.2.1.1

Logging In to the NetEco 1000S.

l You have logged in as system administrator.

Context

The NetEco records run logs automatically every day. When the system becomes abnormal,
the system administrator quickly obtains the corresponding logs through the client to locate
the problem.

Procedure

Step 1 Choose Maintenance > NetEco Maintenance from the main menu.

The NetEco Maintenance page is displayed.

Step 2 Obtain the trace log.

The trace log records the system run log. When the system becomes abnormal, you can obtain
the trace log to locate the problem.

1. Click the Trace Log tab.

2. Click Refresh. The latest log information is displayed.

3. Select the log to be obtained.

NOTE

You can enter the log name keyword, such as the date, in the File Name text box and click Search
to search for all logs whose names contain this keyword.

4. Click Download.

A message asking you whether to open or save the log is displayed at the bottom of the
browser. You can open or save the log as required.

Step 3 Obtain other logs.

Other logs record all logs except the trace log. These logs include database error logs,
configuration file modification logs, attack logs, FTP logs, and script logs. When problems
cannot be located using the trace log, you can obtain other logs to facilitate problem location.

1. Click the Other Logs tab.

2. Click Refresh. The latest log information is displayed.

3. Select the log to be obtained.
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NOTE

You can enter the log name keyword, such as the date, in the File Name text box and click Search
to search for all logs whose names contain this keyword.

4. Click Download.

A message asking you whether to open or save the log is displayed at the bottom of the
browser. You can open or save the log as required.

----End

5.2.6 System Management

5.2.6.1 Managing User Information

This section describes how to manage user information. The user management function
allows you to manage the information about and operation rights of users.

5.2.6.1.1 User Categories

This section describes user categories. You need to familiarize yourself with these user
categories before managing users.

Software users: system administrator, installers, and customers.

Third-party user: OpenAPI users.

Operation permissions vary by user. Table 5-51 lists the software users and their operation
permissions.

Table 5-51 User operation permissions

User Category Operation Permissions

System administrator
NOTE

l The system administrator
cannot be deleted or
modified.

l To improve system security,
you are advised to change
the initial keys set before
product delivery in a timely
manner and periodically (at
an interval of 3 months)
change the user key to
avoid security risks, such as
violent key cracking.

The system administrator has all the operation permissions,
including:
l PV plant management: creates, modifies, and deletes

PV plants; sets information of PV plants, and browses
information about PV plants, device lists, and current
alarms.

l Device management: manually and automatically
connects devices, searches, modifies, and deletes
devices, sets information of devices, browses
information about devices and current alarms.

l Historical data: queries alarm logs and performance
data, synchronizes historical performance data.

l Device maintenance: upgrades devices, replaces
devices, manages devices, patrol to the inverter, obtains
NetEco logs and device logs.

l System management: manages users, sets remote
notification, queries user logs, has license management,
and sets the system parameters.
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User Category Operation Permissions

Installers l PV plant management: creates, modifies, and deletes
PV plants, sets information of PV plants, and browses
information about PV plants, device lists, and current
alarms.

l Device management: automatically connects devices,
modifies and deletes devices, sets information of
devices, browses information about devices and current
alarms.

l Historical data: queries alarm logs and performance
data, synchronizes historical performance data.

l Device maintenance: patrol to the inverter, manages
devices, and obtains device logs.

l System management: manages users and sets remote
notification rules.

Customers You can visit the Overview page to query the overview of
the plant.

OpenAPI users
NOTE

l The OpenAPI users can
only be created by the
system administrator.

l The OpenAPI users do not
have permission to access
the NetEco 1000S or query
other user information in
the NetEco 1000S.

l For account security
purposes, you are advised to
change the user password
periodically (for example,
at an interval of 3 months)
to avoid security risks, such
as violent key cracking.
Only the system
administrator can reset the
password for OpenAPI
users.

You can access the data query interface to query the
following data:
l PV plant list;
l Device list (only inverter data included);
l Real-time monitoring data of a specific PV plant;
l Real-time monitoring data of a device under a specific

PV plant (only inverter data included);
l Yearly, monthly, and daily performance data of a

specific PV plant as well as its total performance data.

 

5.2.6.1.2 Adding a User

This section describes how to add a user on the NetEco 1000S. You can add users as required.
The operation permissions of users vary according to user categories.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.2.1.1

Logging In to the NetEco 1000S.
l You have logged in as a system administrator or installer.
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Procedure

Step 1 Choose System > User Management from the main menu.

The User Management window is displayed.

Step 2 Choose User from the menu bar on the left.

The User page is displayed, as shown in Figure 5-95.

Figure 5-95 User

NOTE

Installers can only see their own information and information about customers they have created.

Step 3 Click Create User.

The Create User window is displayed, as shown in Figure 5-96.

Figure 5-96 Create user

Step 4 Set the user parameters according to Table 5-52 and then click OK.
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Table 5-52 Parameter description

Parameter Description

User name Name of the new user.
The user name can only contain English characters (A to Z
and a to z), digits, hyphens, or underlines.
NOTE

The user name cannot be null or NULL.

l Installers can only create customers and bind PV Plant with
customers. After the login, customers can only manage PV Plants
bound with them.

l When the system administrator adds the permission of a device
for the customers created by the installer, the installer has no
permission of this device.

l When the system administrator cancels the permission of a device
managed by the installers, customers created by the installer still
have the permission of this device.

See 5.2.6.1.7 Setting an Account Policy to set the user name
length.

Password Password of the new user. The password must comply with
the following rules:
l The password cannot be the same as the user name or the

user name in a reversed order.
l The password contains 8 to 32 characters.
l The password contains three of the following:

– Lowercase letters
– Uppercase letters
– Digits

The password is advised to contain special characters, which
include !"#$%&'()*+,-./:;<=>?@[\]^`{_|}~ and space.
NOTE

The system administrator can set the password complexity policy on
the NetEco 1000S client. For details, see 5.2.6.1.8 Setting a
Password Policy.

Email address Email address of the user.

User type Type of the user. The type can be Installer, Customer, or
OpenAPI User.

User status Status of the user. The status includes:
l Disable: The user is disabled and cannot log in to the

NetEco 1000S.
l Enable: The user can log in to the NetEco 1000S.
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Parameter Description

Email password When the created user is customer, there will be this option.
The status includes:
l Yes: The customer will receive an email informing

customer of the login account and password.
l No: The customer will not receive an email informing

customer of the login account and password.

Description Description of the user.
The description cannot contain more than 255 characters.

Select a PV plant that can
be accessed

Permission for the user to access the PV plant.

 

The added user is displayed in the user list in the User Management window.

----End

5.2.6.1.3 Registering an Installer Yourself

You can register yourself as an installer on the NetEco 1000S as required.

Prerequisites
l You have obtained the device SN and registration code.
l The IP address of the NetEco 1000S has been registered with the inverter, and the

inverter has been successfully registered with the management system. For details about
how to configure the IP address of the NetEco 1000S on the inverter, see the inverter
user manual.

Procedure

Step 1 Enter the login page, as shown in Figure 5-97.

Figure 5-97 Login page
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Step 2 Click Register on Figure 5-97.

The Register page is displayed, as shown in Figure 5-98.

Figure 5-98 Registration

Step 3 Set the parameters by referring to Table 5-53, and click Register.

NOTE

Parameters marked with * in Figure 5-98 are required.

Table 5-53 Parameters

Item Description

User name Name of the new installer.
Only letters (A–Z, a–z), digits, hyphens, and underscores are allowed in
the installer name.
NOTE

The installer name cannot be null or NULL.

For the length of the user name, see 5.2.6.1.7 Setting an Account
Policy.
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Item Description

Password Password of the new user. The password rules are as follows:
l The password must be different from the user name or its reverse.
l The password must contain 8 to 32 characters.
l The password must contain three types of the following characters:

– Lowercase letters
– Uppercase letters
– Digits

l The password is advised to contain at least one special character.
Special characters include `~!@#$%^&*()-_=+\|[{}];:'",<.>/? and
spaces.

NOTE
The system administrator can set the password complexity policy on the NetEco
1000S client. For details, see 5.2.6.1.8 Setting a Password Policy.

Email address Email address you bound

Company Company you work at

SN SN of inverter

Registration
code

Registration code corresponding to the SN

Verification code Specify the verification code as prompted.

User
Authorization

You can view the Privacy Policy and and Terms of Use. You must
select Agree to the Privacy Policy and Agree to the Terms of Use for
successful registration.

 

The registered installer logs in to the NetEco 1000S client automatically. The NetEco 1000S
home page is displayed.

----End

5.2.6.1.4 Modifying User Information

This section describes how to modify user information. If information about a user needs to
changed, the password of the user is forgotten or the account is locked, you can modify
information about the user as an administrator or an installer.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.2.1.1

Logging In to the NetEco 1000S.
l You have logged in as a system administrator or installer.

Procedure

Step 1 Choose System > User Management from the main menu.
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The User Management window is displayed.

Step 2 Choose User from the menu bar on the left.

The User page is displayed, as shown in Figure 5-99.

Figure 5-99 User

NOTE

Installers can only see their own information and information about customers they have created.

Step 3 In the User page, you can do the following operations in Table 5-54.

NOTE

l The system administrator can manage all users.

l The installers can manage only users created by them.

Table 5-54 operations

Operations Description

Enable If the Use Status is invalid, you can click  to enable the account.

Disable If the Use Status is normal, you can click  to disable the account.

Unlock If the Use Status is lock, you can click  to unlock the account.

Edit Click  to modify the Email address, use status, description and
control permission of an account.
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Operations Description

Password reset When a user forgets the password for logging in to the NetEco 1000S,
the user can reset the password, and then use the new password to log
in to the NetEco 1000S.
NOTE

The password of the system administrator cannot be reset. Therefore, you have to
remember the password of this user.

l The password cannot be the same as the user name or the user name in a
reversed order.

l The password contains 8 to 32 characters.

l The password contains three of the following:

– Lowercase letters

– Uppercase letters

– Digits

l The password is advised to contain special characters, which include !"#$
%&'()*+,-./:;<=>?@[\]^`{_|}~ and space.

1. Click .
2. In the displayed window, set New password and Confirm

password.
3. Click OK.

Delete
Click . In the displayed window, click OK to delete the account.

 

----End

Other operations
In the User page, the description of all parameter is as shown in Table 5-55.

Table 5-55 Parameters

Parameter Description

User Name Displays names of all accounts in the system.

User Type Displays the type of an account. The type includes Administrator,
Installer, Customer, and OpenAPI User.

PV Plant Displays the PV plant(s) to which the user belongs

Email address Email address of the user.

SN Device SN which is entered while registering.

Description Displays the description of an account.
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Parameter Description

Use Status Displays the status of an account. The status includes:
l normal: indicates that the account is properly used.
l invalid: indicates that the account is currently not used.
l lock: indicates that the account is automatically locked by the

system after the user enters the incorrect password for multiple
times or disobeys the password policy.

 

5.2.6.1.5 Querying PV Plants to Which a User Belongs

This section describes how to query PV plants to which a user belongs. This helps learn the
PV plants that the user can operate and user information recorded in the PV plants, facilitating
the PV plant administrator's management operation.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.2.1.1

Logging In to the NetEco 1000S.
l You have logged in as a system administrator or installer.

Procedure

Step 1 Choose System > User Management from the main menu.

The User Management window is displayed.

Step 2 Choose User from the menu bar on the left.

The User page is displayed, as shown in Figure 5-100.

Figure 5-100 User

NOTE

Installers can only see their own information and information about customers they have created.

Step 3 Set search criteria.
l PV plant: Enter the name of the to-be-queried PV plant. You can enter names of

multiple PV plants and separate them by semicolon (;).
l User Name: Enter the to-be-queried user name.

NOTE

You can set PV plant or User Name as required.

Step 4 Click Query.

----End
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5.2.6.1.6 Modifying the Password of the Current User

This section describes how to modify the password of the current user. You are advised to
modify user password regularly to ensure system security.

Prerequisites

You have logged in to the NetEco 1000S client. For detailed operations, see 5.2.1.1 Logging
In to the NetEco 1000S.

Procedure

Step 1 Click from the main menu.

The Modify Password dialog box is displayed, as shown in Figure 5-101.

NOTICE
To improve system security, you are advised to change the initial keys set before product
delivery in a timely manner and periodically (at an interval of 3 months) change the user key
to avoid security risks, such as violent key cracking.

Figure 5-101 Modify Password

Step 2 Optional: The current user who is the system administrator or installer can change the
password in the following way.

1. Choose System > User Management from the main menu;
2. The User Management dialog box is displayed, Choose Modify Password from the

menu bar on the left,as shown in Figure 5-102;
3. Click Set in Figure 5-102, The Modify Password dialog box is displayed, as shown in

Figure 5-101.
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Figure 5-102 set

Step 3 Enter the Old password, New password and Confirm password.

NOTE

l The password cannot be the same as the user name or the user name in a reversed order.

l The password contains 8 to 32 characters.

l The password contains three of the following:

– Lowercase letters

– Uppercase letters

– Digits

l The password is advised to contain special characters, which include !"#$%&'()*+,-./:;<=>?
@[\]^`{_|}~ and space.

Step 4 Click OK.

----End

5.2.6.1.7 Setting an Account Policy

This topic describes how to set an account policy to improve access security of the NetEco.
The account policy settings include the length of the user name and the policies related to user
login.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.2.1.1

Logging In to the NetEco 1000S.

l You have logged in as system administrator.

Context
l The account policy applies to the following users after the account policy is successfully

set:

– New users.

– Users whose information is modified.

l Account policies apply to all accounts except system administrator.

l The NetEco provides the default account policy, and you can modify it as required.

The current login account will be locked if the number of consecutive failed login attempts
exceeds the preset value within a certain period. The locking policy is as follows:

l system administrator: The current login IP address will be locked. You can use another
IP address to log in to the NetEco 1000S.

l installers or customers: The current login account will be locked. For details about how
to unlock the account, see 5.2.6.1.4 Modifying User Information.
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Procedure

Step 1 Choose System > User Management from the main menu.

Step 2 In the navigation tree on the left, choose Account Policy.
l installers or customers:The current login account will be locked if the number of

consecutive failed login attempts exceeds the preset value within a certain period. For
details about how to unlock the account, see 5.2.6.1.4 Modifying User Information.

l system administrator: The current login IP address will be locked 5 minutes if the
number of consecutive failed login attempts more than 5 within 10 minutes.

NOTICE
Restart the service will make the lock failed, please use caution.

Step 3 On the Account Policy page, set the account policy as required.

When Account disabling policy is selected, this policy is applicable to all users except the
system administrator. If a user has not logged in for a consecutive period longer than the
period specified in The account has not been used for (consecutive days), the account will
be disabled.

To enable a disabled account, see 5.2.6.1.4 Modifying User Information and perform the
required operations.

Step 4 Click Apply.

----End
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5.2.6.1.8 Setting a Password Policy

You can set a password policy to improve access security of the NetEco. The password policy
settings include the user password complexity rules, password change interval, and character
restriction.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.2.1.1

Logging In to the NetEco 1000S.
l You have logged in as system administrator.

Context
l A password policy applies to all users once it is configured. After the minimum length of

the user password is specified and validated, if an online user wants to change the
password, the user needs to set the new password based on the specified minimum
password length requirements.

l You need to set a password based on the password policy when you create a user.
l A new password policy does not affect the configured password.
l The NetEco provides the default password policy, and you can modify it as required.

NOTICE
Disabling the functions of password strength policies and password change intervals will
lower account security. You are advised to enable all password security policies provided by
the NetEco.

Procedure
Step 1 Choose System > User Management from the main menu.

The User Management window is displayed. Choose Password Policy from the menu bar on
the left, as shown in Figure 5-103.

Figure 5-103 Password Policy
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Step 2 In the window shown in Figure 5-103, set Password Policy as required.

NOTE

When you change the passwords of other users as system administrator, the value of Enable account
lock policy has no impact on the change. That is, the password change interval is not limited when you
change the passwords of other users as system administrator.

Step 3 Click Apply.

----End

5.2.6.1.9 Managing the Online Users

You can view online user to find unauthorized login users and log out these users, which
prevents unauthorized operations performed on the NetEco 1000S client.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.2.1.1

Logging In to the NetEco 1000S.
l You have logged in as system administrator.

Procedure

Step 1 Choose System > User Management from the main menu.

Step 2 In the navigation tree on the left, choose View Online User.

Step 3 On the View Online User page, view online users, and their login time, login IP addresses,
and roles to which they belong. In addition, you can perform the following operations:

Task Procedure

Update online user information Click Refresh to update the online user
information.

Force a user to log out When viewing online users, you can force
an unauthorized user to log out. This
prevents the unauthorized user from
performing unauthorized operations on the
NetEco 1000S client.

1. On the View Online User page, click
in the Operation column where the
required user information is located.

2. In the Warning dialog box, click OK.
NOTE

You are advised to view the online users at
regular time, force the unauthorized users to log
out in time.

iManager NetEco 1000S
User Manual 5 Operation and Maintenance

Issue Draft C (2017-12-14) Huawei Proprietary and Confidential
Copyright © Huawei Technologies Co., Ltd.

253



Task Procedure

Enter Single session Mode Users can enter the single-session mode to
prevent the interference from other users'
operations.
1. Select Single session Mode.
2. In the Warning dialog box, click OK.
NOTE

l After entering the single-session mode, users
can log in to the NetEco 1000S only on one
terminal.

l After entering the single-session mode, the
logged-in users are not affected.

l Single-session is a safe mode, recommended
for use.

Exit Single session Mode 1. Deselect Single Session Mode .
2. In the Warning dialog box, click OK.
NOTE

After exiting the single-session mode, users can
re-log in to the NetEco 1000S on multiple
terminals.

 

----End

5.2.6.1.10 Setting the Idle Logout Time

This topic describes how to set the client to be logged out automatically. To prevent other
users from performing unauthorized operations, the NetEco 1000S allows you to set related
idle parameters. The client is automatically logged out after being left idle for a specified
period of time.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.2.1.1

Logging In to the NetEco 1000S.

l You have logged in as system administrator.

Context

This operation applies to the system administrator, installers, and customers. For OpenAPI
users, the idle logout time is 20 minutes and cannot be modified.

Procedure

Step 1 Choose System > User Management from the main menu.

Step 2 Choose Logout Time Setting on the left.

The Logout Time Setting page is displayed, as shown in Figure 5-104.
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Figure 5-104 Logout Time Setting

Step 3 Set the value of Logout time (minutes).

By default, NetEco 1000S enables the function of logging out users after timeout. To disable
this function, clear Logout Time Settings.

NOTE

The logout time ranges from 1 to 1440 minutes. Setting the logout time within 3 minutes is advised.

Step 4 Click Save.

----End

Follow-up Procedure

After the client is automatically logged out, the current user needs to log in to the NetEco
1000S again.

5.2.6.1.11 Setting an IP Access Control Policy

This section describes how to set an access control policy. In this way, users can only use the
specified IP address to log in to the NetEco, ensuring the access security of the NetEco.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.2.1.1

Logging In to the NetEco 1000S.

l You have logged in as system administrator.

Context

To ensure the access security of the NetEco, you are advised to set an access control policy.

Procedure

Step 1 Choose System > User Management from the main menu.
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The User Management window is displayed. Choose Client IP Address from the menu bar
on the left. In the displayed Client IP Address window, click Create, as shown in Figure
5-105.

Figure 5-105 Client IP Address

Step 2 Set Start IP address, End IP address, and Description for accessing the client and click
OK.

----End

5.2.6.1.12 Setting Login Time Control Policies

After the login time control policies are set, users other than system administrator can log in
to the NetEco 1000S only at the specified control time, which ensures NetEco 1000S access
security.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.2.1.1

Logging In to the NetEco 1000S.

l You have logged in as system administrator.

Context

If system administrator wants to control the time segment on which other users can access the
NetEco 1000S, login time control policies need to be set. After the login time control policies
are enabled, the following functions can be implemented:

l Users other than system administrator can log in to the NetEco 1000S only on the control
time segment.

l The logged-in user will be forcibly logged out if the valid access time expires.

Procedure

Step 1 Choose System > User Management > Login Time Control from the main menu

The Login Time Control page is displayed, as shown in Figure 5-106.
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Figure 5-106 Login Time Control

Step 2 Select Enable login time control.

Information shown in Figure 5-107 is displayed.

Figure 5-107 Login time control enabling prompt

Step 3 Set login time control policies according to Table 5-56.

Table 5-56 Setting login time control policies

Parameter Configuration Method

Start date Select the start date for the login from the drop-down list.

End date Select the end date for the login from the drop-down list.
The end date must be later than or equal to the start date.
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Parameter Configuration Method

Start time Select the start time for the login from the drop-down list.
Other users are allowed to access the NetEco 1000S since
the start time.

End time Select the end time for the login from the drop-down list.
Other users are not allowed to access the NetEco 1000S
after the end time.
The end time must be later than or equal to the start time.

Description (Optional) Enter the description information about the
login time control policy. A maximum of 255 characters
are allowed.

 

----End

5.2.6.1.13 Setting Access Control Policies for Mobile Terminals
This section describes how to set access control policies for mobile terminals. In this way,
users can log in to the NetEco only from the specified mobile terminal, ensuring the access
security of the NetEco.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.2.1.1

Logging In to the NetEco 1000S.
l You have logged in as system administrator.
l You have obtained the identification number of the mobile terminal.

NOTE

Identification number of the iOS mobile terminal is the IDFV identifier. Identification numbers of other
mobile terminals are IMEIs/MEIDs of mobile phones or MAC addresses of tablets.

Context
To ensure the access security of the NetEco, enable the access control policies for mobile
terminals is advised.

The identification number of the mobile terminal has been anonymized on the NetEco 1000S
WebUI to protect user's privacy.

Procedure
Step 1 Choose System > User Management from the main menu.

The User Management window is displayed. Choose Mobile Terminal Access Control
from the menu bar on the left, as shown in Figure 5-108.

Figure 5-108 Mobile Terminal Access Control
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Step 2 In the displayed Mobile Terminal Access Control window, click Create Mobile Terminal.

The Create Mobile Terminal page is displayed, as shown in Figure 5-109

Figure 5-109 Mobile terminal access setting

Step 3 Enter the identification number of the mobile terminal that is allowed to access the NetEco,
set Description, and click OK.

After the access control policies are set, the page similar to Figure 5-110 is displayed.

Figure 5-110 Access Control Policy

Step 4 Perform the following operations in the Figure 5-108 window.
l Select Enable Access Control: The access control policy for the mobile terminal is

enabled, and users can log in to the NetEco only from the specified mobile terminal.
l Deselect Enable Access Control: The access control policy for the mobile terminal is

disabled, and users can log in to the NetEco from any mobile terminals.

----End

Follow-up Procedure

l You can click  under Operation in Figure 5-110 to modify the specified mobile
terminal.

l You can click  under Operation in Figure 5-110 to delete the specified mobile
terminal.

5.2.6.2 Querying User Operation Logs

This section describes how to query user operation logs to know the operations performed by
users.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.2.1.1

Logging In to the NetEco 1000S.
l You have logged in as system administrator.
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Context
The NetEco 1000S checks whether the operation log is out of the life cycle, or whether the
number of user operation logs exceeds the preset threshold, at the specified time every day. If
the operation log is out of the life cycle, the NetEco 1000S automatically deletes the
exceeding logs. If the number exceeds the threshold, the NetEco 1000S automatically deletes
20% of the operation logs.

l Check time: 01:00 every day.
l Life cycle: half a year by default.
l Threshold: 100,000.

NOTE

The user operation logs about user authorization will not be deleted, unless this user is deleted.

Procedure

Step 1 Choose System > Log Management from the main menu.

The Log Management window is displayed.

Figure 5-111 Log Management

Step 2 Optional: Set the query criteria by referring to Table 5-57.

Table 5-57 Query criteria parameters

Parameter Description

User name Name of a user.
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Parameter Description

Module Module in which an operation is performed, including:
l Device management: involves plant creation, modification, and

deletion, device search, device access, and device deletion.
l Configuration management: involves device information

modification and control command delivery.
l Security management: involves user login and logout, and user

creation, user information modification, and user deletion.
l Software management: involves software package upload, device

upgrade, and software package deletion.
l Performance management: involves historical performance data

synchronization.
l Device log: involves the obtaining of device logs.
l Remote notification: involves email server parameter and SMS

message server parameter modification, and remote notification
rules creation, modification, deletion, enabling, and disabling.

NOTE
The product feature you have purchased may use personal information of
users when providing services or maintenance. Therefore, you are obligated
to take measures, in compliance with the laws of the countries concerned and
the user privacy policies of your company, to ensure that the personal data of
users is fully protected.

Personal data such as phone numbers and email addresses are masked in the
NetEco GUI and encrypted in the NetEco during batch data transmission to
ensure data security.

l License management: involves querying License Information,
importing or revoking a License and obtaining an ESN.

l System settings: involves the clock synchronization, baud rate
modification, alarm resetting, benefit setting, and collection
period setting.

Object Object on which an operation is performed, including:
l Local NetEco
l NetEco 1000S user
l plant
l Device

Client IP address IP address of the PC client or identification number of the mobile
client used for the login.
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Parameter Description

Operation type Type of operation a user has performed, including:
l System login
l System logout
l Search
l Add
l Synchronize
l Upgrade
l Modify
l Delete
l Reset

Operation time The value must be a time segment.
The start time must be earlier than or equal to the end time.

Contents Operation performed by a certain user.

Level Log level, including:
l Risk
l Minor
l Warning

Log type Log type, including:
l System Logs: record NetEco 1000S running exceptions, network

faults, and NetEco 1000S attacks.
l Operation Logs: record device addition and deletion.
l Security Logs: record NetEco 1000S security operation

information, such as logging in to the client, changing the
password, creating a user, and exiting the client.

 

Step 3 Click Query.

----End

5.2.6.3 Setting Remote Notification

This section describes how to set remote notification. The NetEco 1000S notifies users of
information about alarms or generated power remotely based on remote notification rules.

5.2.6.3.1 Setting Parameters for the Email Server

This section describes how to set parameters for the email server for sending emails to users.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.2.1.1

Logging In to the NetEco 1000S.
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l You have logged in as system administrator.

NOTE

You need to disable the mail filtering function of the antivirus software for the operating system.

l The PC on where the NetEco 1000S software is installed is properly connected to the
email server, and you have obtained the email server's IP address (or domain name) and
port number that are used for email transmission from the email server OM personnel.

NOTICE
TLS communication protocols include TLS1.0, TLS1.1, and TLS1.2. The NetEco supports
TLS1.1, and TLS1.2 protocols. TLS1.0 has security risks. The NetEco uses TLS1.2 by
default.

If an email server supports only TLS1.0, the communication connection may be insecure. In
this case, replace the email server with one supporting TLS1.1 or TLS1.2.

NOTE

The product feature you have purchased may use personal information of users when providing services
or maintenance. Therefore, you are obligated to take measures, in compliance with the laws of the
countries concerned and the user privacy policies of your company, to ensure that the personal data of
users is fully protected.

Personal data such as phone numbers and email addresses are masked in the NetEco GUI and encrypted
in the NetEco during batch data transmission to ensure data security.

Procedure

Step 1 Choose System > Remote Notification from the main menu.

Step 2 Choose Email Server.

The Setting parameters for email server window is displayed, as shown in Figure 5-112.
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Figure 5-112 Setting parameters for email server

Step 3 Setting parameters for email server by referring to Table 5-58.
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Table 5-58 Setting parameters for email server

Parameters Description

Email sending server Enter the IP address or domain name of the SMTP email server.
If the domain name of a website is www.yourdomain.com, the
domain name of the SMTP email server for this website may be
one of the following:
l smtp.yourdomain.com
l mail.yourdomain.com
l smtp.mail.yourdomain.com
For example, the domain name of the SMTP email server for
email@126.com is smtp.126.com.
If the domain name of the SMTP email server obtained based on
the preceding domain naming rule is invalid and email-based
remote notification fails to be enabled, contact the email service
provider to obtain the valid domain name of the SMTP email
server.
The domain names of the SMTP email servers for some frequently
used email boxes are as follows:
l 126.com: smtp.126.com.
l gmail(google.com): smtp.gmail.com.
l 21cn.com: smtp.21cn.com.
l 163.com: smtp.163.com.
l sohu.com: smtp.sohu.com.
l yahoo.com: smtp.mail.yahoo.com.

Email sending port
No.

Port of email server
NOTE

Select the Enable SSL, the SMTPS protocol is used, the default port is
465. Clear the Enable SSL check box, the SMTP protocol is used, the
default port is 25. Ensure that the server port is correct for successful email
transmission.

Sender email address Enter the email address of the sender.

Check permission If the SMTP email server requires authentication, select Check
permission, and set the user name and password for connecting to
the SMTP email server.

Enable SSL Select the Enable SSL, the SMTPS protocol is used. Clear the
Enable SSL check box, the SMTP protocol is used.
Use the SMTPS protocol to send email is advised.
NOTE

If Enable SSL is selected, you must verify that the email server supports
the SMTPS. Otherwise, email sending will fail.

 

Step 4 Optional: Test that parameters for the email server are set correctly.

1. Click Test in the Setting parameters for email server page.
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2. Enter the Recipient email address in the Test Email text box.
3. Click OK.

Step 5 Click Save.

----End

Exception Handling

If The test email has been sent. Please check. is displayed on the NetEco 1000S during
testing whether the parameters configured for the email server are correct, but the test mail is
not received, check the following items:

l Select Check permission.
l Sender email address and User name are the same.

5.2.6.3.2 Setting Alarm Sending Rules

This section describes how to set alarm sending rules. Based on the preset alarm sending
rules, the NetEco 1000S sends emails to notify users of alarm information.

Prerequisites
l You have logged in to the NetEco 1000S client. For details, see 5.2.1.1 Logging In to

the NetEco 1000S.
l You have logged in as the system administrator or installer.
l You have set the email server. For details, see 5.2.6.3.1 Setting Parameters for the

Email Server.

Context

The NetEco 1000S notifies users of alarm information by email: After the NetEco 1000S
receives an alarm reported by a device, the NetEco 1000S waits for 3 minutes, and then sends
all alarm information received within 3 minutes to users using one email.

NOTE

Alarm send delay time specifies the time that the NetEco 1000S waits before sending alarms. The
default value of Alarm send delay time is 180s, that is, 3 minutes. After the value of Alarm send delay
time is changed, the waiting period changes accordingly.

Procedure

Step 1 Choose System > Remote Notification from the main menu.

Step 2 Click Alarm Send Settings.

NOTE

l The product feature you have purchased may use personal information of users when providing
services or maintenance. Therefore, you are obligated to take measures, in compliance with the laws
of the countries concerned and the user privacy policies of your company, to ensure that the personal
data of users is fully protected.

l Personal data such as email addresses are masked in the NetEco GUI and encrypted in the NetEco
during batch data transmission to ensure data security.

Step 3 In the Setting Alarm Sending Rules page, you can perform the following operations.
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Setting Alarm
Sending Rules

Operation Method

Create alarm
sending rules

A alarm notification rule is enabled by default once it is created.
1. Click Create.
2. On the Create Rule page, set parameters and click Save.

NOTE
You can select the alarm email language by setting Mail language.

– Available languages include: Chinese, English, Japanese, French, and
German.

– The Mail language uses the display language on the NetEco 1000S by
default.

Enable alarm
sending rules

Enable a disabled alarm notification rule.
Select one or more alarm sending rules and click Enable to enable
the alarm sending rules.

Disable alarm
sending rules

Disable a alarm notification rule that is not used currently.
Select one or more alarm sending rules and click Disable to disable
the alarm sending rules.

Modify alarm
sending rules

Modify a alarm notification rule to meet management requirements.

1. Click  in the Operation column where the required alarm
notification rule is located.

2. On the Modify Rule page, modify the alarm notification rule
information.

Delete alarm
sending rules

Delete an unused alarm notification rule to ensure sufficient memory
and proper running of tasks on the server.

1. Click  in the Operation column where the required alarm
notification rule is located.

2. In the Warning dialog box, click Yes.

 

----End

5.2.6.3.3 Setting Report Sending Rules

This section describes how to set report sending rules. The NetEco 1000S sends emails to
users each day to notify users of day energy, income and total energy generated by the plant
based on rules.

Prerequisites
l You have logged in to the NetEco 1000S client. For details, see 5.2.1.1 Logging In to

the NetEco 1000S.

l You have logged in as the system administrator or installer.

l You have set the email server. For details, see 5.2.6.3.1 Setting Parameters for the
Email Server.

iManager NetEco 1000S
User Manual 5 Operation and Maintenance

Issue Draft C (2017-12-14) Huawei Proprietary and Confidential
Copyright © Huawei Technologies Co., Ltd.

267



Procedure

Step 1 Choose System > Remote Notification from the main menu.

Step 2 Choose Report Send Settings.

NOTE

l The product feature you have purchased may use personal information of users when providing
services or maintenance. Therefore, you are obligated to take measures, in compliance with the laws
of the countries concerned and the user privacy policies of your company, to ensure that the personal
data of users is fully protected.

l Personal data such as email addresses are anonymized in the NetEco GUI and encrypted in the
NetEco during batch data transmission to ensure data security.

Enter search criteria in Recipient email address or PV plant text box, and click Query.
Target reports sending rules meeting the preset condition are filtered out.

Figure 5-113 Report Send Settings

Step 3 In the Report Send Settings page, you can perform the following operations.

Setting Report
Sending Rules

Operation Method

Create report
sending rules

Based on the created report sending rules, the NetEco 1000S sends
emails to users each day to notify users of day energy and total
energy generated by the plant. This helps maintenance personnel that
are not onsite to learn the day energy and total energy generated by
the plant on the NetEco 1000S in time.
A report sending rule is enabled by default once it is created.
1. Click Create.
2. Set Rule name, Mail language, Mail subject, PV plant, Daily

send time, and Recipient email address on the Create Rule
page.
NOTE

– Available mail languages include: Chinese, English, Japanese, French,
and German. The Mail language uses the display language on the
NetEco 1000S by default.

– The NetEco 1000S has a mail subject by default. The language of the
mail subject is the display language and changes with the Mail
language settings.

– The NetEco 1000S sends day energy and total energy generated by the
PV Plant from 00:00 of the current day to Daily send time.

3. Click Save.

Enable report
sending rules

Enable a disabled report sending rule.
Select one or more report sending rules and click Enable to enable
the report sending rules.
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Setting Report
Sending Rules

Operation Method

Disable report
sending rules

Disable a report sending rule that is not used currently.
Select one or more report sending rules and click Disable to disable
the report sending rules.

Modify report
sending rules

Modify a report sending rule to meet management requirements.

1. Click  in the Operation column where the required report
sending rule is located.

2. On the Modify Rule page, modify the report sending rule
information.

Delete report
sending rules

Delete an unused report sending rule to ensure sufficient memory and
proper running of tasks on the server.

1. Click  in the Operation column where the required report
sending rule is located.

2. In the Warning dialog box, click Yes.

Export report
sending rules

1. Click Export drop-down list box.
– Select Export All from the Export drop-down list box and

save all the report sending rules that are queried to the PC.
– Select the target device in the displayed operation area. Select

Export Selected from the Export drop-down list box and save
the selected report sending rules to the PC.

The message shown in Figure 5-114 is displayed.

Figure 5-114 Message for rule export

2. Select whether to export personal data in plaintext format, and
click OK.
Personal data refers to the email information about recipients.

 

----End

Result

After the report sending rules are set, the NetEco 1000S automatically sends a report email to
the specified mailbox.
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The contents of a report email include the plant and inverter parameters as well as the Daily
Energy Yield bar graph, Income chart, and Active Power line chart. The energy Daily
Energy Yield graph and Income chart provide the energy yield and income of every day in
the current month, as shown in Figure 5-115.

Figure 5-115 Energy yield and income

The Active Power line chart provides the active power of every hour on the current day, as
shown in Figure 5-116.

Figure 5-116 Active power

Table 5-59 describes the descriptions of parameters in the report email.

Table 5-59 Report email

Type Parameter Description

Total Daily Energy Yield Total energy yield of PV plants on the current
day.

Total Energy Yield Total energy yield of PV plants.
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Type Parameter Description

NOTE
Total data
indicates data of
all PV plants
selected when
you set the
report sending
rules.

Total income Total income generated by PV plants.

Detailed PV
plant parameter

PV plant name Name of a PV plant selected when you set the
report sending rules.

Total string capacity Total string capacity of inverters under the PV
plant. If this parameter is not set, - is
displayed.

Total Energy Yield Total energy yield of the PV plant.

Daily Energy Yield Energy yield of the PV plant on the current
day.

Day Performance
Ratio

Performance ratio of the PV plant on the
current day.

Daily income Income of the PV plant on the current day.

Total income Total income generated by the PV plant.

Inverter
parameter

Number of Inverters Number of inverters connected to the PV
plant.

Inverter specific
energy mean value

Average equivalent energy generation
duration of inverters under the PV plant.

Specific energy
maximum value

Maximum equivalent energy generation
duration of inverters under the PV plant.

Specific energy
minimum value

Minimum equivalent energy generation
duration of inverters under the PV plant.

Ratio threshold Ratio threshold of the PV plant. If this
parameter is not set, - is displayed.

Number of inverters
with lower mean value
ratio

Number of inverters whose ratio is lower than
the average value.

 

NOTE

The table below inverter data lists Total Energy Yield, Daily Energy Yield, Specific Energy, and
Mean Value Ratio of each inverter. Mean Value Ratio is the ratio of Specific Energy to Inverter
specific energy mean value of an inverter. When the ratio is smaller than Ratio threshold, it is
displayed in red. In this case, you need to check the inverter to ensure that related functions are
available.
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5.2.6.4 Setting System Parameters
This section describes how to set system parameters to modify communication parameters,
reset alarms, synchronize the clock time, and set the income unit.

5.2.6.4.1 Resetting Alarms

This section describes how to reset alarms. When the target device restores its factory defaults
or changes its connection mode, you must reset alarms for the target device on the NetEco
1000S. In this case, all the existing alarm records for the target device will be deleted, and
alarms are synchronized from the target device to the NetEco 1000S again.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.2.1.1

Logging In to the NetEco 1000S.
l You have logged in as system administrator.

Procedure

Step 1 Choose System > System Settings from the main menu.

Step 2 Click Reset Alarm.

The Reset Alarm window is displayed, as shown in Figure 5-117.

Figure 5-117 Reset Alarm

Step 3 Select the devices for which you want to reset alarms and click Reset Alarm.

The Warning dialog box is displayed.
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Step 4 Click OK.

After alarms are reset, alarm records on the NetEco 1000S will be deleted. However, all
alarms of the device still exist on the device side.

----End

5.2.6.4.2 Clock Synchronization

This section describes how to synchronizes the time on the monitoring PC on which the
NetEco 1000S is installed to devices. This ensures time consistency between the devices and
the NetEco 1000S.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.2.1.1

Logging In to the NetEco 1000S.
l You have logged in as system administrator.

Context

By default, the time synchronization function is not started.

If the time synchronization function is started, the NetEco 1000S performs time
synchronization per hour to synchronize time from the NetEco 1000S server to devices
mounted to the plant.

Procedure

Step 1 Choose System > System Settings from the main menu.

Step 2 Click Clock Synchronization.

Figure 5-118 Clock Synchronization

Step 3 Select this check box. and click Save.

The message Are you sure you want to issue the command? is displayed.
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Step 4 Click OK.

The message The synchronization command has been issued is displayed.

Step 5 Click OK.

----End

5.2.6.4.3 Setting Communication Parameters

This section describes how to set communication parameters. If a device is connected to the
monitoring PC using a serial port, the baud rate of the device must be the same as that set on
the NetEco 1000S. Otherwise, the device communicates with the monitoring PC improperly.
By default, the baud rates of the device and NetEco 1000S are 9600. In normal cases, you can
retain the default settings unless the actual transmission rate is insufficient. After the baud rate
is changed, you need to restart the NetEco 1000S for the setting to take effect.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.2.1.1

Logging In to the NetEco 1000S.
l You have logged in as system administrator.

Procedure

Step 1 Choose System > System Settings from the main menu.

Step 2 Click Communicate Parameter.

The Communicate Parameter window is displayed.

Step 3 Changing Baud rate

1. Select a baud rate from the Baud rate drop-down list and click Save.
The message To change the baud rate, you need to restart the NetEco service. Do you
want to continue? is displayed.

2. Click Yes.
The message Modification succeeded. Please restart the NetEco service. is displayed.

3. Click OK.
4. See 5.2.1.2 Logging Out of the NetEco 1000S and 5.2.1.1 Logging In to the NetEco

1000S to restart NetEco 1000S service.

Step 4 Set whether the SUN2000L inverter supporting only SSL authentication is allowed to access
the NetEco 1000S.

The SUN2000L inverter and NetEco 1000S use the following two authentication modes by
default: SSL authentication and user name/password authentication. The NetEco 1000S can
be compatible with the SUN2000L inverter supporting only SSL authentication, which has
security risks. It is recommended that such SUN2000L inverter be replaced with the
SUN2000L inverter supporting both authentication modes or the SUN2000L inverter be
upgraded to the version supporting both authentication modes.

l Select Compatible Access only supports SSL authentication NEs: The SUN2000L
inverter supporting only SSL authentication is allowed to access the NetEco 1000S, and
the device connection is normal.
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l Deselect Compatible Access only supports SSL authentication NEs: The SUN2000L
inverter supporting only SSL authentication is allowed to access the NetEco 1000S, but
the device is disconnected. To ensure the access security of the NetEco 1000S, you are
advised to deselect Compatible Access only supports SSL authentication NEs.

NOTE

After installing and upgrading NetEco 1000S, Compatible Access only supports SSL authentication
NEs is selected by default.

----End

5.2.6.4.4 Setting Income

NetEco 1000S uses Standard currency selected during the installation for income statistics.
You can set exchange rates between different types of currency and Standard currency to
collect statistics on the income of all PV plants.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.2.1.1

Logging In to the NetEco 1000S.
l You have logged in as system administrator.

Procedure

Step 1 Choose System > System Settings from the main menu.

Step 2 Choose Income Settings.

The page as shown in Figure 5-119 is displayed.
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Figure 5-119 Income Setting

NOTE

NetEco 1000S uses Standard currency for income statistics. Standard currency indicates the currency
type selected when you set currency parameters.

Step 3 Click Add Currency.

The Add Currency Unit dialog box is displayed, as shown in Figure 5-120.

Figure 5-120 Add currency unit

Step 4 Set the currency used for the PV plant and the exchange rate of the currency against
Standard currency, and save the setting.

----End
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Follow-up Procedure

l In the  area of the Add Currency Unit dialog box, edit or delete
the currency.

5.2.6.4.5 Setting Prompt Information

This section describes how to set whether to enable the prompt information displayed after
you log in to the client, access devices, and create a PV plant on the NetEco 1000S client.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.2.1.1

Logging In to the NetEco 1000S.

l You have logged in as system administrator.

Context

After you log in to the NetEco 1000S, access devices, or create a PV plant, the prompt
information is displayed in the lower right corner of the NetEco 1000S client.

You can enable or disable the prompt information as required.

Procedure

Step 1 Choose System > System Settings from the main menu.

Step 2 Choose Tip Message Settings.

The Tip Message Settings page is displayed, as shown in Figure 5-121.

Figure 5-121 Tip Message Settings

Step 3 Set whether to enable the prompt information.

l Enable the prompt information: select Enable tip message display.

l Disable the prompt information: deselect Enable tip message display.

Prompt information is enabled on the NetEco 1000S by default.

Step 4 Click Save.

----End
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5.2.6.5 License Management
License management includes querying license information, obtaining an ESN, importing a
license, and revoking a license. Manage the license to ensure that the NetEco 1000S can be
used normally.

5.2.6.5.1 License Usage Description

The license is used to enable or disable the inverter management function. After the NetEco
1000S is installed, there is a license trial period of 90 days by default. During the trial period,
a license file needs to be imported so that all the functions of the NetEco 1000S can be used.

If a license file is not imported when the trial period expires, login to the NetEco 1000S client
will be limited. After login is limited, installers and customers will not be able to visit the
client. Only the system administrator can visit the client. After login, the page requiring
license import is displayed.

To ensure that you can use all the functions of the NetEco 1000S, check and import a license
file periodically.

How to Obtain a License
Obtain the ESN of the NetEco 1000S server or the license revocation code, and then contact
Huawei technical support to apply for a new license.

5.2.6.5.2 Querying License Information About the NetEco

Query the expiration date and function control of the current License routinely to check
whether the License is about to expire, and solve the problems in a timely manner. In this
way, the NetEco 1000S function can be used normally.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.2.1.1

Logging In to the NetEco 1000S.
l You have logged in as system administrator.
l The License has been imported to NetEco 1000S. If it has not been imported, import it

by referring to 5.2.6.5.3 Importing a License File.

Procedure

Step 1 Choose System > License Management from the main menu.

Step 2 Choose License Information.

The License Information page is displayed.

On the License Information page, check the basic information, function control information,
and ESN information about the License. For details, see Table 5-60.
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Table 5-60 License information

Item Attribute Description

Basic License
Information

Expired on The License is valid until 03:00 this date.

Function Control Function Name Functions provided by the NetEco 1000S.

Supported or Not Whether the function is supported by the
License file.

ESN Information ESN list ESNs of all the NICs managed by the
License. Each ESN is separated by a comma
(,).

ESN quantity The number of ESNs of all the NICs
managed by the License.

 

NOTE

When the License is about to expire, a prompt will be displayed at the upper part of the License
Information page. Handle the problem by following the prompt.

----End

5.2.6.5.3 Importing a License File

When a License is not imported in NetEco 1000S, or NetEco 1000S License is expires, or
cannot meet network management requirements, you must import a new License to the
NetEco 1000S to ensure normal services of the NetEco.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.2.1.1

Logging In to the NetEco 1000S.

l You have logged in as system administrator.

l A new License is obtained.

Procedure

Step 1 Choose System > License Management from the main menu.

Step 2 Choose Import License.

The Import License page is displayed.

Step 3 Click Browse and select a License file.

The License file must be less than 1 MB and the file format should be .dat.

Step 4 Click Upload.

A dialog box for activating the License is displayed.
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Step 5 Click Yes.

----End

5.2.6.5.4 Revoking a License

If the NIC is faulty or a new NIC needs to be used, revoke the current license to generate a
revocation code which is used to apply for a new license file for free.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.2.1.1

Logging In to the NetEco 1000S.
l You have logged in as system administrator.
l License usage is normal in the current environment.

Context

If a NIC is found faulty or the existing NIC needs to be replaced, revoke the existing license
to generate a revocation code that can be used for applying for a new license file.

After NIC replacement, import the new license file to NetEco 1000S. After that, the NetEco
1000S functions can be used properly. For details about how to import a license file, see
5.2.6.5.6 Importing a License on the Page Requiring License Import.

Procedure

Step 1 Choose System > License Management from the main menu.

Step 2 Choose Revoke License.

The Revoke License page is displayed.

Step 3 Click Revoke.

A warning is displayed, as shown in Figure 5-122.

Figure 5-122 Revocation warning

Step 4 Click OK.

A dialog box is displayed, as shown in Figure 5-123.
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Figure 5-123 Password confirming

Step 5 Enter the password of the user and click OK.

The generated revocation code will be displayed beside the Revocation code parameter.

If the revocation code is not generated, contact Huawei technical support.

----End

5.2.6.5.5 Obtaining an ESN

If no license is available for the NetEco 1000S, obtain the equipment serial number (ESN) of
the NetEco 1000S server to apply for a license.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.2.1.1

Logging In to the NetEco 1000S.
l You have logged in as system administrator.
l You have obtained the Media Access Control (MAC) address of the NetEco server.
l No license is available or the license has expired.

Context

If no license file is found or the license has expired after the NetEco 1000S is installed, obtain
the ESN to apply for a new license.

Procedure

Step 1 Choose System > License Management from the main menu.

Step 2 Choose Obtain ESN.

The Obtain ESN page is displayed.

Step 3 Obtain the ESN.
l Obtain the ESN of the current logged-in server only.

NOTE

You can use this method to obtain the ESN of the current logged-in server only. Obtain the ESNs of
other servers by entering their MAC addresses.
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1. Click Choose MAC address. In the drop-down list, select a MAC address to generate an
ESN.

The MAC addresses provided in the drop-down list are the MAC addresses of the
NetEco 1000S servers.

NOTICE
If there are multiple options, select each MAC address one by one and obtain the ESN
for each MAC address.

2. Click Obtain ESN.

l Obtain the ESNs of other servers by entering their MAC addresses.

a. Click Enter a MAC address, and enter a MAC address of the NetEco server.

A maximum of 20 MAC addresses can be entered. Separate two MAC addresses
with a comma (,).

b. Click Obtain ESN.

The generated ESN is displayed at the lower part of the page, as shown in Figure 5-124.

Figure 5-124 Generating an ESN

----End

Follow-up Procedure

When you need to apply for a new license file, contact Huawei technical support and use the
obtained ESN to apply for a new license file.

After the new license is issued, import the license to the NetEco 1000S. For details, see
5.2.6.5.6 Importing a License on the Page Requiring License Import.
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5.2.6.5.6 Importing a License on the Page Requiring License Import

If the license has expired or is invalid, import a new license file or obtain the ESN of the
NetEco 1000S on the page requiring license import.

Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.2.1.1

Logging In to the NetEco 1000S.
l You have logged in as system administrator.
l The trial period of the NetEco 1000S has expired, or the license has expired or is invalid.

Context
If The trial period of the NetEco 1000S has expired, or the license has expired or is invalid,
log in to the NetEco 1000S client as the system administrator. The page requiring license
import is displayed.

Import a new license file.

NOTICE
If you perform an operation after more than 10 minutes elapse since the page requiring license
import is displayed, the login page will be displayed again. To ensure that you can perform
operations successfully, perform the following steps within 10 minutes after the page
requiring license import is displayed.

Procedure
l If you have obtained a new license, perform the following operations:

a. Click Browse on the right of License File.
A dialog box for selecting a file is displayed.

b. Select the license file to be imported and click OK.
c. Click Upload.

The dialog box shown in Figure 5-125 is displayed.

Figure 5-125 Confirm
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d. Click Yes.

The dialog box shown in Figure 5-126 is displayed.

Figure 5-126 Information

e. Click OK.

f. Click Return on the right of License File.

The NetEco 1000S login page is displayed.

l If no license file is available, perform the following operations to obtain the ESN of the
NetEco 1000S so that you can use the ESN to apply for a new license.

a. Obtain the ESN.

n Obtain the ESN of the current logged-in server only:

Click Choose MAC address, in the drop-down list, select a MAC address to
generate an ESN.

The MAC addresses provided in the drop-down list are the MAC addresses of
the NetEco servers.

NOTICE
If there are multiple options, select each MAC address one by one and obtain the
ESN for each MAC address.

n Obtain the ESNs of other servers by entering their MAC addresses:

Click Enter a MAC address, and enter a MAC address of the NetEco server.

A maximum of 20 MAC addresses can be entered. Separate two MAC
addresses with a comma (,).

b. Click Generate ESN.

The generated ESN is displayed at the lower part of the page.

Contact Huawei technical support engineers to apply for a new license using the
obtained ESN, and a.

5.2.7 FAQs
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5.2.7.1 What Do I Do When the Internet Explorer Browser Displays a Message
Asking Me to Close the Compatibility View on to the Login Page?

Symptom

Figure 5-127 Message indicating that the compatibility view needs to be closed

Possible Causes
You have enabled the compatibility view of the Internet Explorer browser.

Procedure

Step 1 Choose Tools > Compatibility View Settings on the Internet Explorer menu bar.

Step 2 Clear the check box for Display all websites in Compatibility View.
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Figure 5-128 Compatibility View Settings

----End

5.2.7.2 What Do I Do When Characters in a CSV File Are Displayed in Disorder?

Symptom

When users open a CSV file exported from the NetEco 1000S, the characters in the file are
displayed in disorder.

Possible Causes

When data in a list is exported to a CSV file, the default separator used by the operating
system is not comma (,).

Procedure

Step 1 Choose Start > Control Panel.

Step 2 In the displayed Control Panel window, click Region and Language.

Step 3 In the displayed Region and Language window, click the Formats tab.

Step 4 Click Additional settings.
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Step 5 In the displayed dialog box, set List separator to comma (,) on the Numbers tab page.

Step 6 Click OK.

----End

5.2.7.3 What Do I Do If a Certificate Error Message or a Security Alarm Is
Displayed on Internet Explorer?

Symptom
When log in to NetEco 1000S using Internet Explorer or Chrome, Internet Explorer or
Chrome displays a certificate error message similar to that shown in Figure 5-129 or Figure
5-130.
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Figure 5-129 Certificate error message

Figure 5-130 Website Security Certificate window (Chrome 50)

Possible Causes

Trusted certificate has not been loaded in the browser.

Procedure

Step 1 Log in to a PC as a user in the Administrators user group.

After the certificate is replaced on Internet Explorer, the certificate is also replaced on
Chrome. This section mainly describes how to replace the certificate on Internet Explorer.

NOTE

If you install only Chrome, choose Manage Certificate > Trusted Root Certification Authorities >
Import in the setting window of the Chrome browser and import the certificate as prompted.

If you start Internet Explorer 11 in the Windows 7 operating system, you need to log in a PC
as a user in the Administrators user group and then start Internet Explorer as user
Administrator. Otherwise, you cannot properly set Internet Explorer:

1. Choose Start > Internet Explorer.
2. In the displayed shortcut menu, choose Run as Administrator.

Step 2 View the certificate.
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1. When the Internet Explorer displays the security certificate message as shown in Figure
5-131, click Continue to this website.

Figure 5-131 Security certificate

2. As shown in Figure 5-132, click Certificate Error.

Figure 5-132 Certificate Error

3. In the displayed dialog box, click View Certificate.

Step 3 In the displayed root certificate dialog box as shown in Figure 5-133, click Install
Certificate.
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Figure 5-133 Installing the root certificate

Step 4 In the displayed Certificate Import Wizard dialog box, click Next.

Step 5 Set the certificate store to Trusted Root Certification Authorities, as shown in Figure
5-134.
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Figure 5-134 Setting the certificate store

Step 6 Click Next.

Step 7 After confirming the certificate import information, click Finish.

Step 8 If the system displays the Security Warning dialog box asking you whether to install the
certificate, click Yes. Otherwise, skip this step.

Step 9 In the displayed dialog box indicating the import is successful, click OK.

Step 10 Click OK to close the Certificate dialog box.

Step 11 In the window of Internet Explorer, choose Tools > Internet Options.

Step 12 In the displayed Internet Options dialog box, click Advanced.

Step 13 In the Settings group box, clear Warn about certificate address mismatch under Security.

Step 14 Click OK to close the Internet Options dialog box.

Step 15 Restart the web browser and log in to NetEco 1000S again.

----End

5.2.7.4 What Do I Do If the Email Server Fails to Send an Email?

This section describes how to solve the problem that the email server fails to send an email.
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Possible Causes
The possible causes of the failure are as follows:

l Incorrect network configuration
l Incorrect IP address or domain name of the email sending server
l Incorrect port number for email sending
l Incorrect user name or password
l Incorrect sender or recipient email address

Procedure

Step 1 Check the network configuration.

1. Choose Start > Control Panel > Network and Internet > Network and Sharing
Center > Network Connections in the operating system.

NOTE

The navigation path of Network Connections on the Control Panel may vary depending on the
OS version. Choose the corresponding path as required.

The Network Connections dialog box is displayed.
2. Click Properties.

The Local Area Connection Properties dialog box is displayed, as shown in Figure
5-135.
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Figure 5-135 Local area connection properties

3. Select Internet Protocol Version 4 (TCP/IPv4) and click Properties.
4. Select Obtain an IP address automatically and Obtain DNS server address

automatically, and click OK.
5. Check whether the problem has been resolved.

– If the problem has been resolved, no further operation is required.
– If the problem persists, go to the next step.

Step 2 Check Email sending server.

1. Check whether the IP address or domain name configured for Email sending server is
correct.
If the configuration is correct, go to the next step. Otherwise, configure the correct IP
address or domain name by referring to 5.2.6.3.1 Setting Parameters for the Email
Server.

2. Check whether the problem has been resolved.
– If the problem has been resolved, no further operation is required.
– If the problem persists, go to the next step.

Step 3 Check Email sending port No.

1. Check whether the setting of Email sending port No is correct.
If the configuration is correct, go to the next step. Otherwise, configure the correct port
number by referring to 5.2.6.3.1 Setting Parameters for the Email Server.
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2. Check whether the problem has been resolved.

– If the problem has been resolved, no further operation is required.

– If the problem persists, go to the next step.

Step 4 Check User name and Password.

1. Check whether User name and Password are correctly configured.

If the configuration is correct, go to the next step. Otherwise, configure the correct user
name and password by referring to 5.2.6.3.1 Setting Parameters for the Email Server.

2. Check whether the problem has been resolved.

– If the problem has been resolved, no further operation is required.

– If the problem persists, go to the next step.

Step 5 Check Sender email address and Recipient email address.

1. Check whether Sender email address and Recipient email address are correctly
configured.

If the configuration is correct, go to the next step. Otherwise, configure the correct email
address by referring to 5.2.6.3.1 Setting Parameters for the Email Server.

2. Check whether the problem has been resolved.

– If the problem has been resolved, no further operation is required.

– If the problem persists, go to the next step.

Step 6 If the problem persists after the preceding possible causes are ruled out, contact Huawei
technical support engineers.

----End

5.2.7.5 Failure to Receive Emails

Symptom

After the alarm or report sending rules are configured on the NetEco 1000S client, no alarm or
report emails are received.

Possible Causes
l Reasons related to the sender's server: The sender's server categorizes the emails as junk

emails and therefore does not send the emails.

An email may be categorized as a junk email for the following reasons:

– The number of emails sent in a day exceeds the limit.

– The content of the email is the same as or similar to that of another email.

l Reasons related to the recipient's server:

– The emails are categorized as junk emails and therefore cannot be received.

– In Windows Server 2012, the email server is used for email receiving by default.
The cause may be that the default host name or domain name of the email server is
not recognized. As a result, the emails fail to be received.

This problem may occur if customers use the email server installed by themselves.
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Procedure

Step 1 Check the sender's email server.
l In Windows Server 2012, enable the SMTP server for email sending.
l In Windows 7 or Windows 10, upgrade the mailbox to a VIP mailbox for email sending.

For detailed operations, contact Huawei technical support engineers.

Step 2 Check whether the problem has been resolved.
l If the problem has been resolved, no further operation is required.
l If the problem persists, go to the next step.

Step 3 Check the recipient's mailbox.

Check whether junk emails contain emails from the NetEco 1000S. If yes, set the mailbox so
that emails from the NetEco 1000S are not categorized as junk emails.

Step 4 Check whether the problem has been resolved.
l If the problem has been resolved, no further operation is required.
l If the problem persists, go to the next step.

Step 5 If the operating system is Windows Server 2012, change the email server attribute.

Set the host name or domain name of the email server to a value in the ****.****.****
format, such as mail.neteco.com.

Step 6 Check whether the problem has been resolved.
l If the problem has been resolved, no further operation is required.
l If the problem persists, contact Huawei technical support.

----End

5.2.7.6 What Do I Do If the Client Does Not Display the Language Selected
During Last Access After Access to the NetEco 1000S Using a Web Browser?

Symptom

When a user accesses the NetEco 1000S using a web browser again, the client does not
display the language selected during last access.

Possible Causes
l The browser has been configured to delete browsing history on exit.
l Cookies have been disabled for the browser.
l The URL entered in the address box of the browser for accessing the client carries a

language attribute.

Procedure

Step 1 Cancel browsing history deletion upon exit for the browser.

1. Choose Tools > Internet Options from the main menu of the browser.
2. On the General tab page, clear Delete browsing history on exit.
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Step 2 Allow cookies.

1. Choose Tools > Internet Options from the main menu of the browser.
2. On the Privacy tab page, click Advanced.

The Advanced Privacy Settings dialog box is displayed.
3. Select Override automatic cookie handing, select Accept under First-party Cookies

and Third-party Cookies, select Always allow session cookies, and click OK.

Step 3 Delete the language attribute (webLang=xxx) carried in the client access URL.

For example, if the client access URL is https://IP address:8443/index.action?
webLang=zh_CN, delete the language attribute from the URL. That is, use https://IP
address:8443/index.action to access the client.

----End

5.2.7.7 What Do I Do to Switch to the Residential NetEco 1000S System
The NetEco 1000S of V100R002C70 or a later version will be a commercial system by
default. To switch it to a residential system, modify the fusionHomeMg.properties file.

Procedure

Step 1 Navigate to the following directory:

NetEco 1000S installation directory\WebRoot\WEB-INF\classes

Step 2 Open the fusionHomeMg.properties file, change the value of isFusionHome to 1, and save
the change result.

Step 3 Restart the NetEco 1000S services and log in to the NetEco 1000S client.

The NetEco 1000S is now a residential system.

----End

Follow-up Procedure
In the residential NetEco 1000S system, the Privacy Policy and Terms of Use must be enabled
at the same time for user authorization. For details, see 5.2.7.8 What Do I Do to Control the
User Authorization upon First Login?.

5.2.7.8 What Do I Do to Control the User Authorization upon First Login?
For the NetEco 1000S of V100R002C70 or a later version, no user authorization is required
upon first login by default. However, you can modify the userManagement.properties file to
change the system configuration so that user authorization will be required upon first login.

Prerequisites
The NetEco 1000S is of V100R002C70 or a later version.

Procedure

Step 1 Update the Privacy Policy and Terms of Use in compliance with local laws and regulations.
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The methods of updating the Privacy Policy or Terms of Use are similar. The following
describes how to update Privacy Policy.

1. Navigate to NetEco 1000S installation directory\tools\userPrivacy\template to obtain
userPrivacy.xml:

NOTE

To update Terms of Use, please navigate to NetEco 1000S installation directory\tools
\UseOfTerms\template to obtain UseOfTerms.xml.

2. Store userPrivacy.xml under NetEco 1000S installation directory\tools\userPrivacy,
open the file in text mode, and edit it.

NOTE

To update Terms of Use, please store UseOfTerms.xml under NetEco 1000S installation
directory\tools\UseOfTerms.

NOTICE
– The file under NetEco 1000S installation directory\tools\userPrivacy must be

named as userPrivacy.xml. If not, modify it.
– The file under NetEco 1000S installation directory\tools\UseOfTerms must be

named as UseOfTerms.xml. If not, modify it.

3. Update the version and time for the Privacy Policy.
Modify the tag content based on Table 5-61 and actual conditions.

Table 5-61 Updating the version and time

Pair Description

<version>
1.0
</version>

Version of the Privacy Policy.
Modify the version when the Privacy Policy is
updated. The first issue is version 1.0, the second
issue version 2.0, and so forth.

<updateTime >
2017-07-06
</updateTime>

Update time of the Privacy Policy.
Modify the time when the Privacy Policy is
updated. The time format is as 2017-07-06.

 
4. Update the Privacy Policy in Chinese, English, Japanese, French, and German based on

Table 5-62 and actual conditions, and save the updates.
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Table 5-62 Five language environments

Pair Description

<country name="zh_CN">
<detail>
Details of Privacy Policy.
</detail>
</country>

The Privacy Policy displayed in Chinese
environment.

<country name="en_US">
<detail>
Details of Privacy Policy. 
</detail>
</country>

The Privacy Policy displayed in English
environment.

<country name="ja_JP">
<detail>
Details of Privacy Policy.
</detail>
</country>

The Privacy Policy displayed in Japanese
environment.

<country name="fr_FR">
<detail>
Details of Privacy Policy.
</detail>
</country>

The Privacy Policy displayed in French
environment.

<country name="de_DE">
<detail>
Details of Privacy Policy.
</detail>
</country>

The Privacy Policy displayed in German
environment.

 

Step 2 Navigate to NetEco 1000S software installation directory\tools, and run the UserTools.bat
script.

The following information is displayed:
1 Update userPrivacy file.
2 Update UseOfTerms file.
3 Change life cycle of operatelog<1~3650>.
4 Exit.
Please Choose:

Step 3 Enter 1 and press Enter.

NOTE

To updated Terms of Use to the NetEco 1000S, enter 2 and press Enter.

The Privacy Policy is updated successfully.
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Step 4 Navigate to the following directory:

NetEco 1000S installation directory\WebRoot\WEB-INF\classes

Step 5 Open the userManagement.properties file, change the value of PrivacyStatementType and
isShowUseTerms to 1, and save the change result.

NOTE

The Privacy Policy and Terms of Use must be enabled at the same time in the residential NetEco 1000S
system.

Step 6 Restart the NetEco 1000S.

The settings become valid.

The User Authorization page is displayed upon the first login, you need to view the Privacy
Policy and and Terms of Use and select Agree to the Privacy Policy and Agree to the Terms
of Use before clicking OK to continue the operations.

----End

Follow-up Procedure
l If the Privacy Policy and Terms of Use are updated, you can run the UserTools.bat script

to synchronize the updated Privacy Policy and Terms of Use to the NetEco 1000S. For
details, refer to Step 1, Step 2, and Step 3 in Procedure.

NOTICE
The NetEco 1000S automatically detects the version of Privacy Policy or Terms of Use
(when the Terms of Use is set to be displayed on User Authorization page) at 00:00:00
every day. If a version change is detected, you will be forcibly logged out of both the
NetEco 1000S client and the NetEco 1000S app. You need to select Agree to the
Privacy Policy and Agree to the Terms of Use on the NetEco 1000S client before using
the NetEco 1000S.

l You can also run the UserTools.bat script to change the life cycle of operation logs.

NOTE

l The life cycle of operation logs is half a year by default.

l This function is irrelevant to updating Privacy Policy and Terms of Use.

a. Go to NetEco 1000S software installation directory\tools, and run the
UserTools.bat script.
The following information is displayed:
1 Update userPrivacy file.
2 Update UseOfTerms file.
3 Change life cycle of operatelog<1~3650>.
4 Exit.
Please Choose:

b. Enter 3 and press Enter.
The following information is displayed:
Please input the life cycle of operatelog:

c. Enter the number of days as required and press Enter.
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User-defined life cycle of operation logs ranges from 1 to 3650, indicating 1–3650
days.

d. Restart the NetEco 1000S to validate the settings.

5.3 NetEco 1000S APP Operation
This section describes how to access the NetEco 1000S system through the NetEco 1000S
APP and how to perform related operations on the NetEco 1000S APP.

5.3.1 Logging In to the NetEco 1000S APP
After installing the NetEco 1000S APP on the mobile terminal, you can access the NetEco
1000S server through the NetEco 1000S APP.

Prerequisites
l You have added the identification number of the mobile terminal in the NetEco 1000S

system. For details, see 4.2.3 Security Configuration for NetEco 1000S APP.
l You have installed the NetEco 1000S APP software on the mobile terminal. For detailed

operations, see 4.2.2 Installing the NetEco 1000S APP Software.
l You have obtained the user Account/Email and password for logging in to NetEco 1000S

APP.
l The mobile terminal has been connected to the network.

Context
The NetEco 1000S APP can be installed on mobile terminals running iOS6.0, Android4.0,
and later versions. Different Android versions support different communication protocols.

l Versions earlier than Android4.4: supports TLSv1.
l Android4.4 and later: support TLSv1, TLSv1.1, and TLSv1.2.

The NetEco 1000S APP supports the TLSv1, TLSv1.1, and TLSv1.2 by default. The TLSv1
has security risks. You are advised to upgrade the Android. For mobile terminals running
Android4.4 or later, disable the TLSv1 by following the instructions provided in 5.3.4 How
Do I Disable the TLSv1?.

Procedure

Step 1 Click the NetEco 1000S APP icon on the desktop of the mobile terminal to open the login
page.

Step 2 Optional: Set the server address of the NetEco 1000S server if this is the first time that you
log in to the NetEco 1000S APP.

Server Addr. indicates the IP address of the NetEco 1000S server. Specify the IP address or
domain name of the server as required.

iManager NetEco 1000S
User Manual 5 Operation and Maintenance

Issue Draft C (2017-12-14) Huawei Proprietary and Confidential
Copyright © Huawei Technologies Co., Ltd.

300



Figure 5-136 Setting the server address

Step 3 Enter Account/Email and password.

Step 4 Click Log In.

NOTICE
If the message The Privacy Policy is updated. Log in to read and agree the Privacy Policy
on WebUI. is displayed, log in to the NetEco 1000S client and agree the Privacy Policy
before logging in to the NetEco 1000S app to continue the operations. For details, see 5.1.8.22
What Do I Do to Control the User Authorization upon First Login?.

After you successfully log in to the NetEco 1000S service, the Overview window is
displayed, as shown in Figure 5-137.
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Figure 5-137 Summary window

NOTE

l You can click  to view the version of the NetEco 1000S APP.

l You can click  to deregister an application.

l You can click  to update data on the overview page.

----End

5.3.2 Viewing PV Plant and Inverter Information
You can view information about the PV plants and about the inverters accessed each PV plant
on the NetEco 1000S APP to learn the operating status of the PV plants and inverters.

Prerequisites

You have logged in to the NetEco 1000S APP. For detailed operations, see 5.3.1 Logging In
to the NetEco 1000S APP.
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Context

l Click  on the page to return to the previous page.

l Click  on the page to return to the Overview page.

Procedure

Step 1 Click  on the Overview page. The Plant List page is displayed, as is shown in
Figure 5-79.

Figure 5-138 Plant list

Step 2 Select the PV plant to be viewed on the Plant List page. The PV plant details page is
displayed, as shown in Figure 5-139.

you can view Status, Current power, Energy yield of current day, Total energy, Income, the
number of inverters, Total Radiation, Temperature, CO2 emission reduction, and Rated Power
of the selected PV plant.

NOTE

There is no Total Radiation and Temperature information in the residential NetEco 1000S system.
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Figure 5-139 PV plant details page

Step 3 On the PV plant details page, the system administrator, operator, guest user who has obtained
the historical data query permissions in the commercial NetEco 1000S system, or the system
administrator, installer in the residential NetEco 1000S system can perform the following
operations.

If You Need To... Then...

Replace the image of the
current PV plant

Click the PV plant icon in Figure 5-139.

View the alarm list of a PV
plant Click Status in Figure 5-139 or  corresponding to the

target PV plant in Figure 5-138. The Alarm List page of
the PV plant is displayed.

To view alarm details, click  corresponding to the
target alarm on the Alarm List page.

Display Current power, Energy
yield of current day, Total
energy, and Income of a PV
plant in charts

Click  in Figure 5-139 separately.
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If You Need To... Then...

View information about the
inverters in a PV plant Click  corresponding to Inverter NO. in Figure

5-139. The Inverter List page is displayed.
l To view Current power, Energy yield of current

day, Total energy, Inverter status, PV input
current and input voltage, and Rated power of an
inverter:
click the line corresponding to the target inverter on
the Inverter List page.

l To view all alarms of an inverter:

1. Click  corresponding to the target inverter on
the Inverter List page. The Alarm List page of
the inverter is displayed.

2. Click  corresponding to the target alarm on the
Alarm List page. The alarm details are displayed.

 

----End

5.3.3 Viewing the Electric Energy Yield and Total Benefits
You can view the daily yield, monthly yield, yearly yield, and total benefits of PV plants on
the NetEco 1000S APP.

Prerequisites
l You have logged in to the NetEco 1000S APP. For detailed operations, see 5.3.1

Logging In to the NetEco 1000S APP.
l You have logged in as the system administrator, operator, guest user who has obtained

the historical data query permissions in the commercial NetEco 1000S system, or the
system administrator, installer in the residential NetEco 1000S system.

Context

l Click  on the page to return to the previous page.

l Click  on the page to return to the Overview page.

Procedure
l View the daily yield:
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a. Click  on the Overview page. The Total yield per day page is
displayed, as shown in Figure 5-140.

Figure 5-140 Total yield per day page

b. On the Total yield per day page, click the date in the red box to choose to view the
electric energy yield of any day.

l View the monthly yield and monthly income:
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a. Click  on the Overview page. The Total yield per month page is
displayed, as shown in Figure 5-141.

Figure 5-141 Total yield per month page

b. On the Total yield per month page, click the date in the red box to choose to view
the electric energy yield and income of any month.

l View the yearly yield and yearly income:
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a. Click  on the Overview page. The Total yield per year page is
displayed, as shown in Figure 5-142.

Figure 5-142 Total yield per year page

b. On the Total yield per year page, click the year in the red box to choose to view
the electric energy yield and income of any year.

l View the total benefits:
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a. Click  on the Overview page. The Income page is displayed, as
shown in Figure 5-143.

Figure 5-143 Income page

b. View the total energy yield of all PV plants and total benefits.

iManager NetEco 1000S
User Manual 5 Operation and Maintenance

Issue Draft C (2017-12-14) Huawei Proprietary and Confidential
Copyright © Huawei Technologies Co., Ltd.

309



5.3.4 How Do I Disable the TLSv1?

Question

This section describes how to disable the TLSv1 to ensure the security of mobile terminals
running Android4.4 or later. The TLSv1 has security risks.

Answer

You can perform the following operations to disable the TLSv1.

Step 1 Open the following file on the server where the NetEco 1000S is installed.

NetEco 1000S software installation directory\WebRoot\WEB-INF\classes
\struts.properties

Step 2 Change the value of appSslTLSJetty to TLSv1.1,TLSv1.2 and save the change result.

Step 3 Restart NetEco 1000S services for the change to take effect.

----End

5.4 NetEco 1000S Maintenance
This section describes how to manage NetEco 1000S users and logs.

5.4.1 Managing Users
This section describes how to manage the NetEco 1000S users, which involve MySQL users
and NetEco 1000S users. You can manage the accounts and authority of these users and
monitor user operations.

5.4.1.1 Managing MySQL Users

This section describes the MySQL users that are required for the NetEco 1000S and how to
change the password of the MySQL administrator.

5.4.1.1.1 MySQL Users and User Authority

This section describes the MySQL users used by the NetEco 1000S and the related authority.

Only the MySQL user is authorized to use the MySQL database. After the MySQL database
is installed, the system Create the default user administrator and dbuser.

For details about the MySQL user accounts, see Table 5-63.

Table 5-63 MySQL user accounts

User Function Authority

administrato
r

Management user of the MySQL
database.

User administrator has the highest
authority of the database.
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User Function Authority

dbuser Operation user of the MySQL
database.

User dbuser has the permission to
the database.

 

5.4.1.1.2 Changing the Passwords of MySQL Users

Change the user passwords of the databases during routine maintenance, which ensures
database user password security.

Prerequisites
l The old password of the MySQL user is available.
l The new password of the MySQL user is available.
l You have started the NetEco 1000S services. For details about how to start the services,

see 5.1.1.1.1 Starting NetEco 1000S Services.

Context
To ensure user password security, plan user passwords that meet password policy and change
passwords periodically.

NOTE

l The password cannot be the same as the user name or the user name in a reversed order.
l The password contains 8 to 32 characters.
l The password contains three of the following:
l Lowercase letters
l Uppercase letters
l Digits

l The password is advised to contain special characters, which include !"#$%&'()*+,-./:;<=>?
@[\]^`{_|}~ and space.

Procedure

Step 1 Changing the passwords of MySQL users: Run the script NetEco software installation\tools
\ConfigTools.bat, When the following information is displayed, enter 2 and press Enter.
1) Change FTPServer password 
2) Change database password 
3) Change Modbus SSL config 
4) Change FTPS SSL config 
5) Change external IP of the NetEco 
6) Change local IP of the NetEco 
7) Exit 
 
Please choose 1-7:

Step 2 When the following information is displayed, enter database username and press Enter.

Please input database username :database username

Step 3 When the following information is displayed, enter password of the database user and press
Enter.

Please input old database password : password of the database user
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Step 4 When the following information is displayed, enter new password of the database user and
press Enter.

Please input new database password :new password of the database user

Step 5 When the following information is displayed, enter new password of the database user
again and press Enter.

Please confirm new database password:new password of the database user

Step 6 When the following information is displayed, the password is changed successfully.

Change succeeded.

Step 7 Restart the NetEco 1000S services.

When the password is changed successfull, you must restart the NetEco 1000S services.
Otherwise, an exception may occur.

----End

5.4.1.2 Managing NetEco 1000S Users
This section describes the roles of NetEco 1000S users and the related authority.

l For details about users in the commercial NetEco 1000S and the related authority, see
5.1.7.1 Managing User Information.

l For details about users in the residential NetEco 1000S and the related authority, see
5.2.6.1 Managing User Information .

5.4.2 Management Logs
This section describes management logs. You can learn about the NetEco 1000S running
status and operations through management logs.

5.4.2.1 NetEco 1000S Log Types
NetEco 1000S logs record important user operations. You can view the log list or details
about a log, or export operation logs, operation logs, or system logs. The NetEco 1000S
provides information about logs with three levels (warning, minor, and critical).

Security Log
Security logs record the security operations that are performed on the eSight client, such as
logging in to the client, changing the password, creating a user, and exiting the client.

You can query security logs to understand the information about NetEco 1000S security
operations.

System Log
System logs record the events that occur on the NetEco 1000S. For example, NetEco 1000S
running exceptions, network faults, and NetEco 1000S attacks. System logs help analyze the
operating status of the NetEco 1000S and rectify faults.

You can query system logs to understand the information about NetEco 1000S system
operations.
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Operation Log

Operation logs record the operations that are performed on the NetEco 1000S, such as device
addition and deletion.

You can query operation logs to understand the information about user operations.

5.4.2.2 Managing the Binary Log of the Database

The binary log of the database records the ciphertext information about database password
changing, which may introduce security risks.

NOTE

The binary log of the MySQL database is a function of the MySQL database. It is used for storing data
for database backup. For details, see the official website of the MySQL database http://
www.mysql.com/.

Enabling the Binary Log of the Database

If you enable the binary log of the database, the system records the ciphertext information
generated when you change the database password, which may introduce security risks. If the
ciphertext information does not need to be recorded, you are advised to disable the binary log
of the database.

l Use the Notepad to open the NetEco 1000S installation directory\mysql\oms_mysql
\my.ini file.

l In the opened file, find the log-bin field, delete # before this field, and save and close the
file. Then, restart the service.

NOTE

Press Ctrl+F to quickly locate the log-bin field.

Disabling the Binary Log of the Database

If you disable the binary log of the database, the system disables the function of saving the
binary log. As a result, you cannot use the binary log to back up data.

l Use the Notepad to open the NetEco 1000S installation directory\mysql\oms_mysql
\my.ini file.

l In the opened file, find the log-bin field, add # before this field, and save and close the
file. Then, restart the service.

5.4.3 Replacing Certificate of the NetEco 1000S System
The NetEco 1000S system provides the default Huawei-preconfigured certificate for security
connection. This certificate applies only to the commissioning scenario. Huawei-
preconfigured certificate cannot ensure the information transmission security. When users
need to ensure information security, they must apply for a legal and valid certificate from the
CA and replace the preconfigured certificate with the applied one. The certificate cracking
possibility increases if one certificate is used for a long period. Therefore, replace the
certificate periodically.
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5.4.3.1 Viewing Certificates

Prerequisites

JavaKeysotre (JKS) certificates have been obtained.

You are authorized to access the NetEco 1000S installation directory.

Context

The Keytool provided by Java can be used to view JKS certificate information.

Check the validity period of the certificate and ensure that the certificate is used in the period
of validity.

Procedure

Step 1 Copy the certificate neteco.jks to NetEco 1000S installation directory\uninstall\jre
\jre_win\bin.

NOTE

By default, after the NetEco 1000S is installed, the preconfigured certificates neteco.jks are saved in the
software installation directory\WebRoot\WEB-INF\workspace directory.

The certificate password provided by the NetEco 1000S by default is Changeme_123.

Step 2 Open the DOS command interface and run the following commands to navigate to the keytool
installation directory. Assume that the software is installed in the D:\NetEco1000S directory.

C:\Users>D:

D:\>cd NetEco1000S\uninstall\jre\jre_win\bin

Step 3 Run the following command to view the certificate information:
keytool -v -list -keystore neteco.jks -storepass Changeme_123 -storetype jks

----End

5.4.3.2 Replacing a Certificate for the NetEco 1000S Client Communicating with
the Server

This section describes how to replace the HTTPS protocol certificate preconfigured for the
web-based NetEco 1000S client communicating with the server.

Prerequisites
l You have installed the NetEco 1000S.
l You are authorized to access the NetEco 1000S installation directory.
l You have applied for a new digital certificate from the Certificate Authority (CA).

NOTE

The name of a certificate applied for from the CA may be different from the following certificate
name. Change the certificate name to be the same as the following certificate name.

– Device certificate: NetEco.cer
– Private key of the device certificate: NetEco_Key.pem
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If a password has been configured for the private key of the device certificate, the
password must also be obtained.

– Certificate issued by a subordinate CA: NEPL_PKI.cer (there may be multiple or
no such certificates)

– Root CA certificate: Huawei_Equipment_CA.cer

NOTE

If the certificate is a .p7b file, you must export the certificate. This section uses the operations of
user.p7b as an example.

1. Double-click the user.p7b to open the certificate.

2. Select the Certificates folder from the Certificates - Current User drop-down list to expand
the folder.

3. Right-click the certificate and choose All Tasks > Export from the shortcut menu. Click Next
in the prompt dialog.

4. Select Base64 encoded X.509(.CER), and click Next.

5. Click Browse, type the certificate file name and the export directory. Click Save. Click Next.

6. Click Finish.

Context
l By default, after the NetEco 1000S is installed, the preconfigured certificate neteco.jks

is saved in the NetEco 1000S software installation directory\WebRoot\WEB-INF
\workspace directory.

NOTE

The certificate for enabling SSL has been incorporated to the neteco.jks certificate. When you enable
SSL on the 5.1.7.3.1 Setting Parameters for the Email Server, you do not need to replace the SSL
certificate.

l To replace the digital certificates, you must manually prepare digital certificates, replace
Huawei certificates with these certificates.

l The password of certificates must be set according to the following requirements:

– The password contains 8 to 32 characters.

– The password contains three of the following:

n Lowercase letters

n Uppercase letters

n Digits

– The password is advised to contain special characters, which include !"#$%&'()*
+,-./:;<=>?@[\]^`{_|}~ and space.

Procedure

Step 1 Copy the certificates.

Copy the new digital certificates to the NetEco 1000S software installation directory\tools
\bin\generateCer\certificate directory.

Step 2 Prepare new certificates.

1. Copy the contents of NEPL_PKI.cer and Huawei_Equipment_CA.cer to NetEco.cer.
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NOTE

You can open NEPL_PKI.cer, Huawei_Equipment_CA.cer, and NetEco.cer in text mode to
copy their contents.

2. Generate the certificate file neteco.jks.

a. Run the script NetEco 1000S software installation directory\tools\SSLTools.bat,
When the following information is displayed, enter 1 and press Enter.
1)Generate SSL certificate 
2)Update SSL certificate 
3)Change SSL certificate password 
4)Restore SSL certificate 
Please choose:

b. When the following information is displayed, enter 1 and press Enter.
1)Generate Jetty Certificate 
2)Generate Modbus/TCP<port:16100>, FTPs Certificate 
3)Generate Modbus/TCP<port:27250>, Certificate
4)Generate Email Certificate
5)Generate APP Certificate 
Please choose:

c. When the following information is displayed, enter the obtained private key
password and press Enter.
Enter pass phrase for .\tools\bin\generateCer\certificate
\NetEco_Key.pem:obtained password of the private key

d. When the following information is displayed, enter the password of the new
certificate and press Enter.
Enter Export Password:password of the new certificate

e. When the following information is displayed, enter the password of the new
certificate again and press Enter.
Verifying - Enter Export Password:confirm the password of the new certificate

f. When the following information is displayed, enter the password of the new
certificate and press Enter.
Enter pass phrase for .\tools\bin\generateCer\keystore\neteco.p12:password of
the new certificate

g. When the following information is displayed, the certificate file neteco.jks is
successfully created.
Create keystore file success.

3. Replacing the certificate.

a. Run the script NetEco 1000S software installation directory\tools\SSLTools.bat,
When the following information is displayed, enter 2 and press Enter.
1)Generate SSL certificate 
2)Update SSL certificate 
3)Change SSL certificate password 
4)Restore SSL certificate 
Please choose:

b. When the following information is displayed, enter 1 and press Enter.
1)Update Jetty Certificate 
2)Update Modbus/TCP<port:16100>, FTPs Certificate 
3)Update Modbus/TCP<port:27250>, Certificate
4)Update Email Certificate
5)Update APP Certificate
Please choose:

c. When the following information is displayed, enter the password of the current
certificate and press Enter.
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Please input current ssl key password:password of the current certificate

NOTE

The certificate password provided by the NetEco 1000S by default is Changeme_123.

d. When the following information is displayed, the certificate is successfully
replaced.
Update certificate success. 
The old keystore file was backed up in folder 
.\tools\bin\generateCer\backup     

NOTE

After the certificate is successfully replaced, the old certificate was backed up in folder NetEco
1000S software installation directory\tools\bin\generateCer\backup.

4. Effective the new certificate password.

a. Run the script NetEco 1000S software installation directory\tools\SSLTools.bat,
When the following information is displayed, enter 3 and press Enter.
1)Generate SSL certificate 
2)Update SSL certificate 
3)Change SSL certificate password 
4)Restore SSL certificate 
Please choose:

b. When the following information is displayed, enter 1 and press Enter.
1)Change Jetty Certificate Key In Config 
2)Change Modbus/TCP<port:16100>, FTPs Certificate Key In Config 
3)Change Modbus/TCP<port:27250>,Certificate Key In Config
4)Change Email Certificate Key In Config
5)Change APP Certificate Key In Config
Please choose:

c. When the following information is displayed, enter the password of the old
certificate and press Enter.
Please input old ssl key password:password of the old certificate

d. When the following information is displayed, enter the new password of the
certificate and press Enter.
Please input new ssl key password:new password of the certificate

e. When the following information is displayed, enter the new password of the
certificate again and press Enter.
Please confirm the new ssl key password:new password of the certificate

f. When the following information is displayed, the password is changed successfully.
Modification success, please restart the service to take effect.     

Step 3 Optional: Restore the certificate.

When an exception occurs in the new certificate or the old certificate is required, you can run
the following command to restore the certificate to the last status.

1. Run the script NetEco 1000S software installation directory\tools\SSLTools.bat,
When the following information is displayed, enter 4 and press Enter.
1)Generate SSL certificate 
2)Update SSL certificate 
3)Change SSL certificate password 
4)Restore SSL certificate 
Please choose:

2. When the following information is displayed, enter 1 and press Enter.
1)Restore Jetty Certificate 
2)Restore Modbus/TCP<port:16100>, FTPs Certificate 
3)Restore Modbus/TCP<port:27250>,Certificate
4)Restore Email Certificate
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5)Restore APP Certificate 
Please choose:

3. When the following information is displayed, enter the password of the current
certificate and press Enter.

Please input current ssl key password:password of the current certificate

4. When the following information is displayed, the certificate is successfully restored.
Restore certificate success!     

5. Restore the password of the old certificate.

a. Run the script NetEco 1000S software installation directory\tools\SSLTools.bat,
When the following information is displayed, enter 3 and press Enter.
1)Generate SSL certificate 
2)Update SSL certificate 
3)Change SSL certificate password 
4)Restore SSL certificate 
Please choose:

b. When the following information is displayed, enter 1 and press Enter.
1)Change Jetty Certificate Key In Config 
2)Change Modbus/TCP<port:16100>, FTPs Certificate Key In Config 
3)Change Modbus/TCP<port:27250>,Certificate Key In Config
4)Change Email Certificate Key In Config
5)Change APP Certificate Key In Config
Please choose:

c. When the following information is displayed, enter the password of the old
certificate and press Enter.

Please input old ssl key password:password of the old certificate

d. When the following information is displayed, enter the new password of the
certificate and press Enter.

Please input new ssl key password:new password of the certificate

e. When the following information is displayed, enter the new password of the
certificate again and press Enter.

Please confirm the new ssl key password:new password of the certificate

f. When the following information is displayed, the password is changed successfully.
Modification success, please restart the service to take effect.     

Step 4 Restart the NetEco 1000S for the settings to take effect.

If you can access NetEco 1000S services properly, the security certificate is replaced
successfully. Otherwise, contact Huawei technical support.

----End

5.4.3.3 Replacing a Certificate for the NE Communicating with the Server

This section describes how to replace the Modbus/TCP protocol certificates preconfigured for
the NE communicating with the server.

Prerequisites
l You have installed the NetEco 1000S.

l You are authorized to access the NetEco 1000S installation directory.

l You have applied for a new digital certificate from the Certificate Authority (CA).
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NOTE

The name of a certificate applied for from the CA may be different from the following certificate
name. Change the certificate name to be the same as the following certificate name.

– Device certificate: NetEco.cer
– Private key of the device certificate: NetEco_Key.pem

If a password has been configured for the private key of the device certificate, the
password must also be obtained.

– Certificate issued by a subordinate CA: NEPL_PKI.cer (there may be multiple or
no such certificates)

– Root CA certificate: Huawei_Equipment_CA.cer

NOTE

If the certificate is a .p7b file, you must export the certificate. This section uses the operations of
user.p7b as an example.

1. Double-click the user.p7b to open the certificate.

2. Select the Certificates folder from the Certificates - Current User drop-down list to expand
the folder.

3. Right-click the certificate and choose All Tasks > Export from the shortcut menu. Click Next
in the prompt dialog.

4. Select Base64 encoded X.509(.CER), and click Next.

5. Click Browse, type the certificate file name and the export directory. Click Save. Click Next.

6. Click Finish.

Context
l By default, after the NetEco 1000S is installed, the preconfigured certificates

server_keystore.jks and HX_server_keystore.jks are saved in the NetEco 1000S
software installation directory\WebRoot\WEB-INF\workspace\neCert directory.

NOTE

HX_server_keystore.jks is a preconfigured certificate especially for SUN2000L invetrters.

l To replace the digital certificates, you must manually prepare digital certificates, replace
Huawei certificates with these certificates.

l The password of certificates must be set according to the following requirements:
– The password contains 8 to 32 characters.
– The password contains three of the following:

n Lowercase letters
n Uppercase letters
n Digits

– The password is advised to contain special characters, which include !"#$%&'()*
+,-./:;<=>?@[\]^`{_|}~ and space.

Procedure

Step 1 Copy the certificates.

Copy the new digital certificates to the NetEco 1000S software installation directory\tools
\bin\generateCer\certificate directory.
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Step 2 Prepare new certificates.

1. Copy the contents of NEPL_PKI.cer and Huawei_Equipment_CA.cer to NetEco.cer.

NOTE

You can open NEPL_PKI.cer, Huawei_Equipment_CA.cer, and NetEco.cer in text mode to
copy their contents.

2. Generate the certificate file neteco_server.jks or HX_server_keystore.jks.

a. Run the script NetEco 1000S software installation directory\tools\SSLTools.bat,
When the following information is displayed, enter 1 and press Enter.
1)Generate SSL certificate 
2)Update SSL certificate 
3)Change SSL certificate password 
4)Restore SSL certificate 
Please choose:

b. When the following information is displayed, enter 2 or 3 and press Enter.

NOTE

n Enter 2, and the certificate file generated is neteco_server.jks.
n Enter 3, and the certificate file generated is HX_server_keystore.jks.

1)Generate Jetty Certificate 
2)Generate Modbus/TCP<port:16100>, FTPs Certificate 
3)Generate Modbus/TCP<port:27250>, Certificate
4)Generate Email Certificate
5)Generate APP Certificate 
Please choose:

c. When the following information is displayed, enter the obtained private key
password and press Enter.
Enter pass phrase for .\tools\bin\generateCer\certificate
\NetEco_Key.pem:obtained password of the private key

d. When the following information is displayed, enter the password of the new
certificate and press Enter.
Enter Export Password:password of the new certificate

e. When the following information is displayed, enter the password of the new
certificate again and press Enter.
Verifying - Enter Export Password:confirm the password of the new certificate

f. When the following information is displayed, enter the password of the new
certificate and press Enter.
Enter pass phrase for .\tools\bin\generateCer\keystore\neteco.p12:password of
the new certificate

g. When the following information is displayed, enter Y and adding the certificate to
keystore.
Trust this certificate? [no]:

h. When the following information is displayed, the certificate was added to keystore
successfully.
Certificate was added to keystore

i. When the following information is displayed, enter Y and press Enter.
Trust this certificate? [no]:

j. When the following information is displayed, the certificate file
server_keystore.jks is successfully created.
Create keystore file success.
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3. Replace the certificates.

a. Run the script NetEco 1000S software installation directory\tools\SSLTools.bat,
When the following information is displayed, enter 2 and press Enter.
1)Generate SSL certificate 
2)Update SSL certificate 
3)Change SSL certificate password 
4)Restore SSL certificate 
Please choose:

b. When the following information is displayed, enter 2 or 3 and press Enter.
1)Update Jetty Certificate 
2)Update Modbus/TCP<port:16100>, FTPs Certificate 
3)Update Modbus/TCP<port:27250>, Certificate
4)Update Email Certificate
5)Update APP Certificate
Please choose:

c. When the following information is displayed, enter the password of the current
certificate and press Enter.
Please input current ssl key password:password of the current certificate

NOTE

The password of the old certificate is the password of the certificate to be replaced. The
certificate password provided by the NetEco 1000S by default is NetEco123.

d. When the following information is displayed, the certificate is successfully
replaced.
Update certificate success. 
The old keystore file was backed up in folder 
.\tools\bin\generateCer\backup 
     

NOTE

After the certificate is successfully replaced, the old certificate was backed up in folder NetEco
1000S software installation directory\tools\bin\generateCer\backup.

4. Effective the new certificate password.

a. Run the script NetEco 1000S software installation directory\tools\SSLTools.bat,
When the following information is displayed, enter 3 and press Enter.
1)Generate SSL certificate 
2)Update SSL certificate 
3)Change SSL certificate password 
4)Restore SSL certificate 
Please choose:

b. When the following information is displayed, enter 2 or 3, and press Enter.
1)Change Jetty Certificate Key In Config 
2)Change Modbus/TCP<port:16100>, FTPs Certificate Key In Config 
3)Change Modbus/TCP<port:27250>,Certificate Key In Config
4)Change Email Certificate Key In Config
5)Change APP Certificate Key In Config
Please choose:

c. When the following information is displayed, enter the password of the old
certificate and press Enter.
Please input old ssl key password:password of the old certificate

d. When the following information is displayed, enter the new password of the
certificate and press Enter.
Please input new ssl key password:new password of the certificate

e. When the following information is displayed, enter the new password of the
certificate again and press Enter.
Please confirm the new ssl key password:new password of the certificate
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f. When the following information is displayed, the password is changed successfully.
Modification success, please restart the service to take effect.     

Step 3 Optional: Restore the certificate.

When an exception occurs in the new certificate or the old certificate is required, you can run
the following command to restore the certificate to the last status.

1. Run the script NetEco 1000S software installation directory\tools\SSLTools.bat,
When the following information is displayed, enter 4 and press Enter.
1)Generate SSL certificate 
2)Update SSL certificate 
3)Change SSL certificate password 
4)Restore SSL certificate 
Please choose:

2. When the following information is displayed, enter 2 and press Enter.
1)Restore Jetty Certificate 
2)Restore Modbus/TCP<port:16100>, FTPs Certificate 
3)Restore Modbus/TCP<port:27250>,Certificate
4)Restore Email Certificate
5)Restore APP Certificate 
Please choose:

3. When the following information is displayed, enter the password of the current
certificate and press Enter.
Please input current ssl key password:password of the current certificate

4. When the following information is displayed, the certificate is successfully restored.
Restore certificate success!     

5. Restore the password of the old certificate.

a. Run the script NetEco 1000S software installation directory\tools\SSLTools.bat,
When the following information is displayed, enter 3 and press Enter.
1)Generate SSL certificate 
2)Update SSL certificate 
3)Change SSL certificate password 
4)Restore SSL certificate 
Please choose:

b. When the following information is displayed, enter 2 or 3 and press Enter.
1)Change Jetty Certificate Key In Config 
2)Change Modbus/TCP<port:16100>, FTPs Certificate Key In Config 
3)Change Modbus/TCP<port:27250>,Certificate Key In Config
4)Change Email Certificate Key In Config
5)Change APP Certificate Key In Config
Please choose:

c. When the following information is displayed, enter the password of the old
certificate and press Enter.
Please input old ssl key password:password of the old certificate

d. When the following information is displayed, enter the new password of the
certificate and press Enter.
Please input new ssl key password:new password of the certificate

e. When the following information is displayed, enter the new password of the
certificate again and press Enter.
Please confirm the new ssl key password:new password of the certificate

f. When the following information is displayed, the password is changed successfully.
Modification success, please restart the service to take effect.     

Step 4 Restart the NetEco 1000S for the settings to take effect.
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If you can access NetEco 1000S services properly, the security certificate is replaced
successfully. Otherwise, contact Huawei technical support.

----End

5.4.3.4 Replacing a Certificate for the Email Server

This section describes how to replace the certificates for NetEco 1000S email server.

Prerequisites
l You have installed the NetEco 1000S.
l You are authorized to access the NetEco 1000S installation directory.
l You have set the email server, and select Enable SSL. For details, see 5.1.7.3.1 Setting

Parameters for the Email Server.
l You have applied for a new digital certificate from the Certificate Authority (CA).

Device certificate: EmailServerTrustKeystore.cer

NOTE

The name of a certificate applied for from the CA may be different from the preceding certificate name.
Change the certificate name to be the same as the preceding certificate name.

Context
l By default, after the NetEco 1000S is installed, the preconfigured certificates

EmailServerTrustKeystore.jks are saved in the software installation directory
\WebRoot\WEB-INF\workspace\neCert\email directory.

NOTE

The certificate for enabling SSL has been incorporated to the EmailServerTrustKeystore.jks
certificate. When you enable SSL on the 5.1.7.3.1 Setting Parameters for the Email Server, you do
not need to replace the SSL certificate.

l To replace the digital certificates, you must manually prepare digital certificates, replace
Huawei certificates with these certificates.

l The password of certificates must be set according to the following requirements:
– The password contains 8 to 32 characters.
– The password contains three of the following:

n Lowercase letters
n Uppercase letters
n Digits

– The password is advised to contain special characters, which include !"#$%&'()*
+,-./:;<=>?@[\]^`{_|}~ and space.

Procedure

Step 1 Copy the certificates.

Copy the new digital certificates to the NetEco software installation directory\tools\bin
\generateCer\certificate directory.

Step 2 Prepare new certificates.
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1. Generate the certificate file EmailServerTrustKeystore.jks.

a. Run the script NetEco 1000S software installation directory\tools\SSLTools.bat,
When the following information is displayed, enter 1 and press Enter.
1)Generate SSL certificate 
2)Update SSL certificate 
3)Change SSL certificate password 
4)Restore SSL certificate 
Please choose:

b. When the following information is displayed, enter 4 and press Enter.
1)Generate Jetty Certificate 
2)Generate Modbus/TCP<port:16100>, FTPs Certificate 
3)Generate Modbus/TCP<port:27250>, Certificate
4)Generate Email Certificate
5)Generate APP Certificate 
Please choose:

c. When the following information is displayed, enter the password of the new
certificate and press Enter.

Please set a new password for .\tools\bin\generateCer\certificate
\EmailServerTrustKeystore.cer:password of the new certificate

d. When the following information is displayed, enter the password of the new
certificate again and press Enter.

Please confirm the password for. \tools\bin\generateCer\certificate
\EmailServerTrustKeystore.cer:confirm the password of the new certificate

e. When the following information is displayed, enter Y and adding the certificate to
keystore.

Trust this certificate? [no]:

f. When the following information is displayed, the certificate file
EmailServerTrustKeystore.jks is successfully created.

Create keystore file success.

2. Replacing the certificate.

a. Run the script NetEco 1000S software installation directory\tools\SSLTools.bat,
When the following information is displayed, enter 2 and press Enter.
1)Generate SSL certificate 
2)Update SSL certificate 
3)Change SSL certificate password 
4)Restore SSL certificate 
Please choose:

b. When the following information is displayed, enter 4 and press Enter.
1)Update Jetty Certificate 
2)Update Modbus/TCP<port:16100>, FTPs Certificate 
3)Update Modbus/TCP<port:27250>, Certificate
4)Update Email Certificate
5)Update APP Certificate
Please choose:

c. When the following information is displayed, enter the password of the current
certificate and press Enter.

Please input current ssl key password:password of the current certificate

NOTE

The certificate password provided by the NetEco 1000S by default is Changeme_123.

d. When the following information is displayed, the certificate is successfully
replaced.
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Update certificate success. 
The old keystore file was backed up in folder 
.\tools\bin\generateCer\backup     

NOTE

After the certificate is successfully replaced, the old certificate was backed up in folder NetEco
1000S software installation directory\tools\bin\generateCer\backup.

3. Effective the new certificate password.

a. Run the script NetEco 1000S software installation directory\tools\SSLTools.bat,
When the following information is displayed, enter 3 and press Enter.
1)Generate SSL certificate 
2)Update SSL certificate 
3)Change SSL certificate password 
4)Restore SSL certificate 
Please choose:

b. When the following information is displayed, enter 4 and press Enter.
1)Change Jetty Certificate Key In Config 
2)Change Modbus/TCP<port:16100>, FTPs Certificate Key In Config 
3)Change Modbus/TCP<port:27250>,Certificate Key In Config
4)Change Email Certificate Key In Config
5)Change APP Certificate Key In Config
Please choose:

c. When the following information is displayed, enter the password of the old
certificate and press Enter.
Please input old ssl key password:password of the old certificate

d. When the following information is displayed, enter the new password of the
certificate and press Enter.
Please input new ssl key password:new password of the certificate

e. When the following information is displayed, enter the new password of the
certificate again and press Enter.
Please confirm the new ssl key password:new password of the certificate

f. When the following information is displayed, the password is changed successfully.
Modification success, please restart the service to take effect.     

Step 3 Optional: Restore the certificate.

When an exception occurs in the new certificate or the old certificate is required, you can run
the following command to restore the certificate to the last status.

1. Run the script NetEco 1000S software installation directory\tools\SSLTools.bat,
When the following information is displayed, enter 4 and press Enter.
1)Generate SSL certificate 
2)Update SSL certificate 
3)Change SSL certificate password 
4)Restore SSL certificate 
Please choose:

2. When the following information is displayed, enter 4 and press Enter.
1)Restore Jetty Certificate 
2)Restore Modbus/TCP<port:16100>, FTPs Certificate 
3)Restore Modbus/TCP<port:27250>,Certificate
4)Restore Email Certificate
5)Restore APP Certificate 
Please choose:

3. When the following information is displayed, enter the password of the current
certificate and press Enter.
Please input current ssl key password:password of the current certificate
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4. When the following information is displayed, the certificate is successfully restored.
Restore certificate success!     

5. Restore the password of the old certificate.

a. Run the script NetEco 1000S software installation directory\tools\SSLTools.bat,
When the following information is displayed, enter 3 and press Enter.
1)Generate SSL certificate 
2)Update SSL certificate 
3)Change SSL certificate password 
4)Restore SSL certificate 
Please choose:

b. When the following information is displayed, enter 4 and press Enter.
1)Change Jetty Certificate Key In Config 
2)Change Modbus/TCP<port:16100>, FTPs Certificate Key In Config 
3)Change Modbus/TCP<port:27250>,Certificate Key In Config
4)Change Email Certificate Key In Config
5)Change APP Certificate Key In Config
Please choose:

c. When the following information is displayed, enter the password of the old
certificate and press Enter.
Please input old ssl key password:password of the old certificate

d. When the following information is displayed, enter the new password of the
certificate and press Enter.
Please input new ssl key password:new password of the certificate

e. When the following information is displayed, enter the new password of the
certificate again and press Enter.
Please confirm the new ssl key password:new password of the certificate

f. When the following information is displayed, the password is changed successfully.
Modification success, please restart the service to take effect.

Step 4 Restart the NetEco 1000S for the settings to take effect.

----End

5.4.3.5 Replacing a Certificate for the NetEco 1000S APP Communicating with the
Server

This section describes how to replace the HTTPS protocol certificates preconfigured for the
NetEco 1000S APP communicating with the server.

Prerequisites
l You have installed the NetEco 1000S.
l You are authorized to access the NetEco 1000S installation directory.
l You have applied for a new digital certificate from the Certificate Authority (CA).

NOTE

The name of a certificate applied for from the CA may be different from the following certificate
name. Change the certificate name to be the same as the following certificate name.

– Device certificate: NetEco.cer
– Private key of the device certificate: NetEco_Key.pem

If a password has been configured for the private key of the device certificate, the
password must also be obtained.
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– Certificate issued by a subordinate CA: NEPL_PKI.cer (there may be multiple or
no such certificates)

– Root CA certificate: Huawei_Equipment_CA.cer

NOTE

If the certificate is a .p7b file, you must export the certificate. This section uses the operations of
user.p7b as an example.

1. Double-click the user.p7b to open the certificate.

2. Select the Certificates folder from the Certificates - Current User drop-down list to expand
the folder.

3. Right-click the certificate and choose All Tasks > Export from the shortcut menu. Click Next
in the prompt dialog.

4. Select Base64 encoded X.509(.CER), and click Next.

5. Click Browse, type the certificate file name and the export directory. Click Save. Click Next.

6. Click Finish.

Context
l By default, after the NetEco 1000S is installed, the preconfigured certificate app.jks is

saved in the software installation directory\WebRoot\WEB-INF\workspace directory.

NOTE

The certificate for enabling SSL has been incorporated to the app.jks certificate. When you enable SSL
on the 5.1.7.3.1 Setting Parameters for the Email Server, you do not need to replace the SSL
certificate.

l To replace the digital certificates, you must manually prepare digital certificates, and
replace Huawei certificates with these certificates.

l The password of certificates must be set according to the following requirements:
– The password contains 8 to 32 characters.
– The password contains three of the following:

n Lowercase letters
n Uppercase letters
n Digits

– The password is advised to contain special characters, which include !"#$%&'()*
+,-./:;<=>?@[\]^`{_|}~ and space.

Procedure

Step 1 Copy the certificates.

Copy the new digital certificates to the NetEco software installation directory\tools\bin
\generateCer\certificate directory.

Step 2 Prepare new certificates.

1. Copy the contents of NEPL_PKI.cer and Huawei_Equipment_CA.cer to NetEco.cer.

NOTE

You can open NEPL_PKI.cer, Huawei_Equipment_CA.cer, and NetEco.cer in text mode to
copy their contents.

2. Generate the certificate file app.jks.
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a. Run the script NetEco software installation directory\tools\SSLTools.bat, When
the following information is displayed, enter 1 and press Enter.
1)Generate SSL certificate 
2)Update SSL certificate 
3)Change SSL certificate password 
4)Restore SSL certificate 
Please choose:

b. When the following information is displayed, enter 5 and press Enter.
1)Generate Jetty Certificate 
2)Generate Modbus/TCP<port:16100>, FTPs Certificate 
3)Generate Modbus/TCP<port:27250>, Certificate
4)Generate Email Certificate
5)Generate APP Certificate 
Please choose:

c. When the following information is displayed, enter the obtained private key
password and press Enter.
Enter pass phrase for .\tools\bin\generateCer\certificate
\NetEco_Key.pem:obtained password of the private key

d. When the following information is displayed, enter the password of the new
certificate and press Enter.
Enter Export Password:password of the new certificate

e. When the following information is displayed, enter the password of the new
certificate again and press Enter.
Verifying - Enter Export Password:confirm the password of the new certificate

f. When the following information is displayed, enter the password of the new
certificate and press Enter.
Enter pass phrase for .\tools\bin\generateCer\keystore\neteco.p12:password of
the new certificate

g. When the following information is displayed, the certificate file app.jks is
successfully created.
Create keystore file success.

3. Replacing the certificate.

a. Run the script NetEco 1000S software installation directory\tools\SSLTools.bat,
When the following information is displayed, enter 2 and press Enter.
1)Generate SSL certificate 
2)Update SSL certificate 
3)Change SSL certificate password 
4)Restore SSL certificate 
Please choose:

b. When the following information is displayed, enter 5 and press Enter.
1)Update Jetty Certificate 
2)Update Modbus/TCP<port:16100>, FTPs Certificate 
3)Update Modbus/TCP<port:27250>, Certificate
4)Update Email Certificate
5)Update APP Certificate
Please choose:

c. When the following information is displayed, enter the password of the current
certificate and press Enter.
Please input current ssl key password:password of the current certificate

NOTE

The certificate password provided by the NetEco 1000S by default is Changeme_123.

d. When the following information is displayed, the certificate is successfully
replaced.
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Update certificate success. 
The old keystore file was backed up in folder 
.\tools\bin\generateCer\backup     

NOTE

After the certificate is successfully replaced, the old certificate was backed up in folder NetEco
1000S software installation directory\tools\bin\generateCer\backup.

4. Effective the new certificate password.

a. Run the script NetEco 1000S software installation directory\tools\SSLTools.bat,
When the following information is displayed, enter 3 and press Enter.
1)Generate SSL certificate 
2)Update SSL certificate 
3)Change SSL certificate password 
4)Restore SSL certificate 
Please choose:

b. When the following information is displayed, enter 5 and press Enter.
1)Change Jetty Certificate Key In Config 
2)Change Modbus/TCP<port:16100>, FTPs Certificate Key In Config 
3)Change Modbus/TCP<port:27250>,Certificate Key In Config
4)Change Email Certificate Key In Config
5)Change APP Certificate Key In Config
Please choose:

c. When the following information is displayed, enter the password of the old
certificate and press Enter.
Please input old ssl key password:password of the old certificate

d. When the following information is displayed, enter the new password of the
certificate and press Enter.
Please input new ssl key password:new password of the certificate

e. When the following information is displayed, enter the new password of the
certificate again and press Enter.
Please confirm the new ssl key password:new password of the certificate

f. When the following information is displayed, the password is changed successfully.
Modification success, please restart the service to take effect.     

Step 3 Optional: Restore the certificate.

When an exception occurs in the new certificate or the old certificate is required, you can run
the following command to restore the certificate to the last status.

1. Run the script NetEco 1000S software installation directory\tools\SSLTools.bat, When
the following information is displayed, enter 4 and press Enter.
1)Generate SSL certificate 
2)Update SSL certificate 
3)Change SSL certificate password 
4)Restore SSL certificate 
Please choose:

2. When the following information is displayed, enter 5 and press Enter.
1)Restore Jetty Certificate 
2)Restore Modbus/TCP<port:16100>, FTPs Certificate 
3)Restore Modbus/TCP<port:27250>,Certificate
4)Restore Email Certificate
5)Restore APP Certificate 
Please choose:

3. When the following information is displayed, enter the password of the current
certificate and press Enter.
Please input current ssl key password:password of the current certificate
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4. When the following information is displayed, the certificate is successfully restored.
Restore certificate success!     

5. Restore the password of the old certificate.

a. Run the script NetEco 1000S software installation directory\tools\SSLTools.bat,
When the following information is displayed, enter 3 and press Enter.
1)Generate SSL certificate 
2)Update SSL certificate 
3)Change SSL certificate password 
4)Restore SSL certificate 
Please choose:

b. When the following information is displayed, enter 5 and press Enter.
1)Change Jetty Certificate Key In Config 
2)Change Modbus/TCP<port:16100>, FTPs Certificate Key In Config 
3)Change Modbus/TCP<port:27250>,Certificate Key In Config
4)Change Email Certificate Key In Config
5)Change APP Certificate Key In Config
Please choose:

c. When the following information is displayed, enter the password of the old
certificate and press Enter.
Please input old ssl key password:password of the old certificate

d. When the following information is displayed, enter the new password of the
certificate and press Enter.
Please input new ssl key password:new password of the certificate

e. When the following information is displayed, enter the new password of the
certificate again and press Enter.
Please confirm the new ssl key password:new password of the certificate

f. When the following information is displayed, the password is changed successfully.
Modification success, please restart the service to take effect.     

Step 4 Restart the NetEco 1000S for the settings to take effect.

Step 5 Replace the certificate of the NetEco 1000S APP in the iOS/Android system. For detailed
operations, see 5.4.4 Replacing APP Secure Certificates.

----End

5.4.4 Replacing APP Secure Certificates
The APP Server and APP provides the default Huawei-preconfigured certificate for security
connection. This certificate applies only to the commissioning scenario. Huawei-
preconfigured certificate cannot ensure the information transmission security. When users
need to ensure information security, they must apply for a legal and valid certificate from the
CA and replace the preconfigured certificate with the applied one. The certificate cracking
possibility increases if one certificate is used for a long period. Therefore, replace the
certificate periodically.

5.4.4.1 Updating an APP Certificate (iOS)

This section describes how to replace the preconfigured certificate of the NetEco 1000S APP
in the iOS system.

Prerequisites
l The NetEco 1000S APP has been installed on your mobile device.
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l You have obtained the new digital certificate that is manually prepared.
l You have replaced the APP Server certificate in the NetEco 1000S System, which

matches with the new certificate in the NetEco 1000S APP. For detailed operations, see
5.4.3.5 Replacing a Certificate for the NetEco 1000S APP Communicating with the
Server.

Context
After the NetEco 1000S APP is installed, the preconfigured Huawei digital certificate is used
by default. If you do not want to use the preconfigured certificate, manually replace it with a
required certificate.

Procedure

Step 1 Name the obtained new certificate client.cer.

Step 2 Import client.cer to the NetEco 1000S using iTunes.

The operations on an iPhone and iPad are similar. This section uses the operations on an
iPhone as an example.

1. On your PC, connect the mobile device to iTunes.
Figure 5-144 shows the iTunes GUI after the connection.

Figure 5-144 iTunes GUI

2. In the left navigation tree, choose APPs.
The APPs page is displayed.

3. Select NetEco in the File sharing area of the APPs page, as shown in Figure 5-145.
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Figure 5-145 File sharing

4. Click Add file in the NetEco Documents area, and add the client.cer certificate of the
Step 1.
The client.cer certificate has been imported into the iTunes, as shown in Figure 5-146.

Figure 5-146 Importing a new certificate

Step 3 Click the NetEco icon on the mobile client.

The NetEco 1000S APP login window is displayed, as shown in Figure 5-147.
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Figure 5-147 NetEco 1000S APP login window

Step 4 Click Cert Change.

If information as shown in Figure 5-148 is displayed, the certificate has been replaced.

Figure 5-148 Successful certificate replacement

Step 5 Restart the NetEco 1000S APP to make the new certificate take effect.

----End

5.4.4.2 Updating an APP Certificate (Android)

This section describes how to replace the preconfigured certificate of the NetEco 1000S APP
in the Android system.
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Prerequisites
l The NetEco 1000S APP has been installed on your mobile device.

l You have obtained the new digital certificate that is manually prepared.

l You have replaced the APP Server certificate in the NetEco 1000S System, which
matches with the new certificate in the NetEco 1000S APP. For detailed operations, see
5.4.3.5 Replacing a Certificate for the NetEco 1000S APP Communicating with the
Server.

Procedure

Step 1 Connect the mobile device to your PC, and save the obtained new certificate to the mobile
device.

Step 2 Click the NetEco 1000S APP icon on the mobile client.

The NetEco 1000S APP login window is displayed, as shown in Figure 5-149.

Figure 5-149 NetEco 1000S APP login window

Step 3 Click Cert Change.

The page for replacing a certificate is displayed.

Step 4 Select the new certificate. In the displayed dialog box, click Confirm to complete the
certificate replacement.
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Step 5 Restart the NetEco 1000S APP to make the new certificate take effect.

----End

5.4.5 Data backup and restoration
dataBase_backup.bat script is executed by the NetEco 1000S automatically to back up
databases and NetEco 1000S software installation directory\WebRoot directory at 04:00
every day. When NetEco 1000S data becomes abnormal, you can manually restore the backup
file.

Backup

Table 5-64 lists the backup content, backup mode, backup file name, and backup file save
path of the NetEco 1000S data.

NOTICE
You are obligated to take measures, in compliance with the laws of the countries concerned
and the user privacy policies of your company, to ensure that the personal data of users is
fully protected.

Table 5-64 Description of MySQL database backup

Item Description

Backup content l All data in the MySQL database.
l NetEco 1000S software installation directory\WebRoot

folder.

Backup mode Automatic backup: dataBase_backup.bat script is executed
by the NetEco 1000S automatically to back up databases and
NetEco 1000S software installation directory\WebRoot
directory at 04:00 every day.
After the automatic backup, only two copies of the backup
file in the backup directory are saved. When more than two
copies exist, the earliest copies will be deleted.

Backup file name YYYY-MM-DD.zip
YYYY-MM-DD is the backup time, for example,
2015-09-16.zip.

Backup file save path The automatic backup files are saved in the following
directories:
l MySQL database: NetEco 1000S software installation

directory\backup\mysqlBackUp\data directory.
l WebRoot folder: NetEco 1000S software installation

directory\backup\mysqlBackUp\WebRoot directory.
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Restoration

When NetEco 1000S data becomes abnormal, you can perform the following operations to
restore the backup file to restore the NetEco 1000S data to the status upon system backup:

NOTE

The restoration is recommended only when data is abnormal.

1. Stop NetEco 1000S services.
Right-click the NetEco 1000S service icon in the lower right corner of the taskbar of the
desktop and choose Exit from the shortcut menu.

2. Navigate to the NetEco 1000S software installation directory\backup\mysqlBackUp
directory and decompress the backup file to be restored.
The automatic backup files are named as YYYY-MM-DD.zip, YYYY-MM-DD is the
backup time. The automatic backup files are saved in the software installation directory
\backup\mysqlBackUp directory. The WebRoot and data folders are generated after
the decompression.

NOTE

l The WebRoot folder contains data in the NetEco 1000S software installation directory
\WebRoot directory.

l The data folder contains MySQL database data.

3. Restore the backup file.
– Restore the WebRoot file: Delete all files from the NetEco 1000S software

installation directory\WebRoot directory and copy the files from the WebRoot
folder generated after the decompression in 2 to the NetEco 1000S software
installation directory\WebRoot directory.

– Restore database data: Delete all files from the NetEco 1000S software
installation directory\mysql\oms_mysql\data directory and copy the files from
the data folder generated after the decompression in 2 to the NetEco 1000S
software installation directory\mysql\oms_mysql\data directory.

4. Start NetEco 1000S services.

5.4.6 Command Reference
This section describes commands for installing, running, and maintaining the NetEco 1000S
system.

NOTE

For details about the functions of the commands in the third-party component MySQL database, Java
and Openssl used in the NetEco 1000S system, see the corresponding official websites.

Command names, addresses, and functions of the NetEco 1000S system, as shown in
Table 5-65, Table 5-66 and Table 5-67.

Table 5-65 Command reference (Software Installation)

Command Name Command Address Command
Function

setup.bat NetEco 1000S Package Contents\setup.bat Used for installing
the software.
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Command Name Command Address Command
Function

setup_install.bat NetEco 1000S Package Contents\scripts
\setup_install.bat

Used for installing
the software (system
invocation).

 

Table 5-66 Command reference (manual execution is allowed)

Command Name Command Address Command
Function

ConfigTools.bat NetEco 1000S software installation
directory\tools\ConfigTools.bat

Used for changing
the database
password or binding
the IP of the server.

SSLTools.bat NetEco 1000S software installation
directory\tools\SSLTools.bat

Used for operating a
certificate.

KeysTools.bat NetEco 1000S software installation
directory\tools\KeysTools.bat

Used for replacing
keys.

Client.bat NetEco 1000S software installation
directory\Client.bat

Used for starting the
NetEco 1000S client.

startup.bat NetEco 1000S software installation
directory\startup.bat

Used for starting all
the service and
system processes.

autoRecovery.bat NetEco 1000S software installation
directory\uninstall\scripts\autoRecovery.bat

Used for executing
backup files for
recovery after
upgrading the
NetEco 1000S fails.

UserTools.bat NetEco 1000S software installation
directory\tools\UserTools.bat

Used for updating
the Privacy Policy
and and Terms of
Use, and changing
the life cycle of
operation logs .

 

Table 5-67 Command reference (system invocation)

Command Name Command Address Command
Function

UninstallForWin-
dowsControlPanel.ba
t

NetEco 1000S software installation
directory\uninstall\UninstallForWindows-
ControlPanel.bat

Used for invoking
the software
uninstallation.
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Command Name Command Address Command
Function

uninstall.bat NetEco 1000S software installation
directory\uninstall\uninstall.bat

Used for uninstalling
the software.

setup_uninstall.bat NetEco 1000S software installation
directory\uninstall\scripts
\setup_uninstall.bat

uninstallall.bat NetEco 1000S software installation
directory\uninstall\scripts\uninstallall.bat

startup.bat NetEco 1000S software installation
directory\bin\startup.bat

Used for checking if
there is an
administrative
authority, then
invoking the
startup_NetEcoTra
y.bat.

ClientInfo.exe NetEco 1000S software installation
directory\bin\ClientInfo.exe

Used for discovering
the IP address of the
remote execution of
scripts.

NetEcoUPSService.e
xe

NetEco 1000S software installation
directory\bin\NetEcoSUNService.exe

Used for starting the
service-related .exe
file.

startup_NetEcoTray.
bat

NetEco 1000S software installation
directory\bin\startup_NetEcoTray.bat

Used for starting the
NetEcoTray service
and the database
service.

log4operation.bat NetEco 1000S software installation
directory\tools\bin\log4operation.bat

Used for recording
logs.

7za.exe NetEco 1000S software installation
directory\uninstall\scripts\7za.exe

Used for
compressing and
decompressing files
in .7z and .tar
formats.

alluninstallInner.bat NetEco 1000S software installation
directory\uninstall\scripts
\alluninstallInner.bat

Used for uninstalling
all products.

copy_uninstallall.bat NetEco 1000S software installation
directory\uninstall\scripts
\copy_uninstallall.bat

Used for copying
scripts for one-click
uninstallation to the
software installation
directory.
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Command Name Command Address Command
Function

copyCompInsEnv.ba
t

NetEco 1000S software installation
directory\uninstall\scripts
\copyCompInsEnv.bat

Used for copying
extension packages
to an extension
repository and
copying an
installation disk
framework to the
software installation
directory.

delete_files.bat NetEco 1000S software installation
directory\uninstall\scripts\delete_files.bat

Used for deleting
unnecessary files
after the software is
installed.

delete_service.bat NetEco 1000S software installation
directory\uninstall\scripts
\delete_service.bat

Used for deleting the
NetEco 1000S and
database services and
the shortcut icon
generated when
installing or
upgrading the
NetEco 1000S.

prebackupfile.bat NetEco 1000S software installation
directory\uninstall\scripts\prebackupfile.bat

Used for copying
source files to a
target location.

process.bat NetEco 1000S software installation
directory\uninstall\scripts\process.bat

Used for checking
whether any
application is in use
under the target
installation directory.

setup_install.bat NetEco 1000S software installation
directory\uninstall\scripts\setup_install.bat

Used for installing
the software
(upgrade scene).

ChangeCerKeyPass-
word.bat

NetEco 1000S software installation
directory\tools\bin\ChangeCerKeyPass-
word.bat

Used for changing
the password of a
certificate.

generateCer.bat NetEco 1000S software installation
directory\tools\bin\generateCer.bat

Used for generating
a new certificate.

restoreCer.bat NetEco 1000S software installation
directory\tools\bin\restoreCer.bat

Used for restoring a
certificate.

updateCer.bat NetEco 1000S software installation
directory\tools\bin\updateCer.bat

Used for replacing a
certificate.
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Command Name Command Address Command
Function

run.vbs NetEco 1000S software installation
directory\uninstall\scripts\run.vbs

Used for obtaining
more Windows 2008
rights.

NetEco1000S.exe NetEco 1000S software installation
directory\uninstall\jre\jre_win\bin
\NetEco1000S.exe

Used for starting the
NetEco 1000S
process.

NetEcoSUNTray.exe NetEco 1000S software installation
directory\uninstall\jre\jre_win\bin
\NetEcoSUNTray.exe

Used for starting the
system tray.

hiddenKey.bat NetEco 1000S software installation
directory\tools\bin\hiddenKey.bat

Used for not
showing passwords.

hiddenKey.exe NetEco 1000S software installation
directory\tools\bin\hiddenKey.exe

Used for not
showing passwords.
hiddenKey.exe is
generated only after
you manually
execute
SSLTools.bat.

delete_shortcut.vbs NetEco 1000S software installation
directory\uninstall\scripts
\delete_shortcut.vbs

Invoked by the
delete_service.bat
script automatically
to delete the shortcut
icon after
uninstalling the
NetEco 1000S.

installNetEcoPost.ba
t

NetEco 1000S software installation
directory\uninstall\scripts
\installNetEcoPost.bat

Invoked by the
system automatically
to initialize databases
after installing or
upgrading the
NetEco 1000S.
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Command Name Command Address Command
Function

dataBase_backup.bat NetEco 1000S software installation
directory\bin

dataBase_backup.b
at script is executed
by the NetEco 1000S
automatically to back
up databases and
NetEco 1000S
software installation
directory\WebRoot
directory at 04:00
every day.
The automatic
backup files are
named as YYYY-
MM-DD.zip, YYYY-
MM-DD is the
backup time. The
automatic backup
files are saved in the
software installation
directory\backup
\mysqlBackUp
directory.

fix_mysql.bat NetEco 1000S software installation
directory\mysql\oms_mysql\bin

Used for fixing
database table index
problems.
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5.4.7 Performance Specifications

Table 5-68 Performance Specifications

Module Function
Description

Performance
Specifications

Specification
Description

Installation
CD-ROM

Management
capacity

l Number of devices:
1860
– Inverter: 1500
– SmartLogger: 300
– EMI and Meter: 30
– PID: 30

l Number of PV plants:
300
For each PV plant, the
total number of
connected SmartLoggers
and inverters directly
connected to the FE
cannot exceed 25.

Standard edition

Commercial NetEco 1000S
system:
l Number of devices:

7200
– Inverter: 6000
– SmartLogger: 1000
– EMI and Meter: 100
– PID: 100

l Number of PV plants:
1000
For each PV plant, the
total number of
connected SmartLoggers
and inverters directly
connected to the FE
cannot exceed 25.

Residential NetEco 1000S
system:
l Number of devices:

12000
– Inverter: 10000
– Optimizer: 2000

l Number of PV plants:
10000

Enterprise edition
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Module Function
Description

Performance
Specifications

Specification
Description

Database Performance
data storage

The maximum number of
devices whose data can be
collected is as follows:
l Standard edition: 1860

– Inverter: 1500
– SmartLogger: 300
– EMI and Meter: 30
– PID: 30

l Enterprise edition
(commercial NetEco
1000S system): 7200
– Inverter: 6000
– SmartLogger: 1000
– EMI and Meter: 100
– PID: 100

l Enterprise edition
(residential NetEco
1000S system): 12000
– Inverter: 10000
– Optimizer: 2000

The relationships between
collection period and data
storage durations are as
follows:
l 5-minute data of the

EMIs is saved for one
year. 5-minute data of
other devices is saved
for one month.

l Data collected on a 15-
minute basis is saved for
two years.

l Data collected by day,
month, or year is saved
for 20 years.

Size of a daily dumped
file for each device: 10
KB
NOTE

l The dumped file for
5-minute performance
data of PV plants is
saved to NetEco
1000S software
installation directory
\backup
\PowerdataTransfer.
The file is named
Plantdaydata_timest
amp.zip.

l The dumped files for
5-minute performance
data of inverters are
saved to NetEco
1000S software
installation directory
\backup
\PowerdataTransfer
and NetEco 1000S
software installation
directory\backup
\PMDataTransfer. The
files are named
Powerdaydata_times
tamp.zip and
InveterPmdata_time
stamp.zip.

l The dumped file for
5-minute performance
data of other devices
is saved to NetEco
1000S software
installation directory
\backup
\PMDataTransfer. The
file is named device
typePmdata_timestam
p.zip.
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Module Function
Description

Performance
Specifications

Specification
Description

Alarm data
storage

Historical alarm log storage
specification: 1,000,000
logs

The system checks data
every early morning. If
the number of data
records reaches
1,000,000, the database
will dump the earliest
50,000 records. The
dumped records cannot
be queried on the client.

Active alarm storage
specification: 30,000 logs

The system checks
alarms upon the
reporting. If the number
of alarms reaches the
upper limit, the earliest
1000 alarms will be
automatically cleared.

Audit log
storage

Logs in the latest six
months are stored by
default. You can change the
configuration in the
background.

Logs over six months
earlier will be deleted
automatically.

Number of
database
connections

l Performance module: 32
l Log module: 16
l Configuration module: 8
l Common module: 8
l Alarm module: 16

It indicates the
maximum number of
databases that can be
connected with each
module.
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Module Function
Description

Performance
Specifications

Specification
Description

User
management

l Commercial NetEco
1000S system
– Maximum number of

users: 2000
– Maximum number of

concurrent online
users: 250

l Residential NetEco
1000S system
– Maximum number of

users: 5000
– Maximum number of

concurrent online
users: 1050

NOTE
If multiple users need to log in
to the client, you are advised
to use the following mode of
the browser for login.
Otherwise, an error may
occur.

l Internet Explorer: Create a
session.

l Chrome 50: Open a new
incognito window.

l Number of IP address
whitelists: 500

-

Browser Browser of the
following
version is
supported:

l Internet Explorer 11
l Chrome 50

-

Monitor
resolution

Optimal
resolution

1280*1024 The display effect is the
best in this resolution.

Minimum
resolution

1024*768 All functions are
available in the
resolution higher than
this one.

 

5.4.8 Customizing the Logo on the Home Page of the NetEco
1000S Client

This section describes how to customize the logo on the home page of the NetEco 1000S
client based on the actual project information.
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Prerequisites
l You have logged in to the NetEco 1000S client. For detailed operations, see 5.1.1.1.2

Logging In to the NetEco 1000S Client.
l You have the permission to read and write NetEco 1000S installation path on the

NetEco 1000S server host.
l You have prepared the customized logo.

Context
The logo in the red box in Figure 5-150 is the default logo on the home page of the NetEco
1000S. You can customize a new logo as required.

Figure 5-150 Default logo

Procedure

Step 1 Archive the customized logo picture to the NetEco 1000S software installation path
\WebRoot\common\userLogo directory.

NOTE

The logo picture customized for the NetEco 1000S must meet the following requirements:

l The pixel is 234 x 60.

l The size of the logo picture cannot exceed 5 MB.

l The logo picture supports only the jpg, jpeg, png, and gif formats. You can archive at most one
picture in each format, and the four formats are sorted by priority in descending order. For example,
when the logo pictures in jpeg and png formats are archived at the same time, replace the logo in
jpeg format preferentially.

Step 2 Rename the file archived in the Step 1 LOGO.

The jpeg file is used as an example. The new name of the customized picture is LOGO.jpeg.

Step 3 Refresh the NetEco 1000S client and observe whether the logo in the upper-left corner is
updated.

----End
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6 Abbreviations

F

FE Fast Ethernet

FTPS File Transfer Protocol over SSL

H

HTTP Hypertext Transfer Protocol

HTTPS Hypertext Transfer Protocol Secure

K

KPI Key Performance Indicator

N

NMS Network Management System

R

RSA Revist-Shamir-Adleman Algorithm

S

SMTP Simple Mail Transfer Protocol

SSH Secure Shell

SSL Secure Sockets Layer

SFTP Secure File Transfer Protocol

T

TLS Transport Layer Security

TCP Transmission Control Protocol

V

VLAN Virtual Local Area Network
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